News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

PaypalDonations

Started by snork13, February 06, 2006, 11:36:58 PM

Previous topic - Next topic

snork13

Link to Mod

A Paypal Merchant account is required, for more information visit: https://www.paypal.com/cgi-bin/webscr?cmd=p/xcl/rec/donate-intro-outside
Paypal generates the html form code you will need for one of the textareas, the other textarea is for maybe a reason why the members should donate, or get fancy like the examples on the Paypal site.

This mod will add a "Donate" link in the top menu, which will take you to your static Paypal Donation page.
On the admin side, under "current theme" you have two textareas for entering the Paypal info.

Special thanks to Bloc for the textarea code ;)

Tested on 1.1RC2 fresh install.

Version 1.2 - added permissions setting and an error in the language





Mods
Please DO NOT PM me with requests for individual support, but post your questions and concerns in the appropriate section of the forum where other users can benefit from them as well. Thank you.
I have been super busy as of late. Working on updates to all my modifications for 2.0.1

Bigguy

I`m gettting an error in Index.template.php when trying to install this. Is there a fix ???

ArkServer

#2
How to center?

http://arkserver.servehttp.com/index.php?action=paypal

works here.

//edit
edit nvm

snork13

Quote from: Bigguy on February 07, 2006, 01:56:38 AM
I`m gettting an error in Index.template.php when trying to install this. Is there a fix ???

yes, i wrote for a fresh install, so if you added other links...then you can edit the links manually. Check out the modification file within the package.

-snork
Mods
Please DO NOT PM me with requests for individual support, but post your questions and concerns in the appropriate section of the forum where other users can benefit from them as well. Thank you.
I have been super busy as of late. Working on updates to all my modifications for 2.0.1

Bigguy

I got it to work on my test site. It was a tab it couldnt put in. It works now.

edi67

good mod but is possible do that only certanly users gropus view it? i not want that all users groups see the message
CrazyZone - My SMF Forum


From the difficult the hardening of the man you can see

snork13

Quote from: edi67 on February 07, 2006, 07:24:02 PM
good mod but is possible do that only certanly users gropus view it? i not want that all users groups see the message

you mean view the donate link as well, or just the page


i guess i could set permissions
Mods
Please DO NOT PM me with requests for individual support, but post your questions and concerns in the appropriate section of the forum where other users can benefit from them as well. Thank you.
I have been super busy as of late. Working on updates to all my modifications for 2.0.1

ladyshanae

Quote8: Use of undefined constant paypal_donation - assumed 'paypal_donation'
File: /home/hprpgnet/public_html/forum/Themes/default/Paypal.template.php (main sub template - eval?)
Line: 25

This shows up in my error log.

Also I can't seem to edit the information once I put it in . . . I think the "Save" button is missing from the bottom of the page now.

Otherwise - fantastic mod :)  Thank you!

snork13

Quote from: ladyshanae on February 08, 2006, 05:39:01 PM
Quote8: Use of undefined constant paypal_donation - assumed 'paypal_donation'
File: /home/hprpgnet/public_html/forum/Themes/default/Paypal.template.php (main sub template - eval?)
Line: 25

This shows up in my error log.

Also I can't seem to edit the information once I put it in . . . I think the "Save" button is missing from the bottom of the page now.

Otherwise - fantastic mod :)  Thank you!

thanks, i missed that...all fixed.
Also Permissions added for who can view the donation page.

uninstall current version, and then install version 1.2

-snork
Mods
Please DO NOT PM me with requests for individual support, but post your questions and concerns in the appropriate section of the forum where other users can benefit from them as well. Thank you.
I have been super busy as of late. Working on updates to all my modifications for 2.0.1

londonhogfan

when I go to uninstall 1.0 to install 1.2 I get this error...

Type Action Description
1. Execute Modification ./index.php Test successful
2. Execute Modification ./Themes/default/index.template.php Test failed
3. Execute Modification ./Themes/default/Settings.template.php Test successful
4. Execute Modification ./Themes/default/Themes.template.php Test successful
5. Execute Modification ./Themes/default/languages/Modifications.english.php Test failed


Is it ok for me to go ahead with the uninstall?

Prasad007

#10
Thanks! This is gr8!! :)


*EDIT*

i get this error
Quote3.     Execute Modification     ./Themes/default/index.template.php     Test failed

what do I do ??

ladyshanae

Awesome!  Everything seems to work perfectly now!

Thank you - this makes my life easier :)

snork13

Quote from: Prasad007 on February 09, 2006, 11:34:42 AM
Thanks! This is gr8!! :)


*EDIT*

i get this error
Quote3.     Execute Modification     ./Themes/default/index.template.php     Test failed

what do I do ??


this happens becuase of the custom link you already have, such as arcade, gallery..etc.
I will see if i can re-write the mod for adding rather then replace for the index.template
Mods
Please DO NOT PM me with requests for individual support, but post your questions and concerns in the appropriate section of the forum where other users can benefit from them as well. Thank you.
I have been super busy as of late. Working on updates to all my modifications for 2.0.1

Prasad007

Quote from: snork13 on February 09, 2006, 01:06:06 PM
Quote from: Prasad007 on February 09, 2006, 11:34:42 AM
Thanks! This is gr8!! :)


*EDIT*

i get this error
Quote3.     Execute Modification     ./Themes/default/index.template.php     Test failed

what do I do ??


this happens becuase of the custom link you already have, such as arcade, gallery..etc.
I will see if i can re-write the mod for adding rather then replace for the index.template
oh okay. thanks for the help! :) id really like to have this mod :)

4css

Since this mod doesn't work on SMF 1.0.6 Can someone give me guidance for hand coding this into my forum?

Any help would be appreciated.
Thanks in advance.
4~css
^i^
The only stupid question is the one that goes unasked!
Fibromyalgia
Friends and family

CSS Directory
My Strand of the web
CSS blog just starting
Did I mention I'm goign to be a grandmom?!!!

Pink Bee

I'm using 1.1RC2

When I try to apply the mod, it gave me this error:
Quote3. Execute Modification ./Themes/default/index.template.php Test failed

snork13

Quote from: pinkbee on February 09, 2006, 10:26:01 PM
I'm using 1.1RC2

When I try to apply the mod, it gave me this error:
Quote3. Execute Modification ./Themes/default/index.template.php Test failed

again, i think it's because of the array, i will see if i can make it work when additional menu links are added
Mods
Please DO NOT PM me with requests for individual support, but post your questions and concerns in the appropriate section of the forum where other users can benefit from them as well. Thank you.
I have been super busy as of late. Working on updates to all my modifications for 2.0.1

BCB1908

Nice mod, but I'm getting the error below.  Any thougts?

QuoteUnable to load the 'main' template.

snork13

Quote from: BCB1908 on February 10, 2006, 01:00:01 PM
Nice mod, but I'm getting the error below.  Any thougts?

QuoteUnable to load the 'main' template.

what version, try 1.3 version. uninstall current version first

-snork
Mods
Please DO NOT PM me with requests for individual support, but post your questions and concerns in the appropriate section of the forum where other users can benefit from them as well. Thank you.
I have been super busy as of late. Working on updates to all my modifications for 2.0.1

BCB1908

Quote from: snork13 on February 10, 2006, 01:57:43 PM
Quote from: BCB1908 on February 10, 2006, 01:00:01 PM
Nice mod, but I'm getting the error below.  Any thougts?

QuoteUnable to load the 'main' template.

what version, try 1.3 version. uninstall current version first

-snork
1.3 is the only I have installed ever.

Advertisement: