News:

SMF 2.1.2 has been released! Take it for a spin! Read more.

Main Menu

SMF 1.1.2 Released

Started by Grudge, February 10, 2007, 07:36:03 AM

Previous topic - Next topic

Oldiesmann

Quote from: nokonium on February 15, 2007, 02:04:37 PM
I have a test board where I work on Tiny Portal. It is 1.1.1 and the only mods installed were TP 0.97 and Advanced Visual Verification. When the patch came out I installed it via the feed into the Package Manager and on test it failed where expected, so I uninstalled the AVV and it updated without any errors. When I wanted to test a TP 0.98 alpha, I uninstalled TP 0.97 (for 1.1.1) and re-applied the patch. On trying to install TP 0.98 I got the package is corrupted etc. although the package_info file includes install and uninstall info for 1.1.2. To install it I had to uninstall the patch, install TP 0.98 and re-apply the patch.

As 1.1.1 board I have no problems installing mods or themes, as 1.1.2 I am having problems, is this a server problem or a result of one of the security loopholes patched in 1.1.2?


As a postscript, I do not think that the Visual Verification improvements in 1.1.2 are good enough, I still want to use the AVV Mod.

Not sure why you ran into problems installing 0.98 after upgrading to 1.1.2.

We were not trying to make the AVV mod obsolete with the changes to the visual verification system - we simply added some much-needed improvements as the original system had some flaws (it didn't work on all servers and was sometimes difficult to read).
Michael Eshom
Christian Metal Fans

PacificWx

Very easy to upgrade - one click and in a matter of seconds it is done - thank you team!

Stuart

Thanks for this great update. I now got rid of any errors I use to have with 1.1.1  :D

nokonium

Quote from: Oldiesmann on February 15, 2007, 02:23:16 PM
Not sure why you ran into problems installing 0.98 after upgrading to 1.1.2.

We were not trying to make the AVV mod obsolete with the changes to the visual verification system - we simply added some much-needed improvements as the original system had some flaws (it didn't work on all servers and was sometimes difficult to read).

I realise that and it is better than it was, however I still feel that in my boards circumstance we need the Advanced version. We get lots of these in the error log

QuoteThe letters you typed don't match the letters that were shown in the picture.
?action=register2

One russian 'bot' tried to register 8 times 12/13 Feb. 'Don't match' is how I want to keep it.



Shadow Queen

I update my forum and didn't have any problem's at all.  But i downgrade the forum back to a 1.1.1 because i am waiting on few mod's and TP...

PTVDesign

you need hxxp:webtmpl.com [nonactive]

Shadow Queen

Yes, It's is a awesome forum!!!

Spritje

Flawless update, thanks a lot.

I have made many modifications, but had 1.1.2 up and running in a few hours. Great work. SMF support is simply amazing.

SticKer

thanks, this upgdate installed without any problem from 1.1.1 to 1.1.2

TimN

Quote from: jdwaso on February 14, 2007, 12:21:08 PM
I have used SMF, and decided to host a forum from my friend using SMF as its great. But am I the only person who cant install ANY packages from that third party thing accessed via the control panel being told.. "The package you are trying to download or install is either corrupt or not compatible with this version of SMF."

Is this cos this release is "too new"?

I recently started having this problem myself. I simply downloaded the zip files or gz files to my local computer then used the package manager to upload those files. It was a simple enough work around. I'm not sure if the problem showed up after the update to 1.1.1 or if it was out of the blue.


My problem with SMF and the update process is this:
I'm running a different forum with phpBB and a lot of custom written pages. When will there be a conversion program written to rewrite all my custom pages to make them work with SMF as actions? LOL
I'm very pleased with SMF so far and the simplicity it brings to running a forum based site. I've been recommending SMF to anyone who asks which forum software is best to use. The update went without a hitch, even though I've rewritten some of the default templates and the forum has quite a few mods installed.
Thanks,
Tim

margarett

QuoteI'm running a different forum with phpBB and a lot of custom written pages. When will there be a conversion program written to rewrite all my custom pages to make them work with SMF as actions? LOL

Most likely not :P
I had a similar problem, but have only one custom page. The best thing to do is to use the help. In my case, a "sub-action" inside help was enough. But in your case, maybe you need to create a custom action. And the best way to do it to custom pages is to use the help template...
Se forem conduzir, não bebam. Se forem beber... CHAMEM-ME!!!! :D

QuoteOver 90% of all computer problems can be traced back to the interface between the keyboard and the chair

stummihouse

Hi.

i dont see the attached patch file in the first post....

SleePy

Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

kingemissary

I'm getting a line 313 debug error when I would navigate to any thread.  There are no packages installed and I have installed the update on four smf's and they all do it.

Ninoslav

Worked flawlessly on both of my forums except for the Pll template which i had already edited (found bug)...
∑∆T M∑! :)

kingemissary

      document.getElementById("quickmodSubmit").style.display = "none";

^ That's the offending line, so what should I do with it?

TimN

Quote from: jdwaso on February 14, 2007, 12:21:08 PM
I have used SMF, and decided to host a forum from my friend using SMF as its great. But am I the only person who cant install ANY packages from that third party thing accessed via the control panel being told.. "The package you are trying to download or install is either corrupt or not compatible with this version of SMF."

Is this cos this release is "too new"?

I found the fix to this problem here http://www.simplemachines.org/community/index.php?topic=141810.0.  Thanks to the hard working coders who make our lives so much easier.
Tim

jtbo

Quote from: Centreflunk on February 13, 2007, 02:30:49 PM
Hi SMF Crew,
Trying to upgrade to 1.1.2 through Package Manager, I get the following message.
Last week I "manually" installed YouTube Mod.
Any idea ???

!!
Error in Package Installation
At least one error was encountered during a test installation of this package. It is strongly recommended that you do not continue with installation unless you know what you are doing, and have made a backup very recently. This error may be caused by a conflict between the package you're trying to install and another package you have already installed, an error in the package, a package which requires another package that you don't have installed yet, or a package designed for another version of SMF.

Type                                      Action                                       Description
1.   Execute Modification         smf_1-1-2.mod                     Modification parse error
2.   Execute Modification         smf_1-1-2_can_fail.xml          Modification parse error
3.   Execute Modification   -                                              Modification parse error

I'm getting same errors.

vetdan

Thanks...very easy install.  Your forum has been a great tool for us.  Thanks for all you do.

tourbi

Thank you. One forum updated easily from packages within the admin area.

The other one, I had to download and add the upgrade. It went just fine. I was really hoping this would fix the packages problem of not working, it didn't.

I'm still pleased. Thank you

Advertisement: