• Welcome to Simple Machines Community Forum. Please login or sign up.
October 22, 2021, 03:57:59 AM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


RSS Feed Poster

Started by SMFHacks.com Team, January 11, 2007, 07:46:04 PM

Previous topic - Next topic

perro88

Quote from: bjraines on May 16, 2008, 02:38:19 PM
Quote from: vbgamer45 on May 02, 2008, 09:55:29 PM
Quote from: bjraines on May 02, 2008, 05:25:55 PM
Do you have any ideas of why it won't process ebay affiliate feeds. I use something similar with drupal nodeapi and it will make a new node out of each ebay listing. It seems to fail with feed poster. I would like to use it this way with a car site I have
I would need to see the feed url.


Here is the feed URL:

http://rss.api.ebay.com/ws/rssapi?FeedName=SearchResults&siteId=0&language=en-US&output=RSS20&from=R34&satitle=gi+joe&sacat=1167
try to add the code I posted before and enable html in the feed

bjraines

Quote from: perro88 on May 16, 2008, 02:54:24 PM
Quote from: bjraines on May 16, 2008, 02:38:19 PM
Quote from: vbgamer45 on May 02, 2008, 09:55:29 PM
Quote from: bjraines on May 02, 2008, 05:25:55 PM
Do you have any ideas of why it won't process ebay affiliate feeds. I use something similar with drupal nodeapi and it will make a new node out of each ebay listing. It seems to fail with feed poster. I would like to use it this way with a car site I have
I would need to see the feed url.


Here is the feed URL:

http://rss.api.ebay.com/ws/rssapi?FeedName=SearchResults&siteId=0&language=en-US&output=RSS20&from=R34&satitle=gi+joe&sacat=1167
try to add the code I posted before and enable html in the feed


I am sorry I must have missed it, what code?

perro88

May 16, 2008, 03:02:07 PM #822 Last Edit: May 17, 2008, 11:40:50 PM by perro88
http://www.simplemachines.org/community/index.php?topic=141776.msg1545893#msg1545893
well your ploblem is because the feeds are in html, nop?

Afro

Hello, i have installed the news feed mod but i cant see the link under configuration. i am using dilber mc theme. there is a blank space created under the configuration . so i gues there is something i need to add in the index template php or somewhere to make it appear. can some one help me pls..i am new to smf..

christicehurst

Quote from: christicehurst on May 13, 2008, 12:42:19 PM
Quote from: christicehurst on May 11, 2008, 10:54:19 AM
Quote from: vbgamer45 on May 11, 2008, 10:29:36 AM
Not sure it uses the createpost function I think that should do it by itself.

I recounted the forum stats a couple times. It shows the post count increases and the post count of the bot user. But the monthly posts for that current period doesn't get updated. Is that somewhere where I can change that?

Quote from: vbgamer45 on May 11, 2008, 10:29:36 AM
Not sure it uses the createpost function I think that should do it by itself.

I'm hoping for some more answers and thoughts into this issue.

For f__k sake seriously. It's been over a week and a simple issue like this should be solved.
www.brisbanelionsunited.com - A forum for everyone!

mymktp1

... A few days ago I was able to run this mod with no problems ...well at least  I thought I was... however , I can not get it to load any new feeds~! Even when I add a new feed it won't load... I am using fake crons... and every time I run cronrss.php it just says "Feed Poster Configuration" can any one help me I checked the log and I get this error...

8: Undefined index: id
File: /hsphere/local/home/xxx/xxx.net/smf/Sources/FeedPoster.php
Line: 264

Medalist

It's really a great mod, but i have a little problem.

If i set hxxp:www.wowblues.com/feed.xml [nonactive] as feed URL, it's working as intended and makes posts.

But i want to get them from hxxp:www.wowblues.com/feed-xml.php [nonactive] URL, so that i can show some other tags in the forum posts like Author, type, area etc.

How is it possible to do this? Cause the site, which broadcasts the XML feed, says (hxxp:www.wowblues.com/spread.php [nonactive]  on the bottom of page) there are more available tags to use from that XML feed.


Heartlander

May 19, 2008, 05:05:48 PM #827 Last Edit: May 19, 2008, 05:14:20 PM by Heartlander
Database Error
Table 'heartland.smf_feedbot' doesn't exist
File: /usr/home/bassman/public_html/heartland/smf/Sources/FeedPoster.php
Line: 56

Please advise.

Heartlander

Nothing for support on this mod?

vbgamer45

You did not create the database tables you need run the sql file to create the database entires.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Heartlander


Heartlander

Has anyone figured out a way to accept all or most of the HTML tags that most RSS feeds spit out?
SMF by default allows only basic tags.

I need to know where to change these parameters.

Thanks much.

Xarcell

Is there easy changes to make this work with the new beta that I can do manually?

Heartlander

I found out an admin can add the [ html][ /html] tags in a post, but it does no good for cron jobs, or the RSS feeder at all.

Angie on Dialysis

Okay I added a few RSS2 (XML) feeds but I don't see any feeds in my news posts even though I specified where they go and who the poster is. When do I see feeds?

I selected "Use fake Cron jobs. Checks if feeds need to be updated on each page load." as that is an option and I know nothing about crons ..

Am I missing something??

http://angieskidney.com/smfbb/cronrss.php

Heartlander

It should run if you point your browser to that link you provided.

Angie on Dialysis

Quote from: Heartlander on May 24, 2008, 10:20:58 PM
It should run if you point your browser to that link you provided.
Oh wow thanks! It did! I didn't know it would finally do it at exactly 6:02pm Eastern time! lol Thx! :) It worked!!

Heartlander

Yeah, for some reason my fake cron jobs don't update on new visits, or work at all for whatever reason...but manually pointing to the link does it.

roberto174

How can i configure the Mod to post the feeds in a pecified Thread, i don't like him to create a separate thread for each item ?

Heartlander

Quote from: roberto174 on May 25, 2008, 12:09:17 PM
How can i configure the Mod to post the feeds in a pecified Thread, i don't like him to create a separate thread for each item ?
Doesn't appear to be possible.
What you might want to do is create and specify a "News" board where they will all get posted to.

Advertisement: