• Welcome to Simple Machines Community Forum. Please login or sign up.
October 19, 2021, 03:03:33 PM

News:

Wondering if this will always be free?  See why free is better.


Tidy Child Boards

Started by Arantor, December 09, 2009, 04:00:36 AM

Previous topic - Next topic

Dr3amstor

Works perfect on the default theme curve but cant get it to work on the black rain template.

Any help, thanks.

Shambles

Quote from: Dr3amstor on August 02, 2012, 08:29:54 AM
...cant get it to work on the black rain template.
That's not a great deal for us to go on :(

Works fine on my BlackBox theme, which is very similar to Rain.

Dr3amstor

Quote from: Shambles™ on August 02, 2012, 08:49:57 AM
Quote from: Dr3amstor on August 02, 2012, 08:29:54 AM
...cant get it to work on the black rain template.
That's not a great deal for us to go on :(

Works fine on my BlackBox theme, which is very similar to Rain.

What I mean is that the child forums do not show in columns but linear.

Dr3amstor

I got it sorted.

Thank you

zappadoc

where to find Tidy Child Boards 1.3 for 2.0 RC3?
thanks

Spoogs

Not supporting that version but if you really need it, it should still be in the package just use version emulate. I don't think there were any code changes anyway.

phpshiva

iff i use more than one column its all on the right side of the page and not left
How can i fix this?

phpshiva

still no one who knows how to fix this?
its showing under last message on the right side and needs to be left

tweetledee

hi.

this seems like a very useful mod for me, but it doesn't seem to work with my theme. (see image)

which file should look into editing to make them appear in columns?... it seems (as shown in the screen grab) that it's trying to do something with the line breaks in between the sets of intended columns.

thanks.

tweetledee

got it fixed.

found this post in the thread:

Quote from: nubieteky on March 07, 2011, 09:58:47 PM
Hi Sir Now  is working perfectly (transferred the file to default themes folder)!!! The childboards adjusts to a strategical position if I add a new sub-board. no spaces in between now!

How could i thank you more..........   ;D

checked out the tidyboard.css in default theme -- the code got really chopped for some reason when it got installed, i'm guessing. copy and pasted original css and it works as it should.

very useful mod. thanks.

phpshiva

Still after all this time waiting for solution about my problem


How to fix this?

Crozz

Is there any way this mod can be made to work in SMF 2.0.3?
It kinda messed up the forum when I tried to emulate it to 2.0.2

Hristo

The mod works just fine in 2.0.3. Emulation is completely harmless to the forum, it does not revert it's code to the emulated version.
There is a way to install it without emulation:
First, open the mod archive, then open the package-info.xml file. Find these 2 lines:
<install for="2.0, 2.0.1, 2.0.2">
and
<uninstall for="2.0, 2.0.1, 2.0.2">

And change them like this, then save:

<install for="2.0, 2.0.1, 2.0.2, 2.0.3">
and
<uninstall for="2.0, 2.0.1, 2.0.2, 2.0.3">

Crozz

Quote from: Hristo on December 27, 2012, 09:30:35 PM
The mod works just fine in 2.0.3. Emulation is completely harmless to the forum, it does not revert it's code to the emulated version.
There is a way to install it without emulation:
First, open the mod archive, then open the package-info.xml file. Find these 2 lines:
<install for="2.0, 2.0.1, 2.0.2">
and
<uninstall for="2.0, 2.0.1, 2.0.2">

And change them like this, then save:

<install for="2.0, 2.0.1, 2.0.2, 2.0.3">
and
<uninstall for="2.0, 2.0.1, 2.0.2, 2.0.3">


Thank you, that did the trick :)

Arantor

All you're doing by editing the package-info.xml file is avoiding using emulation - they do *exactly* the same thing - just override the version that the package parser is going to select.
No good deed goes unpunished
All helpful urges should be circumvented

Frank Hunt

I love this mod but it doesn't work for the current version.  Any chance of updating it?

live627

Oh look,, someone else doesn't read! trolllface.png

Frank Hunt

Quote from: live627 on March 20, 2013, 02:28:44 AM
Oh look,, someone else doesn't read! trolllface.png

Crap, my bad.  I'll actually read and do what he says.

Biology Forums

I currently have it on three columns. However, there are some boards that only have one child board; by putting it into a three column configuration, the parent that has that one child board looks all squished. Is there a way of setting up those parents with one child board not to be in columns? (i.e. have a width of 100%)

If(parent contains 1 child) echo'

floor(width: 100%)

else

floor(100/$modSettings['tidy_child_boards']%)

if(empty($context['added_tidy_header']) && !empty($modSettings['tidy_child_boards']) && $modSettings['tidy_child_boards'] > 1) {
if(empty($context['html_headers']))
$context['html_headers'] = '';
$context['html_headers'] .= '
<link rel="stylesheet" type="text/css" href="' . $settings['default_theme_url'] . '/tidyboards.css?1110" />
<style type="text/css">.tidy_child { width:' . floor(100/$modSettings['tidy_child_boards']) . '%; }</style>';
$context['added_tidy_header'] = 1;
}

Arantor

Not without a more complex overhaul from what I remember and it's been a long time since I originally wrote this... :/
No good deed goes unpunished
All helpful urges should be circumvented

Advertisement: