• Welcome to Simple Machines Community Forum. Please login or sign up.
December 07, 2021, 04:38:38 PM

News:

Wondering if this will always be free?  See why free is better.


Mambo Integration

Started by Chris G., November 03, 2004, 05:49:41 PM

Previous topic - Next topic

Chris G.

My Mambo/SMF integration is proving, unfortunately, a bit disastrous.  I have followed the readme instructions to the letter, but the login and logout functions don't quite work properly:  I'm logged into SMF but not into Mambo.  I also can't log out, nor is the user menu showing up.

http://oceania.freeprohost.com/site

Any help would be greatly, greatly appreciated.  Thanks :).

Kindred

Chris,

this is a known issue. I have reported the same thing. Please check the other Mambo thread (mambo open source) http://www.simplemachines.org/community/index.php?topic=6344.0
(all 23 pages of it)
for similar discussions and possible resolutions....


Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Chris G.

I'm terribly sorry.  Thank you.

-Chris

P.S. I had the vain hope that I wouldn't have to search through the thread :P.  Oh well...onward!

yardbird

Chris,

When I had this problem it was because I had done the whole integration correctly but I was using the wrong method for linking to SMF from Mambo. (I was doing it like I always had)

I believe you need to create a new menu item that links to the SMF component (not a component item, not wrapped, etc)

ALSO... the original Mambo login module should be UNpublished (don't delete it!) and the SMF/Mambo login module should be published.

Once I took care of those I was ok.

Kindred

Well, I hate to disagree, but I still have the issues and am working with Orstio to solve them...

I have the forums published as a Component Menu item...  Not link - component, just component.
I have the mambo login unpublished
I have SMF login published...

things still take about 30+ minutes of being logged in for Mambo to recognize that a user is atually logged in.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Chris G.


Kindred

Chris,

it will log out...

However, the bridge is still not quite bridging...

You will log out of SMF, and then you have to log out of Mambo...   or wait 30+ minutes and Mambo will recognize the logout (just like the login)
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Chris G.

I'll take the wrapper :).  Thanks for all your help, though!

-Chris

Advertisement: