• Welcome to Simple Machines Community Forum. Please login or sign up.
October 28, 2021, 05:27:11 AM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


SimplePortal

Started by SimplePortal Team, March 10, 2008, 11:16:07 PM

Previous topic - Next topic

[SiNaN]

Quote from: maxdg on March 15, 2008, 12:47:29 PM
QuoteI've found the error. It appears only when avatars are disabled in the news.

Great, good job!

I disabled avatars because they overlaying the text.. but only if measures aren't standard.
The working theme you link to me has little avatars..

I think we can set the avatar width. If we can do that, will everything would be okay?
Former SMF Core Developer | My Mods | SimplePortal


maxdg

March 16, 2008, 10:52:31 AM #42 Last Edit: March 16, 2008, 10:58:51 AM by maxdg
Quote from: [SiNaN
I think we can set the avatar width. If we can do that, will everything would be okay?

I think it would be GREAT!
;)

I taked a look around and didn't noticed anything else, except for a little bridging issue with Joomla when I'm on Admin -> Option and Settings page and try to save.

Everything's OK when I'm on www.mysite/forum (directly in SMF with no template integration) but if I'm in the wrapped view I can't save settings because of a :

Unable to load the 'main' template

error..


[SiNaN]

Quote from: maxdg on March 16, 2008, 10:52:31 AM
I think it would be GREAT!
;)

I taked a look around and didn't noticed anything else, except for a little bridging issue with Joomla when I'm on Admin -> Option and Settings page and try to save.

Everything's OK when I'm on www.mysite/forum (directly in SMF with no template integration) but if I'm in the wrapped view I can't save settings because of a :

Unable to load the 'main' template

error..

I'll look at that avatar issue.

Ummm... Don't have any idea about the bridges. But I'll look at that also.
Former SMF Core Developer | My Mods | SimplePortal

maxdg

Thanks a lot for your care .. ;)

Lil Puppy

I like this portal and my members want it very much but I can't use it on my live server :(

For some reason it wont read the language file entries for the text that it uses. See attached images.

I can get it to work perfectly on my home computer server for testing, but when I install it on my hosted server it refuses to show the text for the portal. I've tried manually installing on a fresh SMF 1.1.4 install with no other mods and it still wont work on the hosted server. I'm just getting into PHP so I'm having problems finding the reason for it.

Please help thanks :)

hxxp:presearing.com/test/ [nonactive]

[SiNaN]

Try adding the text strings to the utf-8 language files also.
Former SMF Core Developer | My Mods | SimplePortal

jusplay77

March 17, 2008, 07:44:55 AM #47 Last Edit: March 17, 2008, 07:46:52 AM by jusplay77
Is it possible to add a recently purchased items block to the simple portal? 

The original mod that shows it in the shop is located here:
http://www.daniel15.com/forum/index.php/topic,1219.0.html

However the creator is not around anymore to my knowledge.  The code is there just the same to look at and modify to include with the SimplePortal though I would assume.

Lil Puppy

March 17, 2008, 08:11:25 AM #48 Last Edit: March 17, 2008, 08:59:35 AM by Lil Puppy
Quote from: [SiNaN] on March 17, 2008, 06:58:15 AM
Try adding the text strings to the utf-8 language files also.

Thank you very much :)
I added the language file additions to the appropriate utf8 files and copied the SPortal.english.php file as SPortal.english-utf8.php and it works great now.

Suggestions for future versions:
* utf8 support ;)
* Better Avatar display coding. (have it check the avatar max size setting instead of hard coding it)
* Ability to turn on or off each of the items in the blocks on the left side. (like Karma, IP address, etc.)

[SiNaN]

Quote from: jusplay77 on March 17, 2008, 07:44:55 AM
Is it possible to add a recently purchased items block to the simple portal? 

The original mod that shows it in the shop is located here:
http://www.daniel15.com/forum/index.php/topic,1219.0.html

However the creator is not around anymore to my knowledge.  The code is there just the same to look at and modify to include with the SimplePortal though I would assume.

I have added it to the mod page as SimplePortal_Shop.

http://custom.simplemachines.org/mods/index.php?mod=1104

Quote from: Lil Puppy on March 17, 2008, 08:11:25 AM
Quote from: [SiNaN] on March 17, 2008, 06:58:15 AM
Try adding the text strings to the utf-8 language files also.

Thank you very much :)
I added the language file additions to the appropriate utf8 files and copied the SPortal.english.php file as SPortal.english-utf8.php and it works great now.

Suggestions for future versions:
* utf8 support ;)
* Better Avatar display coding. (have it check the avatar max size setting instead of hard coding it)
* Ability to turn on or off each of the items in the blocks on the left side. (like Karma, IP address, etc.)

Not at all. But I couldn't understand the avatar issue.
Former SMF Core Developer | My Mods | SimplePortal

Lil Puppy

What I meant is that in your coding for the avatar display in the News section it is set at a static number of pixels (80px maybe?). What I suggested is that it checks to see what you have your maximum avatar size settings at in the $modSettings array and set the width of the <td> to +10px larger so that all avatars will fit in that area instead of just the default size avatars (some of us like to use larger avatars for our members, mine is set to 100x100 for example).

This is what I have it set at in the SPortal.template.php
if($modSettings['nshowavatar'])
// $modSettings['avatar_max_width_external'] a setting to set the width by.
// the code below simply adds 10 to the width setting so the <td> will be large enough for the avatar and have some padding.
$avatar_max_table_width=$modSettings['avatar_max_width_external'] + 10;
echo'
<td width="', $avatar_max_table_width, 'px">', $news['avatar']['image'], '</td>';
echo '
<td>

[SiNaN]

Hımmm, I understand. I'll add this also. Thanks. ;)

Soon comes the SMF Gallery Random Picture Block. 8)
Former SMF Core Developer | My Mods | SimplePortal

jusplay77

QuoteI have added it to the mod page as SimplePortal_Shop.

http://custom.simplemachines.org/mods/index.php?mod=1104

Brilliant!  Thanks for the add!

QuoteSoon comes the SMF Gallery Random Picture Block.

Awesome!  Can't wait!

~~

Also, what about a "Game of the Day" add-on (SMF Arcade) - shown below:


[SiNaN]

I'll look at the arcade also. :)
Former SMF Core Developer | My Mods | SimplePortal

maxdg

Quote from: Lil Puppy on March 17, 2008, 10:46:51 AM
This is what I have it set at in the SPortal.template.php

Good, but you have the option "show hide avatar in News" disabled, this way.. or better, it doesn't work..

denzil69

March 18, 2008, 02:53:11 PM #55 Last Edit: March 18, 2008, 04:05:09 PM by denzil69
this looks like a top mod.

im using 1.1.4 default, would it be possible for one of the blocks to include a numbered calendar thats linked to the main calendar.

block has numbers and month/year in it, when an event or holiday the number shows as a link, when you mouse over it, it gives a brief description for example.

many thanks

EDIT: unable to install this mod;

./Sources/ModSettings.php - test failed
./Themes/default/index.template.php - test failed

Using smf 1.1.4 default theme with a few basic mods installed.

oh well...

[SiNaN]

Quote from: maxdg on March 18, 2008, 10:55:09 AM
Good, but you have the option "show hide avatar in News" disabled, this way.. or better, it doesn't work..

This is the correct code:

SPortal.template.php

Find:

if($modSettings['nshowavatar'])
echo'
<td width="80px">', $news['avatar']['image'], '</td>';


Replace:

if($modSettings['nshowavatar'])
{
$avatar_max_table_width=$modSettings['avatar_max_width_external'] + 10;
echo'
<td width="', $avatar_max_table_width, 'px">', $news['avatar']['image'], '</td>';
}


denzil69, calendar is also in my list. Just some time I need. :)

You should install the mod manually I think.
Former SMF Core Developer | My Mods | SimplePortal

jusplay77

Thanks for the fix.  I am now able to use avatars on the portal news :D

thenerd

Hi,

Maybe I missed something but is there a tutorial on how to integrate this portal with a theme other than the default? I don't want to use the default theme but would like to use the SimplePortal if possible.

Thanks
hxxp:www.techalpha.net/index.php?referredby=1 [nonactive]

denzil69

If i upload the mod manually (ie not via the smf admin) wont i still have the errors that are showing on the test as failed?

Advertisement: