• Welcome to Simple Machines Community Forum. Please login or sign up.
November 29, 2021, 09:37:30 AM


Wondering if this will always be free?  See why free is better.

Unable to load the main template

Started by sektor, February 08, 2007, 08:06:45 AM

Previous topic - Next topic


I had the same exact problem, thanks for the fix :) For me it worked fine until 1.1.7 as well, but this one line of changed code fixed it.



I had this error until this moment in "Layout and options" (in the admin panel), and I fixed replacing this line in smf.php (the Orstio solution)

$nqsefurl = substr($nonsefurl, 0, strpos($nonsefurl, 'option')) . preg_replace('/(\;)([^=#]*)([#"])/', '$1$2=$2$3', substr($nonsefurl, strpos($nonsefurl, 'option'), strlen($nonsefurl)));


$nqsefurl = substr($nonsefurl, 0, strpos($nonsefurl, 'option')) . preg_replace('/(\;)([^=#]*)([\;#"])/', '$1$2=$2$3', substr($nonsefurl, strpos($nonsefurl, 'option'), strlen($nonsefurl)));

The com_smf version is 1.1.7, I updated it today and this code line isn't fixed.


Where is this SMF.PHP file located, and where is this bridge.smf.php file located?  I can't find these files to edit the lines...


in the component directory of mambo
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."