• Welcome to Simple Machines Community Forum. Please login or sign up.
October 22, 2021, 07:09:18 AM

News:

Want to get involved in developing SMF, then why not lend a hand on our github!


[3354][IE8] Problems with text box scroller/cursor moving.

Started by Adam112, May 08, 2009, 09:46:18 PM

Previous topic - Next topic

Adam112

May 08, 2009, 09:46:18 PM Last Edit: September 06, 2009, 03:22:13 PM by karlbenson
Hi, first-time poster here -- I'm part of a SMF 1.1.8 based forum elsewhere.

I've found that on that forum, if I type a long enough post (roughly 2-3 lines past where the text box normally ends), the text box begins to act up on me.  If I type anything beyond that point, the viewed part of the text seems to "hop" up a few lines from where I am typing and I can only briefly see the line I am typing, at the very bottom of the box, for the few milliseconds during which time I press the letter key(s).  This is very annoying when writing a post, editing a post, and selecting text in the box to cut or copy.

The box will even hop up a couple of lines if I move my cursor out of the box and over one of the various formatting buttons above it.

This started maybe a week or two ago, and even when I downloaded the new I.E. 8 (8.0.6001.18702 to be exact) it didn't solve the problem.  I'm thinking that maybe the forum admins changed something regarding the text box but I'm not sure if they did.  (It's even happening when I go farther down in the text boxes here.  Gah.)

Is this some compatibility problem between IE and SMF code?  Any insight you might have would be a big help.

Thanks,

karlbenson

We have an existing bug report on this
http://dev.simplemachines.org/mantis/view.php?id=3354

However recent discoveries by both myself and smf user Riker suggest that this is a known IE 8 bug.


Bilbo1960

June 08, 2009, 06:27:12 AM #2 Last Edit: June 08, 2009, 02:10:05 PM by regularexpression
I have recently installed SM forum on my site. I'm using IE8, Windows XP and the default theme.

When I type in long texts or paste in texts in the topic text area (eg. inserting quoted previous poster above text) the text area starts to "jump" and the last line disappears below the bottom of the text area, which makes it difficult to continue typing in text.

Is this a bug or is there a simple solution to this?

By the way, it happens in this text area too if I paste more text in above! So it's not my setup at my site.

Can you help?

karlbenson

This is an IE8 bug.

Many software scripts including smf, phpbb and many others have been scrambling to find a hack/fix until Microsoft patches it.

We have an existing bug report on our tracker.
For 2.x I posted two possible fixes (in the last comment)
http://dev.simplemachines.org/mantis/view.php?id=3354

scottb

Yeah, in IE8 at the top to the right of the address bar you'll see an icon of a torn in half piece of paper. Click on that which will turn on compatability mode and should solve that issue.

karlbenson


Gent

Microsoft is now upgrading their users to Internet Explorer rev. 8 as part of the automatic upgrades.

When typing new messages that are longer than the number of lines in the input box (that's when the scroll bar appears) the cursor and text nervously start to jump up and down.

I've had this reported by a few of my forum members a few weeks ago. Now that I upgraded to IE8 I have the same problem. So I don't know if this is a bug in the Simple Machines software or in IE8. Althouh the problem does not appear on other blog sites.

Note: Even when typing this message I encountered the problem

Aleksi "Lex" Kilpinen

IE8 does that - But if you switch to compatibility mode ( the "IE7" mode ) it should not do it anymore.



[3354][IE8] Problems with text box scroller/cursor moving.
A Finnish Project Manager (Support Specialist)
 Happily running multiple SMF 2.x installations.
  Fooling around with i7-10700 @ 2,90GHz-4.80GHz / 16Gb / RTX-2070 Super / 3840x2160 / Win 10 x64


How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Gent

That is correct. It works fine in compatibility mode. I discovered that after I posted here. (Google is your best friend)

I just wanted to report the bug as at some point we'll have to be compatible with what Microsoft dicates, I guess.

Daniel Hofverberg

Quote from: regularexpression on June 08, 2009, 02:09:46 PM
We have an existing bug report on our tracker.
For 2.x I posted two possible fixes (in the last comment)
http://dev.simplemachines.org/mantis/view.php?id=3354
Are there any usable workarounds for SMF 1.1.9 for this problem? The code given in the bug tracker is not directly usable in 1.1.9.

cc4digital

July 02, 2009, 06:50:21 PM #10 Last Edit: July 04, 2009, 08:37:10 AM by regularexpression
If you are in new topic and your currsor reaches the bottom of the input box there is an issue of scrolling.  The scroll bar trys to stay at the top.  Thus as you type-- it jumps to the top and you can no longer see what you are typing.

If you put IE into compatability mode it work fine.

chuck

karlbenson

This is an IE8 Bug.  However we're hoping to temporarily patch it until MS fixes it.
(this doesn't just affect smf but any html page with any textareas which have a percentage width set.

(We already have an open bug report on this http://www.simplemachines.org/community/index.php?topic=309186.0 )

karlbenson


marcbo

Quote from: Daniel Hofverberg on June 22, 2009, 03:56:06 AM
Quote from: regularexpression on June 08, 2009, 02:09:46 PM
We have an existing bug report on our tracker.
For 2.x I posted two possible fixes (in the last comment)
http://dev.simplemachines.org/mantis/view.php?id=3354
Are there any usable workarounds for SMF 1.1.9 for this problem? The code given in the bug tracker is not directly usable in 1.1.9.

I cannot ask thousands of forummembers to turn on IE compatability mode
Any results yet? Did someone find a workaround for smf 1.1.x?

karlbenson

We have not yet adopted any solution.

Even with the examples within the bugreport, they only convered the standard reply window, not quick reply, nor quick edit.
(and any other text areas with percentage based widths set)

shires82

There are issues with the forum on IE8. When replying to a post the text input area refuses to scroll after a certain number of carraige returns. Although you are still able to type you cannot see the output. You can use the arrow keys to move down to view the text however as soon as you start typing the text displayed is from the starting paragraph (i.e. cannot see what you type / box focus moves)

karlbenson

This is an IE8 Bug.

We have a bug for it on our bugtracker to see whether we can potentially provide a temporary workaround fix until Microsoft patches it.

The easiest solution at the moment is to switch to IE7 (Emulated mode)

Vincent Volmer

Quote from: regularexpression on July 14, 2009, 01:32:12 PM
This is an IE8 Bug.

We have a bug for it on our bugtracker to see whether we can potentially provide a temporary workaround fix until Microsoft patches it.

The easiest solution at the moment is to switch to IE7 (Emulated mode)

Sorry to ask... but is this fixed with SMF2.0RC1.2?

Thanks, Vincent

karlbenson


Kays

If it's bothersome, a quick and dirty way to force IE8 to emulate IE7 is to add this line to the <head> in Index.template.php of the theme you are using.

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />

If at first you don't succeed, use a bigger hammer. If that fails, read the manual.
My Mods

Advertisement: