News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Issues with alerts

Started by chadon, March 12, 2022, 07:34:19 PM

Previous topic - Next topic

chadon

Since upgrading from 2.1 RC3 to 2.1.1. members of my forum are complaining because they don't receive alerts when there is an answer to their topics and sometimes they all arrive in same time.

Some say they resolve the issue when they delete all their read alerts and it starts again after a few days.
I also have the read alerts set to auto delete each week in the admin panel but nothing happens, I still have alerts from a couple weeks ago.

On Simplemachines, I subscribed to receive alerts for this section a few weeks ago but I never received any while many new topics have been created.
Is this a known bug ? I didn't find any topics about it.

chadon

Nobody else has issues with alerts with his forum?

Is it a know bug or is it just my forum?

Arantor

Perhaps it would have been better if I'd simply never bothered. Y'all clearly would be less unhappy that way.

chadon

Not as busy as it used to be. It has over 1 million total messages and 11 000 total members but now it has about 200 members online and 100 new posts each day.

chadon

Quote from: Arantor on March 15, 2022, 08:30:49 AMHow busy is your forum?
Did you have any idea?

Anyways, I confirm, the alert system is no more functional with SMF 2.1.1.

I don't receive any alerts for subscribed topics or boards on Simplemachines.org and two other forums running under SMF 2.1.1.

Aleksi "Lex" Kilpinen

That's kind of odd, because I do. On this forum. Have you checked your personal notification settings?
Slava
Ukraini!


"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

How you can help SMF

Kindred

I receive alerts/notifications on both this and the other 2 2.1.1 sites that I use....

I think your issue is related to something in your personal system....
Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

chadon

Do you receive alerts for topics and boards?

I did receive an alert on March 15 but it was for an updated "Team page" mod, nothing about this topic or the "SMF 2.1.x Support" board.

I also have many users saying they don't receive alerts since the 2.1.1 upgrade.

Illori

they need to set the alerts again for the topics they may have had on watch in SMF 2.0.

chadon

I havn't been using SMF 2.0 since about a couple years when 2.1 RC1 came out and everything was running fine until the 2.1.1 upgrade.

I also started to setup alerts here and on a 3rd forum only after they were upgraded to 2.1.1.

chadon

One month later, my forum has been updated to 2.1.2 and now nobody ever receives alerts.
One month later, Simplemachines has been updated to 2.1.2 and I still didn't receive a single alert.
Does anyone receive alerts other than Kindred ?

Arantor

Yes, I've had alerts today for posts of mine that people have liked.
Perhaps it would have been better if I'd simply never bothered. Y'all clearly would be less unhappy that way.

FrizzleFried

I get alerts here.  I had 3 this morning.


Doug Heffernan

Quote from: chadon on May 20, 2022, 12:36:19 PMOne month later, my forum has been updated to 2.1.2 and now nobody ever receives alerts.
One month later, Simplemachines has been updated to 2.1.2 and I still didn't receive a single alert.
Does anyone receive alerts other than Kindred ?

Personally I have not experienced any issues with alerts.

Aleksi "Lex" Kilpinen

I some times see some lag with alerts here, and then they suddenly come up all at once - but generally alerts work pretty well for me, both here and on my own forum.
Slava
Ukraini!


"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

How you can help SMF

Shades.

None today so far but got 9 or 10 yesterday! Seems to be working like it should! 8)
ShadesWeb.com - Custom Logos - My Themes on SMF | My Themes on ShadesWeb
https://shadesweb.com

BikerHound.com - Sniffing out the road ahead
https://bikerhound.com

Dream as if you'll live forever; Live as if you'll die today. - James Dean

shawnb61

We should dissect this one piece at a time.

If chadon isn't getting alerts here, let's start with that.  I'd first look at:
 - Confirm Notification settings
 - Confirm you're watching some boards/topics
 - Open the browser console - ensure there are no errors; alerts are dependent on .js

Once chadon starts seeing them here, then cut over to diagnosing the forum.

Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

chadon

I received an alert for this topic because Doug Heffernan quoted me but nothing about replies to this topic.

Quote from: shawnb61 on May 20, 2022, 02:21:32 PM- Confirm Notification settings
At the top and bottom of this topic it shows "receive alerts".

- If I go on my profile's watched topics list, it shows :
"Issues with alerts in SMF 2.1.x Support" = No Alerts or Emails

That doesn't make any sense.

- If I go on my profile's watched boards list, it shows :

Current Board Notifications SMF 2.1.x Support New       =  Alert Preferences :receive Alerts.

It shows a new icon because new topics are created regulary and I didn't read them but since I subscribed to this topic a month ago, I didn't receive a single alert.

On my forum, under the 2.1.1 version, I received alerts when I was quoted, when I was mentioned but never when a reply was posted.
Since the 2.1.2 update, I receive no alert at all, not even when I am quoted.

Quote from: shawnb61 on May 20, 2022, 02:21:32 PM- Confirm you're watching some boards/topics
I confirm

Quote from: shawnb61 on May 20, 2022, 02:21:32 PM- Open the browser console - ensure there are no errors; alerts are dependent on .js
The errors are :

  Failed to load resource: net::ERR_BLOCKED_BY_CLIENT lg.php:1

Failed to load resource: net::ERR_BLOCKED_BY_CLIENT show_ads.js:1

Unchecked runtime.lastError: The message port closed before a response was received.


Aleksi "Lex" Kilpinen

In your notification settings, you have selected "How frequently to tell me" as "never". Try changing that, and see if things look different?

Also, there are different levels of notification settings for topics that you can set for each topic separately.
Slava
Ukraini!


"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

How you can help SMF

chadon

Quote from: Aleksi "Lex" Kilpinen on May 21, 2022, 09:02:50 AMIn your notification settings, you have selected "How frequently to tell me" as "never". Try changing that, and see if things look different?
I changed it to immediately.

Quote from: Aleksi "Lex" Kilpinen on May 21, 2022, 09:02:50 AMAlso, there are different levels of notification settings for topics that you can set for each topic separately.
Yes, that's what I explaned in my previous message, it was and still is set to "receive alerts".

I will let you know if the "never" change fixes the issue.

Advertisement: