• Welcome to Simple Machines Community Forum. Please login or sign up.
October 23, 2021, 08:50:22 AM

News:

Join the Facebook Fan Page.


Errors during installation

Started by siavoshkc, August 17, 2017, 05:52:37 AM

Previous topic - Next topic

siavoshkc

When I installed SMF locally for the first time (and second time to be able to copy errors for this post), after it populated DB there were some errors as follows:
Quote
•   Line #130: ERROR: operator + already exists
•   Line #131: ERROR: operator <> already exists
•   Line #736: ERROR: syntax error at or near "s"
LINE 4: ...r_holidays (title, event_date) VALUES ('New Year\'s', '0004-...
^
•   Line #738: ERROR: syntax error at or near "s"
LINE 2: ..._holidays (title, event_date) VALUES ('Valentine\'s Day', '0...
^
•   Line #739: ERROR: syntax error at or near "s"
LINE 2: ...olidays (title, event_date) VALUES ('St. Patrick\'s Day', '0...
^
•   Line #744: ERROR: syntax error at or near "s"
LINE 2: ...dar_holidays (title, event_date) VALUES ('Mother\'s Day', '2...
^
•   Line #745: ERROR: syntax error at or near "s"
LINE 2: ...dar_holidays (title, event_date) VALUES ('Mother\'s Day', '2...
^
•   Line #746: ERROR: syntax error at or near "s"
LINE 2: ...dar_holidays (title, event_date) VALUES ('Mother\'s Day', '2...
^
•   Line #747: ERROR: syntax error at or near "s"
LINE 2: ...dar_holidays (title, event_date) VALUES ('Mother\'s Day', '2...
^
•   Line #748: ERROR: syntax error at or near "s"
LINE 2: ...dar_holidays (title, event_date) VALUES ('Mother\'s Day', '2...
^
•   Line #749: ERROR: syntax error at or near "s"
LINE 2: ...dar_holidays (title, event_date) VALUES ('Mother\'s Day', '2...
^
•   Line #750: ERROR: syntax error at or near "s"
LINE 2: ...dar_holidays (title, event_date) VALUES ('Mother\'s Day', '2...
^
•   Line #751: ERROR: syntax error at or near "s"
LINE 2: ...dar_holidays (title, event_date) VALUES ('Mother\'s Day', '2...
^
•   Line #752: ERROR: syntax error at or near "s"
LINE 2: ...dar_holidays (title, event_date) VALUES ('Mother\'s Day', '2...
^
•   Line #753: ERROR: syntax error at or near "s"
LINE 2: ...dar_holidays (title, event_date) VALUES ('Mother\'s Day', '2...
^
•   Line #754: ERROR: syntax error at or near "s"
LINE 2: ...dar_holidays (title, event_date) VALUES ('Mother\'s Day', '2...
^
•   Line #755: ERROR: syntax error at or near "s"
LINE 2: ...dar_holidays (title, event_date) VALUES ('Father\'s Day', '2...
^
•   Line #756: ERROR: syntax error at or near "s"
LINE 2: ...dar_holidays (title, event_date) VALUES ('Father\'s Day', '2...
^
•   Line #757: ERROR: syntax error at or near "s"
LINE 2: ...dar_holidays (title, event_date) VALUES ('Father\'s Day', '2...
^
•   Line #758: ERROR: syntax error at or near "s"
LINE 2: ...dar_holidays (title, event_date) VALUES ('Father\'s Day', '2...
^
•   Line #759: ERROR: syntax error at or near "s"
LINE 2: ...dar_holidays (title, event_date) VALUES ('Father\'s Day', '2...
^
•   Line #760: ERROR: syntax error at or near "s"
LINE 2: ...dar_holidays (title, event_date) VALUES ('Father\'s Day', '2...
^
•   Line #761: ERROR: syntax error at or near "s"
LINE 2: ...dar_holidays (title, event_date) VALUES ('Father\'s Day', '2...
^
•   Line #762: ERROR: syntax error at or near "s"
LINE 2: ...dar_holidays (title, event_date) VALUES ('Father\'s Day', '2...
^
•   Line #763: ERROR: syntax error at or near "s"
LINE 2: ...dar_holidays (title, event_date) VALUES ('Father\'s Day', '2...
^
•   Line #764: ERROR: syntax error at or near "s"
LINE 2: ...dar_holidays (title, event_date) VALUES ('Father\'s Day', '2...
^
•   Line #765: ERROR: syntax error at or near "s"
LINE 2: ...dar_holidays (title, event_date) VALUES ('Father\'s Day', '2...
^
•   Line #2302: ERROR: syntax error at or near "("
LINE 2: ...e, description, smiley_order, hidden) VALUES (':\'(', 'cry.g...
^

(I think the first lines didn't appear at the first time.)
Then after that instead of showing success I got a page with only these lines:
Quote
•   PHP Warning:  session_destroy(): Trying to destroy uninitialized session in C:\inetpub\test2\Sources\Subs-Auth.php on line 166
•   PHP Warning:  session_regenerate_id(): Cannot regenerate session id - session is not active in C:\inetpub\test2\Sources\Subs-Auth.php on line 170


So I manually increased the step in the address bar to see the final page. The forum started to work fine but I am afraid some day it may bump into a problem. Beside that it wasn't a clean install and I am a bit obsessive about that.
Persian Translator

Arantor

What database server? Also, are you running the SQL file directly or letting SMF run it?
No good deed goes unpunished
All helpful urges should be circumvented

siavoshkc

Quote from: Arantor on August 17, 2017, 07:06:44 AM
What database server? Also, are you running the SQL file directly or letting SMF run it?

Postgres on local machine. I created an empty DB and connected SMF to it.

EDIT: SMF v2.0.14, postgres v9.6.4
Persian Translator

Illori

how were you trying to populate the database?

siavoshkc

Quote from: Illori on August 17, 2017, 09:06:14 AM
how were you trying to populate the database?

I didn't. Installer did.
Persian Translator

shawnb61

Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

siavoshkc

Persian Translator

albertlast

In my opinion is the smf 2.0.x more worst than
smf 2.1 github version in the case of using postgres.

siavoshkc

Quote from: albertlast on August 17, 2017, 11:18:27 AM
In my opinion is the smf 2.0.x more worst than
smf 2.1 github version in the case of using postgres.

I have to use 2.0 for the meantime. Though I can change to MySQL.
Persian Translator

shawnb61

Your call.  I think mod support for pg is spotty.

I haven't installed pg in 2.0, but if I were trying, I'd update the corresponding *.sql file per the instructions in the post referenced above.
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

siavoshkc

Quote from: shawnb61 on August 17, 2017, 02:20:30 PM
Your call.  I think mod support for pg is spotty.

I haven't installed pg in 2.0, but if I were trying, I'd update the corresponding *.sql file per the instructions in the post referenced above.

I did it and it fixed the holidays, but not the page with
Quote•   PHP Warning:  session_destroy(): Trying to destroy uninitialized session in C:\inetpub\test2\Sources\Subs-Auth.php on line 166
•   PHP Warning:  session_regenerate_id(): Cannot regenerate session id - session is not active in C:\inetpub\test2\Sources\Subs-Auth.php on line 170
contents.
Persian Translator

albertlast

two possibilities:
something got wrong by the setup (maybe session table is missing)
or php 7 + pg doesn't work.

The solution keeps in my eyes use smf 2.1 ther you get the best expierence for you setup,
or take mysql and accept that this will be not best setup from performance point of view for smf 2.1 (when you upgrade).

Arantor

That's kind of sad given that 99.99% of all SMF installs aren't on Postgres.
No good deed goes unpunished
All helpful urges should be circumvented

albertlast

well we use 100% posibilities of mysql 5.0 and raised pg from 30%(30% ~ 100% mysql) to 60%.

So ask mysql that they support more sql function and raise the min mysql version to a reasonable version.


shawnb61

Given these issues, and given that many (most?) mods don't run on pg, I would go with mysql.   There is no way to determine pg support by mods that I know of other than trial and error.   

I would treat this install is a preview of things to come: lots of code tweaking to get things to work.
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

albertlast

Yes your are right,
the mod support is unknown.

I tested yesterday the like mod: http://custom.simplemachines.org/mods/index.php?mod=3708
the most work i needed was to get this thing running on smf 2.1.

And two changes was needed to support pg (i had to change native part to smf api calls).

Illori

since likes are part of SMF 2.1 that mod should not be installed on SMF 2.1.

albertlast

i'm not the right person to define if the like system which in smf 2.1 is good or not.

For me i want to understand how a mod works,
what are the issue when a mod came from 2.0 and
how it look when i want run this under pg.

siavoshkc

Persian Translator

siavoshkc

Isn't the problem because I didn't set standard_conforming_strings Poetgres option to off before installation as it was mentioned in the manual?
Persian Translator

Advertisement: