• Welcome to Simple Machines Community Forum. Please login or sign up.
October 18, 2021, 02:00:11 AM

News:

Wondering if this will always be free?  See why free is better.


Having Trouble Transferring hosts

Started by layedbaack, April 10, 2011, 01:26:04 AM

Previous topic - Next topic

layedbaack

so I took of the "}' and it worked...but I got a "404page not found"

Could this be because of the domain? and should I contact hostgator?

Adish - (F.L.A.M.E.R)

Meh! It is not detecting the index.php it seems.

If you do not mind, can you PM me your hostgator FTP details and I'll fix it for you?

layedbaack

Quote from: (F.L.A.M.E.R) on April 11, 2011, 09:22:49 PM
Meh! It is not detecting the index.php it seems.

If you do not mind, can you PM me your hostgator FTP details and I'll fix it for you?

Hey back,

It seems whenever i make an ftp account, Im not able to login so your going to have to use the cpanel info to login to ftp...

Also, the person the bought the pack from the host doesn't want me to share the cpanel details, so can you tell me how to fix it?

Im sorry if this causes any problems >.<

Adish - (F.L.A.M.E.R)

April 11, 2011, 10:22:59 PM #23 Last Edit: April 11, 2011, 10:27:22 PM by (F.L.A.M.E.R)
Well, the Settings.php is the main bit to fix in order to get the forum online.

Open your Settings.php
Code (Find) Select

########## Database Info ##########


Code (Add before) Select

<?php
/**********************************************************************************
* Settings.php                                                                    *
***********************************************************************************
* SMF: Simple Machines Forum                                                      *
* Open-Source Project Inspired by Zef Hemel (zef@zefhemel.com)                    *
* =============================================================================== *
* Software Version:           SMF 2.0 RC5                                         *
* Software by:                Simple Machines (http://www.simplemachines.org)     *
* Copyright 2006-2010 by:     Simple Machines LLC (http://www.simplemachines.org) *
*           2001-2006 by:     Lewis Media (http://www.lewismedia.com)             *
* Support, News, Updates at:  http://www.simplemachines.org                       *
***********************************************************************************
* This program is free software; you may redistribute it and/or modify it under   *
* the terms of the provided license as published by Simple Machines LLC.          *
*                                                                                 *
* This program is distributed in the hope that it is and will be useful, but      *
* WITHOUT ANY WARRANTIES; without even any implied warranty of MERCHANTABILITY    *
* or FITNESS FOR A PARTICULAR PURPOSE.                                            *
*                                                                                 *
* See the "license.txt" file for details of the Simple Machines license.          *
* The latest version can always be found at http://www.simplemachines.org.        *
**********************************************************************************/

########## Maintenance ##########
# Note: If $maintenance is set to 2, the forum will be unusable!  Change it to 0 to fix it.
$maintenance 0; # Set to 1 to enable Maintenance Mode, 2 to make the forum untouchable. (you'll have to make it 0 again manually!)
$mtitle 'Maintenance Mode'; # Title for the Maintenance Mode message.
$mmessage 'Okay faithful users...we\'re attempting to restore an older backup of the database...news will be posted once we\'re back!'; # Description of why the forum is in maintenance mode.

########## Forum Info ##########
$mbname 'My Community'; # The name of your forum.
$language 'english'; # The default language file set for the forum.
$boardurl 'http://www.deathtollscans.com/'; # URL to your forum's folder. (without the trailing /!)
$webmaster_email 'email@youremail.com'; # Email address to send emails from. (like noreply@yourdomain.com.)
$cookiename 'SMFCookie11'; # Name of the cookie to set for authentication.


Code (Find) Select

########## Directories/Files ##########

AFTER the WHOLE BLOCK with the correct paths there...

Code (Add After) Select

########## Error-Catching ##########
# Note: You shouldn't touch these settings.
$db_last_error = 0;


# Make sure the paths are correct... at least try to fix them.
if (!file_exists($boarddir) && file_exists(dirname(__FILE__) . '/agreement.txt'))
$boarddir = dirname(__FILE__);
if (!file_exists($sourcedir) && file_exists($boarddir . '/Sources'))
$sourcedir = $boarddir . '/Sources';
if (!file_exists($cachedir) && file_exists($boarddir . '/cache'))
$cachedir = $boarddir . '/cache';

?>

layedbaack

Thank you so much, it worked!  ;D

Should I try run the repair_settings.php again or should I configure everything myself from here?

Adish - (F.L.A.M.E.R)

Just open it and see if the paths are similar to the suggested. If they aren't, change it manually. Don't bother saving it via repair_settings.php ;)

I am glad that everything worked out fine now. :)

layedbaack

Okay,

And thanks for everyones replies, they really helped a lot!
Also, thanks for taking your time to help my forum and me  ;D It's really appreciated  :)

So I guess this topic is solved  :)



Advertisement: