Upgrading/Installing packages CHMODs home directory

Started by cypdevil, December 19, 2010, 02:12:47 AM

Previous topic - Next topic


It would seem that using any of the installation procedures that ensure all the required files are set to 777 also changes the permissions on the home directory to 777, up the tree. In my case, using an Apache host ISP, the hierarchy is:
The permissions for the directory <ID> are normally set to 705 but it appears that SMF is changing them to 777. My ISP (pair.com) informs me that this is a severe security issue because e-mail becomes readable world-wide. For this reason, the server automatically blocks e-mail if the ID directory is not permitted correctly.

I can't be sure, but I believe this CHMOD of the home directory possibly happens when the installation software asks for the server, ID, password and path or it may be shortly thereafter when it uses these data. This has happened to me several times and I have to ask the ISP to correct the permissions (it apparently can't be done through my FTP client).

If what I say is true, and I have every reason to believe it is, then this appears to be a security breach bug in the installation software. I cannot think of any other reason. Have others experienced similar difficulties?


smf can not change any file/folder permission for a folder/file that smf is not directly installed. so if you are not putting smf in the <id> folder then smf should not touch it. also smf works fine with permissions set 755 instead of 777.


Is this issue solved or do you still require assistance?  SMF will not change file/folder permissions as you described.  Instead it does it exactly as Illori stated.
Jim "JimM" Moore
Former Support Specialist


Quote from: Illori on December 19, 2010, 08:02:56 AM
so if you are not putting smf in the <id> folder then smf should not touch it.

But it does! I'm sorry, it is repeatable and demonstrable at any time with this particular server (ISP?), who accepts no responsibility, saying it is only SMF (and, in my experience, of over 100 apps installed, this is so) that causes the problem. How, I cannot say, but it does. Snoopy has seen a part of it, as he tried, unsuccessfully, to set a mod up on my computer, using TeamViewer. He was as flummoxed as I.

I have installed everything on a different ISP with an Apache server without this problem appearing.

So, the issue remains unsolved but I'm no longer pursuing it as my workaround is to use a different ISP, which is now nearly ready to go on line.

Baby Daisy

I will mark this as solved as you are no longer pursuing a solution.