Simple Machines Community Forum

Customizing SMF => SMF Coding Discussion => Topic started by: jindroush on May 25, 2004, 10:25:13 AM

Title: Problem with inserting of 'strange' characters?
Post by: jindroush on May 25, 2004, 10:25:13 AM
Hi,

What should happen when I write here strange characters? It seems they get converted to
ampersand hash three-digit-number semicolon

but then, they're converted to
ampersand amp semicolon hash number semicolon

so the display then looks like & # 434 ; what is wrong I think.

Test:
příšerně žluťoučký kůň pěl ďábelské ódy
PŘÍŠERNĚ ŽLUŤOUČKÝ KŮŇ PĚL ĎÁBELSKÉ ÓDY

Again, I was trying to find it on the forums, but were unable to make up a good query (not mentioning crashing of my Mozilla on certain pages, damn!)
Title: Re: Problem with inserting of 'strange' characters?
Post by: Oldiesmann on May 25, 2004, 11:25:25 AM
IE automatically converts non-standard symbols into HTML symbol code like that so that you don't have to have a specific language pack installed to view strange symbols (non-standard as in characters that aren't defined for the particular character set you're using. If you plan on using a lot of foreign symbols and don't want to worry about character-set issues, change the encoding to UTF-8 instead of ISO-8859-1. Check out http://www.iana.org/assignments/character-sets for a full list of character sets and places to get more information.
Title: Re: Problem with inserting of 'strange' characters?
Post by: [Unknown] on May 28, 2004, 07:46:38 PM
For this reason you should use an alternate character set in your language file to allow those characters.

-[Unknown]