Simple Machines Community Forum

Archived Boards and Threads... => Archived Boards => Parham's PHP Tutorials => Topic started by: LogWin on October 15, 2006, 10:47:12 PM

Title: Encoding problem
Post by: LogWin on October 15, 2006, 10:47:12 PM
Hi! Guys!

I have a problem.

I need to get some informaition from my old forum's backupfile.
The forum was in two languages English and Russian.
With english part there is no problem, but with the russian.., I could not read it because of encoding.

Maybe someone can give me a hint wich way I can make it readable?

Thank you.
Title: Re: Encoding problem
Post by: Dannii on October 15, 2006, 10:52:10 PM
Which version of SMF do you use? 1.1 RC3 has much greater internationalisation features, prehaps upgrade to it.
Title: Re: Encoding problem
Post by: LogWin on October 16, 2006, 12:41:46 AM
Which version of SMF do you use? 1.1 RC3 has much greater internationalisation features, prehaps upgrade to it.

Thank you for your reply!

But it is not about a forum.
It is just a file (backupfile of my old forum)
I need to get some information... .
Title: Re: Encoding problem
Post by: DBMark on May 16, 2008, 03:15:16 PM
Hello,
If this is a php/mysql thing you want to look into (and not a SMF issue), the following site may be helpful:
http://www.oreillynet.com/onlamp/bhttp://www.oreillynet.com/onlamp/blog/2006/01/turning_mysql_data_in_latin1_t.htmllog/2006/01/turning_mysql_data_in_latin1_t.html (http://www.oreillynet.com/onlamp/bhttp://www.oreillynet.com/onlamp/blog/2006/01/turning_mysql_data_in_latin1_t.htmllog/2006/01/turning_mysql_data_in_latin1_t.html)

I know on my own website I had difficulties displaying Spanish and German characters. Eventually I had to change the encoding of my fields in Mysql by altering the table
Good luck. If you get this cracked it will be an achievement.