Simple Machines Community Forum

Simple Machines => News and Updates => Topic started by: Compuart on October 29, 2006, 05:57:14 AM

Title: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Compuart on October 29, 2006, 05:57:14 AM
Simple Machines is happy to release a new update to Simple Machines Forum 1.0 and 1.1. This release addresses a cross-site scripting vulnerability in the search function. Also a few smaller issues have been addressed.

Note that the fix for the SMF 1.0.x branch will be released as new version 1.0.9, while the fix for the 1.1 RC3 branch will merely be released as patched version, the version of the forum will remain 1.1 RC3 (therefore, most of the modifications should remain compatible).

If you currently have installed 1.0.8 or 1.1 RC3, you can do either of the following to upgrade:
* Use the package manager in your administration center - one click, and you're done.
* Download the update archive file from the download page, and upload all of the files from it.
* Download the modification file, attached to this message, and modify the files manually according to it.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: anonim on October 29, 2006, 09:18:56 AM
and for the others who are still using 1.1 RC2?
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Compuart on October 29, 2006, 09:29:56 AM
Since most modifications have been made compatible for 1.1 RC3 by now, those still running 1.1 RC2 are advised to upgrade to 1.1 RC3 or to apply the changes manually.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Harzem on October 29, 2006, 09:45:24 AM
Thanks for the update.

When I tried to post this into the board I moderate, I got a fatal error on Post.php file. In case you might want to know.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: FunPika4 on October 29, 2006, 10:10:13 AM
Nice guys! I am going to update my RC3 now. Well I don't think you will be able to make any other patches for 1.0. :P There is no room in those decimals. :P  Also, shouldn't put the 1.0.8 into the archive now.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Harzem on October 29, 2006, 10:10:55 AM
Nice guys! I am going to update my RC3 now. Well I don't think you will be able to make any other patches for 1.0. :P There is no room in those decimals. :P

1.0.10 ;)
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: FunPika4 on October 29, 2006, 10:11:57 AM
Nice guys! I am going to update my RC3 now. Well I don't think you will be able to make any other patches for 1.0. :P There is no room in those decimals. :P

1.0.10 ;)
Lol. I have never seen version decimals used in such a way. Hopefully we won't need 1.0.10 though.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: SeiTaN on October 29, 2006, 10:22:31 AM
Recent.php, it is marked as 1.1RC3, not as 1.1RC3-1. I edited it and forum mantenience marked it perfect.

Thanks a lot for all.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: klumy on October 29, 2006, 10:22:58 AM
thanks for the update
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: G6™ on October 29, 2006, 10:23:45 AM
Upgrade from the package manager link in SMF 1.1rc3 went with out any complications and works great.
Thank you Staff for your work done :)
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Compuart on October 29, 2006, 10:35:27 AM
Recent.php, it is marked as 1.1RC3, not as 1.1RC3-1. I edited it and forum mantenience marked it perfect.
Indeed, the version of Recent.php should be changed by the patch. I've re-attached the patch to the first message and updated the patch in the package manager. Thanks for noticing!
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Gazmanafc on October 29, 2006, 10:37:38 AM
Lol. I have never seen version decimals used in such a way. Hopefully we won't need 1.0.10 though.

phpBB do it all the time. Which explains their 2.0.21 or whatever it is. :P

-AwwLilMaggie
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: rockinaway on October 29, 2006, 10:44:51 AM
Nice update, thanks!
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: anonim on October 29, 2006, 10:49:11 AM
Since most modifications have been made compatible for 1.1 RC3 by now, those still running 1.1 RC2 are advised to upgrade to 1.1 RC3 or to apply the changes manually.

there are still modifications not updated. and for a site heavy modded is not so easy
btw, I modified this patch to work to RC2-2 and it works just fine. tks anyway.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: CountryLady on October 29, 2006, 11:09:33 AM
Soooooooooo Easy~! Thank you all. :)
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Stuart on October 29, 2006, 11:16:00 AM
Thanks for this update. Now running SMF 1.0.9.  :D
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: anonim on October 29, 2006, 11:35:42 AM
a little error found when I tried to post a new topics on chit-chat board

action was: http://www.simplemachines.org/community/index.php?action=post2;start=0;board=5

result was:

Fatal error: Argument 1 passed to notifyMembersBoard() must be an object of class �)&/8n)��5H�3��2�շ�շ�շ�շ�շ�շ �շ �շ(�շ(�շ0�շ0�շ8�շ8�շ@�շ@�շH�շH�շP�շP�շX�շX�շȱ)ȱ)h�շh�շp�շp�շx�շx�շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ, called in /home/simple/security/Sources/Post.php on line 1782 and defined in /home/simple/security/Sources/Post.php on line 1996

but, the topics is right there, so maybe you want to check to this
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: SleePy on October 29, 2006, 11:37:26 AM
Oohh.. Finally..

I have known about the search exploit for almost a week.. good thing its finally fixed.. ;D

What is with all the bugs? 1.1 RC2 had to have 2 patches and RC3 has had 1 so far..  :-[ makes me feel like phpbb... >:(
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Harzem on October 29, 2006, 11:40:21 AM
What is with all the bugs? 1.1 RC2 had to have 2 patches and RC3 has had 1 so far..  :-[ makes me feel like phpbb... >:(

This is why they are called "release candidates". They still have minor bugs.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: FunPika4 on October 29, 2006, 11:43:13 AM
What is with all the bugs? 1.1 RC2 had to have 2 patches and RC3 has had 1 so far..  :-[ makes me feel like phpbb... >:(

This is why they are called "release candidates". They still have minor bugs.
Yep, BUT all 3 RC2/RC3 patches I have noticed are the same fixes from the 1.0.x series.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Harzem on October 29, 2006, 11:44:44 AM
Three years from 1.0.0 to 1.0.9 and you have one click automatic installer. It hardly sounds like phpBB ::)
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Gazmanafc on October 29, 2006, 11:45:32 AM
Its not as bad as phpBB what with their 21 patches for their 2.0...

-AwwLilMaggie
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: FunPika4 on October 29, 2006, 11:53:48 AM
Its not as bad as phpBB what with their 21 patches for their 2.0...

-AwwLilMaggie
Yeah, at this rate they will reach 2.0.30 by the end of 2007 if they don't have 2.1.12 already. :P
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: charlottezweb on October 29, 2006, 11:59:56 AM
Thanks guys/gals!
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: mforum on October 29, 2006, 12:13:17 PM
a little error found when I tried to post a new topics on chit-chat board

action was: http://www.simplemachines.org/community/index.php?action=post2;start=0;board=5

result was:

Fatal error: Argument 1 passed to notifyMembersBoard() must be an object of class �)&/8n)��5H�3��2�շ�շ�շ�շ�շ�շ �շ �շ(�շ(�շ0�շ0�շ8�շ8�շ@�շ@�շH�շH�շP�շP�շX�շX�շȱ)ȱ)h�շh�շp�շp�շx�շx�շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ��շ, called in /home/simple/security/Sources/Post.php on line 1782 and defined in /home/simple/security/Sources/Post.php on line 1996

but, the topics is right there, so maybe you want to check to this

I had the same issue but in another board .....
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: charlottezweb on October 29, 2006, 12:17:07 PM
I'm seeing that when I post here too.

Happened just now on the bridges board.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: anonim on October 29, 2006, 12:18:08 PM
yes, there are few boards where we cannot start new topics without errors, but the topics are inserted. I hope they are looking on it.
I think is related with develop version; it is sure is not related with this patch because, at least,  on the few forums I apllied the patch (2 RC3, and 1 RC2-2) I did not get this issue.
but the team will solved this, just give them some time
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Thantos on October 29, 2006, 12:46:03 PM
For those of you who are getting those errors on your site, are you running eaccelerator or a like product?
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Sockratease on October 29, 2006, 12:46:22 PM
Thanks!

I'm struggling with learning this system, but upgrading from the version my web-host provided (1.07) to 1.08 was one-click simple.  And the same goes for the upgrade to 1.09!!

It's nice to know that I don't have to struggle with this aspect of the program!!(https://www.simplemachines.org/community/proxy.php?request=http%3A%2F%2Fi106.photobucket.com%2Falbums%2Fm278%2Fsockratease%2Frelief.gif&hash=7204a1513a425ff9f9fa8115295eeb14)
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Harzem on October 29, 2006, 12:48:29 PM
For those of you who are getting those errors on your site, are you running eaccelerator or a like product?

These errors are on simplemachines.org, not our websites. notifyMember function gives an error. (I hope we are talking about the same thing)
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: www.B2B.in.th on October 29, 2006, 12:49:35 PM
Thank you, From Thailand
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: dphreak on October 29, 2006, 01:08:09 PM
I just downloaded the updater-package manually from the website, the one for 1.0.9 and an error (old files) occurs, in the included upgrade.php the version has been set to 1.0.8...
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: xtremecruiser on October 29, 2006, 01:36:27 PM
I hate to even ask, so flame away
I am still on RC2 because I have so many mods and custom themes I was waiting till the final release so I do not have to do all the changes 2 times.
Is this a patch that Really needs to be done ?
Thanks
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Neol on October 29, 2006, 01:41:40 PM
I can't install the updated_files_SMF_1-1-rc3-1

The package you tried to upload either is not a valid package or has become corrupted.
Title: Request clarification re: Recent.php
Post by: azc on October 29, 2006, 01:47:23 PM
Request clarification re: Recent.php

I need to apply the changes manually using the 'updated_files_SMF_1-1-rc3-1.zip' file.

File 'Recent.php' Software Version is labeled SMF 1.1 RC3 in the zip file.

My questions:

Is this the actually the SMF 1.1 RC3-1 file, and can I just edit the version number?

Is this the old SMF 1.1 RC3 file, and if so, will the new version be made available?

Thank you.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Compuart on October 29, 2006, 01:54:35 PM
I hate to even ask, so flame away
I am still on RC2 because I have so many mods and custom themes I was waiting till the final release so I do not have to do all the changes 2 times.
Is this a patch that Really needs to be done ?
That depends on the degree of security you would like. The vulnerability that's being fixed by this patch is not very severe, but it's only the weakest link that counts when it comes to security.

As said in a previous post, you can apply the changes manually by opening the modification in a text editor.

I can't install the updated_files_SMF_1-1-rc3-1

The package you tried to upload either is not a valid package or has become corrupted.

That's just an archive containing the files that are being changed. If you would like to use the package, download smf_patch_1-0-9_1-1-rc3-1.tar.gz from the first post and upload it to the packages directory.

Title: Re: Request clarification re: Recent.php
Post by: Compuart on October 29, 2006, 01:56:30 PM
Request clarification re: Recent.php

I need to apply the changes manually using the 'updated_files_SMF_1-1-rc3-1.zip' file.

File 'Recent.php' Software Version is labeled SMF 1.1 RC3 in the zip file.

My questions:

Is this the actually the SMF 1.1 RC3-1 file, and can I just edit the version number?

Is this the old SMF 1.1 RC3 file, and if so, will the new version be made available?
The version of this file is indeed not correct. You can safely change it to 1.1 RC3-1.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Compuart on October 29, 2006, 02:06:54 PM
Have updated updated_files_SMF_1-1-rc3-1.zip too.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: BigMike on October 29, 2006, 02:13:05 PM
Thankyou for the notification via email. I just upgraded to RC3 last night. Perfect timing

BigMike
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: azc on October 29, 2006, 02:21:15 PM
Have updated updated_files_SMF_1-1-rc3-1.zip too.

Thank you, Compuart. Much appreciated.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: CGawker on October 29, 2006, 05:01:33 PM
Error for me: 2. Execute Modification ./changelog.txt Failure  

(install via admin panel)

...what should I do?

Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Compuart on October 29, 2006, 05:13:52 PM
If changelog.txt is the only file for which the modification fails, there shouldn't be a problem. In that case you can just continue the patching.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: caipirinha on October 29, 2006, 05:50:53 PM
The search still doesn't work (after update to RC3)

Can anyone tell me if the RC2 Search.php is affected by the xss bug?
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: SleePy on October 29, 2006, 05:52:35 PM
I believe so.. Since not many changes in rc2 to rc3 it would be there.. And since it had to patch the 1.0 line I am guessing it is in all versions...
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: manji on October 29, 2006, 07:11:20 PM
Hi,

I'm using 1.1RC3 with TP 0,95 and I get this error:

                    Type                    Action                    Description   
1.   Execute Modification   smf_1-1-rc3-1.mod   Modification parse error

So... what gives?  ;D

Should I download updated_files_SMF_1-1-rc3-1.zip and upload it manually?

Cheers!   
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: SleePy on October 29, 2006, 07:14:27 PM
Redownload the file and try again..

I was able to upgrade just fine and I run TP..
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: manji on October 29, 2006, 07:49:11 PM
Hi,

So I downloaded updated_files_SMF_1-1-rc3-1.zip and uploaded the files. All is working OK, but it still says 1.1RC3 in the bottom, not 1.1RC3-1.

And the reminder on the package tab is still there. Should I do smth to remove that or just leave it :)

Cheers!
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Debbie2 on October 29, 2006, 08:11:09 PM
Does 1.0.9 support FULLTEXT search? Or do I need 1.1 RC3 for that?
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: FunPika4 on October 29, 2006, 08:26:00 PM
changelog.txt had no problems for my board.

Also perhaps you should update your tinyportal to 0.9.6 manji.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: georgepdog on October 29, 2006, 11:18:09 PM
I just downloaded the updater-package manually from the website, the one for 1.0.9 and an error (old files) occurs, in the included upgrade.php the version has been set to 1.0.8...

I updated from the package manager.  Everything went smoothly, but then, we had an issue with one of our mods.  It mentioned the following:

Unknown column 'mem.pmAutoRespondAwayMsgActivate' in 'field list'
File: /home/arsport1/public_html/smf/Sources/Load.php
Line: 476

Note: It appears that your database may require an upgrade. Your forum files are currently at version SMF 1.0.9, whereas your database is at version SMF 1.0.8. It is recommended that you execute the latest version of upgrade.php.

So, I checked and noticed that all of the files were the ones updated by the package manager today.  However, since I ran it through the package manager, I did not run the upgrade.php separately.  So, I uploaded the upgrade.php to the site and ran it.  I got the same error message as above quote from dphreak with the exception that my forum shows it is at 1.0.9.  What can I do?  Or should I do anything?
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Fiery on October 30, 2006, 02:13:23 AM
Thanks for the update, I appreciate all of your hard work!  ;D
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: licheng on October 30, 2006, 03:56:49 AM
I download update files to upgrade from SMF 1.0.8 to SMF 1.0.9, but got a messenge something like

Quote
The upgrader found some old or outdated files.

Please make certain you uploaded the new versions of all the files included in the package.

Click here to try again.

I have tried upgrade files to upgrade SMF, but got the same messenge.

Oh, yes, I use the default theme without any modification, and use English as default language.

Any suggestion?

Thanks. :)
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Macia Paladin on October 30, 2006, 03:59:19 AM
Oohh.. Finally..

I have known about the search exploit for almost a week.. good thing its finally fixed.. ;D

What is with all the bugs? 1.1 RC2 had to have 2 patches and RC3 has had 1 so far..  :-[ makes me feel like phpbb... >:(

I tried doing a search fro an answer, but I'm not having much luck. What do you do if you were already hacked with the Search exploit BEFORE the patch came out? My forumers are getting tired of my "forum reboots".
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: manji on October 30, 2006, 04:28:12 AM
changelog.txt had no problems for my board.

Also perhaps you should update your tinyportal to 0.9.6 manji.

Thanks for the head's up! They seem to be having some trouble with it, though! :)

Hi,

So I downloaded updated_files_SMF_1-1-rc3-1.zip and uploaded the files. All is working OK, but it still says 1.1RC3 in the bottom, not 1.1RC3-1.

And the reminder on the package tab is still there. Should I do smth to remove that or just leave it :)

Cheers!

Any help with this?

Cheers!
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: zeniitti on October 30, 2006, 07:28:28 AM
It gave me this error :(

Code: [Select]
Fatal error: Call to undefined function: tp_loadtheme() in /home/xxxxx/domains/xxxxx/public_html/Sources/Load.php on line 660
Possible error with theme? Running 1.0.8 + 0.9.6beta TP. Didn't try default theme though...
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: ApocryphA on October 30, 2006, 07:45:55 AM
Hi,

I'm running 1.0.7.  The host doesn't seem to allow me to use the Package Manager, so I'll have to upload the upgrade files manually.  Now do I need to install the 1.0.8 first, or should I just go ahead with 1.0.9 directly?

Thanks!

Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Dannii on October 30, 2006, 07:50:59 AM
If you're going to use the upgrade package, you can just skip straight to 1.0.9
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: SuicideOption on October 30, 2006, 09:33:12 AM
Apparently I'm stupid, or EXTREMELY new at this...but I can't find the patch in the package manager.  I've looked for about 20 minutes, but there's so many mods. I may just be overlooking it...
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: manji on October 30, 2006, 09:34:13 AM
Apparently I'm stupid, or EXTREMELY new at this...but I can't find the patch in the package manager.  I've looked for about 20 minutes, but there's so many mods. I may just be overlooking it...

When you click on the Package tab in the Admin section of YOUR forum, it should show right up :)

Cheers,
J
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: SuicideOption on October 30, 2006, 09:40:13 AM
Thank you so much, I was going to drive myself crazy.  I was actually going into the package server and scrolling through page after page of mods.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Compuart on October 30, 2006, 10:15:05 AM
I download update files to upgrade from SMF 1.0.8 to SMF 1.0.9, but got a messenge something like

Quote
The upgrader found some old or outdated files.

Please make certain you uploaded the new versions of all the files included in the package.

Click here to try again.

I have tried upgrade files to upgrade SMF, but got the same messenge.

Oh, yes, I use the default theme without any modification, and use English as default language.

Any suggestion?

There was a version number in the previous packages from the download page that hadn't been updated.  To get the upgrade working you can either download the files again or replace the following in upgrade.php:

Code: (upgrade.php) [Select]
define('SMF_VERSION', '1.0.8');
by:
Code: (upgrade.php) [Select]
define('SMF_VERSION', '1.0.9');
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Bernak on October 30, 2006, 10:31:55 AM
Thanks for the update,
now running 1.0.9  :)

Can't change to 1.1, i would need to update too much stuff and the 1.0 is great!  ;D
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: DSM on October 30, 2006, 11:55:46 AM
I installed the update on RC3 and everything went good, but I'm wondering how to edit the forum version in the footer? I edited it index.php and just changed the version to SMF instead of SMF 1.1 RC3 but that didn't work. I also edited index.english.php and changed some code to this.

$real_version = $forum_version;
$forum_version = "SMF";
$forum_copyright = '<a href="http://www.simplemachines.org/" title="Simple Machines Forum" target="_blank">Powered by ' . $forum_version . '</a> |
<a href="http://www.simplemachines.org/about/copyright.php" title="Free Forum Software" target="_blank">SMF &copy; 2001-2005, Lewis Media</a>';
$forum_version =  $real_version;

This method worked before but now it doesn't.

I also tried this method, in index.php after loadUserSettings(); I added

if (!$user_info['is_admin']))
  $GLOBALS['forum_version'] = 'SMF';

and this method doesn't work either.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: manji on October 30, 2006, 01:28:57 PM
while the fix for the 1.1 RC3 branch will merely be released as patched version, the version of the forum will remain 1.1 RC3 (therefore, most of the modifications should remain compatible).

So I guess the version number won't change :-)

Cheers,
João.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: KB on October 30, 2006, 04:47:49 PM
Unfortunately, Ive ran into problems using the package manager to update my 1.0.8 to 1.0.9
Ive tried two different zips now and both result in the error
" The package you tried to upload either is not a valid package or has become corrupted. "

I also downloaded these zips several times, no change....plus tried the gzip versions as well.

I have had no problems using the Package manager since changing my hosting to avoid the "safe mode" issues.  And as I remember, the 1.0.8 upgrade, had a single link for me to click within my admin CP to initiate the upgrade via the Package Manager...which was not the case this time.  I had to download the update to my local machine and attempt the upload via PM.

Im most likely just not "seeing the forest because of the trees" here, but before I do a manual install....I would appreciate any suggestions to get the PM to work! 

One thing I noticed in the 1.0.9 update files though.....
I unzipped the files (and no, I didnt try to upload the uncompressed files..lol) but noticed that it did NOT contain a file called "package-info.xml" .....so.....could this be the reason for my unsuccessful attempts at install via the PM?

THANKS!!!!!!

Oh and btw...love the halloween theme!!!! :)
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Harzem on October 30, 2006, 04:50:20 PM
You are trying to upload "smf_patch_1-0-9_1-1-rc3-1.tar.gz" via PM right?
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: KB on October 30, 2006, 05:17:13 PM
You are trying to upload "smf_patch_1-0-9_1-1-rc3-1.tar.gz" via PM right?

Ive not tried that one today....but did the gzip file that was on the downloads thread...sometime last night.  Same result.

What Ive tried most recently is the " updated_files_SMF_1-0-9.zip "

so NOW HOWEVER....I guess I need to insert my "DOH!!..homer" smiley here...lol...because I just did the upgrade successfully using the PATCH gzip file!!!!!

THANKS HarzeM!!!  ITs great to see "the forest" now!!! :)
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: DHC on October 30, 2006, 05:52:08 PM
Since most modifications have been made compatible for 1.1 RC3 by now, those still running 1.1 RC2 are advised to upgrade to 1.1 RC3 or to apply the changes manually.

there are still modifications not updated. and for a site heavy modded is not so easy
btw, I modified this patch to work to RC2-2 and it works just fine. tks anyway.

PLEASE!! Post that patch!

I too have a heavily-modded RC2 board and CANNOT take the time to convert everything over to RC3. In fact, there are STILL mods I am using which are NOT migrated to RC3.

Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Jazeker on October 30, 2006, 07:22:44 PM
I hate to be a pain in the ass, but I recently upgraded from 1.0.7 to 1.0.8 via the package manager with no pain.  Now, with the move from 1.0.8 to 1.0.9 it keeps asking me for my ftp info while that has not changed.  it reports success on all files, but keeps asking me for the ftp info.  I guess this is not the fault of SMF, but it would be handy to know where to start...

Thanks :)
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: tethead on October 30, 2006, 07:52:36 PM
OK, i managed to do the update on a remote dedicated Debian Etch server by un-tar'ing the file in the right directory then running upgrade.php, which ran thru just fine.  however, when i go into the admin section of the forums and check the detailed versions, there are still several files in red that lists "1.1 RC3" as the installed version while "1.1 RC3-1" as the current version.  i am not sure what else to do to upgrade those files. 

the ones still needing to be updated are:
ManageBoards.php
PersonalMessage.php
Recent.php
Register.php
Search.php

am i up to date and those just report inaccurately? 

thanks.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: licheng on October 30, 2006, 10:39:33 PM
There was a version number in the previous packages from the download page that hadn't been updated.  To get the upgrade working you can either download the files again or replace the following in upgrade.php:

Code: (upgrade.php) [Select]
define('SMF_VERSION', '1.0.8');
by:
Code: (upgrade.php) [Select]
define('SMF_VERSION', '1.0.9');

You're right. :)

I used smf_1-0-9_update.tar.bz2 to update my forums, and the version number in upgrade.php is 1.0.8.

Now I have updated all my forums successfully.

Thank you very much.

Have a nice day. :)
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: DHC on October 30, 2006, 10:47:06 PM
Since most modifications have been made compatible for 1.1 RC3 by now, those still running 1.1 RC2 are advised to upgrade to 1.1 RC3 or to apply the changes manually.

Please explain - step-by-step, exactly WHICH file is to be used to update a RC2 board - and what you mean to "apply the changes manually."
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Dannii on October 30, 2006, 10:59:19 PM
This patch is not for RC2. There is no way to install it automatically. You will have to manually edit the source files and make the same changes the mod does.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: tethead on October 30, 2006, 11:01:05 PM
any idea about my quandary, re: incorrect version #s after an update to my RC3 installation?
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Dannii on October 30, 2006, 11:50:02 PM
Open up the files in a text editor and check if the changes were actually made to those files.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: saadahmed007 on October 31, 2006, 12:00:11 AM
If I want to fix the 1.1 RC3 branch, then what should I download from attachments?

smf_patch_1-0-9_1-1-rc3-1.tar.gz  or updated_files_SMF_1-1-rc3-1.zip
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: mediawizard on October 31, 2006, 02:42:39 AM
Nice guys! I am going to update my RC3 now. Well I don't think you will be able to make any other patches for 1.0. :P There is no room in those decimals. :P

1.0.10 ;)
Lol. I have never seen version decimals used in such a way. Hopefully we won't need 1.0.10 though.

I use Joomla. Currently on 1.0.11, plus they also have a 1.5 beta!!
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: borizb on October 31, 2006, 03:23:36 AM
Works fine for me (1.08 -> 1.09), thx a lot!
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Alcor on October 31, 2006, 03:38:52 AM
I try to apply it through the package installer and I have this message.

Quote
Session verification failed. Please try logging out and back in again, and then try again.

SMF Version 1.1RC3
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: House on October 31, 2006, 03:58:29 AM
I'm only a new SMF admin, been using it maybe 6 weeks now.

In Package Manager I follow the link in:
Quote
A security issue has been identified in SMF 1.0.8. You can install this patch (click here to install) to easily update yourself to the latest version.

and get:
Quote
The package you are trying to download or install is either corrupt or not compatible with this version of SMF.

I DEFINITELY installed 1.0.8 using "smf_1-0-8_install.tar.gz" (it's still in my download folder) but when I check the Mod List i have:
Quote
      Mod Name     Version
1.    MySQL 5.0.12 Compatibility Update    1.0    [ Uninstall ]
2.    SMF 1.0.7 / 1.1 RC2 Update    1.0    [ Uninstall ]
Does this mean I'm 'half running' 1.0.7. I didn't install it, How is this possible? What gives and what do I have to do to upgrade? Why can't I uninstall the 1.0.7 patch?
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Kajol on October 31, 2006, 06:47:58 AM
I got some problems (has to do the my rights). Can I also upload and install it manuall? If yes, how?
Thanks for quick help.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Gr@fiker on October 31, 2006, 09:02:29 AM
yaw ne açığı bu ben heç bişe anlamadım :D Harzem englişçe bilmiyorum bi anlatsana :P
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Harzem on October 31, 2006, 09:06:48 AM
yaw ne açığı bu ben heç bişe anlamadım :D Harzem englişçe bilmiyorum bi anlatsana :P

Türkçe konuşmaları türkçe bölümüne sakla. Orada da sabit konu var.

- Please keep non-english posts in the language boards -
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Farmacija on October 31, 2006, 09:30:00 AM
i manually update files in Sources folder and that files are profile.php, register.php and search.php but there still is version 1.08 on index page of forum althoug i done update to 1.09?

and few minutes there isnt the download link in the first post in this message and now, there is. why??
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: fugiFox on October 31, 2006, 09:47:05 AM
When trying to apply the mod i get the error
Code: [Select]
Some of the files the package manager needs to modify are not writable. This needs to be changed by logging into FTP and using it to chmod or create the files and folders. Your FTP information may be temporarily cached for proper operation of the package manager.I recently upgraded my forum to RC3 and perhaps some permission accidentally changed.
Which files needs access to the patch?

Thanks
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: CJ111 on October 31, 2006, 10:37:31 AM
Quote
The package you are trying to download or install is either corrupt or not compatible with this version of SMF

I got RC3 installed. However, I deleted the version number in the bottom of the forum, to avoid giving too much information to hackers. The link to the smf forum is still there however.

Could this be the reason why I get the above error?  ???
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: JayBachatero on October 31, 2006, 10:55:29 AM
Quote
The package you are trying to download or install is either corrupt or not compatible with this version of SMF

I got RC3 installed. However, I deleted the version number in the bottom of the forum, to avoid giving too much information to hackers. The link to the smf forum is still there however.

Could this be the reason why I get the above error?  ???
Yes that is the reason for your error.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: CJ111 on October 31, 2006, 11:56:50 AM
Quote
The package you are trying to download or install is either corrupt or not compatible with this version of SMF

I got RC3 installed. However, I deleted the version number in the bottom of the forum, to avoid giving too much information to hackers. The link to the smf forum is still there however.

Could this be the reason why I get the above error?  ???
Yes that is the reason for your error.
I knew it  ::)
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: FunPika4 on October 31, 2006, 02:24:03 PM
Since most modifications have been made compatible for 1.1 RC3 by now, those still running 1.1 RC2 are advised to upgrade to 1.1 RC3 or to apply the changes manually.

there are still modifications not updated. and for a site heavy modded is not so easy
btw, I modified this patch to work to RC2-2 and it works just fine. tks anyway.

PLEASE!! Post that patch!

I too have a heavily-modded RC2 board and CANNOT take the time to convert everything over to RC3. In fact, there are STILL mods I am using which are NOT migrated to RC3.


Just wondering, which mods are you using that are not RC3 compatible?
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: janus zeal on October 31, 2006, 04:08:03 PM
lol, until i loged in all the forum stuff was in japanese... O.O

Anyways, thanks for the update. ^_^
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Seg on October 31, 2006, 04:35:17 PM
I was freaking out a bit till I saw that all the files changed were in Sources and I didn't need to rewrite my custom themes. :) Yay modularity! :D
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: tourbi on November 01, 2006, 02:30:24 AM
Thank you!! :)  I was able to upgrade in my domain administration panel, installatron.  What a great service. 
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: a2h on November 01, 2006, 08:30:06 AM
just thought id share a portion of my introduction of my site:

Quote
**I would like to personally thank and recognize my friends at simplemachines.org and tinyportal.net for thier help, for thier creation of this software, the theme design, and working with us to build this site. All copyrights are that of thier respective owners.  Simplemachines and TP simply kick ass! Thanks Everyone**

need i say more?....
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Panzer- on November 01, 2006, 02:34:31 PM
Woot, thanks alot :)
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Gent on November 01, 2006, 05:33:46 PM
Thanks guys, it works great. You're the best!
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Marcos_O on November 01, 2006, 08:47:06 PM
I tried updating my forum to version 1.0.9 and got this error in my admin panel...

An Error Has Occurred!
2: fopen(/SSI.php): failed to open stream: No such file or directory
File: /home/******/public_html/forum/Sources/Admin.php
Line: 950

Help...what does this mean and how do I fix?

Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: SleePy on November 01, 2006, 09:04:36 PM
Its trying to open the SSI.php file.. but the odd thing is its either not adding the correct path or just adding a / for no reason..
The line number is off So I can't find it in the admin.php..
You got any mods installed?
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Marcos_O on November 01, 2006, 09:12:15 PM
Its trying to open the SSI.php file.. but the odd thing is its either not adding the correct path or just adding a / for no reason..
The line number is off So I can't find it in the admin.php..
You got any mods installed?

Yea, thats what I get when I tried uploading via the admin panel...no mods installed as I have kept it simple....any other suggestions why I get that error message
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: czhy on November 02, 2006, 03:24:08 AM
Nice update, thanks!
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: SkyWay on November 02, 2006, 05:23:50 PM
I'm getting this error and I haven't got any mods or tried to install any packages before. What's wrong?

(https://www.simplemachines.org/community/proxy.php?request=http%3A%2F%2Fimg.photobucket.com%2Falbums%2Fv338%2FPicklehammer%2Ferror.png&hash=bc64cfd5f180f936b66dbc1998877db1)
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Gazmanafc on November 02, 2006, 05:29:04 PM
Which files are listed as "Test Failed"?

-AwwLilMaggie
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: SkyWay on November 02, 2006, 06:12:44 PM
It doesn't say as far as I can see.

By the way it IS 1.1 RC3 that I have installed just now.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: SkyWay on November 02, 2006, 06:23:59 PM
It's ok. I tried updating without using the package manager and it went without a hitch. Thanks though, ;)
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: bjornbjorn on November 03, 2006, 07:47:58 AM
// Edit: disregard my message.

Sorry for the FUD - my problem was not caused by SMF (but SMF got influenced since I was loading it's css style through s9y, which was the real cause of the problem. Or actually, a PHP 5.2.0 upgrade was, so no fault with either SMF or s9y :) ).

- bjorn
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: kriskd on November 03, 2006, 08:48:18 PM
Installed on my RC3 forum via the package manager with no problems.

Question -- is this patch included on the upgrade files for RC3?  I ask because I still have an RC2 forum I need to upgrade and I'd just like to know if installing this patch will be an additional step.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: FunPika4 on November 03, 2006, 10:19:33 PM
Installed on my RC3 forum via the package manager with no problems.

Question -- is this patch included on the upgrade files for RC3?  I ask because I still have an RC2 forum I need to upgrade and I'd just like to know if installing this patch will be an additional step.
I believe when you upgrade RC2 to RC3 the patch will be have to be installed via package manager.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Daniel15 on November 04, 2006, 02:10:04 AM
The parch applied successfully for me, with the exception of the edit to $sourcedir/Profile.php. The problem was this line in the smf_1-0-9.mod file:
Code: [Select]
<edit file>
$sourcedir/Profile.php
</edit file>

<search for>
* Software Version:           SMF 1.0.8                                       *
</search for>

...
It's searching for SMF 1.0.8 in the file, but mine said SMF 1.0.6. This was strange seeing as I had SMF 1.0.8 installed... It's fine now, though. I changed it manually, and it appears to be fine :)
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: reefzone on November 04, 2006, 03:26:54 AM
Hi,

I apply the patch without any problems. Only when I upload it from package manager, it said in the first row, >config .txt File not found? But the installation proceed without any problem.

How can I know the package is correctly installed?
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: magic1136 on November 04, 2006, 11:47:29 AM
happy to  update a new release
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: SleePy on November 04, 2006, 12:11:00 PM
The parch applied successfully for me, with the exception of the edit to $sourcedir/Profile.php. The problem was this line in the smf_1-0-9.mod file:
Code: [Select]
<edit file>
$sourcedir/Profile.php
</edit file>

<search for>
* Software Version:           SMF 1.0.8                                       *
</search for>

...
It's searching for SMF 1.0.8 in the file, but mine said SMF 1.0.6. This was strange seeing as I had SMF 1.0.8 installed... It's fine now, though. I changed it manually, and it appears to be fine :)

From what I know. Package Manager Updates Only changes the file versions on the files it edits.. Thats why you got the problem..
You have to edit the file manually and change it..
You can do that to all your files so they all say 1.0.9 if you need to..
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Paraiba on November 04, 2006, 12:30:57 PM
Whoa how easy was that!  :D
Package manager - there's an update, click here to install, test successful, install, done.

Contrast that with "another package"

Email - there's a patch. Bang head on desk, "OH NO! Not again"
Go to site, download zip, hold breath, unzip. How many files this time?
Only 43, Oh good, It'll only take me 3 hours.
Run file compares, mark up changes, apply changes.
Go back to site as one lot of code that needs to be changed doesn't seem to be there.
Post on board. Remove post as there suddenly seem to be many other identical posts.
Wait for reply.
Email - there's a patch to the patch.  Bang head on desk, "OH NO! Not again"..........................................
 ;D
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Gazmanafc on November 04, 2006, 12:32:36 PM
Email - there's a patch to the patch to the patch. ;)
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Paraiba on November 04, 2006, 01:16:48 PM
Email - there's a patch to the patch to the patch. ;)
Oh OK, which button do I press?  :-*
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: jeweledleah on November 04, 2006, 02:27:19 PM
you know, something weird happened, once I updated to 1.09   now, when I try to posy something as link - it adds a whole bunch of extra stuff (like a copy of a link within the url brackets)  and it refuses to change the color of the link text.  never happened with older version, so what gives?  i don't know if anything else is going to act up, since posting the link is the only option I've tried since update, but I wanted to let you know.. 
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: devnet on November 05, 2006, 07:54:15 PM
I'm running 1.1 RC3.  I applied the patch through the admin panel.  I'm also running a wrapped forum inside joomla 1.0.11.

Now when I post to a wrapped address like http://www.mypclinuxos.com/index.php?option=com_smf&Itemid=6&topic=406.0 the address trunctuates and sends my members to http://www.mypclinuxos.com/index.php?option=com_smf&amp;Itemid=6&amp;top

So, how do I go about fixing this problem?  You cannot link at all...even using url tags won't make this work.

Do I need to start this thread in the joomla sub forum?  Or is this a problem for everyone?  You can see exactly what I mean in the second reply to this thread: http://www.mypclinuxos.com/index.php?option=com_smf&Itemid=6&topic=405.msg3289#msg3289
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: SleePy on November 05, 2006, 09:03:35 PM
That would be a joomla bridge problem. Not a SMF problem..

I would post down in Bridges section about this.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: bebe on November 07, 2006, 08:06:57 AM
Hi,

So I downloaded updated_files_SMF_1-1-rc3-1.zip and uploaded the files. All is working OK, but it still says 1.1RC3 in the bottom, not 1.1RC3-1.

And the reminder on the package tab is still there. Should I do smth to remove that or just leave it :)

Cheers!

Nobody reply on the above.

I did the update manually by replacing the 6 files but when i go to Admin-->Packages, i saw this
Quote
A security issue has been identified in SMF 1.1 RC3. You can install this patch (click here to install) to easily update yourself to the latest version.

If you have any problems applying it, you can use the version posted on the downloads page - although, any modifications you have installed will need to be uninstalled. Please post on the forum if you need more help
.
basically the same thing as what manji has mentioned earlier.

Please let us know what should we do to get rid of the reminder.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Dannii on November 07, 2006, 08:54:23 AM
The reminder shows there unless you installed the patch through the package manager.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: bebe on November 07, 2006, 05:11:09 PM
So the only way we could get rid of the reminder would be re-patch using the Package Manager? *sweat*
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: winrules on November 07, 2006, 05:43:33 PM
So the only way we could get rid of the reminder would be re-patch using the Package Manager? *sweat*
Yeah.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: SleePy on November 07, 2006, 06:43:50 PM
wouldn't uploading the file to pacakes folder and editing install.list also remove it?
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: winrules on November 07, 2006, 08:31:48 PM
wouldn't uploading the file to pacakes folder and editing install.list also remove it?
Yes...
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: bebe on November 07, 2006, 09:44:57 PM
So the only way we could get rid of the reminder would be re-patch using the Package Manager? *sweat*
Yeah.
Thanks  winrules. I'll re-patch it right away then.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Sockratease on November 08, 2006, 12:30:55 PM
Hi.

I updated to 1.09 very easily.  I'm still too new at this to risk a release candidate, and here is a good example of why:

I used package manager to upload a "Users in the last 24 hours" mod.

Works Great!

The only reason I have not posted that in the bit where the mod came from is that now I can't update ANY more mods at all!

I tried the member color mod, and some tests, but nothing works.

They are all giving the legendary "The package you are trying to download or install is either corrupt or not compatible with this version of SMF." message.

I think I need to manually change a 1.08 to 1.09 somewhere, but am totally lost as to where!

Any suggestions?

Thanks in advance for any help.

Peace
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Migraine on November 09, 2006, 10:27:23 AM
Currently using 1.0.8.  Everytime I try to upload the patch, regardless of if I do so manually or via the package manager, I get the following error:

Quote
An Error Has Occurred!
2: copy(/home/doenet/public_html/forum/index.php~): failed to open stream: Permission denied
File: /home/doenet/public_html/forum/Sources/Subs-Package.php
Line: 1307 



Here is what I have for line 1307:

Quote
      copy($working_file, $working_file . '~'); 


Is there something I need to change in that string of code in order for the patch to work?? 

Thanks,

~M
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Daniel15 on November 09, 2006, 11:21:46 PM
Migraine, to solve your problem, CHMOD your forum's Sources directory to 0777. This can be done via your FTP client, or via cPanel's File Manager (if you have cPanel access).
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: klra on November 10, 2006, 02:38:54 PM
I installed the latest patch to 1.0.8 using the Ig-Oh theme.

I now have this error message displayed in a large orange rectangle, all of my pages -

Quote
Attention of Ig-Oh theme:

This theme doesn't correspond to the version of SMF that you are using. This theme is made for SMF 1.0.7 & SMF 1.0.8.

Members are not seeing this, and the theme is fully functional.

Is there any way this noob can remove this error message?

Thanks in advance-
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: internetwebbuilders on November 10, 2006, 03:37:51 PM
Patch from 1.0.8 to 1.0.9 still won't install even after I CHMOD 777 to the Sources directory.  I'm still getting this error:

An Error Has Occurred!
2: copy(/var/www/vhosts/DOMAIN.com/httpdocs/fanforum/index.php~): failed to open stream: Permission denied
File: /var/www/vhosts/DOMAIN.com/httpdocs/fanforum/Sources/Subs-Package.php
Line: 1307
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: SleePy on November 10, 2006, 03:41:03 PM
CHMOD your fanforum folder..
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Gazmanafc on November 10, 2006, 03:47:57 PM
I installed the latest patch to 1.0.8 using the Ig-Oh theme.

I now have this error message displayed in a large orange rectangle, all of my pages -

Quote
Attention of Ig-Oh theme:

This theme doesn't correspond to the version of SMF that you are using. This theme is made for SMF 1.0.7 & SMF 1.0.8.

Members are not seeing this, and the theme is fully functional.

Is there any way this noob can remove this error message?

Thanks in advance-

Consult with the theme author to make it 1.0.9 compatible. Also, you are hiding the copyright text on http://klrworld.com/forums with black, the text must be clearly visible on all pages, please alter your style sheet accordingly.

-AwwLilMaggie
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: klra on November 10, 2006, 03:57:37 PM
Quote
Also, you are hiding the copyright text on http://klrworld.com/forums with black, the text must be clearly visible on all pages, please alter your style sheet accordingly.

I'm not hiding anything- the black bottom is part of the Ig-Oh theme, not intentional by any means on my part.

I wish I knew how to change that file, but I'm very new at this. Maybe the theme author has a fix-

Any advice on changing the color would be appreciated-

I'll contact the Ig-Oh author asking for an update as well.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: klra on November 10, 2006, 04:05:44 PM
Fixed the black background - looked around in the css file & found the culprit.

thanks for the heads up.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Gazmanafc on November 10, 2006, 04:12:11 PM
Thanks for fixing it. :)

-AwwLilMaggie
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: klra on November 10, 2006, 04:31:59 PM
No problem- I wasn't even aware it was a issue.

Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: PacificWx on November 11, 2006, 04:52:08 AM
upgraded to RC3 - no hassles, helped me simplify the forum somewhat
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: 4fit? on November 11, 2006, 10:16:36 AM
Sorry for the ultimate newb question, but......
I just recently took over our site.  The forum is currently SMF1.0.7.  The mods listed are :
1 - SMF 1.0.6 Update
2 - SMF 1.0.7 / 1.1 RC2 Update (marked as installed)

When I go to the Package Manager, there is a statement at the top saying that a security issue has been found with 1.0.7.  When I click the this patch update link, it says that it is going to install 1.0.8.
How exactly do I go about upgrading to the most recent version?  This will be my first attempt at this so any detailed assistance you could provide would be greatly appreciated!  What all needs to be done before I upgrade?  I really don't want to cause any down time on our site.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: winrules on November 11, 2006, 11:50:40 AM
FIrst upgrade to 1.0.8, and then upgrade to 1.0.9.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: 4fit? on November 11, 2006, 03:51:52 PM
FIrst upgrade to 1.0.8, and then upgrade to 1.0.9.
Thanks for the response!!  Anything I should do before I upgrade?  Or just click the Apply Mod button for SMF 1.0.8 Upgrade Package in the Package Manager?
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: FunPika4 on November 11, 2006, 04:17:47 PM
FIrst upgrade to 1.0.8, and then upgrade to 1.0.9.
Thanks for the response!!  Anything I should do before I upgrade?  Or just click the Apply Mod button for SMF 1.0.8 Upgrade Package in the Package Manager?
Nope. You can have your 1.0.7 to 1.0.9 in minutes. :)

Also you could do a manual upgrade if you want. But package is easier.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: 4fit? on November 12, 2006, 11:09:32 AM
Nope. You can have your 1.0.7 to 1.0.9 in minutes. :)

Also you could do a manual upgrade if you want. But package is easier.
Great!  Just upgraded in a matter of seconds!  Thanks for the response!!
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: alexxfender on November 13, 2006, 05:19:44 AM
SMF Upgrade Utility
Upgrading...
Putting your forum into maintenance mode... Successful.

Updating Settings.php with changes... Successful.

Creating new tables and inserting default data... Successful.

Converting activity logs... Successful.

Converting Boards and Categories... Successful.

Converting attachments, topics, and messages... Successful.

Converting members and personal messages... Unsuccessful!
This query:

    SELECT ID_MEMBER, im_ignore_list, gender, secretAnswer
    FROM smf_members
    LIMIT 0, 500;

Caused the error:

    Unknown column 'im_ignore_list' in 'field list'
TRY AGAIN ..

What is this error?
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Liza on November 13, 2006, 11:18:05 AM
Thank you so much, I was going to drive myself crazy.
I still drive crazy. Why it's so difficult to upgrade from RC2 to RC3. After all the pages i didn't found a hint
that solve it.

I don't want to to rewrite all post again.
I have 1.1RC2 - which file i have to use to upgrade to RC3. Which steps i have to do - THX a lot
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Gazmanafc on November 13, 2006, 11:48:56 AM
- Download the UPGRADE package for 1.1 RC3 from the download page
- Extract its contents into any folder on your computer
- Upload the files for 1.1 RC3 over your files for 1.1 RC2
- Run upgrade.php in your browser
- When it says that the upgrade is complete, delete upgrade.php

Upgrading SMF (http://docs.simplemachines.org/index.php?board=3.0)

-AwwLilMaggie
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Liza on November 13, 2006, 01:07:33 PM
Thx  :D
Step 4 -> Error 404

Perhaps i read the "upgradeSMF" Manual, delete all and start another try
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Migraine on November 13, 2006, 02:28:52 PM
Migraine, to solve your problem, CHMOD your forum's Sources directory to 0777. This can be done via your FTP client, or via cPanel's File Manager (if you have cPanel access).

Thanks Daniel... The settings were already at 777.  Just for good measure, I reset them, resaved them, but still get the same error.  ::)

~M
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: mystilon on November 13, 2006, 03:39:50 PM
A while back I downloaded the zip for 1.1 RC3, and I just installed it on a new site.  I noticed the message about a security update, and when I clicked on the link that is supposed to install the patch, I get this message (in all browsers):

Not Acceptable
An appropriate representation of the requested resource /smf/index.php could not be found on this server.

(The error message is apparently a 406 error)

Any ideas?
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Sockratease on November 13, 2006, 07:24:45 PM
Hi.

Me again...

I never resolved my previous question, but I think this will shed more light on it!

Note: It appears that your database may require an upgrade. Your forum files are currently at version SMF 1.0.9, whereas your database is at version SMF 1.0.7. It is recommended that you execute the latest version of upgrade.php.

Ummm...


I don't have a copy of upgrade.php, and can't find it!

There's nothing at .../smf/upgrade.php  and I downloaded the 1.09 package again, thinking I could pull out that one file and upload it, but could not find it included there!

I tried searching around, but could not find where to get a copy of the correct file.

If someone could point me in the right direction, I would be Very Grateful!

Thanks.

Peace.(https://www.simplemachines.org/community/proxy.php?request=http%3A%2F%2Flissawhipped.com%2Fsmf%2FSmileys%2Fdefault%2Fpeace.gif&hash=3c8cb01fab3cfa0c064c4f399b162140)

Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: jbraum on November 13, 2006, 07:50:07 PM
My profile is showing this.  What do I need to do to correct this problem?


Table 'della_della.log_online' doesn't exist
File: /home/della/public_html/Sources/Profile.php
Line: 944

It appears that your database may require an upgrade. Your forum files are currently at version SMF 1.0.9, whereas your database is at version SMF 1.0.8. It is recommended that you execute the latest version of upgrade.php.

Thanks
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: SleePy on November 13, 2006, 07:55:49 PM
Note: It appears that your database may require an upgrade. Your forum files are currently at version SMF 1.0.9, whereas your database is at version SMF 1.0.7. It is recommended that you execute the latest version of upgrade.php.

Download 1.0.9 Update. Upload the upgrade.php and the sql file in there

Run the upgrade.php (ie: http://yoursite.com/forum/upgrade.php).. When done delete the upgrade.php (and the sql file if you want).
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: jbraum on November 13, 2006, 08:09:48 PM
Thanks,

Did what you suggested in addition I replace the profile.php because of the error and everthing is in working order.

-Jeff
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Sockratease on November 13, 2006, 08:10:30 PM
Note: It appears that your database may require an upgrade. Your forum files are currently at version SMF 1.0.9, whereas your database is at version SMF 1.0.7. It is recommended that you execute the latest version of upgrade.php.

Download 1.0.9 Update. Upload the upgrade.php and the sql file in there

Run the upgrade.php (ie: http://yoursite.com/forum/upgrade.php).. When done delete the upgrade.php (and the sql file if you want).

Thanks!

I downloaded the wrong 1.09 file!

I feel Relief (https://www.simplemachines.org/community/proxy.php?request=http%3A%2F%2Flissawhipped.com%2Fsmf%2FSmileys%2Fdefault%2Frelief.gif&hash=361d5886f2ea59fbf6fd2be656d23690)

(That's my other custom smilie!  Feel free to steal them!)
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Phoenxx on November 14, 2006, 10:09:44 AM
I'm getting the same kind of error.
Quote
Got error 127 from storage engine
File: /home/blacka3/public_html/forum/Sources/ManageMembers.php
Line: 1899

Note: It appears that your database may require an upgrade. Your forum files are currently at version SMF 1.0.9, whereas your database is at version SMF 1.0.2. It is recommended that you execute the latest version of upgrade.php.
I have run the update, but I'm not sure how to delete upgrade.php after :(
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: DawnsWebDesigns on November 14, 2006, 11:05:45 AM
I downloaded this fine but when I tried to install it via the package manager I get a box telling me to open an index page or save it to my computer. ?  :o
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Nostalgia on November 15, 2006, 07:57:50 AM
Nice update, thanks!
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Jenie on November 15, 2006, 07:37:51 PM
I have tried to use this patch, but when I click on to install I get this...

Quote
Error in Package Installation
At least one error was encountered during a test installation of this package. It is strongly recommended that you do not continue with installation unless you know what you are doing, and have made a backup very recently. This error may be caused by a conflict between the package you're trying to install and another package you have already installed, an error in the package, a package which requires another package that you don't have installed yet, or a package designed for another version of SMF.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Gazmanafc on November 15, 2006, 07:46:31 PM
Which files are failing?

-AwwLilMaggie
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Jenie on November 15, 2006, 09:06:07 PM
When I click on...this patch (click here to install)...I get that error stated as above. This is what it says under "Install Actions". I just recently installed SMF 1.1 RC3 on my site,

Type     Action     Description
1.    Execute Modification    smf_1-1-rc3-1.mod    Modification parse error

It doesn't tell me which files though. Not sure if I should install this since I was getting the error. I'm new to this type of forum (I like it however :) just don't want to ruin my forum. Any suggestions?
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: SubhashBose on November 16, 2006, 06:05:43 AM
Please Help..
When I was trying to apply the patch using the packahe manager from the forum I got this error
Code: [Select]
Error in Package Installation

At least one error was encountered during a test installation of this package.
 It is strongly recommended that you do not continue with installation unless
you know what you are doing, and have made a backup very recently. This
error may be caused by a conflict between the package you're trying to install
 and another package you have already installed, an error in the package, a
package which requires another package that you don't have installed yet, or
 a package designed for another version of SMF.

Though I have updated by the attached file with this topic, and it is sucessfull but still I am concerned about the error. Is this due to any error in forum files?

Please let me know..
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Gazmanafc on November 16, 2006, 07:21:00 AM
That error will only appear if the package manager fails to find what it's looking for. Which files(s) are failing?

-AwwLilMaggie
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: vaulter on November 17, 2006, 05:44:23 AM
Hi there

I'm running SMF 1.0.8 and when i try to upgrade i get the following error:

Quote
2: fopen(): SAFE MODE Restriction in effect. The script whose uid is 10170 is not allowed to access /home/httpd/vhosts/mysite/httpdocs/forum/Packages/temp owned by uid 48
File: /home/httpd/vhosts/mysite/httpdocs/forum/Sources/Subs-Package.php
Line: 1476

Any ideas on this?

Thanks
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Daniel15 on November 17, 2006, 07:17:34 AM
vaulter, that error is caused by your web host having safe mode enabled. Try deleting the 'Packages/temp' directory using your FTP client, and then do the upgrade again.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: vaulter on November 17, 2006, 07:52:25 AM
Thanks for the reply Daniel15.  Still no joy with that though.  Do you know of another way around this?

Thanks again
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: vaulter on November 17, 2006, 07:58:06 AM
Actually, scrub that.  The temp directory created was chmod to 755 and the server wasn't letting me chmod it to 777.  I deleted it again, created a new one and chmod that to 777 which allowed the upgrade :)

Thanks again for your help :)
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: IngeJones on November 17, 2006, 08:15:08 AM
Two questions, please:

Do the SMF 1.1 RC3 files on the Downloads page already come updated with this patch?

I would like to try a test forum from this release before updating my live forums, if I use the Install version for a new forum, will it be a hassle setting it up to use my host's database service?  Would it be easier for me to instead use Fantastico in c-panel to set up their offered version of SMF and then use the Upgrade version on top of it?
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Compuart on November 17, 2006, 09:39:59 AM
Do the SMF 1.1 RC3 files on the Downloads page already come updated with this patch?
The 1.1 RC3 files on the download page have not been patched. The reason for that is to make sure all mods written for 1.1 RC3 keep working properly. Only stable branches (1.0.x series) get a new version number which can be downloaded from the download page.

Quote
I would like to try a test forum from this release before updating my live forums, if I use the Install version for a new forum, will it be a hassle setting it up to use my host's database service?  Would it be easier for me to instead use Fantastico in c-panel to set up their offered version of SMF and then use the Upgrade version on top of it?
You could go both ways, but I think installing 1.1 RC3 from scratch is easier. The only difference is probably that without Fantastico, you'd need to create a database and a database user yourself (using cPanel that should be relatively easy).
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: IngeJones on November 17, 2006, 10:55:39 AM
Thank you :)
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: baijianpeng on November 18, 2006, 02:06:40 PM
Now I am planning to set up my forum with SMF 1.1 rc3. If I download it from your download area, do I still need to apply this patch for 1.1 rc3 attached in the first post ?

I noticed that files in the patch is newer than files in the install package. Why didn't you updated the package in the download area ?

Thank you !
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Gazmanafc on November 18, 2006, 02:11:17 PM
The patch has not been included in the RC3 package to ensure that mods will work for it. You will need to apply this patch after your installation, the simplest way is through the package manager.

-AwwLilMaggie
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: baijianpeng on November 18, 2006, 07:16:52 PM
Understood. Thank you.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: FirstOverboard on November 19, 2006, 06:35:52 PM
Upgrading without loosing my customizations (manually?)

I have the SMF forum installed as version 1.0.4, according to the admin page. Under the Admin page > Detailed Version Check , a handful of source files are showing as being from older versions because they are highlighted in red and a newer version is listed to the right of them.

I'm worried about losing the customizing and formatting of my current site if i do an upgrade.

Can I just download the 1.0.9 zip file and upload (and overwrite) only the source files that appear to be old versions according to my admin panel? Will this "manually upgrade" my site?

Or is there more to it than that?
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: MacGig on November 19, 2006, 10:02:06 PM
1.1. patch didnt work for me. just my luck. :(
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Gazmanafc on November 19, 2006, 10:23:16 PM
You should then apply it manually or upload the updated files.

-AwwLilMaggie
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: sinbad on November 20, 2006, 12:12:10 AM
I have upgrade from very old version of YABBSE to the new 1.0.9

How easy it was!

I have no problem at all.

Thanks for your great work.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: NoWords on November 24, 2006, 04:42:31 AM
hello,

I'm absolutely newbie, i read the forum regarding upgradings and still have doubts...
I'm using SMF 1.0.9. and don't know which upgrade have to install to get the latest SMF version running.

sorry for such a simple question.

Thanks
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: Gazmanafc on November 24, 2006, 09:37:48 AM
You are running the latest version of 1.0. So there's no upgrade needed just yet.

(Unless you wanna go to 1.1 ;))

-AwwLilMaggie
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: NoWords on November 24, 2006, 10:27:29 AM
Thanks!!!

 ;D
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: thomastorfs on November 27, 2006, 01:10:50 PM
Hi,

I recently moved to a VPS host. First I had some problems regarding PHP5, so I switched back to PHP4. The only thing not working right now is the package manager. If I try to upload or even update RC3 with this fix, it gives errors.

The instant link to the RC3 fix gives me the following message:

Code: [Select]
You are not allowed to administrate this forum.
Please login below or register an account with Quasar - Intron Theory Forums.

Does anyone have an idea what the cause of this could be?


thanks,

Thomas


EDIT: ok, so far it seems to be an URL recognition problem. If I put the download link between brackets in the address bar, the forum says the package is corrupt or incompatible. I also have eAccelerator installed. Would that be a problem?

Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: TheMovieman on November 29, 2006, 11:40:45 AM
OK, I tried upgrading from 1.08 to 1.09 and get this error message:

"You cannot download or install new packages because the Packages directory is not writable!"

Now, I tried using my FTP program to change the permission to 777, but everytime I check to see if it stuck, it shows only 775. No matter how many times I try and change it, it goes back to that. I then logged into my cpanel which shows that the permission is set at 777... Yet I still cannot get this to upgrade.

Edit: I closed my FTP, logged in again and it indeed shows the permissions set to 777. Still can't upgrade...

In a previous post someone mentioned something about a temp file within the Packages directory, I don't seem to have that directory in mine. I've upgraded before (I think it was from 1.06 to 1.08 or something) with little or no problem.

Any help would be appreciated

Thanks
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: stuartbrandon on December 01, 2006, 08:09:02 AM
OK I'm surre I'm running the RC3, so why this ?

An Error Has Occurred!
The package you are trying to download or install is either corrupt or not compatible with this version of SMF. 
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: 青山 素子 on December 01, 2006, 11:21:02 AM
TheMovieman:

Awfully strange, but if the software can't write to the Packages directory, then something is still going on. Try creating a directory called "temp" inside the packages directory with permissions of 777 and try again.

stuartbrandon:

Try downloading the update package onto your computer, then uploading it that way with the package manager.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: TheMovieman on December 03, 2006, 01:54:08 AM
TheMovieman:

Awfully strange, but if the software can't write to the Packages directory, then something is still going on. Try creating a directory called "temp" inside the packages directory with permissions of 777 and try again.

Nope, still get the error. I closed my ftp program, opened it back up (just in case) and the Packages folder has the 777 permissions, and so does the temp folder I created... I didn't have this issue the last time.

However, I just thought. I had a critical error a couple months ago when I tried upgrading via fantastico and I had to open a ticket with my hosting company to get the backup online. Could that be why? I'd rather not use Fantastico again, so hopefully this will be figured out.
Title: Re: SMF 1.0.9 and patch for 1.1 RC3 released
Post by: NeFReT on December 03, 2006, 04:57:24 PM
Nice update, thanks!