Simple Machines Community Forum

SMF Support => Türkçe Bölümü (Turkish) => Language Specific Support => Dokümantasyon => Topic started by: ahmetarig on December 03, 2006, 05:48:28 AM

Title: Modların Yeni Sürümlere Çevrilmesi
Post by: ahmetarig on December 03, 2006, 05:48:28 AM
Bu işlem çok basittir. Ancak yeni sürümlerde azda olsa kod değişikliği olmuştur.
Anlatımda kod değişikliklerini göz önüne almıyoruz.


İlk önce çevirmek istediğimiz modu arşivden çıkaralım.
İşlem yapacağamız tek dosya package-info.xml dir.
 package-info.xml dosyasını not defterinde açalım.

bul
Code: [Select]
<install for=Bu yaznın karşısında modun yükleneceği forum sürümleri yazar.

örnek:
Code: [Select]
<install for="1.1 RC3">
yapacağımız işlem diğer sürümlerin sonrasına "," (virgül) koyup kullandığımız sürümü yazmak

örnek:
Code: [Select]
<install for="1.1 RC3 ,1.1">

yukarıdaki işlemi yaptıktan sonra
Code: [Select]
<uninstall for=Aynı işlemi burdada uygulayın

son olarak package-info.xml kaydedip diğer dosyalarla beraber arşivleyin (zip , tar.gz gibi )
Modları artık istediğiniz sürümlerde çalıştırabilirsiniz.

Anlaşılmayan bir taraf varsa lütfen yazınız.
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: mersindost on December 03, 2006, 06:13:55 AM
Artık Bunları Öğrenmenin Bir Faydası Olmaz Sanırım. Biliyorsunuz İzin Almadan Mod Filan Yapılmıyor. ;)
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: ahmetarig on December 03, 2006, 06:18:11 AM
izin almana gerek yok. kendi siten için istediğin modu çevirebilirsin. ama o modları burda veya başka yerde yayınlayamazsın.
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: ToKMaK on December 03, 2006, 08:12:27 AM
modu temaya uygun hale nasıl gietirirz..
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: ahmetarig on December 03, 2006, 08:15:50 AM
http://www.simplemachines.org/community/index.php?topic=131255.0

burda anlattım
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: AskSairi on December 03, 2006, 08:22:33 AM
cok faydali bir bilgiye benziyor
tesekkurler
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: Gang$ta on December 03, 2006, 08:31:56 AM
tesekkürler ;)
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: ayesoft on December 03, 2006, 08:37:13 AM
eski sürümler için işe yaramıyor rc2 rc3 arasında pek fark yok o yüzden çalışıyor ama eski sürümlerde hata verebiliyor kod yapısından kaynaklanıyor zaten çoğu mod rc2 için böylece rc3 tede çalışacaktır ;)
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: ahmetarig on December 03, 2006, 08:39:57 AM
eski sürümler için işe yaramıyor rc2 rc3 arasında pek fark yok o yüzden çalışıyor ama eski sürümlerde hata verebiliyor kod yapısından kaynaklanıyor zaten çoğu mod rc2 için böylece rc3 tede çalışacaktır ;)
modların hemen hemen hepsi rc2 ve rc3 uyumlu arlarında pek fazla kod değişikliği yok.
Yukardada açıkladım kod değişikliği göz önüne alınmamıştır diye ;)
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: AskSairi on December 03, 2006, 08:48:12 AM
Code: [Select]
<?xml version="1.0"?>
<!DOCTYPE package-info SYSTEM "http://www.simplemachines.org/xml/package-info">
<package-info xmlns="http://www.simplemachines.org/xml/package-info" xmlns:smf="http://www.simplemachines.org/">
<name>Kütüphane Modu Rc3 KraL</name>
<id>KraL:Kutuphane Modu Rc3 KraL</id>
<type>modification</type>
<version>1.1.3 Rc3 Tr</version>
<install>
<readme type="inline"><![CDATA[
    KraL Www.AskiMSensin.CoM Www.MerceKForum.CoM Www.SanaLForumlar.CoM
Acýklama : Bu Mod Sýk Kullanýlardaki Gibi Begendiginiz Konularý Kütüphanenize Eklemeyi Saglar..
     
                ]]></readme>

<modification format="xml" type="file">kutuphane_Mod.xml</modification>

<require-file name="Bookmark.php" destination="$sourcedir" />
                <require-file name="Bookmark.template.php" destination="$themedir" />
                <code type="file">create_table.php</code>
</install>

<uninstall>
<modification reverse="true">kutuphane_Mod.xml</modification>
</uninstall>

</package-info>


burda degismesi gereken nedir peki
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: ahmetarig on December 03, 2006, 08:54:30 AM
burda bişey değişmene gerek yok. eğer uygulanan kodlarda bir değişiklik yoksa hata almadan modu kullabilirisin.
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: AskSairi on December 03, 2006, 09:15:55 AM
anlasilan kodlarda baya degisiklik var cunku bir suru hata veriyorrrr
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: ahmetarig on December 03, 2006, 09:17:44 AM
anlasilan kodlarda baya degisiklik var cunku bir suru hata veriyorrrr
değişiklik görülemeyecek kadar az. sen bir hata yapmışsındır.
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: NeFReT on December 04, 2006, 05:26:08 PM
Çok Gerekli Bir Bilgi Saol ahmetarig
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: STRONGHOLD on December 05, 2006, 07:55:22 AM
S.a.

Öncelikle bilgi için teşekkürler arkadaşım...Memeber Color Link modunu ve birkaç modu daha aynen dediğin gibi tekrar tekrar yaptım ama Yüklemeye çalışınca -Hiçbir Yükleneme Eylemi Yapılmadı veya Tamamlanamadı diyor...

 Biryerde yanlış yapıyom galiba ya  :-\
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: ahmetarig on December 05, 2006, 08:06:28 AM
S.a.

Öncelikle bilgi için teşekkürler arkadaşım...Memeber Color Link modunu ve birkaç modu daha aynen dediğin gibi tekrar tekrar yaptım ama Yüklemeye çalışınca -Hiçbir Yükleneme Eylemi Yapılmadı veya Tamamlanamadı diyor...

 Biryerde yanlış yapıyom galiba ya  :-\

bende member color linki ilk çevirdiğimde olmadı ama daha sonra tekrar denedim oldu sana pmden  yollayım. yaptığın hataya bak
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: STRONGHOLD on December 05, 2006, 08:15:55 AM
S.a.

Öncelikle bilgi için teşekkürler arkadaşım...Memeber Color Link modunu ve birkaç modu daha aynen dediğin gibi tekrar tekrar yaptım ama Yüklemeye çalışınca -Hiçbir Yükleneme Eylemi Yapılmadı veya Tamamlanamadı diyor...

 Biryerde yanlış yapıyom galiba ya  :-\

bende member color linki ilk çevirdiğimde olmadı ama daha sonra tekrar denedim oldu sana pmden  yollayım. yaptığın hataya bak

Çok teşekkür ederim ahmetarig ;) Çalıştı...

Ama hata nerede yaptığımı tam anlayamadım...ben sadece 1.1 şeklinde ekleme yaptım... 1.1 final diye mi eklemek gerekiyormuş?
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: ahmetarig on December 05, 2006, 08:18:36 AM
hayır final yazmana gerek yok. benim yolladığımla kendi yaptığını karşılaştırısan farkı görürsün ;)
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: STRONGHOLD on December 05, 2006, 08:39:48 AM
Hımm..Ok anladım hatayı ;) Teşekkürler dostum tekrar. Kolay gelsin sana ;)
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: _MeRt_ on December 05, 2006, 08:46:52 AM
aynı hata bendede  var sorun ney? açıklar mısın?
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: ahmetarig on December 05, 2006, 08:59:07 AM
1.1 final uyumlu package.xml yolluyorum sorunun neyse bul.
Code: [Select]
<?xml version="1.0"?>
<!DOCTYPE package-info SYSTEM "http://www.simplemachines.org/xml/package-info">

<package-info xmlns="http://www.simplemachines.org/xml/package-info" xmlns:smf="http://www.simplemachines.org/">
<id>din1031:MemberColorLink</id>
<name>Member Color Link</name>
<version>1.8.7</version>
<type>modification</type>
<install for="1.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.7, 1.0.8, 1.1 Beta 1, 1.1 Beta 2, 1.1 final">
<readme type="inline">
This mod add some new options in the forum settings.
With this you can show the userlinks in the color of the group or post color.
You can see this effect in threaddisplay, Mainboard and in the Boardindex (Thread Owner, Child Board and Last Poster).

This version should work in 1.1. Beta 1 (Beta 2), too.

The Birthday links can only work if the calendar.template and the boardindex.template are changed
in all themes of your Forum.

Türkceye Ceviren : iMoTeP_1

Copyright 2005 by DIN1031 @ www.ayu-kult.de/forum/
</readme>
<modification format="boardmod">MemberColorMod181a.mod</modification>
</install>
<uninstall for="1.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.7, 1.0.8, 1.1 Beta 1, 1.1 Beta 2, 1.1 final">
<modification format="boardmod" reverse="true">MemberColorMod181a.mod</modification>
</uninstall>
<install for="1.1 RC1">
<readme type="inline">
This mod add some new options in the forum settings.
With this you can show the userlinks in the color of the group or post color.
You can see this effect in threaddisplay, Mainboard and in the Boardindex (Thread Owner, Child Board and Last Poster).

This version should work only in 1.1 RC1

The Birthday links can only work if the calendar.template and the boardindex.template are changed
in all themes of your Forum.

Copyright 2005 by DIN1031 @ www.ayu-kult.de/forum/
</readme>
<modification format="boardmod">MemberColorMod185.mod</modification>
</install>
<uninstall for="1.1 RC1">
<modification format="boardmod" reverse="true">MemberColorMod185.mod</modification>
</uninstall>
<install for="1.1 RC2, 1.1">
<readme type="inline">
This mod add some new options in the forum settings.
With this you can show the userlinks in the color of the group or post color.
You can see this effect in threaddisplay, Mainboard and in the Boardindex (Thread Owner, Child Board and Last Poster).

This version should work only in 1.1 RC2 and above

The Birthday links can only work if the calendar.template and the boardindex.template are changed
in all themes of your Forum.

Copyright 2005-2006 by DIN1031 @ www.ayu-kult.de/forum/
</readme>
<modification format="boardmod">MemberColorMod187.mod</modification>
</install>
<uninstall for="1.1 RC2, 1.1">
<modification format="boardmod" reverse="true">MemberColorMod187.mod</modification>
</uninstall>
</package-info>
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: _MeRt_ on December 05, 2006, 11:24:16 AM
Çok sağ ol, buldum kardeş...
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: ℓσяєиz on December 05, 2006, 12:30:56 PM
çok faydalı bir tüyo. ;)

sana katılıyorum ama en saglıklısı manual kurmak diye düşünüyorum çünki değişen bazı kodlar var arada
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: ahmetarig on December 05, 2006, 02:35:23 PM
çok faydalı bir tüyo. ;)

sana katılıyorum ama en saglıklısı manual kurmak diye düşünüyorum çünki değişen bazı kodlar var arada
çok uzun kodlamalı modlar var kod değişikliğinde yüklerken hangi dosyada değişiklik olduğunu diyor zaten. sadece o dosyayla uğraşılır.
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: Elmacik on December 05, 2006, 02:55:05 PM
Bunları daha önce konuşmuştuk.
Size çok dikkatli olmanızı öneririm.
Ne yaptığınız bilmeden bu yöntemle veritabanını bozabilirsiniz.
Çünkü eski versiyonlar ve yeni versiyonlar arasnıda hem kod değişiklikleri hem de veritabanı değişiklikleri olur. Uyumsuzluk forumunuzu bozabilir.

Basit modlarda ise bu yöntem genellikle iyi sonuç verir.
Size yine de manuel kurulumu öğrenmenizi tavsiye ederim.

Sağol ahmetarig
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: ahmetarig on December 05, 2006, 03:31:01 PM
Böyle bir hata olabilir ama sonuçta veritabanını bozacak mod veritabanında yeni bir tablo oluşturur. phpmyadmindende o tablo silinir ve düzelir.
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: Elmacik on December 05, 2006, 04:17:41 PM
Veritabanında yeni tablo oluşturabilir, mevcut tablolara yeni sutün ekleyebilir, mevcut sütunları değiştirebilir.
Sürümler arasında dosyalar da değiştiği için kodları da bozabilir. Dosyanın yenisiyle değiştirilmesi bu defa da forumu bozabilir.
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: ahmetarig on December 06, 2006, 05:36:29 AM
Veritabanında yeni tablo oluşturabilir, mevcut tablolara yeni sutün ekleyebilir, mevcut sütunları değiştirebilir.
Sürümler arasında dosyalar da değiştiği için kodları da bozabilir. Dosyanın yenisiyle değiştirilmesi bu defa da forumu bozabilir.

evt dediklerin doğru. modu çevirip ilk önce localde denemesini yapmak daha doğru olur.
Ama mod yazarlarıda dahil yeni sürümlere bu şekilde çeviriyor. Tabi ilk önce kendileri deneme yapıp yayınlıyor.
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: Microfost on December 09, 2006, 12:21:16 PM
Bende 1.1 modları arıyodum süper oldu bu
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: CiCeRo on December 13, 2006, 07:39:09 PM
Çok teşekkür ederim ben 1.1 de denedim çalıştı hemde sorunsuz.
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: Forumlarimiz.com on January 22, 2007, 01:43:57 PM
Registered Links  1.1 için Mod Yok Burada Bulamadım :S
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: SiveroN on January 22, 2007, 04:05:07 PM
Registered Links  1.1 için Mod Yok Burada Bulamadım :S

Kendin oluşturabilirsin ;)

package-info.xml yi ac

icinde <install> ya da <install for="

vardır

for=".. ,1.1,1.1.1"

ekle

aynısını <uninstall a da yap ve yeni sürümünde kullan ;)
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: Forumlarimiz.com on January 23, 2007, 05:28:57 AM
Olmadı Kardes  Hiç bir Kurulum EyLEMİ Felan Yok Diyor Yaw :(
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: SiveroN on January 23, 2007, 05:31:23 AM
valla olması lazım cünkü aynı modifikasyonu bende kullanıyorum ve calısıyor :-\ tekrar dene istersen ya da package-info.xml yi buraya kod olarak koy neresinin değiştirileceğini yazim sana...
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: Forumlarimiz.com on January 23, 2007, 05:48:52 AM
Mod Registered Links
Açıklama Bu mod ile ziyaretçiler konu içerisindeki linkleri görememektedir... Kendim bu modu modifiye ederek ftp, email, flash, img tagları içinde uygun hale getirdim...
Uyumluluk 1.1 RC2
Hakkında Modun orjinali vbgamer45 adlı üyeye aittir. http://mods.simplemachines.org/index.php?mod=342
Download http://www.forumsn.com/Badboy/reglinks_modified_by_badboy.zip

--------------------------------------------------------------------------------
buyur kardes mod yukarıdan indirdim  bakarsan sevinirim
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: SiveroN on January 23, 2007, 05:56:18 AM
Simdi BadBoy varken bunu anlIk bana düşmez ama... neyse.

zip ten cıkar dosyaları icinde package-info.xml var onu not pad te ac

icinde su var : <install for="1.1 RC2">

bunu <install for="1.1 RC2, 1.1 , 1.1.1">

yap

<uninstall for="1.1 RC2"> var <uninstall for="1.1 RC2, 1.1, 1.1.1">

yap kaydet sonra ziple kullan ;)
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: Forumlarimiz.com on January 23, 2007, 06:28:29 AM
Kardeş Cok Tesekkurler Oldu Ama  Benim Tema Mns  Ona  Göre Nasıl uyarlıyacam?  manuel kurlum ile hiç bilgim yok
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: SiveroN on January 23, 2007, 06:36:32 AM
Kardeş Cok Tesekkurler Oldu Ama  Benim Tema Mns  Ona  Göre Nasıl uyarlıyacam?  manuel kurlum ile hiç bilgim yok

Bu temada sadece Languages klasöründeki Modification.Turkish.php yi etkiler

Bunu Bul

Code: [Select]

?>


Öncesine şunu ekle

Code: [Select]

//Üye Linkleri
$txt['no_view_links'] = 'Linklerin Görülmesine İzin Verilmiyor';
$txt['no_view_view'] = 'Linki Görebilmek İçin';
$txt['no_view_register'] = 'Üye Ol';
$txt['no_view_or'] = 'veya';
$txt['no_view_login'] = 'Giriş Yap';
//END Reg Links Text Strings


Diğer kodlar Subs.php ye otomatik eklenir ve her temada calısır.
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: ahmetarig on January 23, 2007, 06:38:52 AM
Sana basit bir yöntem söyleyim. mns temasının tüm dosyalarını default klasörüne at. ve aynı dosyaların üstüne yazdır. daha sonra admin panelinden kullanılan temayı default seç. Artık modları hiç uğraşmadan paket olarak yükleyip kullanabilirsin.

Ben bunu yapmıcam diyosan. Bu konun biraz aşağısında  modların temalara göre çevrilmesi var ordan halledersin.
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: Forumlarimiz.com on January 23, 2007, 07:14:12 AM
Teşekkur ler  ama dediğiniz  işlemleri yapmadan önce default thme ye seçip denedim  yine linkler görunuyor :S  www.msndiyari.com girip bakabilirsiniz... üyeliksiz giriş var zaten
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: ahmetarig on January 23, 2007, 07:22:26 AM
Bak benim sitede dediğim gibi default temayı kullanıyorum ve modları direk yüklüyorum. Hiç bir sorun yok. Siten daha yeniymiş. Tüm modları kaldır ve mns style klasörünün içindeki tüm dosyaları defaulta taşı. daha sonra modları kurup dene.
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: Forumlarimiz.com on January 23, 2007, 07:27:19 AM
kareş ben daha hiç bir mod kurmamamısım registered link ten baska ve default temada da  çalısmadı..şimdi senin dedıgın şeklşi uyguluyorum...yinede  hiç bir değişiklik yok
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: ahmetarig on January 23, 2007, 07:39:31 AM
Sorun sende yanlış bişeyler yapıyosun. Bence localde bir forum kur modları burda dene daha sonra sitene yükle.
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: crazyim on April 07, 2007, 10:33:20 AM
Merhaba;
Reklam modu ekledim kurulumda sorun yok.Fakat seçenekler ve opsiyonlar kısmında en alta yeni bir bölüm çıktı ama hiçbir yazısı yok..Tick atılacak bir kaç kare ve mesaj yazma bölümü var.Herhangi bir ayzı yok...Sizce sorun nedir arkadaşlar?
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: 4LP3RUZ1 on April 08, 2007, 02:25:59 AM
@crazyim:

Bu konu ile bir alakası yok, lütfen modun Türkçe açıklamalarını oku. (Modifikasyon bölümünde)
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: KardesTurk on September 26, 2007, 10:46:00 AM
Arkadaslar ayni sorun bendede var fakat ne denediysem olmadi buyrun package-info.xml dosyasi sudur
Code: [Select]
<?xml version="1.0"?>
<!DOCTYPE package-info SYSTEM "http://www.simplemachines.org/xml/package-info">
<!-- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
This is a simplified package manifest for SMF packages.

ATTENTION: If you are trying to install this manually, you should try
the package manager.  If it will not work for you, please take a look
at the following for information on this format:
http://mods.simplemachines.org/docs/manual-install.php

 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -->

<package-info xmlns="http://www.simplemachines.org/xml/package-info" xmlns:smf="http://www.simplemachines.org/">
<id>smf:smf-1.0.11-1.1.3</id>
<name>SMF 1.0.11 / 1.1.3 Update</name>
<version>1.1</version>

<type>modification</type>

<install for="1.0.10">
<readme type="inline">
This patch file will update your forum to SMF 1.0.11.
</readme>
<modification type="file" format="boardmod">smf_1-0-10_to_1-0-11_patch.mod</modification>
</install>
<install for="1.1.2">
<readme type="inline">
This patch file will update your forum to SMF 1.1.3.
</readme>
<modification type="file" format="boardmod">smf_1-1-2_to_1-1-3_patch.mod</modification>
<modification type="file" format="xml">smf_1-1-3_can_fail.xml</modification>
</install>
<uninstall for="1.0.11">
<modification type="file" format="boardmod" reverse="true">smf_1-0-10_to_1-0-11_patch.mod</modification>
</uninstall>
<uninstall for="1.1.3">
<modification type="file" format="boardmod" reverse="true">smf_1-1-2_to_1-1-3_patch.mod</modification>
</uninstall>
</package-info>
Yani ben hala 1.1.2 kullanmaktayim önce 1.1.3 geçmek istiyorum sonrasinda 1.1.4 yapacaktim fakat olmadi bi el atan olursa sevinirim, ve birsey daha gereken update paketini indirdim ve bilgisayardan yuklemeye çalistim fakat yine hata verdi
Bir hata meydana geldi!
Yüklemek istediğiniz paket'de sorun var yada geçerli bi paket değil.


simdiden tskler.
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: mrzcn on October 07, 2007, 01:49:22 PM
arkadaşlar modlar kuruluyken 113 den 114 de upgrade etsem modları sonra bu sürüme uyarlayabilirmiyim ?
eskiden upgrade ettiğimde modlar görünmez olmuştu çok sorunlar çıktı.bunun bi kolay yolu olmalı.

teşekkrler
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: antitezz on December 23, 2007, 06:41:05 PM
ellerine kollarına sağlık :D valla çok makbule geçti :D
Title: 530 Login authentication failed hatası
Post by: Sami Ekici on January 03, 2009, 07:55:22 AM
530 Login authentication failed hatası alanlar...

530 Login authentication failed hatası sunucu içerisinde ftp servisinden dolayı kaynaklanır. Bu servisin yeniden sunucu yönetimi kimdeyse ( hosting firması ) ordan yeniden başlatılması gereklidir.

Selamlar.
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: DNA27 on February 07, 2009, 08:41:03 PM
Code: [Select]
<?xml version="1.0"?>
<!DOCTYPE package-info SYSTEM "http://www.simplemachines.org/xml/package-info">
<package-info xmlns="http://www.simplemachines.org/xml/package-info" xmlns:smf="http://www.simplemachines.org/">
  <name>SMF Shoutbox</name>
  <id>Deep:SMF_Shoutbox</id>
  <type>modification</type>
  <version>1.16b</version>

  <install>
    <require-file name="sbox.php" destination="$sourcedir" />
    <require-file name="sboxDB.php" destination="$sourcedir" />
    <require-file name="sbox.english.php" destination="$languagedir" />
    <require-file name="sbox.german.php" destination="$languagedir" />
    <require-file name="sbox.french.php" destination="$languagedir" />
    <require-file name="sbox.template.php" destination="$themedir" />
    <require-file name="sbox_refresh.gif" destination="$themedir/images" />
    <require-file name="chat-inbound_GSM.wav" destination="$boarddir" />
    <code type="file">sbox_setup.php</code>
    <readme type="inline"><![CDATA[
      This allows you to put a shoutbox on your SMF forum above the board index of the default theme.

    Originally written By Deep (diem4@gmx.net), inspired by Matthew Wolf (a.k.a Grudge)
    Heavily improved by Markus Birth (mbirth@webwriters.de)
    Copyright 2006 - Neither this package or any of it's contents may be distributed without authorisation.
    ]]></readme>
    <modification type="file">sbox_latest.xml</modification>
  </install>

  <upgrade from="1.10">
    <readme type="inline"><![CDATA[Thanks for trying the shiny new update feature. Although the Package manager might show you an error, the upgrade should work.

PLEASE UNINSTALL ANY LANGUAGE PACK FOR SHOUTBOX BEFORE UPGRADING!]]></readme>
    <modification type="file" reverse="true" format="boardmod">sbox_110.mod</modification>
    <require-file name="sbox.php" destination="$sourcedir" />
    <require-file name="sboxDB.php" destination="$sourcedir" />
    <require-file name="sbox.english.php" destination="$languagedir" />
    <require-file name="sbox.german.php" destination="$languagedir" />
    <require-file name="sbox.french.php" destination="$languagedir" />
    <require-file name="sbox.template.php" destination="$themedir" />
    <require-file name="sbox_refresh.gif" destination="$themedir/images" />
    <require-file name="chat-inbound_GSM.wav" destination="$boarddir" />
    <code type="file">sbox_upgrade.php</code>
    <modification type="file">sbox_latest.xml</modification>
  </upgrade>
  <upgrade from="1.11">
    <readme type="inline"><![CDATA[Thanks for trying the shiny new update feature. Although the Package manager might show you an error, the upgrade should work.

PLEASE UNINSTALL ANY LANGUAGE PACK FOR SHOUTBOX BEFORE UPGRADING!]]></readme>
    <modification type="file" reverse="true" format="boardmod">sbox_111.mod</modification>
    <require-file name="sbox.php" destination="$sourcedir" />
    <require-file name="sboxDB.php" destination="$sourcedir" />
    <require-file name="sbox.english.php" destination="$languagedir" />
    <require-file name="sbox.german.php" destination="$languagedir" />
    <require-file name="sbox.french.php" destination="$languagedir" />
    <require-file name="sbox.template.php" destination="$themedir" />
    <require-file name="sbox_refresh.gif" destination="$themedir/images" />
    <require-file name="chat-inbound_GSM.wav" destination="$boarddir" />
    <code type="file">sbox_upgrade.php</code>
    <modification type="file">sbox_latest.xml</modification>
  </upgrade>
  <upgrade from="1.12">
    <readme type="inline"><![CDATA[Thanks for trying the shiny new update feature. Although the Package manager might show you an error, the upgrade should work.

PLEASE UNINSTALL ANY LANGUAGE PACK FOR SHOUTBOX BEFORE UPGRADING!]]></readme>
    <modification type="file" reverse="true" format="boardmod">sbox_112.mod</modification>
    <require-file name="sbox.php" destination="$sourcedir" />
    <require-file name="sboxDB.php" destination="$sourcedir" />
    <require-file name="sbox.english.php" destination="$languagedir" />
    <require-file name="sbox.german.php" destination="$languagedir" />
    <require-file name="sbox.french.php" destination="$languagedir" />
    <require-file name="sbox.template.php" destination="$themedir" />
    <require-file name="sbox_refresh.gif" destination="$themedir/images" />
    <require-file name="chat-inbound_GSM.wav" destination="$boarddir" />
    <code type="file">sbox_upgrade.php</code>
    <modification type="file">sbox_latest.xml</modification>
  </upgrade>
  <upgrade from="1.13">
    <readme type="inline"><![CDATA[Thanks for trying the shiny new update feature. Although the Package manager might show you an error, the upgrade should work.

PLEASE UNINSTALL ANY LANGUAGE PACK FOR SHOUTBOX BEFORE UPGRADING!]]></readme>
    <modification type="file" reverse="true" format="boardmod">sbox_113.mod</modification>
    <require-file name="sbox.php" destination="$sourcedir" />
    <require-file name="sboxDB.php" destination="$sourcedir" />
    <require-file name="sbox.english.php" destination="$languagedir" />
    <require-file name="sbox.german.php" destination="$languagedir" />
    <require-file name="sbox.french.php" destination="$languagedir" />
    <require-file name="sbox.template.php" destination="$themedir" />
    <require-file name="sbox_refresh.gif" destination="$themedir/images" />
    <require-file name="chat-inbound_GSM.wav" destination="$boarddir" />
    <code type="file">sbox_upgrade.php</code>
    <modification type="file">sbox_latest.xml</modification>
  </upgrade>
  <upgrade from="1.14">
    <readme type="inline"><![CDATA[Thanks for trying the shiny new update feature. Although the Package manager might show you an error, the upgrade should work.]]></readme>
    <require-file name="sboxDB.php" destination="$sourcedir" />
    <require-file name="sbox.english.php" destination="$languagedir" />
    <require-file name="sbox.german.php" destination="$languagedir" />
    <require-file name="sbox.french.php" destination="$languagedir" />
    <require-file name="sbox.template.php" destination="$themedir" />
  </upgrade>
  <upgrade from="1.15b">
    <readme type="inline"><![CDATA[Thanks for trying the shiny new update feature. Although the Package manager might show you an error, the upgrade should work.]]></readme>
    <require-file name="sbox.template.php" destination="$themedir" />
  </upgrade>

  <uninstall>
    <readme type="inline">Uninstall will remove all the changes made by the shoutbox.</readme>
    <modification type="file" reverse="true">sbox_latest.xml</modification>
    <remove-file name="$sourcedir/sbox.php" />
    <remove-file name="$sourcedir/sboxDB.php" />
    <remove-file name="$languagedir/sbox.english.php" />
    <remove-file name="$languagedir/sbox.german.php" />
    <remove-file name="$languagedir/sbox.french.php" />
    <remove-file name="$themedir/sbox.template.php" />
    <remove-file name="$themedir/images/sbox_refresh.gif" />
    <remove-file name="$boarddir/chat-inbound_GSM.wav" />
    <remove-file name="$boarddir/sbox.history.html" />
    <code type="file">sbox_remove.php</code>
  </uninstall>
  <install>
    <readme type="inline">Sorry, but the SMF Shoutbox Mod doesn't support your SMF version!</readme>
  </install>
</package-info>

1.1.8 hata veriyor dediginiz kod burda yok :S ne yapmam gerek
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: Yağız... on February 08, 2009, 05:28:22 AM
Normalde hata vermemesi gerekiyor...  <install> ve <uninstall> yazan yerleri <install for="1.1.8"> ve <uninstall for="1.1.8"> olarak değiştirin.
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: DNA27 on February 08, 2009, 06:28:38 AM
ok dir Allah razı olsun
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: lifelife on June 27, 2009, 04:36:19 PM
bende yok o install for dan  :'(
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: Yağız... on June 27, 2009, 04:54:31 PM
Yoksa her sürümde yükleyebilirsiniz(ama her sürüme uymayabilir).
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: CeeMoo on July 23, 2009, 03:19:27 AM
Ellerine sağlık kardeş
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: _ImmorTaL_ on August 01, 2010, 11:42:33 AM
530 Login authentication failed alıyorum
Title: Re: Modların Yeni Sürümlere Çevrilmesi
Post by: Balaban on August 20, 2010, 09:51:16 PM
Ne yaparken ?