Simple Machines Community Forum

SMF Support => Language Specific Support => Italiano (Italian) => Topic started by: MarMa on December 28, 2006, 04:51:42 AM

Title: Forum CRASHATO: HELP !!!
Post by: MarMa on December 28, 2006, 04:51:42 AM
aiuto !
mi si è crashato il forum e nn capisco xkè!

premettendo che avevo installato la versione 1.07, prima mi diceva: errore in BoardIndex.php
allora ho riuploadato solo quella pag, ma nulla
allora ho provato a caricare tutta la cartella sources
ancora nulla

allora ho provato a fare l'upgrade, seguendo le istruzione di questo forum
e ancora niente

ora nn riesco neanche + a entrare
sembra che nn carichi la pwd
i dati degli utenti sembrani rimasti intatti
ci si può iscrivere ma la struttura delle tabelle nn è disponibile

aiuto, che devo fare ?!

se c'è qualche anima buona sotto natale...che riesce a capire cosa è successo e dove ho sbagliato
http://marcomangiarotti.altervista.org/forum/index.php

in privato posso fornire utente e pwd di prova


please help
nn sono una programmatrice e con tutti quegli script mi va il cervello in pappa!
 :( :'(
Title: Re: Forum CRASHATO: HELP !!!
Post by: francesco_ud on December 28, 2006, 03:58:42 PM
ciao,
che tipo di errore ti ritornava? sei in grado di postare tutta la stringa che ti viene ritornata?

così in base a questo si può stabilire cosa può essere  ;)
Title: Re: Forum CRASHATO: HELP !!!
Post by: MarMa on December 29, 2006, 08:48:23 AM
ciao,
che tipo di errore ti ritornava? sei in grado di postare tutta la stringa che ti viene ritornata?

così in base a questo si può stabilire cosa può essere  ;)

purtroppo no, e ora, dopo che sono riuscita a mettere in maintenace mode mi da altri problemi
tipo che al momento di loggarsi nn carica la pwd

cmq all'inizio, diceva semplicemente "error in BoardIndex.php"


ho provato anche caricato "repair settings" ma nulla da fare

avendo fatto un backup del forum, mi andrebbe bene anche riuscire a cancellare il vecchio forum e installare la nuova versione ma mi da cmq dei problemi..

mah&sob
Title: Re: Forum CRASHATO: HELP !!!
Post by: francesco_ud on December 29, 2006, 11:27:01 AM
provieni da qualche forum particolare?

hai provato a reinserire tutti i file del sito, dai template ai source?
Title: Re: Forum CRASHATO: HELP !!!
Post by: MarMa on December 29, 2006, 02:38:51 PM
provieni da qualche forum particolare?

hai provato a reinserire tutti i file del sito, dai template ai source?

guarda, è questo
http://marcomangiarotti.altervista.org/forum/

hoprovato a reinstallare tutti i files, ma nulla
sempre boardindex.php error
ho provato anche con l'upgrade, ma nisba

e soprattutto nn riesco a capire come dal mattino al pomeriggio sia potuto accadere
siamo anche in pochi a frequentarlo, anche se il forum è quello di marco mangiarotti, giornalista del QN e giudice in amici e music farm

c'è chi ha ipotizzato al sabotaggio, ma nn so che credere.. mah!
Title: Re: Forum CRASHATO: HELP !!!
Post by: francesco_ud on December 29, 2006, 05:01:13 PM
purtroppo vedo solo che sei in modalità manutenzione..
Title: Re: Forum CRASHATO: HELP !!!
Post by: MarMa on December 30, 2006, 02:37:51 AM
purtroppo vedo solo che sei in modalità manutenzione..

xkè da lì nn riesco più a muovermi.

nn mi fa loggare.
riconosce se un utente è o non è iscritto (evidentemente il DB nn è corrotto del tutto..) ma non mi fa entrare.
al momento del login la pwd viene "cancellata" e infatti mi dice "devi inserire la pwd per loggarti".
ma va?!
Title: Re: Forum CRASHATO: HELP !!!
Post by: francesco_ud on December 30, 2006, 04:41:34 AM
hai accesso al server?

se si prova a togliere la modalità manutenzione.
Title: Re: Forum CRASHATO: HELP !!!
Post by: MarMa on December 30, 2006, 07:44:44 AM
hai accesso al server?

no, sob
 :'( :-[
Title: Re: Forum CRASHATO: HELP !!!
Post by: francesco_ud on December 30, 2006, 08:36:12 AM
scusa, ma come hai fatto a copiare i files allora?
per caso hai dei messaggi all'interno del forum? perchè se non ne hai, prima di tutto io proverei a rifare la procedura di installazione da 0, e vedrei se ci sono nuovi problemi
Title: Re: Forum CRASHATO: HELP !!!
Post by: MarMa on December 31, 2006, 04:32:54 AM
scusa, ma come hai fatto a copiare i files allora?
per caso hai dei messaggi all'interno del forum? perchè se non ne hai, prima di tutto io proverei a rifare la procedura di installazione da 0, e vedrei se ci sono nuovi problemi

l'ho fatto prima che mi "escludesse" l'accesso.
infatti sono riuscita a mettere in maintenance mode..
ma ora ciccia

cmq proverò a reinstallare tutto daccapo

il quesito che mi sorge, è se è meglio diciamo "formattare" il vecchio DB, così da nn avere sovrapposizioni di dati o no..
anche come formattare sarebbe utile..
devo guardare un pò come funzionano i tools di altervista

uff che pizza però
Title: Re: Forum CRASHATO: HELP !!!
Post by: francesco_ud on January 02, 2007, 01:39:13 PM
se non hai dati puoi tramite phpmyadmin cancellare direttamente tutte le tabelle per poi rifare l'installazione da 0.
Title: Re: Forum CRASHATO: HELP !!!
Post by: MarMa on January 02, 2007, 05:47:03 PM
se non hai dati puoi tramite phpmyadmin cancellare direttamente tutte le tabelle per poi rifare l'installazione da 0.

ah, grazie del consiglio
è un programma o il pannello di controllo del DB ?

scusa, ma non sono programmatrice
già mi fare troppo, con tutti questi script, figurati te

;-)
Title: Re: Forum CRASHATO: HELP !!!
Post by: francesco_ud on January 02, 2007, 06:25:15 PM
non ti preoccupare,anche io all'inizio ero un pò spaventato da queste cose!

sostanzialmente dovresti avere un certo indirizzo web che ti permette di accedere ad una pagina che ti mette a disposizione uno strumento con cui tu puoi gestire il tuo database. permettendoti di fare backup, cancellare tuple, o intere tabelle.

il programma è molto valido e conoscere il suo funzionamento può essere molto utile!
Title: Re: Forum CRASHATO: HELP !!!
Post by: MarMa on January 07, 2007, 02:53:51 AM
non ti preoccupare,anche io all'inizio ero un pò spaventato da queste cose!

sostanzialmente dovresti avere un certo indirizzo web che ti permette di accedere ad una pagina che ti mette a disposizione uno strumento con cui tu puoi gestire il tuo database. permettendoti di fare backup, cancellare tuple, o intere tabelle.

il programma è molto valido e conoscere il suo funzionamento può essere molto utile!

anzitutto grazie per la pazienza

allora, mi confermi che phpmyadmin è un programmetto..?
mi metto a cercarlo...
Title: Re: Forum CRASHATO: HELP !!!
Post by: piccoloweb on January 07, 2007, 10:04:32 AM
scusate s emi intrometto

sei su altervista il phpmyadmin lo hai gia
devi andare nel tuo pannello di controllo in altervista ,se mi ricordo alla voce files o tool lo hai li 


riguardo il tuo errore anche a me lo fece quando tentai un aggiornamento ho risolto appunto cancellando il forum e mettendone uno vergine scaircato da smf ,perche quello che avevo nel pc ho pensato che fosse corrotto
Title: Re: Forum CRASHATO: HELP !!!
Post by: MarMa on January 07, 2007, 10:19:38 AM
scusate s emi intrometto

sei su altervista il phpmyadmin lo hai gia
devi andare nel tuo pannello di controllo in altervista ,se mi ricordo alla voce files o tool lo hai li 


riguardo il tuo errore anche a me lo fece quando tentai un aggiornamento ho risolto appunto cancellando il forum e mettendone uno vergine scaircato da smf ,perche quello che avevo nel pc ho pensato che fosse corrotto

hai fatto benissimo ad intrometterti
allora cercherò, appena passati questi gg di festa, di fare come hai detto tu e speriamo bene
Title: Re: Forum CRASHATO: HELP !!!
Post by: francesco_ud on January 08, 2007, 03:57:08 AM
esatto phpmyadmin devi averlo già diciamo "di serie".

non mi è chiaro se hai dei dati nel forum però, se non hai nulla cancella tutte le tabelle,  poi reinstalla tutto quanto.

domanda, i permessi sono tutti settati correttamente?
Title: Re: Forum CRASHATO: HELP !!!
Post by: MarMa on January 08, 2007, 05:45:37 AM
esatto phpmyadmin devi averlo già diciamo "di serie".

non mi è chiaro se hai dei dati nel forum però, se non hai nulla cancella tutte le tabelle,  poi reinstalla tutto quanto.

domanda, i permessi sono tutti settati correttamente?

mah, credo di sì
ora sono mezza influenzata.. appena mi passa tutto cerco di mettermi al lavoro
e vediamo che succede
Title: Re: Forum CRASHATO: HELP !!!
Post by: MarMa on January 22, 2007, 08:46:18 AM
niente.. sono sul pannello di phpmyadmin ma non capisco come fare a resettare il tutto..?

HELP!
Title: Re: Forum CRASHATO: HELP !!!
Post by: francesco_ud on January 22, 2007, 04:17:45 PM
hai qualche dato all'interno del database? utenti registrati, messaggi?

se non hai nulla in quanto non hai mai utilizzato il forum elimina tutte le tabelle e poi reinstalla tutto il forum da zero.
Title: Re: Forum CRASHATO: HELP !!!
Post by: MarMa on January 22, 2007, 05:22:15 PM
hai qualche dato all'interno del database? utenti registrati, messaggi?

se non hai nulla in quanto non hai mai utilizzato il forum elimina tutte le tabelle e poi reinstalla tutto il forum da zero.

sì! è quello il problema.
ci sono dei dati che vorrei togliere, ma non so come.
il pannello di phoadmin è per me incomprensibile..
se ti serve ti faccio uno screenshot.

c'è un opzione, non in quel pannello, ma sempre dentro ad altervista tipo "cancella database" che ho fatto, ma non è stato resettato come speravo..
Title: Re: Forum CRASHATO: HELP !!!
Post by: MarMa on January 23, 2007, 04:08:03 AM
ecco lo screenshot
come vedi, anche con l'opzione "cancella DB", non viene cancellato..

(http://img181.imageshack.us/img181/5335/snap12na.jpg)

Edit:
forse ce l'ho fatta a cancellare le varie query rimaste..
Title: Re: Forum CRASHATO: HELP !!!
Post by: francesco_ud on January 23, 2007, 08:20:26 AM
allora sulla sinistra della pagina trovi:

il nome del database (my_alcune_parole_che_non_capisco(35))

se ci clicchi sopra ti fa vedere la lista delle tabelle che ci sono in quel db.
fallo poi, a centro pagina ti verranno visualizzate le tabelle, i nomi sono uguali a quelli che trovi sotto il nome del db nella colonna sx.

se tu le selezioni tutte in basso trovi due cestini, uno chiaro ed uno rosso, quello rosso cancella tutte le tabelle, l'altro le svuota, mantenendole.

ora se non hai dati (dopo aver selezionato tutte le tabelle, spuntando la singola ceckbox di ogni tabella) premi il tasto con il cestino rosso, ti chiederà conferma digli di si e poi ti cancella tutto, fatto ciò puoi reinstallare da 0 il tuo forum
Title: Re: Forum CRASHATO: HELP !!!
Post by: MarMa on January 24, 2007, 06:42:51 AM
grazie
ieri col temporale m'era saltato fastweb..
stasera provo a reinstallare tutto..

sperem!
Title: Re: Forum CRASHATO: HELP !!!
Post by: francesco_ud on January 24, 2007, 01:34:50 PM
fammi sapere come procede la cosa! in caso chiedi pure!
Title: Re: Forum CRASHATO: HELP !!!
Post by: MarMa on January 24, 2007, 02:08:57 PM
fammi sapere come procede la cosa! in caso chiedi pure!

ho provato a ricaricare tutto, far partire l'installer ma ora mi dice

Quote
The installer was unable to access the "marcomangiarotti" database. With some hosts, you have to create the database in your administration panel before SMF can use it. Some also add prefixes - like your username - to your database names.

Click here to try this step again.

sob

eppure il DB, anche se vuoto, risulta attivo..
mado che depressione che mi sta venendo..
Title: Re: Forum CRASHATO: HELP !!!
Post by: MarMa on January 24, 2007, 02:24:35 PM
Edit:
a ri-provo ad installare di nuovo tutto.
ma stavolta il "vecchio" forum+template che avevo prima..
Title: Re: Forum CRASHATO: HELP !!!
Post by: MarMa on January 25, 2007, 02:36:36 PM
ho installato la versione aggiornata 1.1.1.
ora, non mi carica più la pagina in italiano del classic theme.
non è che forse andava bene solo per la 1.0.6?

e nel pannello di manutenzione non ho più il comando "carica (vecchio) database " ?
come fo..?

ho paura di utilizzare l'opzione di altervista, magari mi "incasina" di nuovo tutto...
 :o
Title: Re: Forum CRASHATO: HELP !!!
Post by: francesco_ud on January 26, 2007, 03:39:06 AM
siamo a buon punto ora, anche se era meglio che tu installassi la versione 1.0.6 nuovamente, in quanto il db della versione 1.1.1 può essere diverso, quindi sarebbe stato meglio agire con l'upgrader, ma nulla è cmq impossibile


i file per l'italiano li trovi qui : http://www.smitalia.net  ;D

poi vedi se in locale riesci ad installare la versione 1.0.6 e uppare il db a convertirlo alla versione 1.1.1 e poi lo uppi nella versione 1.1.1 che hai in remoto.

ps non ho sotto mano la versione 1.1.1 quindi non riesco ad aiutarti troppo nelle funzioni, io uso una 1.0.9 attualmente.
Title: Re: Forum CRASHATO: HELP !!!
Post by: MarMa on January 26, 2007, 05:09:39 AM
siamo a buon punto ora, anche se era meglio che tu installassi la versione 1.0.6 nuovamente, in quanto il db della versione 1.1.1 può essere diverso, quindi sarebbe stato meglio agire con l'upgrader, ma nulla è cmq impossibile


i file per l'italiano li trovi qui : http://www.smitalia.net  ;D

poi vedi se in locale riesci ad installare la versione 1.0.6 e uppare il db a convertirlo alla versione 1.1.1 e poi lo uppi nella versione 1.1.1 che hai in remoto.

ps non ho sotto mano la versione 1.1.1 quindi non riesco ad aiutarti troppo nelle funzioni, io uso una 1.0.9 attualmente.


ok, allora proverò a cancellare di nuovo tutto e mettere la 1.0.6.
il fatto è che non mica ben capito come si l'upgrade.

da dopo il 4 mi ci metterò allora

grazie moltissime!
Title: Re: Forum CRASHATO: HELP !!!
Post by: francesco_ud on January 26, 2007, 01:09:02 PM
sostanzialmente upgradare permette di aggiornare i campi del database per renderli compatibili con una versione successiva. quindi se i campi dei database (che alla fine è composto da alcune tabelle) non coicidono, non ci può essere un corretto scambio di dati tra database e forum..
ora io ti consiglio di installare la 1.0.6, e di passare alla versione 1.1.1 tramite i file appositi, che saranno  composti dal pachetto upgrade, non update, in quanto passi salla versione 1.0 alla versione 1.1 (se dovevi passare dalla versione 1.0.8 alla 1.0.9 dovevi usare il pacchetto update, idem per passare dalla 1.1 rc2 alla 1.1 rc3).

appurato questo con calma installa da 0 la versione 1.0.6, importa il database, esegui tutti le operazioni di verifica dei dati, successivamente aggiorna alla versione 1.1.1 tramite l'apposito pacchetto (installa i files di linguaggio che trovi su smitalia) e poi testa se tutto funge correttamente.
ricorda fino a quando non sei sicuro di aver il forum al 100% non cancellare quel backup!
Title: Re: Forum CRASHATO: HELP !!!
Post by: MarMa on January 26, 2007, 01:44:44 PM
sostanzialmente upgradare permette di aggiornare i campi del database per renderli compatibili con una versione successiva. quindi se i campi dei database (che alla fine è composto da alcune tabelle) non coicidono, non ci può essere un corretto scambio di dati tra database e forum..
ora io ti consiglio di installare la 1.0.6, e di passare alla versione 1.1.1 tramite i file appositi, che saranno  composti dal pachetto upgrade, non update, in quanto passi salla versione 1.0 alla versione 1.1 (se dovevi passare dalla versione 1.0.8 alla 1.0.9 dovevi usare il pacchetto update, idem per passare dalla 1.1 rc2 alla 1.1 rc3).

appurato questo con calma installa da 0 la versione 1.0.6, importa il database, esegui tutti le operazioni di verifica dei dati, successivamente aggiorna alla versione 1.1.1 tramite l'apposito pacchetto (installa i files di linguaggio che trovi su smitalia) e poi testa se tutto funge correttamente.
ricorda fino a quando non sei sicuro di aver il forum al 100% non cancellare quel backup!

e chi lo cancella il backup !
scherzi..

cmq dal 4 febb mi ci metterò su.
la cosa è, che avevo prima provato a metter su la 1.0.6 ma anche lì non mi dava l'opzione carica DB..
e non capisco xkè!?
Title: Re: Forum CRASHATO: HELP !!!
Post by: Faber73 on January 26, 2007, 05:58:46 PM
Il DB và caricato da phpMyAdmin
Title: Re: Forum CRASHATO: HELP !!!
Post by: MarMa on February 22, 2007, 12:17:13 PM
Il DB và caricato da phpMyAdmin

scusa, non sono pratica.
ovvero?

cmq ora provo a ricaricare la vecchia versione che avevo, poi ripristino (se dio vuole..) il vecchio DB e poi procedo con l'aggiornamento..?
è questa la procedura?
Title: Re: Forum CRASHATO: HELP !!!
Post by: MarMa on March 07, 2007, 12:14:09 PM
mi da questo errore

Quote
The installer was unable to access the "marcomangiarotti" database. With some hosts, you have to create the database in your administration panel before SMF can use it. Some also add prefixes - like your username - to your database names.

Click here to try this step again.

eppure le volte passate ho sempre fatto allo stesso modo..
dal pannello di altervista, cancella DB, e poi ho proceduto dal file install..
ora però mi da questo errore e non riesco a capire come risolverlo.
 :o
Title: Re: Forum CRASHATO: HELP !!!
Post by: theshown on March 08, 2007, 05:32:49 AM
Su altervista i database non sono preceduti dal prefisso "my_" ? nel tuo caso dovrebbe essere "my_marcomangiarotti".
Title: Re: Forum CRASHATO: HELP !!!
Post by: MarMa on March 08, 2007, 06:00:39 AM
Su altervista i database non sono preceduti dal prefisso "my_" ? nel tuo caso dovrebbe essere "my_marcomangiarotti".

sì.
e lo metto da install.php.
però mi da quell'errore.

è normale che dal pannello di phpmyadmin mi dica "my_marcomangiarotti(0)"?
capisco che non ci sono tabelle (in effetti le ho cancellate tutte e dato pure cancella DB) però devo forse mica fare altro..?  
Title: Re: Forum CRASHATO: HELP !!!
Post by: MarMa on March 08, 2007, 06:32:33 AM
ok, ora ho risolto la parte dell'installazione!
yuppi-do

ora vedo se riesco a caricare il backup..
 :o
Title: Re: Forum CRASHATO: HELP !!!
Post by: MarMa on March 08, 2007, 07:17:38 AM
ho tentato di importare da phpMyAdmin il vecchio DB..
mi da questo errore

Quote
Errore

Pare che ci sia un errore nella query SQL immessa. L'errore del server MySQL mostrato qui sotto, se c'è, può anche aiutare nella risoluzione del problema

ERROR: Stringa di Punctuation Sconosciuta @ 130
STR: ><
SQL:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html><head>
   <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
   <meta name="description" content="E' accaduto un errore!" />
   <meta name="keywords" content="PHP, MySQL, bulletin, board, free, open, source, smf, simple, machines, forum" />
   <script language="JavaScript" type="text/javascript" src="http://nomeforum.altervista.org/forum/Themes/default/script.js"></script>
   <script language="JavaScript" type="text/javascript"><!--
      var smf_theme_url = "http://nomeforum.altervista.org/forum/Themes/classic";


query SQL:


che vuol dire..?
 :o