Simple Machines Community Forum

Customizing SMF => Graphics and Templates => Theme Site Themes => Topic started by: Gary on January 10, 2007, 07:54:12 AM

Title: vSMFB-Multi-4
Post by: Gary on January 10, 2007, 07:54:12 AM
Link to the theme (http://custom.simplemachines.org/themes/index.php?lemma=203)
(http://custom.simplemachines.org/themes/index.php/action,download/lemma,203/image,thumb)

A theme that parodies the vBulletin layout but keeping the SMF Charm of the Core and Babylon themes.

Screens Included.

DESIGNED BY: MT2-Soft (http://multitalk2.com)

Click Here for an MT2-Soft FAQ (http://multitalk2.com/index.php?topic=6526)

This theme (will) also include the ability to install extra colour packs and a drop down for your users to select a colour they wish to use.

Support for vbgamer45's mods that add extra tabs to the theme is included, just install and they'll automatically be added.

NOTE: Currently only one colour style is available the SMF Core (Default) style.

This theme is compatable with 1.1 Final and 1.1.1, this is not (and will not) be compatable with 1.0.

Current Colour Packs:
SMF Core (Default)

Current Languages:
English American
English British

If you wish to translate for me, then contact me.

Download extra language and colour packs here: http://multitalk2.com/vsmfb-multi-4 (Temp URL for now :P)
Title: Re: vSMFB-Multi-4
Post by: ahmetarig on January 10, 2007, 09:32:49 AM
nice theme ;)
Title: Re: vSMFB-Multi-4
Post by: Gary on January 10, 2007, 09:57:11 AM
Thanks. There are gonna be more Colour Packs available soon. I've started to compile a couple. You can install them via your package manager. :P

-AwwLilMaggie
Title: Re: vSMFB-Multi-4
Post by: nitins60 on January 10, 2007, 10:15:28 AM
When i open PM! Only Reply with quote is available n your theme only! When i click on it, it's saying "shall i remove message?"
Title: Re: vSMFB-Multi-4
Post by: Gary on January 10, 2007, 10:26:32 AM
Whoops! I'll look into that ASAP.

-AwwLilMaggie
Title: Re: vSMFB-Multi-4
Post by: Crip on January 10, 2007, 05:26:53 PM
Demo would be nice. :P
Title: Re: vSMFB-Multi-4
Post by: Gary on January 11, 2007, 09:57:03 AM
crip, My forum uses it (http://multitalk2.com). But mine is slightly different because its called vSMFB-Multi-Core (the third in the vSMFB-Multi line, this theme here, is the fourth) :P I'm planning on upgrading that forum to the Development Edition at some point and update the theme for that version too.

nitins60, I had a look of the PersonalMessages.template.php file and I couldnt see anything wrong. Everything that was there, was there. Both on the page and the code.

-AwwLilMaggie
Title: Re: vSMFB-Multi-4
Post by: nitins60 on January 11, 2007, 11:09:48 AM
You messed up that part!

I can see only delete button with text reply with quote(when you turn off images you can see)! I can't see REPLY button! I can't see REPLY WITH QUOTE! hope i am not sleeping!
Title: Re: vSMFB-Multi-4
Post by: Gary on January 11, 2007, 11:12:46 AM

// Show reply buttons if you have the permission to send PMs.
echo'
<div align="right">';
if ($context['can_send_pm'])
{
// You can't really reply if the member is gone.
if (!$message['member']['is_guest'])
{
// Were than more than one recipient you can reply to? (Only in the "button style", or text)
if ($message['number_recipients'] > 1 && (!empty($settings['use_buttons']) || !$settings['use_image_buttons']))
echo '
<a href="', $scripturl, '?action=pm;sa=send;f=', $context['folder'], $context['current_label_id'] != -1 ? ';l=' . $context['current_label_id'] : '', ';pmsg=', $message['id'], ';quote;u=all"><img src="' . $settings['images_url'] . '/' . $context['user']['language'] . '/im_reply.gif" alt="" border="0" /></a>', $context['menu_separator'];
echo '
<a href="', $scripturl, '?action=pm;sa=send;f=', $context['folder'], $context['current_label_id'] != -1 ? ';l=' . $context['current_label_id'] : '', ';pmsg=', $message['id'], ';quote;u=', $context['folder'] == 'outbox' ? '' : $message['member']['id'], '"><img src="' . $settings['images_url'] . '/' . $context['user']['language'] . '/quote.gif" alt="" border="0" /></a>', $context['menu_separator'], '
<a href="', $scripturl, '?action=pm;sa=send;f=', $context['folder'], $context['current_label_id'] != -1 ? ';l=' . $context['current_label_id'] : '', ';pmsg=', $message['id'], ';u=', $message['member']['id'], '"><img src="' . $settings['images_url'] . '/' . $context['user']['language'] . '/im_reply.gif" alt="" border="0" /></a> ', $context['menu_separator'];
}
// This is for "forwarding" - even if the member is gone.
else
echo '
<a href="', $scripturl, '?action=pm;sa=send;f=', $context['folder'], $context['current_label_id'] != -1 ? ';l=' . $context['current_label_id'] : '', ';pmsg=', $message['id'], ';quote"><img src="' . $settings['images_url'] . '/' . $context['user']['language'] . '/quote.gif" alt="" border="0" /></a>', $context['menu_separator'];
}
echo '
<a href="', $scripturl, '?action=pm;sa=pmactions;pm_actions[', $message['id'], ']=delete;f=', $context['folder'], ';start=', $context['start'], ';', $context['current_label_id'] != -1 ? ';l=' . $context['current_label_id'] : '', ';sesc=', $context['session_id'], '" onclick="return confirm(\'', addslashes($txt[154]), '?\');"><img src="' . $settings['images_url'] . '/' . $context['user']['language'] . '/delete.gif" alt="' . $txt[145] . '" border="0" /></a>
<input style="vertical-align: middle;" type="checkbox" name="pms[]" id="deletedisplay', $message['id'], '" value="', $message['id'], '" class="check" onclick="document.getElementById(\'deletelisting', $message['id'], '\').checked = this.checked;" />
</div>';


The code is there. I didnt see anything wrong. It might help if you could post a print screen on what buttons you're getting both for sending PMs to Members and Guests.

-AwwLilMaggie
Title: Re: vSMFB-Multi-4
Post by: nitins60 on January 11, 2007, 11:35:39 AM
Sorry! Actually i messed up some code here! :P
Title: Re: vSMFB-Multi-4
Post by: Nanuciao on January 14, 2007, 07:19:26 PM
I installed the theme but it says there isn't the copyright of SMF.
Why?

Max
Title: Re: vSMFB-Multi-4
Post by: Gary on January 15, 2007, 09:12:08 AM
The copyright is there, are you using 1.0? Because this theme is not (and wil not) be compatable with 1.0

-AwwLilMaggie
Title: Re: vSMFB-Multi-4
Post by: Nanuciao on January 15, 2007, 12:37:36 PM
Quote from: AwwLilMaggie on January 15, 2007, 09:12:08 AM
The copyright is there, are you using 1.0? Because this theme is not (and wil not) be compatable with 1.0

-AwwLilMaggie

http://playitusa.dreamhosters.com/forum/index.php

Please come and take a look: I have the latest version but at the bottom there's he warning 'cause the copyright is missing...

Max
Title: Re: vSMFB-Multi-4
Post by: Gary on January 16, 2007, 09:28:36 AM
The theme that shows for guests is the Default. Can you PM me a test account?

-AwwLilMaggie
Title: Re: vSMFB-Multi-4
Post by: Gary on January 17, 2007, 10:15:51 AM
I think I've figured it out. I think its something to do with the show time being off or something.

Try this.
Title: Re: vSMFB-Multi-4
Post by: Rickeo on January 17, 2007, 07:30:04 PM
Copyright notice isnt on mine either
Title: Re: vSMFB-Multi-4
Post by: Rickeo on January 17, 2007, 07:30:30 PM
and am using version 1.1.1
Title: Re: vSMFB-Multi-4
Post by: 1948Pal on January 17, 2007, 10:27:14 PM
Quote from: AwwLilMaggie on January 17, 2007, 10:15:51 AM
I think I've figured it out. I think its something to do with the show time being off or something.

Try this.
This template worked. The copyright notice warning is gone now.
Couple other things tho, can't save changes made in the themes options, like adding own logo, or checking/unchecking any of the boxes(under current theme). And your current location shows always as inline links, can't change it to tree view like!
Title: Re: vSMFB-Multi-4
Post by: Gary on January 18, 2007, 09:03:21 AM
Quote from: 1948Pal on January 17, 2007, 10:27:14 PM
This template worked. The copyright notice warning is gone now.
Couple other things tho, can't save changes made in the themes options, like adding own logo, or checking/unchecking any of the boxes(under current theme). And your current location shows always as inline links, can't change it to tree view like!

You should be able to add your own logo fine and dandy, but if you wanna intsall extra colour packs (which I'm yet to package up, been busy) then it'd have to be transparent.

I'll look into the tree thing too. :P

Quote from: antuan on January 18, 2007, 04:17:37 AM
Tenkius gringuito culero por el tema pinche xD
Um. English please. :P

-AwwLilMaggie
Title: Re: vSMFB-Multi-4
Post by: Rickeo on January 18, 2007, 11:15:08 PM
So how do I get mine to work now mine still doesnt have the copyright notice I downloaded ur attachment of index php but now what do I do with it??
Title: Re: vSMFB-Multi-4
Post by: Rickeo on January 18, 2007, 11:24:50 PM
Oh I fixed it now but I have to say doesnt look much differant than the normal smf skin thought it was supposed to mimic VB ahhhh well done anyway sorry to critisise just not for me sorry
Title: Re: vSMFB-Multi-4
Post by: Gary on January 19, 2007, 10:42:09 AM
Heh. I designed it that way to retain some SMF Charm within it. ;)

-AwwLilMaggie
Title: Re: vSMFB-Multi-4
Post by: S1L1C0N on January 23, 2007, 03:32:20 PM
Love it!
Title: Re: vSMFB-Multi-4
Post by: Banitsa on January 25, 2007, 11:39:55 AM
I also get the copyright message V.1.1.  Any chance of an updated download with the index fix?

Thanks for the theme.

Title: Re: vSMFB-Multi-4
Post by: Gary on January 26, 2007, 10:42:22 AM
I'll update it as soon as I can, for the mean time use this. The last one had a drop down because I was doing testing with the other colour packs. And I forgot to remove it. :P
Title: Re: vSMFB-Multi-4
Post by: westie on January 28, 2007, 12:59:42 AM
Hi
This is the message I get at the bottom on the page, is it the same as others have had and the one you talk about above.  I have no idea how to remove it any assistance would be most gratfull.

Sorry, the copyright must be in the template.
Please notify this forum's administrator that this site is missing the copyright message for SMF so they can rectify the situation. Display of copyright is a legal requirement. For more information on this please visit the Simple Machines website.
Not sure why this message is appearing? Take a look at some common causes.  
Title: Re: vSMFB-Multi-4
Post by: Gary on January 28, 2007, 10:29:37 AM
Yes, that is the one. Download the index.template.php in my post above, and upload it into the vSMFB-Multi-4 folder. I will replace it in the package ASAP.

Its something to do with having the Show load time turned off I think. Try turning it on first, if that doesnt work, upload the file.

-AwwLilMaggie
Title: Re: vSMFB-Multi-4
Post by: westie on January 28, 2007, 06:49:20 PM
Than you very much.
Title: Re: vSMFB-Multi-4
Post by: westie on January 28, 2007, 09:04:32 PM
Sorry to be a pain, I'm new at this.  Where do I find: 'Show load time turned off'. I've downloaded your attachment to my hard drive, 'how do it up load to package'  I tried placing it inside the theme zip and deleting the index.template.php that was inside the zip.

Might be less painful for me to wait for the updated package.  Cheers.
Title: Re: vSMFB-Multi-4
Post by: Gary on January 29, 2007, 09:30:42 AM
Its in the settings in the admin center to turn it on and off.

Admin > Features and Options > Layout and Options > Display time taken to create every page

-AwwLilMaggie
Title: Re: vSMFB-Multi-4
Post by: westie on January 30, 2007, 02:49:32 AM
Yes that worked did as you said above, copyright notice now gone - Many Thanks.  I followed the link to 'other colours' but couldn't find them.  Will be be a B/W theme.
Title: Re: vSMFB-Multi-4
Post by: Gary on January 30, 2007, 10:22:02 AM
There arent any other colours at the moment, they're all still in production. But yes, there will be a black pack called Bam-TV Dark, and a white one called LBCC Pure.

All the colour packs are named after a site that me, Mike Frith (http://www.simplemachines.org/community/index.php?action=profile;u=8687) or one of our friends has made.  
Title: Re: vSMFB-Multi-4
Post by: Gary on February 04, 2007, 08:46:24 AM
Okay, here's the first extra colour pack.

Bam-TV Dark (Black)

All you do is install it via your package manager.  
Title: Re: vSMFB-Multi-4
Post by: Gary on April 13, 2007, 10:18:53 AM
The main package has been updated to make sure that the copyright is shown when the Load time is either on or off.

-ALM
Title: Re: vSMFB-Multi-4
Post by: biftek on August 17, 2007, 09:30:56 PM
i have just changed from using phpbb to using smf , i like this template but been trying to work out how to make it like the vb type style , the grey on white background so you get white borded effect happening
eg: www.ausbb.com
although the forum is phpbb and the template is subrebel , but it should make clear what i mean
Title: Re: vSMFB-Multi-4
Post by: Gary on August 17, 2007, 09:46:33 PM
Just change the style/style_core.css file, which is the stylesheet for the SMF Core (Default) style.

-ALM
Title: Re: vSMFB-Multi-4
Post by: biftek on August 17, 2007, 10:21:49 PM
ah yes of course thanks , i was taking the hard path trying to edit the template , coming from phpbb templates are a little different
Title: Re: vSMFB-Multi-4
Post by: Gary on June 07, 2008, 04:03:15 PM
For those who might've noticed, I took the theme down for a bit for updating. It has now been updated and it's now back in the listing.

It is still bound by the MT2-Soft license though. Copyright must be shown unless you make agreements with me.
Title: Re: vSMFB-Multi-4
Post by: hmpargi on June 09, 2008, 09:29:40 AM
well i installed ur theme but under the coloumn Moderators on home page it dont show my moderators :( how should i enable this feature
Title: Re: vSMFB-Multi-4
Post by: Horme Gaming on June 12, 2008, 04:46:22 PM
do you have any moderators set on your boards?
Title: Re: vSMFB-Multi-4
Post by: Gary on June 12, 2008, 04:49:20 PM
Yes. Generally having moderators would help. The moderator column will show even if none have been set.
Title: Re: vSMFB-Multi-4
Post by: tMicky on September 20, 2012, 07:59:15 PM
Will this work for 2.0, 2.02?
Title: Re: vSMFB-Multi-4
Post by: Gary on September 20, 2012, 09:11:16 PM
No. The theme only supports 1.1