Simple Machines Community Forum

SMF Support => Bosanski/Hrvatski/Srpski (Bosnian/Croatian/Serbian) => Language Specific Support => SMF Prevod => Topic started by: Dupli on June 19, 2007, 03:42:36 PM

Title: Big Glupi problem
Post by: Dupli on June 19, 2007, 03:42:36 PM
Ovak

imao sam stari site sa smf-om 1.1.1 koji je funkcionirao sa hrvatskim jezikom, tj nije bio problem to riješiti ni na bilo kojem skinu koji sam digao gore, zatim sam ga updejtao na 1.1.2 i dalje je sve radilo normalno...

Sad sam prešao na novi host i tu je po defoultu u fantastiku ponuđen smf 1.1.2 jerje zadnja verzija i on već u defoultu ima ponuđen hrvatski koji je Admin panelu oznaćen kao Croatian UTF-8 što nije naš charset, skinio sam hrvatski paket za 1.1.2 sa smf-a i implementirao ga i i dalje imem probleme tipa kada se ostavi post ne prihvaća "đ č ć " i ostavlja upitnike umjesto njih a "š i ž " prihvaća i ne radi greške

veći problem nastane i to eror u subs.php - u u liniji 457...

jeli imao netko slićan problem i kako ga riješio?
Title: Re: Big Glupi problem
Post by: markonio on June 20, 2007, 03:45:53 AM
Croatian UTF-8 što nije naš charset, skinio sam hrvatski paket za 1.1.2 sa smf-a i implementirao ga

Koliko ja znam, UTF-8 je internacionalni charset (od japanskog do eskimskog ;)) i sadrži sve HR znakove.

Moguče rješenje problema: Skinuti HR prijevod za UTF-8 i instalirati ga. U forumu otići na admin-održavanje foruma-Convert the database and data to UTF-8 (ne koristim HR prijevod, pa neznam kako piše).

Ovo je ovako iz glave. Preporučam ti da prvo isprobaš lokalno...
Title: Re: Big Glupi problem
Post by: Dupli on June 20, 2007, 08:34:45 AM
pokušao sam sa ovim ali i dalje bez učinka, Cijeli forum je na HR i znakovi "č đ ć" i kad pišeš post vidljivi su, čak su vidljivi i kad odeš, tj klikneš na pregled, no kad se ostavi post na forumu ti znakovi se pretvore u upitnike, isto tako nastane greška ako je neki od tih znakova u naslovu
Title: Re: Big Glupi problem
Post by: Dupli on June 26, 2007, 08:40:00 AM
Dali ima netko da je instalirao friško predzadnju verziju smf-a 1.1.2. i da je u postovima imao problema sa "ć č i đ " ?
Title: Re: Big Glupi problem
Post by: markonio on June 26, 2007, 09:41:00 AM
Mislim da bi nam link na forum pomogao....
Title: Re: Big Glupi problem
Post by: Dupli on June 26, 2007, 10:25:27 AM
Vidiš...isprićavam se   . . . www.klubistika.net/smf/index.php potrebno je regat se
Title: Re: Big Glupi problem
Post by: nela on August 22, 2007, 08:58:04 AM
da i ja imam isti problem

pojavljuju mi se upitnici umjesto čćđ, a žš rade normalno

ja sam danas instalirala verziju 1.1.3 , instalacijom preko fantastica
Title: Re: Big Glupi problem
Post by: JerryCRO on August 22, 2007, 09:10:15 AM
odi u settings.php ,tamo ti na kraju prije ?> piše
Quote
$db_character_set = 'utf8';
i promjeni u windows-1250 znaći ta linija treba izgledat ovako
Quote
$db_character_set = 'windows-1250';
Title: Re: Big Glupi problem
Post by: nela on August 22, 2007, 05:39:53 PM
hvala

stvar radi - ali mi je nestalo nekih 1/3 postova - umjesto posta - sve prazno  ???