Simple Machines Community Forum

SMF Support => SMF 1.1.x Support => Topic started by: ChiSamurai on June 28, 2007, 07:01:50 AM

Title: Problems with deleting Topics
Post by: ChiSamurai on June 28, 2007, 07:01:50 AM
Hi there,

I have a big problem with my SMF 1.1.3:

If a user deletes his own topic, all topics in the thread are "invisible" (it is set to "0 topics 0 posts". But if you access the "invisible" topics with

http://www.myurl.com/index.php?board=x.0

you can access them.

When you start a new topic in this "empty" thread they are visible again.

Any ideas?
Title: Re: Topics "hidden" after user deleted Topic
Post by: ChiSamurai on June 28, 2007, 07:14:26 AM
Ok, I just tried to delete a topic by myself and got this error:

Quote
Datenbankfehler: Lost connection to MySQL server during query
Datei: /home/www.myurl.com/Sources/RemoveTopic.php
Zeile: 361

I can translate it if needed...

There is no problem with the MySQL-database
Title: Re: Topics "hidden" after user deleted Topic
Post by: ChiSamurai on June 28, 2007, 07:26:14 AM
Used the search function and found this Topic: http://www.simplemachines.org/community/index.php?topic=63232.0

It removes the error message but the Topics are still "invisible" after doing it. Another problem: the deleted topics are still there, so I can't delete any topic

Edit:
Topics were deleted. But there is still the problem that the other topics in the Childboard are not visible but accessible and the statistic for this Childboard is set to "0 topics 0 posts". Adding a new post fixes it and all topics are there again.

After all the Problem seems to be with MYSQL Version 5.0.18 and .19 at least. Upgrading to 5.0.20 should solve the problem completely.

My host unfortunately doesnt want to upgrade due to compatibility and security-reasons so I have to get a workaround. Has anybody an idea how this could be fixed?

Maybe the solution shoud be pinned.
Title: Re: Topics "hidden" after user deleted Topic
Post by: ChiSamurai on June 28, 2007, 09:30:30 AM
Fixed it at my board:

Find this in ManageAttachments.php and RemoveTopic.php
Quote
removeAttachments('a.attachmentType = 0
and replace it with
Quote
removeAttachments('a.attachmentType = \'0\'

After done this, you should be able to delete topics again.

Now execute this: Administration-Panel -> Forum Maintenance -> Recount all forum totals and statistics

This should fix the statistics and after deleting a topic the rest should be visible.

Maybe sbdy can change the subject of this post to "Problems with deleting Topics" or something.

Greets,
Samurai
Title: Re: Topics "hidden" after user deleted Topic
Post by: greyknight17 on June 29, 2007, 10:30:18 PM
Glad you resolved the issue.

You can edit the subject yourself. In your first post, click on the Modify link and change the subject.

You may mark your topic as resolved. Click on the icon to the left of the subject line in your first post and select the check mark.
Title: Re: Problems with deleting Topics
Post by: ChiSamurai on July 01, 2007, 12:10:29 PM
done :)