Simple Machines Community Forum

Archived Boards and Threads... => Archived Boards => Classic Themes => Topic started by: A.M.A on August 15, 2004, 03:51:19 AM

Title: [Theme] xtEnhanced for SMF 1.0.3
Post by: A.M.A on August 15, 2004, 03:51:19 AM
This is some enhancement that I have added to the xtSMF theme .. hope you like them.

Samples

Download


Modifications
SSI:
1. open 'myHOME.php' and change
require(dirname(__FILE__) . '/SSI.php'); to your exact forum location.
2. open 'myHOME.php' and change
<< :: SMF SSI.php 1.0 :: >> to your site name.
3. open 'myHOME.php' and change
myWebSite to your site name.
4. open 'myHOME.php' and change
<li>No1</li> to your links.
5. open 'myHOME.php' and change
(c)2004 your copyright! to your own copyrights.

index.template.php:
1. open 'index.template.php' and change
Links here! to your links.
2. open 'xtLOGO.gif' in the images folder and change it to your logo if you need one.

MessageIndex.template.php & Search.template.php:
1. open any file and change
Quote
var max=3;
if (form.search.value.length < max) {
alert("Minimum allowed characters is (" + max + "). Please try again.");
to the number you like. This will handle minimum charters for search.

Display.template.php:
1. open 'Display.template.php' and remove
&nbsp;<a href="javascript:window.external.AddFavorite(\'', $scripturl,'?topic=', $context['current_topic'],'\',%20\'', $context['subject'], '\')"><img src="', $settings['images_url'], '/xtFAV.gif" alt="bookmark this topic!" align="middle" border="0" /></a>if you do not want the bookmark this topic, it only works with IE.
2 . the smileys in the quick reply box are located in the 'images' folder and they are the classic ones.


Notes
1. the buttons and tags as well as the theme itself are free as long as you use them with SMF!!
2. the menu design was inspired by 'solardreamstudios.com'
3. XHTML validation. Thanks goes to 'kegobeer (http://www.simplemachines.org/community/index.php?action=profile;u=4524)'
4. update minor typo thanks to Spaceman-Spiff.

*- If you have installed a pervious version of this theme, please read the changes (http://www.simplemachines.org/community/index.php?topic=31935.0)!
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: Tomer on August 15, 2004, 03:58:26 AM
Very nice.
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: Room11 on August 15, 2004, 04:01:16 AM
Excellent use of SSI - becoming a portal maybe?
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: Kris on August 15, 2004, 04:16:21 AM
Looks great!

The menu is available in other languages? (and buttons?)
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: Tristan Perry on August 15, 2004, 06:30:51 AM
That looks great  :)
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: bloc on August 15, 2004, 06:50:59 AM
Very good! Like the new buttons on the top. :)
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: LeeH on August 15, 2004, 11:29:25 AM
Very nice!  Snazzy Navigation thingie, and I like the rounded corners of the tables.
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: Horseman on August 15, 2004, 11:40:11 AM
Very good! Can you make this theme in german language?
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: kegobeer on August 15, 2004, 03:29:14 PM
Nice theme.  I'm trying it out on my site now.  I found it doesn't validate XHTML though.  A few changes and it was validating correctly:


Great job!
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: [darksteel] on August 15, 2004, 04:35:31 PM
Esto si es un Theme !!

Very Nice ;)
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: kegobeer on August 15, 2004, 08:35:22 PM
One last thing: in index.template.php, I had to rename all xtHead.gif to xtHEAD.gif (Apache is case-sensitive).
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: A.M.A on August 16, 2004, 06:26:34 AM
Thanks all :) glad you like it.

Kris - Horseman
If you are interested, I'll PM you the images without text so you can put your own.

kegobeer
Could you please send me the altered files or PM me the changes .. I'll appreciate it. Thanks
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: kegobeer on August 16, 2004, 10:58:06 AM
Sure, no problem.

[EDIT] Hmmm, for some reason I can't attach files to posts or messages.  You can get the zip here (http://pictures.kazebeer.com/linkdir/updates.zip).
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: A.M.A on August 16, 2004, 12:00:15 PM
Quote from: kegobeer on August 16, 2004, 10:58:06 AM
Sure, no problem.

[EDIT] Hmmm, for some reason I can't attach files to posts or messages.  You can get the zip here (http://pictures.kazebeer.com/linkdir/updates.zip).

Thanks for the effort .. I'll update the theme later.
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: † ÐëepÇuT¹ † on August 16, 2004, 12:19:19 PM
I'm blind, can you post the changes you've made 8) -Btw that new menu looks kick ass.
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: A.M.A on August 16, 2004, 12:22:20 PM
Quote from: « † ÐëepÇuT¹ † » on August 16, 2004, 12:19:19 PM
I'm blind, can you post the changes you've made 8) -Btw that new menu looks kick ass.
:)  that's why I make it into a new theme.
Thanks
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: Tristan Perry on August 16, 2004, 12:54:20 PM
It looks great, although I think it'd look better if the background of the menu is the same as the xtHead image. It'd fit in much more if you did that.  :)
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: A.M.A on August 16, 2004, 05:51:34 PM
Quote from: Tau Online on August 16, 2004, 12:54:20 PM
It looks great, although I think it'd look better if the background of the menu is the same as the xtHead image. It'd fit in much more if you did that.  :)
Is not it already .. or you mean replacing the whole Ellipse!
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: Tristan Perry on August 17, 2004, 04:58:21 AM
Quote from: A.M.A on August 16, 2004, 05:51:34 PM
Is not it already .. or you mean replacing the whole Ellipse!
Here:
(http://tauonline.org/menu.jpg)

Can you see how the background the xtHead stops and then the menu bar starts? I think it may look even better if the background of the xtHead was behind the menu bar. I'm sorry if you don't know what I mean, I couldn't explain it well...It's not a very big problem at all, it's just an idea.
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: Vinoth on August 17, 2004, 06:12:53 AM
Nice Work AMA
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: A.M.A on August 17, 2004, 11:02:00 AM
Tau Online
I see .. you have changed the original (xtHead) and give it a brighter light .. if you look closer at the edge of the Ellipse you will find the shades of the original one. Try to redo your logo using the original one without modifying its color .. the original color is '7BA6D0' while yours is '85B1E0'.

whtgoogle
Thanks.
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: Spaceman-Spiff on August 17, 2004, 02:37:04 PM
this javascript will be slightly better:

MessageIndex.template.php & Search.template.php:

Quotevar max=3;
if (form.search.value.length < max) {
alert("Minimum allowed characters is (" + max + "). Please try again.");

just a minor typo, and also using " + max + " will make people only need to change once

btw, very good theme, i'm gonna use it for one of my forums :)
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: Tristan Perry on August 17, 2004, 02:51:23 PM
Quote from: A.M.A on August 17, 2004, 11:02:00 AM
Tau Online
I see .. you have changed the original (xtHead) and give it a brighter light .. if you look closer at the edge of the Ellipse you will find the shades of the original one. Try to redo your logo using the original one without modifying its color .. the original color is '7BA6D0' while yours is '85B1E0'.

whtgoogle
Thanks.
Ah right! Thank you  :) I've fixed it now.
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: A.M.A on August 18, 2004, 11:25:23 AM
Spaceman-Spiff
Thanks for the correction and the tip .. will update later.

Tau Online
yup looking good now :)
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: Jiminy on August 18, 2004, 12:18:41 PM
Very nice work A.M.A.

I'm an SMF newbie. I'm currently in the progress of implementing version RC1 on my web site. I'll probably not go live before the french translation will be available.

Is is OK with you if I customized the theme to match my web site colors and translate the buttons to french ? For that matter, would you provide empty buttons (without label) ?

Cheers.
Jim.
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: A.M.A on August 18, 2004, 06:14:08 PM
Jim
sure .. check your PM.
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: klumy on August 21, 2004, 11:54:11 AM
the forum looks great ;)
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: Jazhawk on August 21, 2004, 12:50:41 PM
Sweeet!! It's real smooth A.M.A.

-Jazhawk 
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: A.M.A on August 21, 2004, 06:36:14 PM
klumy - Jazhawk
Glad you like it .. thanks
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: andrea on August 22, 2004, 07:56:33 AM
Love this theme A.M.A. ! Well done as usual.  :)


P.S. attaching your theme's tumnail for using in a RC1 theme overview.
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: A.M.A on August 22, 2004, 08:19:37 AM
Quote from: andrea on August 22, 2004, 07:56:33 AM
Love this theme A.M.A. ! Well done as usual.  :)


P.S. attaching your theme's tumnail for using in a RC1 theme overview.
Thanks Andrea
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: kenchix1 on August 24, 2004, 01:58:15 AM
I uploaded the files to my site, go to admin and specified the directory where I uploaded the files. then I got a screen full of this :

Notice: Undefined index: lang_character_set in /home/philipp/public_html/Sources/Load.php on line 858
Notice: Undefined offset: 62 in /home/philipp/public_html/Sources/BoardIndex.php on line 147
Notice: Undefined offset: 62 in /home/philipp/public_html/Sources/BoardIndex.php on line 149
Notice: Undefined offset: 62 in /home/philipp/public_html/Sources/BoardIndex.php on line 147
Notice: Undefined offset: 62 in /home/philipp/public_html/Sources/BoardIndex.php on line 149
Notice: Undefined offset: 62 in /home/philipp/public_html/Sources/BoardIndex.php on line 147
Notice: Undefined offset: 62 in /home/philipp/public_html/Sources/BoardIndex.php on line 149
Notice: Undefined offset: 62 in /home/philipp/public_html/Sources/BoardIndex.php on line 147
Notice: Undefined offset: 62 in /home/philipp/public_html/Sources/BoardIndex.php on line 149
Notice: Undefined offset: 62 in /home/philipp/public_html/Sources/BoardIndex.php on line 147
Notice: Undefined offset: 62 in /home/philipp/public_html/Sources/BoardIndex.php on line 149


some of the images appeared like the menu, but everything else is

Notice: Undefined offset: 334 in /home/philipp/public_html/Sources/Load.php(1090) : eval()'d code on line 136
Notice: Undefined offset: 330 in /home/philipp/public_html/Sources/Load.php(1090) : eval()'d code on line 136
Notice: Undefined offset: 21 in /home/philipp/public_html/Sources/Load.php(1090) : eval()'d code on line 136
Notice: Undefined offset: 334 in /home/philipp/public_html/Sources/Load.php(1090) : eval()'d code on line 136
Notice: Undefined offset: 330 in /home/philipp/public_html/Sources/Load.php(1090) : eval()'d code on line 136
Notice: Undefined offset: 21 in /home/philipp/public_html/Sources/Load.php(1090) : eval()'d code on line 136

what went wrong ?

please help.
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: kenchix1 on August 24, 2004, 03:14:47 AM
I got it working. thanks ! :)
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: kenchix1 on August 24, 2004, 05:28:41 AM
How do you use the SSI on the samples ? where do i put it ?

Btw, the theme is really great and I use it in my site. Thank you. :)
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: A.M.A on August 24, 2004, 07:28:01 PM
Quote from: kenchix1 on August 24, 2004, 05:28:41 AM
How do you use the SSI on the samples ? where do i put it ?

Btw, the theme is really great and I use it in my site. Thank you. :)
http://www.simplemachines.org/community/index.php?topic=14906.0
thanks
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: FaSan on August 24, 2004, 08:19:28 PM
Quote from: A.M.A on August 15, 2004, 03:51:19 AM
menu in German (http://www.alnabri.net/smf-stuff/xtEnhanced-German.zip) thanks goes to Horseman (http://www.simplemachines.org/community/index.php?action=profile;u=141)
menu in Dutch (http://www.alnabri.net/smf-stuff/xtEnhanced-Dutch.zip) thanks goes to Kris (http://www.simplemachines.org/community/index.php?action=profile;u=306)


Hi !

I need the PSD file's for translate in my language (italian).

Thanks, FaSan
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: kenchix1 on August 25, 2004, 12:17:20 AM
Quote from: A.M.A on August 24, 2004, 07:28:01 PM
Quote from: kenchix1 on August 24, 2004, 05:28:41 AM
How do you use the SSI on the samples ? where do i put it ?

Btw, the theme is really great and I use it in my site. Thank you. :)
http://www.simplemachines.org/community/index.php?topic=14906.0
thanks

Thanks again.

Is it possible to cut the table of the xtenhanced theme at index.template then start the table in boardindex.template or messageindex.template? I would like to insert something on the header of the message board but it seems that Internet Explorer is so stup*d for it not to determine what is 100%. I tried running what i did in mozilla and it works fine. I just thought that maybe the solution is to cut the table then insert what i need to insert in between then start the table on messageindex.template or boardindex.template.

something like this :
|------------------------------------|
|  menu of XT theme              |
--------------------------------------
          ads/banner/link               --> this is what I am going to insert
|-------------------------------------|
| Forum                                    |
| Forum                                    |
| Forum                                    |
---------------------------------------


Thank you in advance.

Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: A.M.A on August 25, 2004, 12:15:53 PM
If I understand you fully .. I guess you do not need to cut table and touch baordindex nor messageindex
In the index.template you just have to add your ads or whatever after this code:
    <td width="0%" style="background-image: url(', $settings['images_url'], '/xtLEFTb.gif);"></td>
    <td width="100%">';
or this:
// The main content should go here.  A table is used because IE 6 just can't handle a div.
echo '
<table width="100%" cellpadding="0" cellspacing="0" border="0"><tr><td align="left">';
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: Jazhawk on August 25, 2004, 03:29:25 PM
I thought you might have updated this so I downloaded it.  Installed it and nothing happens.  I had the other working just fine but this one does nothing.

never mind.

-Jazhawk
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: kenchix1 on August 25, 2004, 09:13:39 PM
Quote from: A.M.A on August 25, 2004, 12:15:53 PM
If I understand you fully .. I guess you do not need to cut table and touch baordindex nor messageindex
In the index.template you just have to add your ads or whatever after this code:
    <td width="0%" style="background-image: url(', $settings['images_url'], '/xtLEFTb.gif);"></td>
    <td width="100%">';
or this:
// The main content should go here.  A table is used because IE 6 just can't handle a div.
echo '
<table width="100%" cellpadding="0" cellspacing="0" border="0"><tr><td align="left">';


thank you. That is what I did before but when you view the page using IE, the page exceeds the length of the screen (more than 100%, around 110%) BUT when I view the page using Mozilla, everything is perfect. Im thinking of a way how to insert the banner/link in such a way that in can be viewed properly on either mozilla or IE.

Thank you again. :)
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: A.M.A on August 25, 2004, 09:20:44 PM
Could you please show me the code you are trying to use.
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: kenchix1 on August 25, 2004, 11:09:45 PM
Quote from: A.M.A on August 25, 2004, 09:20:44 PM
Could you please show me the code you are trying to use.

It's the google ads leader board 728x90 code that I tried to insert below the code that you mentioned.
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: kenchix1 on August 25, 2004, 11:15:43 PM
this is the site http://www.philippineforums.com. When you use mozilla to browse it, everything is perferct, But if you use Internet Explorer, page increase it's width and exceed the screen as if the whole page was stretch to the right.
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: kenchix1 on August 25, 2004, 11:29:13 PM
I replaced the banner ads with a smaller one  so it would look clean for awhile. but I'm still hoping to put the 728x90 banner.

thank you very much for all the help. :)
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: A.M.A on August 26, 2004, 10:58:50 AM
oh .. I don't really know how Google Ads work, but from the following thread I guess there is a problem with their script that makes tables exceed its limit.
http://www.simplemachines.org/community/index.php?topic=1301.0

by the way do you have this problem with the 'default' theme!
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: Jazhawk on August 26, 2004, 01:37:25 PM
A.M.A

I just want to say again that xtEnhanced is one good looking theme.  Clean, easy on the eyes and cleaver.  (not sure how to explain 'cleaver' but somehow it fits) ;)  I want to remove the text beside the control block and replace it my own logo.  Is there a thread for that already?

-Jazhawk
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: Springer on August 26, 2004, 04:07:48 PM
Does anyone have a forum running this that I could look over?.
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: Jazhawk on August 26, 2004, 05:31:41 PM
Quote from: Springer on August 26, 2004, 04:07:48 PM
Does anyone have a forum running this that I could look over?.

Come over to

http://sweatsocks.shorturl.com

Login: test
Password: tester

-Jazhawk
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: A.M.A on August 26, 2004, 06:36:54 PM
Jazhawk
thanks :)

The header contains three columns .. Menu , Forum's name , Logo

If you want to change the Forum's name or delete it or even replace it with a logo .. you have to find in index.template.php :
Quote<td width="40%" align="center" style="background-image: url(', $settings['images_url'], '/xtHEAD.gif);" bgcolor="#83B3E0"><span style="font-family: Georgia, sans-serif; font-size: xx-large;">', $context['forum_name'], '</span></td>
what you need is change , delete , replace the red code only.

Logo will appear on the far right of the header .. and there is already an image which is found in the (xtEnhanced\images) folder under the name 'xtLOGO.gif' .. you cannot see it cause it has the same background colors ..
You need to open that image in your favorite graphic program and add a logo to it , save it then upload it back to your server.
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: Jazhawk on August 26, 2004, 06:40:42 PM
Thanx again A.M.A.

-Jazhawk
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: kenchix1 on August 26, 2004, 09:07:28 PM
Quote from: A.M.A on August 26, 2004, 10:58:50 AM
by the way do you have this problem with the 'default' theme!

I don't have any problem with the default theme using the 728x90 banner, both in IE and mozilla. as I said before, the 728x90 banner in XTenhanced theme doesn't have any problem with mozilla BUT with IE, the table exceeds the screen. I think it has something to do with the div on top of the whole table.  :-\

Thanks again for the help.
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: Springer on August 26, 2004, 10:56:07 PM
How did you get the image border around the forum?  Edit index.template?
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: A.M.A on August 27, 2004, 07:44:58 AM
kenchix1
I'll do some test on an image with your desired dimension and see what I can come up with.

Springer
Yes.
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: A.M.A on August 27, 2004, 10:34:04 PM
kenchix1 , I hope this will fix the sizing problem , in 'index.template.php' look for:
        <td width="0%" style="background-image: url(', $settings['images_url'], '/xtHEAD.gif);">';
change to:
        <td width="20%" style="background-image: url(', $settings['images_url'], '/xtHEAD.gif);">';

also look for:
        <td width="40%" align="center" style="background-image: url(', $settings['images_url'], '/xtHEAD.gif);" bgcolor="#83B3E0"><span style="font-family: Georgia, sans-serif; font-size: xx-large;">', $context['forum_name'], '</span></td>
        <td width="60%" align="center" style="background-image: url(', $settings['images_url'], '/xtHEAD.gif);" bgcolor="#83B3E0"><img src="', $settings['images_url'], '/xtLOGO.gif"  alt=""/></td>

change to:
        <td width="20%" align="center" style="background-image: url(', $settings['images_url'], '/xtHEAD.gif);" bgcolor="#83B3E0"><span style="font-family: Georgia, sans-serif; font-size: xx-large;">', $context['forum_name'], '</span></td>
        <td width="50%" align="center" style="background-image: url(', $settings['images_url'], '/xtHEAD.gif);" bgcolor="#83B3E0"><img src="', $settings['images_url'], '/xtLOGO.gif"  alt=""/></td>

You just need to change the width of the columns ( <td> )

my mistake .. was depending on the browser to render images size correctly even if the width of the columns is short .. I guess FireFox passes the test while the old IE did not  :-\
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: turtleman on August 31, 2004, 07:14:07 AM
If I might make a suggestion...

This theme is totally awesome BTW  :D

The one problem that I saw right away was if you have the quick reply displayed, the little smiley faces squash the size of the reply box.

If you go into the Display.template.php toward the bottom you will see:
<a href="javascript:void(0);" onclick="replaceText(\' :-\\\ \', document.postmodify.message); return false;"><img src="' . $settings['images_url'] . '/undecided.gif" align="bottom" alt="Undecided" title="Undecided" border="0" /></a>
<a href="javascript:void(0);" onclick="replaceText(\' :-*\', document.postmodify.message); return false;"><img src="' . $settings['images_url'] . '/kiss.gif" align="bottom" alt="Kiss" title="Kiss" border="0" /></a>
<a href="javascript:void(0);" onclick="replaceText(\' :\\\'(\', document.postmodify.message); return false;"><img src="' . $settings['images_url'] . '/cry.gif" align="bottom" alt="cry" title="cry" border="0" /></a>
<textarea cols="75" rows="7" style="width: 95%; height: 100px;" name="message" tabindex="1"></textarea><br />


All you need to do is just add an html line return before the textarea.  Kind of makes it look nicer in my opinion.  Thanks!
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: Vinoth on September 01, 2004, 09:04:14 AM
Nice work
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: Durriken on September 13, 2004, 02:16:22 PM
LOL I seem to suck major booty at installing themes.  Grrr... *keeps trying*.

BTW kenchix1, I am having the same problem you originally reported.  How did you fix that?
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: kenchix1 on September 13, 2004, 10:18:14 PM
I replaced the theme.  :D
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: kenchix1 on September 13, 2004, 10:22:18 PM
Quote from: A.M.A on August 27, 2004, 10:34:04 PM
kenchix1 , I hope this will fix the sizing problem , in 'index.template.php' look for:
        <td width="0%" style="background-image: url(', $settings['images_url'], '/xtHEAD.gif);">';
change to:
        <td width="20%" style="background-image: url(', $settings['images_url'], '/xtHEAD.gif);">';

also look for:
        <td width="40%" align="center" style="background-image: url(', $settings['images_url'], '/xtHEAD.gif);" bgcolor="#83B3E0"><span style="font-family: Georgia, sans-serif; font-size: xx-large;">', $context['forum_name'], '</span></td>
        <td width="60%" align="center" style="background-image: url(', $settings['images_url'], '/xtHEAD.gif);" bgcolor="#83B3E0"><img src="', $settings['images_url'], '/xtLOGO.gif"  alt=""/></td>

change to:
        <td width="20%" align="center" style="background-image: url(', $settings['images_url'], '/xtHEAD.gif);" bgcolor="#83B3E0"><span style="font-family: Georgia, sans-serif; font-size: xx-large;">', $context['forum_name'], '</span></td>
        <td width="50%" align="center" style="background-image: url(', $settings['images_url'], '/xtHEAD.gif);" bgcolor="#83B3E0"><img src="', $settings['images_url'], '/xtLOGO.gif"  alt=""/></td>

You just need to change the width of the columns ( <td> )

my mistake .. was depending on the browser to render images size correctly even if the width of the columns is short .. I guess FireFox passes the test while the old IE did not  :-\


Thank you very much, I'll try to do it. :)
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC1)
Post by: Francisco on October 02, 2004, 06:48:01 PM
 Nice work!  :D

One question, could you give me an example link to change it on our forums?

Thank you!
Title: SSI - xtEnhanced
Post by: Axion on October 15, 2004, 09:58:25 PM
what is the SSI download for or whats its use

i like the look of it but dont know what it is for website main page of what ?

thanks
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC2)
Post by: A.M.A on October 16, 2004, 12:23:13 PM
see this topic for more help:
http://www.simplemachines.org/community/index.php?topic=14906.0
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC2)
Post by: umiya on October 17, 2004, 09:17:05 PM
i would like to add the nav menu to far right wher elogo should be....iv tired just placing the code form the current one but it didnt seem to want to work...any suggestions?
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC2)
Post by: Benny Elgazar on October 29, 2004, 03:55:36 PM
WOW!!! :) Good Job!
i download now the Theme!
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC2)
Post by: Depeche Mode on December 11, 2004, 08:13:53 AM
2 author

Which font you've been using making "profile, admin and stuff" buttons? I have to translate them in russian to use them on my forum, see?
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC2)
Post by: Superboy on December 11, 2004, 09:05:42 AM
Quote from: LeeH on August 15, 2004, 11:29:25 AM
Very nice!  Snazzy Navigation thingie, and I like the rounded corners of the tables.

How do you make the corners of tables rounded? Is it just a round corner pic?

Great theme BTW, Well done!!  ;D
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC2)
Post by: A.M.A on December 11, 2004, 02:37:14 PM
Quote from: umiya on October 17, 2004, 09:17:05 PM
i would like to add the nav menu to far right wher elogo should be....iv tired just placing the code form the current one but it didnt seem to want to work...any suggestions?
so sorry for the delayed reply .. did not notice till now!
the header is divided into three columns .. you need to replace the last column with the first one.

Quote from: koko on October 29, 2004, 03:55:36 PM
WOW!!! :) Good Job!
i download now the Theme!
thanks


Quote from: Depeche Mode on December 11, 2004, 08:13:53 AM
2 author

Which font you've been using making "profile, admin and stuff" buttons? I have to translate them in russian to use them on my forum, see?
04b_09

Quote from: Superboy on December 11, 2004, 09:05:42 AM
How do you make the corners of tables rounded? Is it just a round corner pic?

Great theme BTW, Well done!!  ;D
yes .. thanks
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC2)
Post by: windborn on December 21, 2004, 09:55:38 AM
Hi, got a couple of questions I hope get answered.

My forum is here: http://windborn.xtreme-webhost.com/forum/index.php

How do I edit all the 'windborn.xtreme-webhost.com's to a name I want... I can't find the place to edit them.
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC2)
Post by: A.M.A on December 21, 2004, 04:46:10 PM
Admin -> Edit Server Settings -> Message Board Name
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC2)
Post by: windborn on December 26, 2004, 01:22:01 AM
Sorry to bother you, but I have another question :/

Which file should I open to edit the part at the top where it says "Testforum"? Can't seem to find where it is. Sorry, I'm not familiar with smf..
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC2)
Post by: [Unknown] on December 26, 2004, 01:59:58 AM
Admin -> Server Settings.

-[Unknown]
Title: Re: [Theme] xtEnhanced (SMF 1.0 RC2)
Post by: Seb87 on December 27, 2004, 11:49:49 AM
I need the .psd to translate in french

thanks :)
Title: Re: [Theme] xtEnhanced for SMF 1.0
Post by: WxChat.com on January 10, 2005, 01:10:46 PM
very nice theme.. have it on my testboard ;)
http://www.wxchat.com/smf

Aaron
Title: Re: [Theme] xtEnhanced for SMF 1.0
Post by: CartDestr on January 14, 2005, 10:33:55 AM
1.0.1 ...
Title: Re: [Theme] xtEnhanced for SMF 1.0.1
Post by: PrideDragon on January 15, 2005, 06:13:12 AM
Sorry my i'have bad english

Problem color with firefox

Example:
Firefox

(http://www.barconi.net/public/p.jpg)




IE

(http://www.barconi.net/public/p1.jpg)

Title: Re: [Theme] xtEnhanced for SMF 1.0.1
Post by: A.M.A on January 15, 2005, 09:54:06 AM
in your style .. change .catg0
background-image: url(http://www.barconi.net/forums/Themes/Nuova cartella/images/titleback.gif);
to:
background-image: url(http://www.barconi.net/forums/Themes/Nuova%20cartella/images/titleback.gif);
Title: Re: [Theme] xtEnhanced for SMF 1.0.1
Post by: PrideDragon on January 15, 2005, 11:40:30 AM
THX

It possible have button for Arcade??
Title: Re: [Theme] xtEnhanced for SMF 1.0.1
Post by: Midgard on January 19, 2005, 05:05:30 AM
Very nice A.M.A, thank you
Title: Re: [Theme] xtEnhanced for SMF 1.0.1
Post by: danking on January 19, 2005, 05:13:54 AM
Is their a way to add banners to this thme just very small ones via banner manager im very new to all this so any help I would be grateful my site is www.peertopeerchat.tk thanks for any help!!!
Title: Re: [Theme] xtEnhanced for SMF 1.0.1
Post by: A.M.A on January 19, 2005, 05:42:59 PM
PrideDragon
The menu design was made for SMF menu buttons only .. adding more to it am afraid will somehow break the whole design.

Midgard
thanks .. glad you like it.

danking
Where exactly you need the banner and what is the HTML code of the banner.

Title: Re: [Theme] xtEnhanced for SMF 1.0.1
Post by: danking on January 20, 2005, 03:28:15 PM
They are gif images to I want to be able to use banner manager with this theme so just have some small very small images along the top maybe in the bit where it says links here but on mine it says connexions arcade www.peertopeerchat.tk if this helps
Title: Re: [Theme] xtEnhanced for SMF 1.0.1
Post by: A.M.A on January 20, 2005, 04:39:57 PM
I think they will be good just below the link, just above the user info box.
open index.template.php and look for:
<table border="0" cellpadding="2" width="98%" cellspacing="0">
Add your code above that .. again I do not know what code you will be using and am not sure if it will work either. One thing though is to remember the use of the single quote  '  that needs to be escaped   /'
Title: Re: [Theme] xtEnhanced for SMF 1.0.1
Post by: Oldiesmann on January 24, 2005, 11:59:22 AM
Added to my test board... http://smf.oldiesmann.us/index.php?theme=28 (see http://smf.oldiesmann.us/index.php?topic=32.msg74#msg74 for a complete list of themes available on that board - more will be added shortly)
Title: Re: [Theme] xtEnhanced for SMF 1.0.1
Post by: forsakenlad on January 24, 2005, 01:05:11 PM
If you send me the photoshop templates of the buttons, I would gladly translate them to Turkish...
Title: Re: [Theme] xtEnhanced for SMF 1.0.1
Post by: forsakenlad on January 25, 2005, 10:19:39 AM
Hey A.M.A, I've sent two pm's to you regarding the translation, did you recieve them?
Title: Re: [Theme] xtEnhanced for SMF 1.0.1
Post by: forsakenlad on February 04, 2005, 06:45:52 PM
Here are the turkish buttons, I would be glad if you can add them to the main message:

For the regular buttons click here (http://turkish.doom9.org/smf/xtparts_turkish.zip)
If you want to change the font, etc. (psd files) click here (http://turkish.doom9.org/smf/xtparts_turkish_psd.zip)
Title: Re: [Theme] xtEnhanced for SMF 1.0.1
Post by: A.M.A on February 04, 2005, 07:02:52 PM
Greatly appreciate the effort .. thanks. Updated the first post and added the file to my site.
Title: Re: [Theme] xtEnhanced for SMF 1.0.1
Post by: forsakenlad on February 04, 2005, 07:15:01 PM
Ok, no problem, thanks again for the great theme...  ;)
Title: Re: [Theme] xtEnhanced for SMF 1.0.1
Post by: [ maCe ] on February 04, 2005, 10:20:04 PM
Great Theme!

I don't know if its been mentioned already, but theres a small type in the style.css file:

line 189:

.catbg12
{
      background-image: url(images/titleback1.gif);
}


The .catbg12 should be .catbg2 shouldn't it?

as I think thats what causes the greyish background to the catagory bars when there are new posts, instead of displaying the normal gradient background.

- maCe
Title: Re: [Theme] xtEnhanced for SMF 1.0.1
Post by: A.M.A on February 06, 2005, 10:55:35 PM
No, It is used by the theme .. no need to change it.
Title: Re: [Theme] xtEnhanced for SMF 1.0.1
Post by: dcantwell on February 08, 2005, 06:30:12 AM
would it be possible to get the psd's for the buttons?

Top theme btw thanks for your hard work
Title: Re: [Theme] xtEnhanced for SMF 1.0.1
Post by: Tarik on February 17, 2005, 04:26:06 AM
Nice work! The best theme I've ever seen!

Could you please PM me empty buttons? I want to translate them into Russian.
Title: Re: [Theme] xtEnhanced for SMF 1.0.1
Post by: tylerd213 on February 27, 2005, 07:15:44 PM
How do I change the Links Here!  I cant find it anywhere in the index.template.php
Title: Re: [Theme] xtEnhanced for SMF 1.0.1
Post by: A.M.A on February 28, 2005, 04:32:42 AM
line#223
<td width="100%" colspan="3" style="background-image: url(', $settings['images_url'], '/xtEnHead.gif);" height="20" align="left">&nbsp;Links
here!</td>


If you do not mind I'll delete your other post.
Title: Re: [Theme] xtEnhanced for SMF 1.0.3
Post by: sokhi on August 06, 2005, 09:55:56 AM
Excellent theme xtEnhanced

thanks
Title: Re: [Theme] xtEnhanced for SMF 1.0.3
Post by: Takeo on August 13, 2005, 11:40:11 AM
Hi there!

I'm kind a newby and I've installed recently SMF 1.0.5. I was wondering if this template is compatible with the current version that I'm using.

Another thing that I've noticed, is that you give some things to do within the code. I'm only using the forum, what do I really need to do to have this template running?

Please help me :(

Thanks! :)
Title: Re: [Theme] xtEnhanced for SMF 1.0.3
Post by: mitymo on August 21, 2005, 02:43:19 PM
Great theme!!!
I really like the menu. Terrific graphics. I'm a total noob when it comes to php. Can you tell me if it would be possible to move the menu to the center of the header and have either text on either side of it or have text on one side and a small logo on the other side? Thanks.
:D
Title: Re: [Theme] xtEnhanced for SMF 1.0.3
Post by: CYB3R-SeCuRiTy on August 26, 2005, 11:04:09 AM
THX a LOT but i i've started to use SMF yet and i dunno how can i use it who can help me... :)
pls mail me : cyb3r_security@hotmail.com
Title: Re: [Theme] xtEnhanced for SMF 1.0.3
Post by: i.am.Ben on August 28, 2005, 04:15:20 AM
so nice!!!!
:)
Title: Re: [Theme] xtEnhanced for SMF 1.0.3
Post by: N3lson on August 31, 2005, 06:13:38 AM
Hi nice theme , i want t know what code i have to change to put the panel of the user along the page in top:

Now -----------------------------------------------------------    ----------------------------------------------------------
        |....hello .....                                                       |   |                          news                                    |
        |----------------------------------------------------------|   |--------------------------------------------------------|                                                                   

Want this

|-----------------------------------------------------------------------------------------------------------------------------|
|hello                                                                                                                                                     |
|-----------------------------------------------------------------------------------------------------------------------------| 

Thank you
Title: Re: [Theme] xtEnhanced for SMF 1.0.3
Post by: forsakenlad on August 31, 2005, 05:31:08 PM
Can you be more spesific? A screenshot would be really handy ;)
Title: Re: [Theme] xtEnhanced for SMF 1.0.3
Post by: N3lson on September 01, 2005, 01:12:54 AM
I want like that :
When you log in appears a small panel with this informations (your avatar,how long you you are online, how pm you have ) and after this board in the wrigh exist another borad (Board News).
What i what to do is this, delete the news board (that i know) and make the board with the your information (avatar, PM you have) larger , in a way to use all top fórum:

I can´t send a pictur because uploads here are disable. and sorry my english i´m portuguese.
Thank you
Title: Re: [Theme] xtEnhanced for SMF 1.0.3
Post by: A.M.A on September 15, 2005, 11:03:56 AM
Sorry for the delay ..

Takeo
Yes it works with 1.0.5

mitymo
Yes, you can do this. If you are still interested, I'll show you how.

CYB3R-SeCuRiTy
You mean you can not install it!

i.am.Ben
Thanks.

N3lson
Sorry .. I did not get it. If you can post a picture of what you need it would be great.
Title: Re: [Theme] xtEnhanced for SMF 1.0.3
Post by: cyb3r_security on December 24, 2005, 03:54:20 AM
looks great i'll use it :d
Title: Re: [Theme] xtEnhanced for SMF 1.0.3
Post by: Veej on January 15, 2006, 02:03:47 PM
I really like it - one of the best themes!
However, please could you tell me how I could add my own button design if it would be at all possible?
I mean get rid of that oval type thing on the top left and make my own navigational buttons to go there.

Is it easily possible?
thanks!
Title: Re: [Theme] xtEnhanced for SMF 1.0.3
Post by: David Boreanaz on March 25, 2006, 12:15:04 AM
Wow! is very good...  :-X
Title: Re: [Theme] xtEnhanced for SMF 1.0.3
Post by: Diggo on March 27, 2006, 11:39:28 AM
I love this Theme!
Will there be a re-release for SMF 1.1 ? Or has anybody made it compatible yet?
Title: Re: [Theme] xtEnhanced for SMF 1.0.3
Post by: Oğulcan on April 01, 2006, 02:56:58 PM
Very good.Thank you.