Simple Machines Community Forum

Archived Boards and Threads... => Archived Boards => Classic Themes => Topic started by: bloc on October 25, 2004, 12:35:56 PM

Title: [Theme] Mercury (SMF v1.0.5 - 1.1RC2)
Post by: bloc on October 25, 2004, 12:35:56 PM
All files have been moved to the themes site:

http://themes.simplemachines.org/index.php?lemma=18
Title: Re: [Theme] Mercury for RC1
Post by: klumy on October 25, 2004, 12:47:15 PM
Looks great ;)
Title: Re: [Theme] Mercury for RC1
Post by: A.M.A on October 25, 2004, 01:19:20 PM
Great as always Bloc .. love the background in the Author section.
Title: Re: [Theme] Mercury for RC1
Post by: brlmedia on October 26, 2004, 12:41:17 PM
it's different! nice work
Title: Re: [Theme] Mercury for RC1
Post by: codenaught on October 26, 2004, 03:46:32 PM
Yeah very nice! So far all of your themes have been quite nice.  :)
Title: Re: [Theme] Mercury for RC1
Post by: trenchteam on October 27, 2004, 06:55:45 AM
nice work. Never fail to impress
Title: Theme of Mercury
Post by: MrPHD on November 14, 2004, 11:20:04 AM
Where can i find this theme of Bloc, Mercury theme for rc2. Thanks
Title: Re: Theme of Mercury
Post by: Tristan Perry on November 14, 2004, 11:24:11 AM
Clicky  :) (http://www.simplemachines.org/community/index.php?topic=15620.msg154143#msg154143)
Title: Re: Theme of Mercury
Post by: proto-man on November 14, 2004, 12:09:29 PM
I think maybe he wanted it for RC2 not 1. I dont think there is one for RC1 is there?
Title: Re: [Theme] Mercury for RC1
Post by: bloc on November 14, 2004, 12:22:30 PM
Not yet(RC2 version). But it(RC1) works fine in RC2 though - just missing the "mark unread" button really.
Title: Re: [Theme] Mercury for RC1
Post by: allfripou on November 14, 2004, 01:11:38 PM
Wonderful theme . One of the best so far :)

Thx
Title: Re: [Theme] Mercury for RC2
Post by: bloc on December 05, 2004, 08:03:46 AM
Updated the theme for use in SMF 1.0 RC2.

See first post for details.
Title: Re: [Theme] Mercury for RC2
Post by: gfpk2 on February 08, 2005, 01:55:00 PM
Hey Bloc thanks for the theme, one of the best without doubt and my favourite.

Some appreciations:

- Those two background colours could be different:

(https://www.simplemachines.org/community/proxy.php?request=http%3A%2F%2Fimg176.exs.cx%2Fimg176%2F2025%2Fcapture17we.jpg&hash=43799e57e278f306e5974a34d5e16cb3)


- In the Spanish package, this is wrong, the correct is "MARCAR"

(https://www.simplemachines.org/community/proxy.php?request=http%3A%2F%2Fimg176.exs.cx%2Fimg176%2F8549%2Fcapture27xq.jpg&hash=8d130e2dd64b40d0eab3971a673c85cc)
(https://www.simplemachines.org/community/proxy.php?request=http%3A%2F%2Fimg83.exs.cx%2Fimg83%2F8806%2Fapollo2sl.gif&hash=bf249c4cc69c884e4b5924093bc1efbd)


- A suggestion, this header could be a little more elaborated, with some kind of box or similar for news, stats and info, and a little space for a small logo; do you understand me? sorry about my poor English

(https://www.simplemachines.org/community/proxy.php?request=http%3A%2F%2Fimg176.exs.cx%2Fimg176%2F8066%2Fcapture38dn.jpg&hash=69151a6b92f816d35289a2e2b44c8012)


Thank you very much for your themes, buttongenerator and fantastic job! :-*


Title: Re: [Theme] Mercury for RC2
Post by: bloc on February 08, 2005, 02:24:33 PM
Thank you. :) I will look at these things in the update to v.1.0.1.

Title: Re: [Theme] Mercury (SMF v1,0/v1.01)
Post by: bloc on February 15, 2005, 06:39:35 PM
Updated to v1.0/v1.0.1. See details in first post.
Title: Re: [Theme] Mercury (SMF v1,0/v1.01)
Post by: Oldiesmann on February 18, 2005, 07:31:49 PM
http://smf.oldiesmann.us/index.php?theme=68

Themes folder on that board now takes up 84.83MB of space :)
Title: Re: [Theme] Mercury (SMF v1,0/v1.01)
Post by: Radianation on February 22, 2005, 05:07:48 AM
My favorite out of the box theme. Thank you.
Title: Re: [Theme] Mercury (SMF v1,0/v1.01)
Post by: [darksteel] on February 22, 2005, 11:38:02 AM
good imagination :P

Great Theme :P
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: bloc on July 14, 2005, 08:30:51 PM
Updated to SMF 1.1beta3. See first post for download link.
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: m00h on July 16, 2005, 07:51:22 AM
Hmm is it a bug?

Firefox 1.0.4 + SMF 1.1 Beta 3 Public + Mercury 1.1beta3 =
(https://www.simplemachines.org/community/proxy.php?request=http%3A%2F%2Fimg315.imageshack.us%2Fimg315%2F6583%2Funtitled4pn.th.png&hash=ae373cb57d8fabee6cb9bbf76ed85756) (http://img315.imageshack.us/my.php?image=untitled4pn.png)

IE works fine ;)


Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: bloc on July 22, 2005, 10:34:56 AM
Mercury for SMF 1.1beta3 had a bug in it that prevented the karma function from working properly.

Those who want to correct it, can download the archive again and just replace Display.template.php.
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: TANDIONO.COM on August 13, 2005, 07:56:08 AM
Hi! How can i made a "topbar" in my template, something like this >> It has a "topbar" like Themis, which you can put in own HTML code.
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: bloc on August 13, 2005, 08:24:13 AM
There is already the option of a topbar in Mercury?

Admin / current theme settings / topbar
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: TANDIONO.COM on August 13, 2005, 09:14:00 AM
im going to install in a new themes :) may i know what's the code
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: anna.young on September 03, 2005, 12:16:05 PM
I really like this theme, already tried it in my test v1.0.5.

I'm not able to download a 1.1beta3 as 'www.blockzone.net could not be found'.  I think you moved your server Bloc, but I can't find the new one...  Thanks

Anna
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: bloc on September 03, 2005, 12:47:30 PM
I will update the links...bloczone should be correct in a couple of days again though.
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: anna.young on September 03, 2005, 12:56:35 PM
Couple of days???  :(   Thanks.

Anna
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: anna.young on September 03, 2005, 03:27:32 PM
Whah, that was quick! Thanks  Bloc...  :)

I downloaded it, it installed fine...  One little cute thing is missing though.

The background icon for Posters info is not therein 1.1beta3...

(https://www.simplemachines.org/community/proxy.php?request=http%3A%2F%2Fimg.photobucket.com%2Falbums%2Fv420%2Fannayoung%2FVarious%2FVarious%2FScreen%2520Shots%2FMercuryB.jpg&hash=97f1838dfd19f4861ecc692b0665dbc1)

I rather liked it.  Any way to get it back on?

Thanks again,

Anna
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: bloc on September 03, 2005, 05:44:32 PM
Its not there? This I have to check.
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: bloc on September 03, 2005, 05:56:33 PM
hm, I can't believe I did not see that before.. :) anyway, updated the theme files with it, so if you want it, just re-upload Display.template.
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: anna.young on September 03, 2005, 06:05:37 PM
Thanks, I'll do it now...  this was FAST!!!   8)

Anna
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: anna.young on September 03, 2005, 06:21:43 PM
I just did re-uploaded that one file Display.template, cleared cache, re-started the browser,  and it is still not showing... Anna
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: anna.young on September 03, 2005, 06:29:14 PM
It's OK now, I guess I was too fast...  I re-uploaded it again and it is lovely...

Thanks!!!!!!!  :)

Anna
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: dar on September 05, 2005, 02:46:20 AM
1.1 Beta
May I ask please how I can get a side bar (like this forum) which I can edit (with links, pics etc.) and can I do it so the colours match the Mercury theme?

I would also like room above the forum for banner advertising.

How is this done please?

Many thanks,
dar
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: bloc on September 05, 2005, 06:25:50 AM
That would be a major addition to Mercury, and I am not planning it now, sorry.

As for banner above, use the "topbar" option in admin / current theme settings.
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: dar on September 05, 2005, 04:32:15 PM
Thanks Bloc.

But is it possible for me to load the forum and theme into a frame then?

If this doesn't belong here, please say so  -  I just thought you might know the answer as a continuation of the thread.

Many thanks,
dar
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: bloc on September 05, 2005, 06:30:51 PM
AfAIK there are some issues with putting it in frames..but there are threads on how to integrate the forum into your site:

http://www.simplemachines.org/community/index.php?topic=19638.0
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: dar on September 05, 2005, 06:36:06 PM
Many thanks, Bloc - much appreciated.

Just in case I misled you - I am talking about a (switchable?) option where a box shows up like on the side of Admin Centre - where we can put links etc.

If that makes a difference - sorry I did not think of giving that as an example.

Many thanks,

dar
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: dar on September 05, 2005, 07:08:47 PM
Or at least something I could hyperlink back to my front page ....

dar
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: bloc on September 06, 2005, 05:12:11 AM
Ah, you mean like Themis theme for example? It has a sidebar which you can pretty much construct yourself with html code.
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: anna.young on September 06, 2005, 06:38:50 PM
Hello Bloc, just to let you know that 'last_post.gif' was missing from 'images/icons' folder.  It was easy enough to put one in, but perhaps you would like to know about it...

Thank you again, all members love our new look - just a sample:  '...I love it!!  It's so clean looking and easy to read....'   '...pictures look so much brighter...' 

Anna
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: bloc on September 06, 2005, 07:06:56 PM
I am glad your members like it. :) And thanks for the heads-up, I need to correct that.
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: 1MileCrash on September 06, 2005, 07:33:48 PM
bloc, are most of your themes named after greek/roman/WHATEVER  gods and goddesses?

I just noticed that.  :)
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: bloc on September 06, 2005, 08:41:20 PM
Yes. :)
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: 1MileCrash on September 07, 2005, 06:16:34 PM
Yes. :)

cool.

When do we get athena? Or Zeus?

 :P
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: Radianation on September 08, 2005, 05:17:19 AM
(https://www.simplemachines.org/community/proxy.php?request=http%3A%2F%2Fancienthistory.about.com%2Flibrary%2Fgraphics%2Fhadespersephone2.jpg&hash=b76aa1cf737acd8ade6d488cf300cb14)

Allow me to throw in my request for a Hades theme. It would go nicely with my black & red site.  8)
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: bloc on September 08, 2005, 07:27:58 AM
Yes. :)

cool.

When do we get athena? Or Zeus?

 :P
Never I guess.. :P ;D. They do mean something... So it might something else next time.

In fact they mean this:

Helios = sungod - dark , poweful
Juno = queen of gods - different, classy
Mercury = messenger of gods - fast(loading) :)
Cerberus = three-headed watchdog who guards the entrance to the lower world - need I say more? ;D
Apollo = sungod - light, powerful..in fact Helios theme was made after Apollo theme, and is a kind of darker version of it.

Hades? oh, I do have a "Hades" theme in works, and it will be darker than dark. And that is NOT as in more black color. ;D
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: TarantinoArchives on September 08, 2005, 08:12:20 AM
www.spaghetti-western.net/forum proudly uses this great theme (slightly modified)
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: chaking on September 12, 2005, 04:09:58 AM
Ok, I've had a lot of trouble due to the arcade mod lately.. so I changed a lot of stuff... but I was hoping you would be able to help me out with this error I keep getting... 1.1 beta 3

Quote
Pages: [1] 8: Undefined index: topbottomEnable
File: /home/u3/hookahforum/html/Themes/mercury11/Display.template.php (eval?)
Line: 534

Hopefully its something simple that you know, if not, I love the theme anyhow...
Thanks!
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: bloc on September 12, 2005, 05:14:30 AM
This is a bug that has been corrected...namely in the Display.template.php. If you open that file and go to line 534, it should read like this:
Code: [Select]
                                                <a name="bot"></a><b>', $txt[139], ':</b> ', $context['page_index'], ($modSettings['topbottomEnable'] ? $context['menu_separator'] . '<a href="#top">' . ($settings['use_image_buttons'] ? '<img src="' . $settings['images_url'] . '/' . $context['user']['language'] . '/go_up.gif" alt="' . $txt['topbottom4'] . '" border="0" align="top" />' : $txt['topbottom4']) . '</a>' : ''), '
If it doesn't, you need the updated file.
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: chaking on September 12, 2005, 05:50:27 AM
unfortunately it does read that exactly...  can you think of anything else that would cause it? thanks for the help, much appreciated
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: bloc on September 12, 2005, 07:08:47 AM
If you change it to:

Code: [Select]
          <a name="bot"></a><b>', $txt[139], ':</b> ', $context['page_index'], (isset($modSettings['topbottomEnable']) ? $context['menu_separator'] . '<a href="#top">' . ($settings['use_image_buttons'] ? '<img src="' . $settings['images_url'] . '/' . $context['user']['language'] . '/go_up.gif" alt="' . $txt['topbottom4'] . '" border="0" align="top" />' : $txt['topbottom4']) . '</a>' : ''), '
..does that work?
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: chaking on September 12, 2005, 07:37:11 AM
Yes, I got it... thank you for your help... The first one actually did work, I had a couple copies of the file and got them mixed up... thank you ver much Bloc... You've helped me a couple times now and your work is always fantastic... thanks again
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: anna.young on September 22, 2005, 01:00:15 PM
I just upgraded to SMF. 1.1 CR 1. 

Everything so far seems to work with Mercury.  I understand from the SMF. 1.1 CR 1 thread at  http://www.simplemachines.org/community/index.php?topic=50176.0 that all I need to do is to append the part of the template with 'Mark as read'  button.

I'm a beginner and would like to confirm here that I'm placing the code in the appropriate place in the appropriate file.

Is this correct placement in Display.Template?:

// This is a special case; if they can see mark unread, put it at the top... otherwise show add poll.
        if ($context['user']['is_logged'] && $settings['show_mark_read'])
      $buttonArray[] = '<a href="' . $scripturl . '?action=markasread;sa=topic;t=' . $context['mark_unread_time'] . ';topic=' . $context['current_topic'] . '.' . $context['start'] . ';sesc=' . $context['session_id'] .' ">' . ($settings['use_image_buttons'] ? '<img src="' . $settings['images_url'] . '/' . $context['user']['language'] . '/markunread.gif" alt="' . $txt['mark_unread'] . '" border="0" />' : $txt['mark_unread']) . '</a>';

Thank you so very much

Anna
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: bloc on September 22, 2005, 01:45:04 PM
I would think so. Does it seem to work as it should?
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: anna.young on September 22, 2005, 01:58:05 PM
Didn't try it as yet, after loosing the bridge to Coppermine, I'm paranoid...  :( I wanted to confirm first that I'm at least in the correct file...

As you don't seem to be alarmed Bloc, I'll try it...

Thank you

Anna
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: anna.young on September 22, 2005, 02:16:17 PM
Didn't make any difference at all - I got the same error:

Session verification failed. Please try logging out and back in again, and then try again.

There is probably another place somewhere re 'Mark as read' button on the main page...?

Anna
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: TarantinoArchives on September 22, 2005, 02:52:09 PM
this topic describes all changes:

http://www.simplemachines.org/community/index.php?topic=50411.0
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: anna.young on September 22, 2005, 03:08:13 PM
Thank you kindly TarantinoArchives

Anna
Title: Re: [Theme] Mercury (SMF v1.0.5 / 1.1beta3)
Post by: anna.young on September 27, 2005, 11:15:45 PM
Where exactly should I enlarge the size of the newsbox so that it would display 4 lines.

(https://www.simplemachines.org/community/proxy.php?request=http%3A%2F%2Fimg.photobucket.com%2Falbums%2Fv420%2Fannayoung%2FVarious%2FVarious%2FScreen%2520Shots%2FNewsbox.jpg&hash=984718595b592527bc3c0f724b969bde)

There is plenty of room there but only 2 lines out of 4 display properly.

Thank you kindly

Anna
Title: Re: [Theme] Mercury (SMF v1.0.5 - 1.1RC1)
Post by: bloc on October 07, 2005, 05:55:22 PM
Updated to work with SMF 1.1RC1.
Title: Re: [Theme] Mercury (SMF v1.0.5 - 1.1RC1)
Post by: eizellspende on January 03, 2006, 04:36:43 PM
Hello,

you Theme is really great. I wnat to change the Icons for one topic, where can I change them?
It means all the topics should have the same Icon only one of them should have a different Icon, is there a possibility to mkae this changes?

Thanks

Chris
Title: Re: [Theme] Mercury (SMF v1.0.5 - 1.1RC1)
Post by: bloc on January 03, 2006, 07:41:17 PM
I am not sure I follow...the topic icons is something you change when making/editing a topic? The other icons is of course to show if the topic is a poll, locked etc.
Title: Re: [Theme] Mercury (SMF v1.0.5 - 1.1RC1)
Post by: the_knight on January 06, 2006, 04:33:59 PM
happy new year .

Your theme is really interesting and cool.
I wonder if it was compatible with the RC2 ???
I'll try ...

Title: Re: [Theme] Mercury (SMF v1.0.5 - 1.1RC2)
Post by: bloc on January 14, 2006, 08:48:04 AM
Updated to work with SMF1.1RC2. See first post for download link.
Title: Re: [Theme] Mercury (SMF v1.0.5 - 1.1RC2)
Post by: dominik on February 06, 2006, 10:18:10 AM
Realy a great theme. Thx to the creator  8)
Title: Re: [Theme] Mercury (SMF v1.0.5 - 1.1RC2)
Post by: dominik on February 12, 2006, 06:46:58 AM
Me again. I have two questions.

1. How i can add something like ">>" at the Button of the Page, to go to the next page. So not only 1 2 [3] 4 but something like << < 1 2 [3] 4 > >>

2. How can i change the Font in the Header? (Titlename)
Title: Re: [Theme] Mercury (SMF v1.0.5 - 1.1RC2)
Post by: Baseball_Fan on April 10, 2006, 11:56:27 PM
I love the theme, but I need to add an arcade button. I looked for where to add the code to add a button, and could not find it. How can another button be added to the top (where it lists "home" "help" "profile" etc)??
Title: Re: [Theme] Mercury (SMF v1.0.5 - 1.1RC2)
Post by: bloc on April 11, 2006, 03:24:56 PM
Look in index.templae.php under "template_menu". There all buttons are rendered. You can simply copy one of those and adjust the link and image name/path.
Title: Re: [Theme] Mercury (SMF v1.0.5 - 1.1RC2)
Post by: steve123 on April 14, 2006, 04:34:37 PM
Great theme. I have the integrated chat function installed but when I load your theme I don't see the chat icon anymore. Is there a way I can put the chat icon. Thanks.
Title: Re: [Theme] Mercury (SMF v1.0.5 - 1.1RC2)
Post by: bloc on April 14, 2006, 07:02:39 PM
I think you need to modify BoardIndex.template for that. The chat is shown on forum frontpage right?
Title: Re: [Theme] Mercury (SMF v1.0.5 - 1.1RC2)
Post by: -!¦[·ÃNÐ¥·]¦!- on March 25, 2007, 04:57:48 PM
Thank you for this theme, nice work, it's my favourite. But, I want to see the title of the forum like a link. When you click the word you go to the home site on www.pupdd.com.ar Is it possible?

(https://www.simplemachines.org/community/proxy.php?request=http%3A%2F%2Fimg48.imageshack.us%2Fimg48%2F5733%2Ftopforumxt8.png&hash=f3ca8666846f4f5eea8c3de6a405776d)

(Sorry for my poor English)
Title: Re: [Theme] Mercury (SMF v1.0.5 - 1.1RC2)
Post by: Existant on July 31, 2007, 06:07:47 PM
I love the theme, and just installed it last night.

A question if I may

When a post is stickied, how do I make it so the background of the stick posts, in the list of posts, is slightly darker, so it is more visibly evident that it is sticky?
Title: Re: [Theme] Mercury (SMF v1.0.5 - 1.1RC2)
Post by: Deaks on January 10, 2008, 10:02:45 AM
topic is now locked please refer to:

http://www.simplemachines.org/community/index.php?topic=77772.0