Simple Machines Community Forum

SMF Support => SMF 2.0.x Support => Topic started by: echelon3 on April 12, 2008, 11:35:27 PM

Title: "Don't allow post text in notifications" not working...
Post by: echelon3 on April 12, 2008, 11:35:27 PM
Hi, I've tried having the box next to Don't allow post text in notifications checked and unchecked, but I still get the PM message in my emails. Not sure if this is a bug or just me....


I'm on SMF 2.0 Beta 3 Public
Title: Re: "Don't allow post text in notifications" not working...
Post by: SleePy on April 20, 2008, 01:54:05 PM
Is this still happening?
Do you have any mods installed?
Title: Re: "Don't allow post text in notifications" not working...
Post by: echelon3 on April 22, 2008, 12:19:16 AM
Yup and I recently did a clean install. There are no mods installed. I suppose I can edit it's template to make sure...
Title: Re: "Don't allow post text in notifications" not working...
Post by: niko on April 22, 2008, 07:55:01 AM
I think this option doesn't affect PMs.

In PersonalMessage.english.php

You could replace

Code: [Select]
$txt['pm_email'] = 'You have just been sent a personal message by SENDER on ' . $context['forum_name'] . '.' . "\n\n" . 'IMPORTANT: Remember, this is just a notification. Please do not reply to this email.' . "\n\n" . 'The message they sent you was:' . "\n\n" . 'MESSAGE';
with
Code: [Select]
$txt['pm_email'] = 'You have just been sent a personal message by SENDER on ' . $context['forum_name'] . '.' . "\n\n";
Title: Re: "Don't allow post text in notifications" not working...
Post by: echelon3 on April 22, 2008, 10:42:12 PM
THanks, I'll try it out