Simple Machines Community Forum

SMF Support => SMF 2.0.x Support => Topic started by: Elhcay on February 26, 2009, 08:52:22 AM

Title: Weird attachment layout?
Post by: Elhcay on February 26, 2009, 08:52:22 AM
Weird attachment layout in SMF2 RC1?

Converted from phpBB and upgraded to SMF2 RC1. But there's something odd about the layout/positioning of attachments of images for non-administrators. When viewing as a guest/member for example, the horizontal rule appears on the top right corner of each message, jutting out of the table, stretching outside to the right, while the images may sometime appear at a random place within the message rather than the bottom.

Tried a fresh install of RC1, but with same problem.

Tested posting and viewing attachments with SMF2 beta 3, all appears correct.

Any idea how to fix this? It's something to do with certain css or display.php file?
Title: Re: Weird attachment layout?
Post by: timned88 on February 26, 2009, 09:33:14 AM
i had the same problem and it was an easy fix once i knew what to look for.

go in display.template.php and look for...  line #497

ORIGINAL
Code: [Select]
               <div id="msg_', $message['id'], '_footer" class="attachments smalltext">';

MODIFIED
Code: [Select]
               <div class="post floatleft" id="msg_', $message['id'], '_footer" class="attachments smalltext">';


enjoy.
Title: Re: Weird attachment layout?
Post by: Elhcay on February 27, 2009, 10:27:51 AM
Thanks, that fixed it.

So, the RC1 is missing formatting of the attachment? Has this been reported?
Title: Re: Weird attachment layout?
Post by: timned88 on February 27, 2009, 09:25:59 PM
it's a known bug.  i had the same problem and made sure it was well reported ;)
Title: Re: Weird attachment layout?
Post by: karlbenson on February 28, 2009, 08:10:25 AM
Yeah its on the smf bug tracker.