Simple Machines Community Forum

Archived Boards and Threads... => Archived Boards => Mambo Bridge Support => Topic started by: German_AC on May 10, 2009, 03:43:28 PM

Title: Problem with smf who is online 2 transalation
Post by: German_AC on May 10, 2009, 03:43:28 PM
Hi, I just installed who is online 2 in my mambo site, wich is in spanish. Everything works fine but it still shows "Guests and Users" in english.
I can't find the way to translate this two words.

Thanks!
Title: Re: Problem with smf who is online 2 transalation
Post by: Kindred on May 13, 2009, 06:22:17 PM
I can not recall if I hardcoded those or used the SMF strings...    check the mod_smf_whosonline2.php file...
Title: Re: Problem with smf who is online 2 transalation
Post by: German_AC on May 25, 2009, 04:27:32 PM
Thanks kindred. I got it solved.

Now I m having a new problem. If I click on user name to see the profile, or if I click on PM button, the smf send pm page and profile page appear corrupt, i guess its something about template.

Any ideas?
Title: Re: Problem with smf who is online 2 transalation
Post by: Kindred on May 25, 2009, 05:04:08 PM
I'm not sure exactly what you are reporting...  however, I suspect one of two things...
1- your template is non-standard and may be broken...   2- you are using SMF 2.0RC1 (which I suspect will not work correctly with the 1.1.x versions of the bridge modules)
Title: Re: Problem with smf who is online 2 transalation
Post by: German_AC on May 25, 2009, 07:38:48 PM
Check it.

http://www.etowers-20.net/~hvpsn/

If you click on the online users, even when you cannot see profiles being a visitor you may see that the template corrupts and doesn't display correctly.

Template was downloaded from official smf site, and I'm using smf 1.1.9.

Thanks
Title: Re: Problem with smf who is online 2 transalation
Post by: Kindred on May 25, 2009, 07:45:04 PM
again, I don't really understand what you mean by "template corrupts".  I went to your site, but there are no users online so I was unable to view any...


but I just looked at the profile link from the recent posts module...
http://www.etowers-20.net/~hvpsn/index.php?option=com_smf&Itemid=&?action=profile;u=1

I do, however, notice that your FORUM is not actually using com_smf...

your forum links to
http://www.etowers-20.net/~hvpsn/foro/index.php?www

which is NOT the bridge....
Title: Re: Problem with smf who is online 2 transalation
Post by: German_AC on May 25, 2009, 08:55:32 PM
Ok, let me show you the problem. This happens when I click con send PM (the same happens with profile):

(http://img41.imageshack.us/my.php?image=sample1x.jpg)

This is how it should be. If you enter first to the forum and click send PM, it work fine:

(http://img39.imageshack.us/my.php?image=sample2j.jpg)
Title: Re: Problem with smf who is online 2 transalation
Post by: German_AC on May 25, 2009, 10:11:37 PM
Quote from: Kindred on May 25, 2009, 07:45:04 PM
your forum links to
http://www.etowers-20.net/~hvpsn/foro/index.php?www

which is NOT the bridge....

I linked directly to forum url. How should I do? Which is the bridge url?

Thanks
Title: Re: Problem with smf who is online 2 transalation
Post by: Kindred on May 25, 2009, 10:16:38 PM
You need to create an item in the main menu that points to the com_smf component

I suspect that the missing language strings are due to how you have the board set up...    (i.e.  Do you have "sync language" checked off in the bridge set up?   Do you have the default enlgish language files present in your themes/default/languages directory?
Title: Re: Problem with smf who is online 2 transalation
Post by: German_AC on May 25, 2009, 10:27:16 PM
Quote from: Kindred on May 25, 2009, 10:16:38 PM
You need to create an item in the main menu that points to the com_smf component

Ok, I go to add item, Component->Select SMF Bridge but when I click in the new item, nothing happens, only a blank page.
I also tried to add a Link to component, but the bridge doesn't appears in the list of components available to link.

I'm so lost, sorry.
Thanks for the patience
Title: Re: Problem with smf who is online 2 transalation
Post by: Kindred on May 25, 2009, 10:28:47 PM
PM me an admin login for mambo/smf and I will take a look.
Title: Re: Problem with smf who is online 2 transalation
Post by: German_AC on May 25, 2009, 10:40:50 PM
Quote from: Kindred on May 25, 2009, 10:28:47 PM
PM me an admin login for mambo/smf and I will take a look.

I just send you account data. Thanks a lot man!
Title: Re: Problem with smf who is online 2 transalation
Post by: German_AC on May 25, 2009, 10:48:20 PM
Quote from: Kindred on May 25, 2009, 10:16:38 PM
I suspect that the missing language strings are due to how you have the board set up...    (i.e.  Do you have "sync language" checked off in the bridge set up?   Do you have the default enlgish language files present in your themes/default/languages directory?

I set sync language to NO, and is worst. Take a look:

(http://img188.imageshack.us/my.php?image=sample3.jpg)

I have both, default english files and spanish files.
Title: Re: Problem with smf who is online 2 transalation
Post by: Orstio on May 26, 2009, 12:46:18 AM
The language synch in the bridge is for use with the Nokkaew component.  If you don't have that installed, then you should always turn it off.
Title: Re: Problem with smf who is online 2 transalation
Post by: German_AC on May 26, 2009, 12:54:31 AM
Well, after going around and testing different options I finally get it working fine!

I add a link to the componente (the bridge), set integration Unwrapped and sync language to NO. When I click on PM or user profile now screen shows perfect.

Thanks for the support.
Title: Re: Problem with smf who is online 2 transalation
Post by: German_AC on May 26, 2009, 02:07:06 AM
Well, me again with another question. I'm using bridge registration. Everything works fine but, activation email still in english even when i installed spanish language, and last message after registration remains in english to. Where can I modify this?

Thanks
Title: Re: Problem with smf who is online 2 transalation
Post by: Kindred on May 26, 2009, 05:43:00 AM
look in components/com_smf_registration/languages
Title: Re: Problem with smf who is online 2 transalation
Post by: German_AC on May 26, 2009, 11:56:51 AM
I don't have any languages directory in /components/com_smf_registration

Only two files:

smf_registration.php
smf_registration.html.php
Title: Re: Problem with smf who is online 2 transalation
Post by: Kindred on May 26, 2009, 08:33:32 PM
hmmm....   check the two files for hard-coded language strings....
Title: Re: Problem with smf who is online 2 transalation
Post by: German_AC on May 27, 2009, 02:36:06 PM
Ok, I'm working on it.
Title: Re: Problem with smf who is online 2 transalation
Post by: German_AC on May 30, 2009, 01:39:14 PM
I can't find it, tried everything, but the message after registation complete, and activation mail steel been displayed in english.
Title: Re: Problem with smf who is online 2 transalation
Post by: Orstio on May 30, 2009, 02:13:09 PM
Bridge registration uses the Mambo registration email.  Have you installed the language pack in Mambo?
Title: Re: Problem with smf who is online 2 transalation
Post by: German_AC on May 30, 2009, 02:23:41 PM
Yes, if I set mambo registration instead bridge registration it works fine, but when using bridge registration dont.
Title: Re: Problem with smf who is online 2 transalation
Post by: Orstio on May 30, 2009, 02:26:10 PM
Is there a reason you prefer to use the bridge registration instead of the Mambo registration?
Title: Re: Problem with smf who is online 2 transalation
Post by: German_AC on May 30, 2009, 02:44:14 PM
Well, I tried mambo registration, but the best results was using bridge.

So, tecnically, modificating registration.po it should work??
Title: Re: Problem with smf who is online 2 transalation
Post by: Orstio on May 30, 2009, 03:14:28 PM
Results should be the same regardless of registration type, as long as you have the proper mambots published.

Technically, yes, but I'm not sure that the bridge registration component was updated so well for Mambo 4.6.x.  It has never been a terribly popular choice, from past experience.  People seem to prefer either Mambo registration, SMF registration, or CB registration.