Simple Machines Community Forum

Archived Boards and Threads... => Archived Boards => Mambo Bridge Support => Topic started by: joshkol on August 06, 2009, 09:25:08 PM

Title: Login problems
Post by: joshkol on August 06, 2009, 09:25:08 PM
Whenever I try to login I get this error:

You are not authorized to view this resource.

Im using the latest SMF and Mambo (not beta) and the bridge login.
Title: Re: Login problems
Post by: Orstio on August 06, 2009, 09:44:46 PM
What version NUMBER of SMF?
 
What version NUMBER of the bridge?
 
Do you have a URL?
 
Are you using the bridge login module?  Is your bridge component menu item publicly accessible?
Title: Re: Login problems
Post by: joshkol on August 06, 2009, 09:49:13 PM
Smf 1.1.10
Mambo 4.6.2
Bridge 1.1.2

kilowattlaser.com
It is publicly accessible
Title: Re: Login problems
Post by: Orstio on August 06, 2009, 09:54:04 PM
Your SMF database user does not have access to your Mambo database.
Title: Re: Login problems
Post by: joshkol on August 06, 2009, 10:06:34 PM
Im using 1and1 hosting and the admin backend is not cpanel, any idea on how to add users to the database?
Title: Re: Login problems
Post by: Orstio on August 06, 2009, 10:07:21 PM
Do you have SSH?
Title: Re: Login problems
Post by: joshkol on August 06, 2009, 10:11:05 PM
Dont tihnk so, although I have phpmyadmin
Title: Re: Login problems
Post by: Orstio on August 06, 2009, 10:12:09 PM
Then you need to have SMF and Mambo in the same database.
Title: Re: Login problems
Post by: joshkol on August 06, 2009, 10:17:12 PM
So I need to uninstall smf, should I just delete the bridge then smf and reinstall both?
Title: Re: Login problems
Post by: Orstio on August 06, 2009, 10:21:25 PM
Why do you need to uninstall SMF?
 
Export your SMF database to a gzip file on your computer from phpMyAdmin.
 
Go to your Mambo database, and import the gzip file.
 
Change your SMF database info in your SMF admin panel to match your Mambo database info.
Title: Re: Login problems
Post by: joshkol on August 06, 2009, 10:27:20 PM
I got this error trying to import

#1044 - Access denied for user 'dbo293818669'@'%' to database 'db293906775'

dbo293818669 is mambo
db293906775 is smf
Title: Re: Login problems
Post by: Orstio on August 06, 2009, 10:39:56 PM
Check the text file inside the gzip.  Make sure it does not have any database specific information.
Title: Re: Login problems
Post by: joshkol on August 07, 2009, 02:13:23 AM
The error is no longer there now that its in the same database, but I cant login now. It just goes back to index.
Title: Re: Login problems
Post by: Orstio on August 07, 2009, 06:14:46 AM
In SMF, do you have subdomain independent cookies enabled?
 
Do you have the SMF_login or SMF_logout mambots published?
 
Are you accessing your site at kilowattlaser.com , or at www.kilowattlaser.com (http://www.kilowattlaser.com) ?
Title: Re: Login problems
Post by: joshkol on August 07, 2009, 01:05:33 PM
Subdomain independent cookies are enabled.
Both of those mambots are published.
And I access it with the www
Title: Re: Login problems
Post by: Orstio on August 07, 2009, 05:40:37 PM
Quote
Both of those mambots are published.
And I access it with the www

There's two of your problems.
 
If you are using the bridge login module, you should not have the SMF_login and SMF_logout mambots published.
 
When you installed Mambo, you told it that the URL was without the www.  You'll never be logged into Mambo unless the URL in your browser matches the URL you told it when it was installed.
Title: Re: Login problems
Post by: joshkol on August 07, 2009, 07:33:05 PM
I changed the url to www in the global config and unpublished both mambots. When I try to login it still wont work =/
Title: Re: Login problems
Post by: joshkol on August 18, 2009, 01:55:03 AM
Still can't get this to work, any help is appreciated.
Title: Re: Login problems
Post by: Orstio on August 18, 2009, 02:24:48 AM
Make sure the SMF_header_include mambot is published.
Title: Re: Login problems
Post by: joshkol on August 18, 2009, 09:10:02 PM
I published it just now and got the same results.
Title: Re: Login problems
Post by: H on September 12, 2009, 04:01:39 PM
joshkol, do you still require assistance with this? :)
Title: Re: Login problems
Post by: joshkol on September 12, 2009, 07:36:20 PM
I do, im at the point where I wouldn't mind giving you admin to help solve this issue.