Simple Machines Community Forum

SMF Support => SMF 2.0.x Support => Topic started by: Confused Too on June 08, 2010, 07:08:16 AM

Title: [SOLVED] unexpected ',' in
Post by: Confused Too on June 08, 2010, 07:08:16 AM
I am getting the following error in the Admin Control Panel
Parse error: syntax error, unexpected ',' in /home/??????/???????/forum/Sources/ManageSettings.php on line 139
when entering the following menus or sub-menus in Configuration:-

Does anyone who speaks fluent PHPees see any error there.
Sorry but no I don't know when it began or what mods were added which may have caused it.  I just found it a couple of days ago when I went to check some settings.

It doesn't appear to cause a problem with the forum but should I need to alter anything in those areas I will be unable to do so.

The ManageSettings.php Line 139:

'karma' => array(
),
),
'sig' => array(
'description' => $txt['signature_settings_desc'],
),
'profile' => array(
'description' => $txt['custom_profile_desc'],   //Line 139 ....
),
),
);

// Call the right function for this sub-acton.
$subActions[$_REQUEST['sa']]();
}


SMF 2.0 RC3
Mods:
SMF Staff Page   1.7
SMF Gallery Lite   2.2
Profile Comments   2
Login Logger   1
Internal_Links_Use_Same_Window   1.2
Force Topic Read On Login Mod   2.1
Member NotePad   1.2.1
Admin member list registration date   1.1
Purge inactive members with a number of posts   1.0.2
PM to New Members   1.2
Advanced Reputation System   1.8.1
Google Analytics Code   1.1
Board Notices   1.0.1
Annoy User   1.2
Advanced Footer Mod   1.1
Advanced Recent Posts   1.1
Hide SMF Version   1.0.6
Ad Managment   2.3.6.2
Moderator and Administrator Comment Tags   1.8
Users Online Today   1.5.5

Title: Re: unexpected ',' in
Post by: Antechinus on June 08, 2010, 07:26:40 AM
We'd need to check the whole file. A few lines before then looks suspicious but I can't tell for sure without seeing what preceded it. The problem is that errors are not necessarily on the line indicated by the error message. That basically just indicates when the mistake has snowballed enough to really screw things up.
Please attach a copy of your file to a post so we can check it. :)
Title: Re: unexpected ',' in
Post by: Confused Too on June 08, 2010, 08:15:01 AM
Antechinus,
Thanks Here it is.
Another way round, I thought was to unload some mods and see if it works but they all ****** when I go to unload them.
I am assuming that something has gone wrong somewhere here.
Title: Re: unexpected ',' in
Post by: Antechinus on June 08, 2010, 08:25:03 AM
Try this.
Title: Re: unexpected ',' in
Post by: Confused Too on June 08, 2010, 08:43:52 AM
Your a Star.
Was it a simple problem?

Have a big Kiss  :-* :-* :-* :-* :-*
Title: Re: unexpected ',' in
Post by: CapadY on June 08, 2010, 08:51:45 AM
[I Think (not sure of course) the code shloud be this:


   'karma' => array(
         ),
         'sig' => array(
            'description' => $txt['signature_settings_desc'],
         ),
         'profile' => array(
            'description' => $txt['custom_profile_desc'],   //Line 139 ....
         ),
      ),
   );

   // Call the right function for this sub-acton.
   $subActions[$_REQUEST['sa']]();
}
Title: Re: [SOLVED] unexpected ',' in
Post by: Antechinus on June 08, 2010, 09:05:39 AM
Yes it was an extra closing bracket and comma on the karma array (line 131). I thought it might be but needed to see the lot to be sure.