Simple Machines Community Forum

SMF Support => SMF 2.0.x Support => Topic started by: !RFAN on June 23, 2010, 09:01:11 AM

Title: use name Problem
Post by: !RFAN on June 23, 2010, 09:01:11 AM
whenever my new members try to register an account on my forum with user name having character * they receive an error

The username you tried to use contains the reserved name '*'. Please try another username.

i dont have any reserved name with this character..

whats wrong??
Title: Re: use name Problem
Post by: YogiBear on June 23, 2010, 09:06:37 AM
* is a character used for wildcards. For example, if you want to use Member Search to find all users on bear.whatever you type *@bear.whatever and the list will appear.
Title: Re: use name Problem
Post by: !RFAN on June 23, 2010, 09:10:30 AM
i see on other forums of IPB members have user names with * character... y cant we have on smf??
Title: Re: use name Problem
Post by: YogiBear on June 23, 2010, 09:16:09 AM
Well, it depends on which characters are used as Wildcards and whether Wildcards can be used at all. Same thing when trying to save a file - eg. a song title - in pc programs which won't allow the apostrophe.
Title: Re: use name Problem
Post by: !RFAN on June 23, 2010, 09:18:32 AM
hmmm.. got it.. btw.. what will u suggest me if i want to allow members to use this character..

thankx btw..
Title: Re: use name Problem
Post by: !RFAN on June 24, 2010, 01:18:56 AM
anyone please??
Title: Re: use name Problem
Post by: I B D on July 11, 2010, 02:29:07 PM
amigozone, id say it be easier just not allow names with * you could look in register.php there should be an area in there