Simple Machines Community Forum

SMF Support => Language Specific Support => Bosanski/Hrvatski/Srpski (Bosnian/Croatian/Serbian) => Topic started by: batterydoc on June 03, 2011, 01:19:10 PM

Title: Problem sa slovima ČčĆćĐ𩹮ž- Problem REŠEN, rešenje u postu
Post by: batterydoc on June 03, 2011, 01:19:10 PM
Pregledao uzduž i popreko, gomila korisnika je imala probleme sa prikazivanjem YU karaktera.

Da li su uspeli te probleme da reše, ili su prešli preko njih, ne znam, jer nema povratnih informacija.

Imam instaliranu verziju 2.0 RC5 , i imam takav problem, videćete na slici u prilogu.

Ako ima neko ko može da pomogne da rešim taj problem.

Probao sam sa konvertovanjem database u UTF8, ali nažalost, nije pomoglo.

Neki drugi predlog?



Hvala, u svakom slučaju.
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: Masterd on June 03, 2011, 01:29:24 PM
Imaš li ovu liniju u Settings.php datoteci?

$db_character_set = 'utf8';
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: batterydoc on June 03, 2011, 02:56:56 PM
Quote from: Masterd on June 03, 2011, 01:29:24 PM
Imaš li ovu liniju u Settings.php datoteci?

$db_character_set = 'utf8';

Imam, Linija 64
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: Madzgo on June 03, 2011, 03:05:14 PM
Da li si ti lično instalirao taj forum?
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: batterydoc on June 03, 2011, 03:08:33 PM
Quote from: Madzgo on June 03, 2011, 03:05:14 PM
Da li si ti lično instalirao taj forum?

Jesam,

ne znam zašto je to bitno.
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: Dzonny on June 03, 2011, 03:27:03 PM
promeni tu liniju utf8 na utf-8.
Da li si radio export/import baze pre nego što ti se pojavio ovaj problem?
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: batterydoc on June 03, 2011, 03:37:06 PM
Quote from: Dzonny on June 03, 2011, 03:27:03 PM
promeni tu liniju utf8 na utf-8.
Da li si radio export/import baze pre nego što ti se pojavio ovaj problem?

Unknown character set: 'utf'

kad promenim na utf-8

Menjao sam verziju, sa 1.1.13 na 2.0 RC5

od samog početka su se pojavili problemi,

Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: Madzgo on June 04, 2011, 01:51:11 AM
Quote from: batterydoc on June 03, 2011, 03:08:33 PM
Quote from: Madzgo on June 03, 2011, 03:05:14 PM
Da li si ti lično instalirao taj forum?

Jesam,

ne znam zašto je to bitno.
E pa zeznuo si u instalaciji, kao i ovi moji :)

Imalo je da se odabere da koristis UTF-8 i da bi radila naša slova to mora da se odabere.

E sad, rešenje bi moglo da bude da importuješ bazu u novu instalaciju smf-a, ali ja to ne umijem te ne očekuj od mene pomoć ;)
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: Masterd on June 04, 2011, 05:51:30 AM
Quote from: Dzonny on June 03, 2011, 03:27:03 PM
promeni tu liniju utf8 na utf-8.

Ne! To nikako nemoj raditi! 
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: Madzgo on June 04, 2011, 07:26:12 AM
Već je uradio :)
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: Masterd on June 04, 2011, 07:34:59 AM
Onda neka vrati onako kako je bilo.

Quote from: Madzgo on June 04, 2011, 01:51:11 AM
Imalo je da se odabere da koristis UTF-8 i da bi radila naša slova to mora da se odabere.

To je i napravio, inače ne bi imao tu liniju. Ako ti je baza dosita konvertirana u UTF-8 i to nije pomglo, jedino rješenje je da ručno izmijeniš naslove podforuma.
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: batterydoc on June 04, 2011, 12:35:52 PM
Quote from: Madzgo on June 04, 2011, 01:51:11 AM
Quote from: batterydoc on June 03, 2011, 03:08:33 PM
Quote from: Madzgo on June 03, 2011, 03:05:14 PM
Da li si ti lično instalirao taj forum?

Jesam,

ne znam zašto je to bitno.
E pa zeznuo si u instalaciji, kao i ovi moji :)

Imalo je da se odabere da koristis UTF-8 i da bi radila naša slova to mora da se odabere.

E sad, rešenje bi moglo da bude da importuješ bazu u novu instalaciju smf-a, ali ja to ne umijem te ne očekuj od mene pomoć ;)

I to je odrađeno, sve po PS-u

Problem je što u jednoj rečenici jedan karakter pokaže kako treba a drugi ne pokaže.
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: batterydoc on June 04, 2011, 11:23:52 PM
Quote from: Masterd on June 04, 2011, 07:34:59 AM
Onda neka vrati onako kako je bilo.

Quote from: Madzgo on June 04, 2011, 01:51:11 AM
Imalo je da se odabere da koristis UTF-8 i da bi radila naša slova to mora da se odabere.

To je i napravio, inače ne bi imao tu liniju. Ako ti je baza dosita konvertirana u UTF-8 i to nije pomglo, jedino rješenje je da ručno izmijeniš naslove podforuma.

I ručno kad promenim, opet dobijam ? umesto karaktera.
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: Masterd on June 05, 2011, 03:42:34 AM
Onda konvertiraj bazu još jednom, ali kompletnu bazu.
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: batterydoc on June 05, 2011, 06:46:32 AM
Iz Admin panela, ili?
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: Masterd on June 05, 2011, 09:50:16 AM
Probaj iz phpMyAdmina.
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: batterydoc on June 05, 2011, 11:25:26 AM
Quote from: Masterd on June 05, 2011, 09:50:16 AM
Probaj iz phpMyAdmina.

Ne vidim opciju za konvertovanje

Verzija je 3.3.9.2

Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: Madzgo on June 05, 2011, 01:44:52 PM
Pa kad ne postoji opcija
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: Masterd on June 05, 2011, 01:59:06 PM
Postoji u tabu operacija.
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: batterydoc on June 05, 2011, 02:47:39 PM
Quote from: Masterd on June 05, 2011, 01:59:06 PM
Postoji u tabu operacija.

Ovo mi je pocetna strana Myadmin

Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: Masterd on June 06, 2011, 02:20:22 AM
Oprosti, ali ja ne znam čirilicu.
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: batterydoc on June 06, 2011, 06:03:19 AM
Nije problem

Engleski



Hrvatski



Samo mi reci gde da potražim opciju za konvertovanje
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: Braca on June 06, 2011, 07:38:21 AM
Quote from: Masterd on June 06, 2011, 02:20:22 AM
Oprosti, ali ja ne znam čirilicu.


http://www.preslovljavanje.com/?option=com_preslovljavanje&task=prevedi

:P
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: batterydoc on June 09, 2011, 01:02:11 PM
Svi junaci, nikom ponikoše,

i u crnu zemlju, pogledaše.

Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: Branko. on June 09, 2011, 07:49:17 PM
http://wiki.simplemachines.org/smf/Converting
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: Mihac™ on June 10, 2011, 03:20:05 AM
Pa nemrem vjerovati da se takva tema podiže po stoti puta. Šta fakat nitko ništa ne čita kod instalacije i svi programeri su idioti i budale kojii su radili na razvoju SMF-a?

Šta ne piše lijepo kod instalacije i to na samom početku da li želiš bazu u utf-8?
Ma neeeee, to ne piše nigdje nego hajmo malo zakomplicirati s upitnicima, prepravljanjima i nazadnje to nije nikada kako treba niti će ikada niti kako treba.

Digne se na UT-8 instalacija, napravi rimport stare baze,  najbolje kad se sredi da su poruke posebno, korisnici posebno, teme posebno i sve ostalo posebno jer milion modova koji su instalirani prije će ostaviti hrpu redaka u starim tablicama i biti će opet grešaka.
Kad se sve to napravi se lijepo ode u administraciju foruma i ako jezik nije na utf-8, a znamo da nije, onda se samo tu napravi konvert entija koji inače i nije potrebno raditi jer sve radi.
Eto na mom test forumu gdje isprobavam sve i svašta radi baš sve i nikada mi se još nije desilo da mi pogrešno pokazuje bilo koja slova.
Radije nemojte postavljati takve teme ako se ne znate služiti tražilicom na forumu pošto sve to piše već stotine puta, a meni se bez ljutnje jednostavno ne da čitati stalno jedno te isto.
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: batterydoc on June 10, 2011, 08:27:47 AM
Quote from: Mihac™ on June 10, 2011, 03:20:05 AM
Pa nemrem vjerovati da se takva tema podiže po stoti puta. Šta fakat nitko ništa ne čita kod instalacije i svi programeri su idioti i budale kojii su radili na razvoju SMF-a?

Šta ne piše lijepo kod instalacije i to na samom početku da li želiš bazu u utf-8?
Ma neeeee, to ne piše nigdje nego hajmo malo zakomplicirati s upitnicima, prepravljanjima i nazadnje to nije nikada kako treba niti će ikada niti kako treba.

Digne se na UT-8 instalacija, napravi rimport stare baze,  najbolje kad se sredi da su poruke posebno, korisnici posebno, teme posebno i sve ostalo posebno jer milion modova koji su instalirani prije će ostaviti hrpu redaka u starim tablicama i biti će opet grešaka.
Kad se sve to napravi se lijepo ode u administraciju foruma i ako jezik nije na utf-8, a znamo da nije, onda se samo tu napravi konvert entija koji inače i nije potrebno raditi jer sve radi.
Eto na mom test forumu gdje isprobavam sve i svašta radi baš sve i nikada mi se još nije desilo da mi pogrešno pokazuje bilo koja slova.
Radije nemojte postavljati takve teme ako se ne znate služiti tražilicom na forumu pošto sve to piše već stotine puta, a meni se bez ljutnje jednostavno ne da čitati stalno jedno te isto.

Pametnjakoviću,

a otkud znaš da nisam pročitao i odradio onako kako treba, i da pored svega dobijam, to što dobijam, i pokušavam da dobijem savet, ili ideju kako to popraviti.

A ako ti se ne čita, ti nemoj čitati.

Pozdrav
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: batterydoc on June 10, 2011, 09:24:07 AM
Quote from: batterydoc on June 03, 2011, 01:19:10 PM
Pregledao uzduž i popreko, gomila korisnika je imala probleme sa prikazivanjem YU karaktera.

Da li su uspeli te probleme da reše, ili su prešli preko njih, ne znam, jer nema povratnih informacija.

Imam instaliranu verziju 2.0 RC5 , i imam takav problem, videćete na slici u prilogu.

Ako ima neko ko može da pomogne da rešim taj problem.

Probao sam sa konvertovanjem database u UTF8, ali nažalost, nije pomoglo.

Neki drugi predlog?

Hvala, u svakom slučaju.

A i vidi se da nisi čitao, jer u mom prvom postu lepo piše zbog čega podižem ovo pitanje po stoti put.

Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: Madzgo on June 10, 2011, 01:43:29 PM
Quote from: Mihac™ on June 10, 2011, 03:20:05 AM
Pa nemrem vjerovati da se takva tema podiže po stoti puta. Šta fakat nitko ništa ne čita kod instalacije i svi programeri su idioti i budale kojii su radili na razvoju SMF-a?

Šta ne piše lijepo kod instalacije i to na samom početku da li želiš bazu u utf-8?
Ma neeeee, to ne piše nigdje nego hajmo malo zakomplicirati s upitnicima, prepravljanjima i nazadnje to nije nikada kako treba niti će ikada niti kako treba.

Digne se na UT-8 instalacija, napravi rimport stare baze,  najbolje kad se sredi da su poruke posebno, korisnici posebno, teme posebno i sve ostalo posebno jer milion modova koji su instalirani prije će ostaviti hrpu redaka u starim tablicama i biti će opet grešaka.
Kad se sve to napravi se lijepo ode u administraciju foruma i ako jezik nije na utf-8, a znamo da nije, onda se samo tu napravi konvert entija koji inače i nije potrebno raditi jer sve radi.
Eto na mom test forumu gdje isprobavam sve i svašta radi baš sve i nikada mi se još nije desilo da mi pogrešno pokazuje bilo koja slova.
Radije nemojte postavljati takve teme ako se ne znate služiti tražilicom na forumu pošto sve to piše već stotine puta, a meni se bez ljutnje jednostavno ne da čitati stalno jedno te isto.

Kod mene je slučaj da sam preuzeo forum instaliran od strane stranog hosta, koji nije znao za ČĆŽŠĐ...
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: batterydoc on June 10, 2011, 01:51:45 PM
Quote from: Madzgo on June 10, 2011, 01:43:29 PM
Kod mene je slučaj da sam preuzeo forum instaliran od strane stranog hosta, koji nije znao za ČĆŽŠĐ...

I kako si rešio problem?

8)

Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: Madzgo on June 10, 2011, 05:18:10 PM
Nisam.
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: batterydoc on June 17, 2011, 02:05:56 PM
Prebacio sam forum sa 2 RC5 na Stabilnu verziju 2.0 međutim i dalje imam isti problem sa prikazivanjem naših slova.

U istom redu prikaže š a ć je prikazano kao ?

Da li to neka zna da reši ?

>

:(

Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: Mihac™ on June 17, 2011, 02:29:48 PM
u cpanelu prebaci tablice na utf-8 i stvar je rješena
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: batterydoc on June 17, 2011, 02:36:52 PM
Quote from: Mihac™ on June 17, 2011, 02:29:48 PM
u cpanelu prebaci tablice na utf-8 i stvar je rješena

Jedno glupo pitanje, gde u C-panelu?
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: ▓▒RapidBelgrade▒▓ on June 17, 2011, 02:51:53 PM
mislio je na tabele u bazi... 
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: Madzgo on June 17, 2011, 02:58:11 PM
<?php

$host 
'localhost';
$user 'username';
$pass 'password';
$db 'database';

// your connection
mysql_connect($host$user$pass);
mysql_select_db($db);

// convert code
$res mysql_query("SHOW TABLES");
while (
$row mysql_fetch_array($res))
{
    foreach (
$row as $key => $table)
    {
        
mysql_query("ALTER TABLE " $table " CONVERT TO CHARACTER SET utf8 COLLATE utf8_general_ci");
        echo 
$key " =&gt; " $table " CONVERTED<br />";
    }
}

// close connection
mysql_close();
?>


Izmijeni na vrhu $user i $password, stavi username i password cpanela, php my admina. i stavi ime baze.

onda sacuvaj kao nesto.php u root foruma, i pokreni tvojforum.com/nesto.php

za svaki slucaj napravi backup baze
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: batterydoc on June 17, 2011, 03:01:16 PM
Sve tabele su pri instalaciji prebačene na UTF

i tabela smf_boards u kojoj su imena boardova i tema su na UTF




I kada probam da promenim u phpMyAdmin  u bazi slovo ? u č prikazuje mi sledeću grešku



Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: Madzgo on June 17, 2011, 03:06:10 PM
Probaj ovo sto sam napisao gore.


A to što piše da su utf-8, to je i problem, samo piše.
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: batterydoc on June 17, 2011, 03:12:44 PM
Hvala,

rešio sam problem.


8)
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: batterydoc on June 17, 2011, 03:32:05 PM
Quote from: batterydoc on June 17, 2011, 02:05:56 PM
Prebacio sam forum sa 2 RC5 na Stabilnu verziju 2.0 međutim i dalje imam isti problem sa prikazivanjem naših slova.

U istom redu prikaže š a ć je prikazano kao ?

Da li to neka zna da reši ?

>

:(

Znam ja, rešio sam problem

Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: Dzonny on June 18, 2011, 01:15:48 PM
Fino što si rešio problem, bilo bi još bolje kada bo podelio to ovde kako bi ostali koji imaju dati problem znali šta da rade :)
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž
Post by: batterydoc on June 18, 2011, 02:37:16 PM
Quote from: Dzonny on June 18, 2011, 01:15:48 PM
Fino što si rešio problem, bilo bi još bolje kada bo podelio to ovde kako bi ostali koji imaju dati problem znali šta da rade :)

Nije pomoglo to što sam preko Admin panela, konvertovao u Utf,

mora da se preko phpMyAdmin svaka tabela proveri i prebaci na utf8_general_ci,

i to ručno.

Izabere se iz Baze podataka tabela, i onda u delu "Struktura" ako je potrebno, prepraviti na utf8_general_ci.

Kod mene su bile mešovite, pojedine su bile kako treba, a druge su bile latin1_swedish_ci ( kao da ih je RapidBelgrade pravio)



Ispraviti na pravilan kod



i onda se dobija pravilan kod, i pravilno se prikazuju sva naša slova



I nema više problema, sve je napisano kako treba da bude napisano.



Nadam se da će nekom da pomogne

8)





Title: Re: Problem sa slovima ČčĆćĐ𩹮ž- Problem REŠEN, rešenje u postu
Post by: batterydoc on June 18, 2011, 02:42:21 PM
Možda nisam trebao da pokažem rešenje,

nego da, kao pojedinci naplaćujem rešenje.

8)
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž- Problem REŠEN, rešenje u postu
Post by: Dzonny on June 18, 2011, 03:07:41 PM
Quote from: batterydoc on June 18, 2011, 02:42:21 PM
Možda nisam trebao da pokažem rešenje,

nego da, kao pojedinci naplaćujem rešenje.

8)


Hm, ne znam koliko bi to dobro išlo obzirom da je to sasvim normalan postupak kada ti neko kaže "proveri da li je baza na collation-u tom i tom". Naravno, tada se misli na celu bazu tj svaku tabelu, a ne samo na pojedinačnu.

U svakom slučaju hvala za slike u za how-to, svakako će pomoći :)
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž- Problem REŠEN, rešenje u postu
Post by: batterydoc on June 18, 2011, 03:19:44 PM
Quote from: Dzonny on June 18, 2011, 03:07:41 PM

Hm, ne znam koliko bi to dobro išlo obzirom da je to sasvim normalan postupak kada ti neko kaže "proveri da li je baza na collation-u tom i tom". Naravno, tada se misli na celu bazu tj svaku tabelu, a ne samo na pojedinačnu.

U svakom slučaju hvala za slike u za how-to, svakako će pomoći :)

To našta se misli, je jedno, jer nisu svi toliko u materiji, niti su vidoviti.

A trebalo je i pronaći gde da se promeni Collation, za svaku bazu pojedinačno.

I ja se nadam da će pomoći, da se ljudi ne muče kao što sam se ja mučio dok nisam našao rešenje.

8)
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž- Problem REŠEN, rešenje u postu
Post by: MobiMania on July 07, 2011, 04:52:21 PM
Uradio sam sve kako piše al neče opet :S
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž- Problem REŠEN, rešenje u postu
Post by: batterydoc on July 07, 2011, 05:01:15 PM
Quote from: carrera on July 07, 2011, 04:52:21 PM
Uradio sam sve kako piše al neče opet :S

Da li si kada si prebacio sve na utf8_general_ci,

probao da ponovo ukucaš naša slova?
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž- Problem REŠEN, rešenje u postu
Post by: MobiMania on July 07, 2011, 05:03:15 PM
Mogu ja ispravit kad pišem RUČNO :S..al imam previše boarda tako da nemam vremena
Title: Re: Problem sa slovima ČčĆćĐ𩹮ž- Problem REŠEN, rešenje u postu
Post by: batterydoc on July 07, 2011, 05:11:23 PM
Quote from: carrera on July 07, 2011, 05:03:15 PM
Mogu ja ispravit kad pišem RUČNO :S..al imam previše boarda tako da nemam vremena

Moraš to ručno da uradiš, ili direktno u bazi, ili u admin panelu.

8)