Simple Machines Community Forum

Customizing SMF => Graphics and Templates => Theme Site Themes => Topic started by: Akyhne on June 27, 2011, 08:27:52 PM

Title: Bad Company 3
Post by: Akyhne on June 27, 2011, 08:27:52 PM
Link to the theme (http://custom.simplemachines.org/themes/index.php?lemma=2435)

(http://themes.e-debatten.dk/index.php?action=dlattach;topic=14.0;attach=87;image)

Support & Comments (http://themes.e-debatten.dk/index.php?topic=14.0)

Did you like this theme?
(https://www.paypal.com/en_US/i/btn/btn_donate_LG.gif) (https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=9993480)

A nice, dark Battlefield theme, inspired on the Battlefield game series.

October 2011:
! Checkboxes could not be determined if they were checked or not in Opera 11.51
! Plain text in code windows could not be seen.

December 2011
+ Added SMF 2.1 style drop down menu

Demo: http://themes.e-debatten.dk/
Download: http://themes.e-debatten.dk/index.php?action=tpmod;dl=item15
Title: Re: Bad Company 3
Post by: Don_Lucci on June 28, 2011, 01:30:38 PM
Hello

First of all I wanna say what a great Theme you made ( Bad Company 3 )!
But I have a problem with it. I searched on the internet to fix my problem and sometimes I thought I found the solution, but it's still doesnt't work.

My problem is i can upload the new theme and i see the background ( the picture ) but the forum is gone and I also see something of new message and the hello ( name ). I uploaded with zip file, I also tried it with filezilla and I also tried those 2 things on my other computers. So when i want my forum back I first need to set the default theme on. Therefor i need my other computer on and logged in. And now I tried downloaded it again so I'm sure it's the full theme I uploaded.

Can you pleas help me ?

Kind regards
Lucci
Title: Re: Bad Company 3
Post by: Akyhne on June 28, 2011, 02:07:33 PM
Are you installing the theme in a SMF 2 forum?
Title: Re: Bad Company 3
Post by: Don_Lucci on June 28, 2011, 02:56:03 PM
yup I just uploaded again the new version 2.0 and its still the same problem :(

And if you wanne see it : www.bsmggamers.com/forum (http://www.bsmggamers.com/forum)

Greets
Title: Re: Bad Company 3
Post by: Akyhne on June 28, 2011, 03:01:37 PM
How did you install the theme?
Title: Re: Bad Company 3
Post by: Don_Lucci on June 28, 2011, 03:09:34 PM
I dit it on 2 ways.
First one = I downloaded the theme on zipfile.
Then l went to admin panel on the forum and i choose 'themes and layout' and than 'manage and install' , than I clicked on browse and i took the zipfile from my pc and uploaded the file.
Than I choose the theme on 'overall forum default' and saved it , and then I saw the background but no forum.

Seconde way: I uploaded the unzippedfile into the theme files in filezilla. and then putted the name of the file into adminpanel -> 'from a directory on the server:' and made a default name. And installed it and this didn't worked either.

It's strange, I really want this theme .

Greets

Title: Re: Bad Company 3
Post by: Akyhne on June 28, 2011, 03:21:44 PM
"Powered by SMF 1.1.13" - not SMF2!
Title: Re: Bad Company 3
Post by: Don_Lucci on June 28, 2011, 03:28:21 PM
It says Compatible With: 2.0 ?

Excuse me for your time but I'm not so known with this, just a few days.

Greets

Title: Re: Bad Company 3
Post by: Akyhne on June 28, 2011, 03:30:51 PM
Yeah, only compatible with SMF 2. But you have SMF 1.1.13 installed.
Title: Re: Bad Company 3
Post by: Don_Lucci on June 28, 2011, 03:32:11 PM
No I downloaded 2.0 . I'm sure .

Greets
Title: Re: Bad Company 3
Post by: Don_Lucci on June 28, 2011, 03:35:20 PM
Ow wait i think I see it  . Ok thanks i will tell if it works now .
Title: Re: Bad Company 3
Post by: sadaam on July 01, 2011, 05:25:55 AM
Dear i m using Smf2.0 and i just install a new theme " Bad company 3 " . But My ad mod not dislaped ads with this theme ..What to do..? May i re install the ad mod..? or something else i have to do..plz guide me brother...
Title: Re: Bad Company 3
Post by: Akyhne on July 01, 2011, 06:38:09 AM
Ask the mod author
Title: Re: Bad Company 3
Post by: Remmington on July 07, 2011, 11:28:24 AM
Awesome theme, worked really well with our clan site.
Title: Re: Bad Company 3
Post by: Akyhne on July 07, 2011, 06:17:34 PM
Thanks :)
Title: Re: Bad Company 3
Post by: Akyhne on July 28, 2011, 09:31:24 PM
1000 downloads in the first month. Thx for all the interest!

I've now installed the theme in some of the boards on my own site. Seing how things looks, I might make the backgrounds a bit less transparent.

See for yourself: http://www.worldofgt.com/index.php?board=65.0 & http://www.worldofgt.com/index.php?board=66.0
Title: Re: Bad Company 3
Post by: doyle53 on August 07, 2011, 09:47:03 AM
I have a question  i also am running this theme  and all members love it but i want  to link forum back to our  website how can do this? I have no problem with html links but am new to php. Do a do it index.template.php?
Title: Re: Bad Company 3
Post by: Akyhne on August 07, 2011, 10:26:57 AM
It's not a theme setting but a setting in the software itself.

Unfortunately, one has to edit system files.

Find the ./Sources/Subs.php and browse down to line 3892:
Code: [Select]
$buttons = array(
'home' => array(
'title' => $txt['home'],
'href' => $scripturl,
'show' => true,
'sub_buttons' => array(
),
'is_last' => $context['right_to_left'],
),

This part desides where the link points:
'href' => $scripturl,

Change it to:
'href' => 'http://mysite.com',
.. or whatever your link is.

You can also make sub menu links, scroll a bit down in the file to
Code: [Select]
'admin' => array(
'title' => $txt['adm....
There you can see the section
Code: [Select]
'sub_buttons' => array(
'featuresetting.....
That's the way sub links are build.
Title: Re: Bad Company 3
Post by: doyle53 on August 07, 2011, 11:01:40 AM
Works great thanks for your help   ;D
Title: Re: Bad Company 3
Post by: Akyhne on August 07, 2011, 11:03:39 AM
You are welcome. Another time, please post in the proper support topics, instead of sending emails ;)
Title: Re: Bad Company 3
Post by: doyle53 on August 07, 2011, 01:26:36 PM
Sorry did not know about this area of support stumbled upon it   LOL
Title: Re: Bad Company 3
Post by: smtek on August 21, 2011, 08:37:31 AM
The text within code tag is not visible due to too brigt . How unchange it.


and how to change the color of sticky topic background.
Title: Re: Bad Company 3
Post by: Akyhne on August 21, 2011, 02:13:46 PM
code.bbc_code

.stickybg
.stickybg2
Title: Re: Bad Company 3
Post by: bruce86 on September 17, 2011, 08:47:24 AM
Beautiful theme!.. :o :o
Make themes on games in General?
Title: Re: Bad Company 3
Post by: Neo55 on September 19, 2011, 05:48:27 PM
Hi Akyhne,

I too am using this BF3 theme, looks great but I want to change the posters/authors name color. For example:

Someone starts a new topic or even reply to one. Their name is on left as all are but is in orange and I would like to change the names to another default color.

Is this possible
Thanks
Title: Re: Bad Company 3
Post by: Akyhne on September 19, 2011, 06:10:16 PM
Just change the
Code: [Select]
.poster h4, .poster h4 a {
    color: #C06002;
}
to whatever color you want.
Title: Re: Bad Company 3
Post by: bruce86 on September 20, 2011, 01:03:13 PM
1. You do not see the image.
2. Can I insert the theme with version 2.0.1?
3. How to remove the writing?
Thanks..:)
Title: Re: Bad Company 3
Post by: Wacko999 on October 09, 2011, 07:11:23 PM
The theme looks great and I managed to get in an make a few color changes so I could see posts in the TP shoutbox.
The one thing that I can't figure out is when you go into a screen with check boxes such as 'Features and Options", you can't tell if the boxes are checked or not.  Any pointers on how to change these so you can see them?
Title: Re: Bad Company 3
Post by: Akyhne on October 10, 2011, 06:05:05 AM
Hmm, I see them in IE9, FF latest, Safari latest, Chrome latest, but not in Opera latest. So I guess that's your browser.

I'll take a look at it.
Title: Re: Bad Company 3
Post by: Akyhne on October 10, 2011, 06:09:35 AM
Change index.css:
Code: [Select]
/* All input elements that are checkboxes or radio buttons shouldn't have a border around them. */
input.input_check, input.input_radio
{
border: none;
background: none;
}

to
Code: [Select]
/* All input elements that are checkboxes or radio buttons shouldn't have a border around them. */
input.input_check, input.input_radio
{
border: none;
background: #fff;
}
Title: Re: Bad Company 3
Post by: Wacko999 on October 10, 2011, 07:23:40 PM
You nailed that one on the head!  I am using Opera.
This fixed it and now the check boxes are viewable.
Thanks!
Title: Re: Bad Company 3
Post by: BigMatt on October 12, 2011, 01:25:34 AM
Great theme!  Is it possible to modify it so that there is more room for the logo?  Ours is 91 pixels high and it overlaps the user info.
Title: Re: Bad Company 3
Post by: Akyhne on October 12, 2011, 01:54:09 AM
You will have to play with some css to get it to work.
Title: Re: Bad Company 3
Post by: GateCrasher on October 13, 2011, 12:17:47 AM
i got smf 2.1 i think on gamingtroops.com and if you see the url header i put in at top saying name of site is covering part of the left login can you help me please i used firebug but only came up with html codes and the files dont have any index.html in them to find the line to justify center away from login
Title: Re: Bad Company 3
Post by: Akyhne on October 13, 2011, 02:05:17 AM
Well, resize your image.
Title: Re: Bad Company 3
Post by: {KJ} on October 13, 2011, 04:04:21 PM
Hello, LOVE YOUR THEME.
I'm using it for our gaming site.
I want to add tabs at the top of the home page.
Next to where it says, HOME FORUM HELP SEARCH.
Can you please help Akyhne? thank you
Title: Re: Bad Company 3
Post by: Akyhne on October 13, 2011, 06:42:37 PM
Look in Sources/Subs.php around line #3890 for "   // All the buttons we can possible want and then some, try pulling the final list of buttons from cache first."

That area defines all the buttons.
Title: Re: Bad Company 3
Post by: GateCrasher on October 13, 2011, 10:05:15 PM
ok fixed by editing the backdrop.jpg so now another question is there a working chat module for it on 2.0.1 bad company 3 theme?
Title: Re: Bad Company 3
Post by: Akyhne on October 13, 2011, 10:20:09 PM
Any chat should work, but you almost always need to tweak some css to get it to look like you want it..
Title: Re: Bad Company 3
Post by: FileAxis on October 15, 2011, 03:32:01 PM

  Your theme looks fantastic but the game is called "Battlefield 3" not "Bad Company 3".

Title: Re: Bad Company 3
Post by: Akyhne on October 15, 2011, 11:02:15 PM
Yeah... I've been told a hundred times... ::)
Title: Re: Bad Company 3
Post by: {KJ} on November 08, 2011, 01:40:38 AM
Look in Sources/Subs.php around line #3890 for "   // All the buttons we can possible want and then some, try pulling the final list of buttons from cache first."

That area defines all the buttons.

You're awesome thank you.
My title is showing up twice...
www.mpbattlefields.com
At the top, notice it says MP Battlefields in blue, then just below bigger and in orange again.
Is this possible to fix?
Title: Re: Bad Company 3
Post by: Akyhne on November 08, 2011, 02:49:02 AM
Well, you seemed to have deleted this:
Code: [Select]
h1.forumtitle2 {
    color: #224466;
    float: left;
    font-family: Geneva,verdana,sans-serif;
    font-size: 2.8em;
    line-height: 45px;
    margin: 3px 0 0 2px;
    padding: 0;
    position: absolute;
}
... in index.css

EDIT:
No, you have actually renamed a class:
Code: [Select]
<h1 class="forumtitle2">to...
Code: [Select]
<h1 class="forum2">
Title: Re: Bad Company 3
Post by: {KJ} on November 08, 2011, 09:01:14 AM
Perfect!  8)
Title: Re: Bad Company 3
Post by: Akyhne on December 11, 2011, 10:45:58 AM
This theme has been moved to my own theme site (read first post).
Title: Re: Bad Company 3
Post by: Rehash D Internet on July 04, 2012, 02:40:20 PM
Superb theme, but would it be possible to tell me how to remove the avatar on the main index?

Thanks
Title: Re: Bad Company 3
Post by: Akyhne on July 04, 2012, 03:49:27 PM
What avatar?
Title: Re: Bad Company 3
Post by: Biology Forums on July 04, 2012, 04:43:19 PM
Looks awesome
Title: Re: Bad Company 3
Post by: gmzeuner on October 18, 2012, 02:32:59 PM
Is there a way to fix the background so that only the posts float/scroll up or down?
Title: Re: Bad Company 3
Post by: Akyhne on October 19, 2012, 06:23:53 AM
Just add fixed to the background of the body tag.

Line #36 in index.css

Change
Code: [Select]
background: #000 url(../images/theme/backdrop.jpg) no-repeat 50% 0;
to
Code: [Select]
background: #000 url(../images/theme/backdrop.jpg) no-repeat fixed 50% 0;
Title: Re: Bad Company 3
Post by: gmzeuner on October 23, 2012, 06:53:03 AM
Thank you very much
Title: Re: Bad Company 3
Post by: CasperB on October 28, 2012, 08:19:54 PM
hello.

im using your theme... and i just uploaded a logo with URL but... the logo show over the user info at my site hdgaming . atspace . co . uk  do you have an idea ?
Title: Re: Bad Company 3
Post by: Akyhne on October 29, 2012, 01:03:50 AM
You are obviously using an image that is to large for the layout.

In index.css after #top_section, change the min-height to 100px:
Code: [Select]
#top_section {
    margin-bottom: 3px;
    min-height: 100px;
}
Title: Re: Bad Company 3
Post by: CasperB on October 29, 2012, 03:33:04 AM
where is that file located in the theme folder ?
Title: Re: Bad Company 3
Post by: Akyhne on October 29, 2012, 04:02:39 AM
bad company theme/css/index.css
Title: Re: Bad Company 3
Post by: CasperB on October 29, 2012, 04:59:41 AM
okay thanks for the help :) its looks okay now :)
Title: Re: Bad Company 3
Post by: Winguisax2 on March 07, 2013, 11:08:08 PM
Small bug in internet explorel and other internet browser member post new post and the new icon is missing
Title: Re: Bad Company 3
Post by: mntwins7 on May 30, 2013, 07:36:46 PM
I am REALLY hoping that someone will see this.

How do I make the board LESS transparent. It's a bit hard to read. Otherwise, I LOVE THIS THEME!
Title: Re: Bad Company 3
Post by: Deaks on May 30, 2013, 08:21:41 PM
ok upload this image images / Themes

Let me know if its too dark or light :)
Title: Re: Bad Company 3
Post by: Deaks on May 30, 2013, 08:30:09 PM
if you need it this is a bit darker
Title: Re: Bad Company 3
Post by: hellstorm77 on June 24, 2013, 11:07:43 AM
How would i change the category background color? what is the class name? (http://i.imgur.com/Er8kRfJ.png)
Title: Re: Bad Company 3
Post by: big red on February 16, 2020, 02:28:31 PM
Nice theme - Thank You!

  All members names in posts are in orange. I would like the color to retain what the membership group color is. Any help with this please?