Simple Machines Community Forum

SMF Support => Language Specific Support => Français (French) => Topic started by: ll_ll on July 25, 2011, 02:06:27 PM

Title: Diverses questions :)
Post by: ll_ll on July 25, 2011, 02:06:27 PM
Bonsoir,

1ere question :

Les modos ne peuvent pas utiliser la modification rapide sur les posts dont ils ne sont pas les auteurs, or ça le faisait bien sur le SMF 1.1.

2ème question :

Pour les karma sur le 1.1 on pouvait assigner un commentaire pour chaque karma, or sur celui qui est en natif sur le 2.0, on ne peut pas (où je n'ai pas vu comment l'activé)

3ème question :

L'onglet MODERER apporte quoi exactement aux modos?
Je n'arrive pas a activé la possibilité aux modos d'avertir les membres. (j'ai activé l'option mais ils ne l'ont tjs pas)

Merci d'avance
Title: Re: Diverses questions :)
Post by: maximus23 on July 25, 2011, 04:16:40 PM
Bonjour,
 
1 : Si voir question de permissions :)
 
2:  Aucune idée je ne vois pas ce que tu veux dire :)
 
3 : Pour avertir cliquer sur le membre et là utiliser envoyer un avertissement.
     Le centre de modération sert pour les avertissements, messages rapportés,
     Approbation de messages ou de membres, les adhésions etc ...
 
:)
Title: Re: Diverses questions :)
Post by: ll_ll on July 25, 2011, 04:24:32 PM
Bonjour,
 
1 : Si voir question de permissions :)
 
2:  Aucune idée je ne vois pas ce que tu veux dire :)
 
3 : Pour avertir cliquer sur le membre et là utiliser envoyer un avertissement.
     Le centre de modération sert pour les avertissements, messages rapportés,
     Approbation de messages ou de membres, les adhésions etc ...
 
:)
1 : Il fallait activé la "Modération de message" dans Options principales :)

2 : Sur la 1.1 en cliquant sur APPLAUDIR ou pouvait mettre un commentaire (ex : +1  Tu m'as bien aidé maxou)

3 : C'est bon j'ai trouvé, il fallait juste bien TOUT lire et activer la modération de message dans OPTIONS PRINCIPALES
Quote
Système d'Avertissement

Cette fonctionnalité permet aux administrateurs et modérateurs de donner des avertissements aux utilisateurs; cela inclut aussi des fonctionnalités avancées pour supprimer automatiquement les droits utilisateur proportionnellement au niveau d'avertissement. Notez que pour profiter pleinement de cette fonction, "Modération de message" doit être activé.

Title: Re: Diverses questions :)
Post by: maximus23 on July 25, 2011, 04:50:55 PM
Bonjour,
 
Pour le Karma tu peux voir ceci :
 
http://custom.simplemachines.org/mods/index.php?mod=1129 (http://custom.simplemachines.org/mods/index.php?mod=1129)
 
http://custom.simplemachines.org/mods/index.php?mod=192 (http://custom.simplemachines.org/mods/index.php?mod=192)
 
:)
 
Title: Re: Diverses questions :)
Post by: ll_ll on July 26, 2011, 01:17:21 AM
Bonjour,

Merci je pense installer le 2ème.
Title: Re: Diverses questions :)
Post by: ll_ll on July 28, 2011, 05:09:44 PM
Bonsoir,

J'ai activé comme indiqué plus haut la Modération de message et donc l'approbation des sujets/messages pour les nouveaux membres dans mon cas.

J'aimerai avoir une alerte d'un sujet/message d'approbation comme pour l'approbation d'une suppression de compte d'un membre sur l'index.template.php
Code: [Select]
// Are there any members waiting for approval?
if (!empty($context['unapproved_members']))
echo '
', $context['unapproved_members'] == 1 ? $txt['approve_thereis'] : $txt['approve_thereare'], ' <a href="', $scripturl, '?action=admin;area=viewmembers;sa=browse;type=approve">', $context['unapproved_members'] == 1 ? $txt['approve_member'] : $context['unapproved_members'] . ' ' . $txt['approve_members'], '</a> ', $txt['approve_members_waiting'], '';

J'ai essayé divers codes mais ça ne fonctionne pas :(
Ci-dessous un code que j'ai fait et qui me semble logique, après je pense qu'il y a des codes a ajouter dans d'autres fichiers mais je sais pas où ni lesquels
Code: [Select]
// Voir s'il y a des sujets et/ou posts à approuver

if (allowedTo('approve_posts') && $context['unapproved_posts'])

echo '
', $txt['unapprovedposts'], '';


Autre chose
Sur la 1.1 on avait apparemment le même mod "Karma Description" que pour la 2.0
http://custom.simplemachines.org/mods/index.php?mod=192
Sauf que je n'ai plus les descriptions (commentaires) avant la migration... mais j'ai le total des karmas. Bizarre ou c'est normal?

Merci d'avance
Title: Re: Diverses questions :)
Post by: maximus23 on July 28, 2011, 06:14:54 PM
Bonjour,
 
Pour l'approbation si ton thème est à jour il doit le mettre automatiquement :)
 
Pour le karma là aucune idée je ne l'utilise pas :)
 
 
Title: Re: Diverses questions :)
Post by: ll_ll on July 28, 2011, 06:28:20 PM
Bonjour,
 
Pour l'approbation si ton thème est à jour il doit le mettre automatiquement :)

Tu veux dire que sur le thème par défaut on le voit très bien?

Edit : Non c'est la même chose, sur la page d'accueil il y a juste ça à coté du board (!)

Or que je souhaite avoir une phrase comme pour l'approbation d'un compte membre (si possible)
Title: Re: Diverses questions :)
Post by: maximus23 on July 28, 2011, 06:34:59 PM
Bonjour,
 
Logiquement oui :)
 
 
Title: Re: Diverses questions :)
Post by: ll_ll on July 28, 2011, 06:36:02 PM
Bonjour,
 
Logiquement oui :)
Non c'est la même chose, sur la page d'accueil il y a juste ça à coté du board (!)

Or que je souhaite avoir une phrase comme pour l'approbation d'un compte membre (si possible)
Title: Re: Diverses questions :)
Post by: maximus23 on July 28, 2011, 07:40:18 PM
Bonsoir,
 
Voir ceci : http://custom.simplemachines.org/mods/index.php?action=search;basic_search=appr (http://custom.simplemachines.org/mods/index.php?action=search;basic_search=appr)
 
:)
 
 
Title: Re: Diverses questions :)
Post by: ll_ll on July 29, 2011, 05:04:47 AM
Bonjour,
Merci j'étais loin avec mon code ;D
Title: Re: Diverses questions :)
Post by: ll_ll on July 29, 2011, 09:55:53 AM
Bonsoir,
 
Voir ceci : http://custom.simplemachines.org/mods/index.php?action=search;basic_search=appr (http://custom.simplemachines.org/mods/index.php?action=search;basic_search=appr)
 
:)
Bon j'ai un souci,
J'ai installé ce mod http://custom.simplemachines.org/mods/index.php?mod=2952

Tout fonctionne sur mon forum test comme il faut.
Sur mon forum officiel (ce sont les mêmes fichiers modifiés) le texte 'total_unapproved_topics' n'apparait UNIQUEMENT quand je suis sur l'onglet MODÉRER et sur Messages non approuvés  ??? :-\

J'ai beau cherché je ne comprends pas :(
Title: Re: Diverses questions :)
Post by: maximus23 on July 29, 2011, 10:02:46 AM
Bonjour,
 
Revérifie ton codage et passe sur le thème par défaut pour voir :)
 
 
Title: Re: Diverses questions :)
Post by: ll_ll on July 29, 2011, 10:07:50 AM
Idem sur le thème par défaut :(

Je regarde un truc là
Title: Re: Diverses questions :)
Post by: ll_ll on July 29, 2011, 10:16:19 AM
Non je viens de refaire tous les codes et pareil sur les 2 thèmes

Edit : j'ai installé ce mod là http://custom.simplemachines.org/mods/index.php?mod=2909
Et le 1er MOD fonctionne bien maintenant :o

Truc de dingue
Title: Re: Diverses questions :)
Post by: maximus23 on July 29, 2011, 10:46:07 AM
Bonjour,
 
Regarde bien car tu dois avoir un conflit avec un autre mod. Tu as peut-être une recherche qui abouti mais le code de remplacement peut-être erronné si il ne remplace qu'un occurence car de ce fait il met la sienne et efface l'autre.
 
Regarde aussi ton journal d'erreurs :)
 
 
Title: Re: Diverses questions :)
Post by: ll_ll on July 29, 2011, 10:59:03 AM
Mon journal d'erreur pour lui tout est ok (enfin pour l'instant)

Le problème c'est que sur le fofotest il y a les mêmes mod que sur l'officiel.

C'est simple avant de mettre un MOD il passe en test sur le forumtest et ensuite copie des fichiers sur l'officiel.

Mais je ne vois pas comment voir s'il y a conflit entre 2 mod a part de les désinstaller un a un et voir celui qui pose problème.
Title: Re: Diverses questions :)
Post by: maximus23 on July 29, 2011, 11:51:51 AM
Bonsoir,
 
Pourquoi n'installes-tu pas un forum en local via wampserver et là tu sauras gérer tes mods via l'install auto et voir ce qui se passe quand tu as un problème de ce genre ? Cela ira très vite pour toi installer ou désintaller :)
 
 
Title: Re: Diverses questions :)
Post by: ll_ll on July 29, 2011, 12:03:16 PM
Bonsoir,
 
Pourquoi n'installes-tu pas un forum en local via wampserver et là tu sauras gérer tes mods via l'install auto et voir ce qui se passe quand tu as un problème de ce genre ? Cela ira très vite pour toi installer ou désintaller :)
Je ne suis pas assez caler pour faire ça, je suis dans le monde de Webmestre que depuis novembre dernier ;D
L'autre Webmaster qui s'est occupé de la migration, s'est faire cela et a fait un forum en local pour lui.

Mais comme le forum test, les mods fonctionnent bien je ne vois pas comment régler le problème :( (enfin s'il y a conflit, je ne le vois pas et tout fonctionne bien avec le 2ème MOD)
Title: Re: Diverses questions :)
Post by: maximus23 on July 29, 2011, 12:21:34 PM
Bonsoir,
 
C'est le truc le plus difficile à trouver mais bon si ton set de base fonctionne en mode test et que tout est identique là c'est un mystère de l'informatique :)
 
 
Title: Re: Diverses questions :)
Post by: ll_ll on July 30, 2011, 04:15:40 AM
Autre bug...

J'ai enfin installé la restriction d'e-mail
http://custom.simplemachines.org/mods/index.php?mod=1493

Sauf que je ne le vois pas dans Admin->Fonctionnalités et Options-> Réglages

ManageSettings OK
Subs-Members OK
Modificationsenglish OK
Modificationsfrench OK

Journal d'erreur Rien à signaler
Title: Re: Diverses questions :)
Post by: maximus23 on July 30, 2011, 04:34:02 AM
Bonjour,
 
C'est dans Options de Paquets :)
 
 
Title: Re: Diverses questions :)
Post by: ll_ll on July 30, 2011, 07:37:32 AM
Merci :)
Title: Re: Diverses questions :)
Post by: ll_ll on August 01, 2011, 05:38:03 PM
J'arrive pas a créé mon favicon >:(

Je l'ai fait via un générateur favicon http://www.favicon.cc/
Télécharger sur la racine de mon site (à la place de l'ancien) et je ne le voit tjs pas même en vidant mes cookies :-\
Title: Re: Diverses questions :)
Post by: maximus23 on August 01, 2011, 05:45:36 PM
Bonjour,
 
Vérifier pour mettre un format et une taille acceptée par tout les navigateurs.
 
Vérifier que le nom doit-être favicon.ico et se trouver à la racine du forum.
 
Bien vider le cache et cela devrait aller :)
 
 
Title: Re: Diverses questions :)
Post by: ll_ll on August 01, 2011, 06:03:39 PM
Hello

Format 16x16
Nom favicon.ico de 1ko

J'ai demandé aux membres si ca a changé pour eux...j'vais attendre les réponses
Title: Re: Diverses questions :)
Post by: maximus23 on August 01, 2011, 06:08:31 PM
Bonjour,
 
Tu dois bien vider ton cache pas tes cookies :)
 
 
Title: Re: Diverses questions :)
Post by: ll_ll on August 02, 2011, 01:16:29 AM
Ah c'est bcp mieux...du coup pas la peine d'avoir un générateur de favicon :)
Title: Re: Diverses questions :)
Post by: ll_ll on January 05, 2013, 05:50:57 AM
Bonjour :)

Dites moi sur certains forums on peut afficher le pseudo du membre qui visualise le post via cette balise {USERNAME}

Mais ça ne fontionne pas sur SMF, il y a t'il un MOD pour ça?
Je ne sais même pas comment chercher ça ici :P

Merci d'avance
Title: Re: Diverses questions :)
Post by: maximus23 on January 05, 2013, 06:32:32 AM
Bonjour,
 
Tu veux visualiser celà ou sur le forum ?
 
:)
Title: Re: Diverses questions :)
Post by: ll_ll on January 05, 2013, 06:55:02 AM
Par exemple :
Toi maximus tu regardes un fil d'un sujet.
Dans ma signature j'ai écris "Salut {USERNAME}..."

Toi tu vois "Salut maximus23..."

Alors sur SMF c'est peut être un autre code que {USERNAME} mais c'est le résultat qu'on me demande.
Title: Re: Diverses questions :)
Post by: ll_ll on January 09, 2013, 03:35:42 PM
Bonjour,

Pas possible alors?
Title: Re: Diverses questions :)
Post by: maximus23 on January 09, 2013, 07:34:51 PM
Bonsoir,
 
Il faut certainement ajouter un script dynamique style js mais pas d'idées pour le moment :)
 
 
Title: Re: Diverses questions :)
Post by: ll_ll on January 13, 2013, 02:56:15 AM
Bonjour,

Ok ce n'est vraiment pas grave. On peut oblier 8)

Merci