Simple Machines Community Forum

SMF Support => SMF 2.0.x Support => Topic started by: Mike72 on January 29, 2012, 12:04:52 PM

Title: Detailed Version Check
Post by: Mike72 on January 29, 2012, 12:04:52 PM
Hi guys,

My Default Templates seem to be the wrong version. Can someone explain to me how I can update it.

(http://i.imgur.com/jGw39.jpg)

Thanks
Title: Re: Detailed Version Check
Post by: hcfwesker on January 29, 2012, 12:09:34 PM
You possibly have a MOd installed that is outdated, not using 2.0.2 template files.  Click on the Default Templates title, and see which version is shows in red.

Oh, just tested and ran mine, seems its the PersonalMessage.template.php file.  not sure if yours is the same.

^ Heck, lol, the same pops up for a freshly installed SMF 2.0.2 forum.  strange  ???
Title: Re: Detailed Version Check
Post by: Mike72 on January 29, 2012, 12:12:39 PM
You possibly have a MOd installed that is outdated, not using 2.0.2 template files.

I have two mods that are 2.0.1
Never thought of that being the cause of it. Thank's for the fast reply.
Title: Re: Detailed Version Check
Post by: Mike72 on January 29, 2012, 12:13:35 PM
You possibly have a MOd installed that is outdated, not using 2.0.2 template files.  Click on the Default Templates title, and see which version is shows in red.

Oh, just tested and ran mine, seems its the PersonalMessage.template.php file.  not sure if yours is the same.

^ Heck, lol, the same pops up for a freshly installed SMF 2.0.2 forum.  strange  ???

That's what's showing on mine. "PersonalMessage.template.php'
Title: Re: Detailed Version Check
Post by: hcfwesker on January 29, 2012, 12:15:55 PM
Like I said, it even pops up on afreshly installed 2.0.2 forum.  so I'm sure its nothing to be too concerned about.  Still strange, though lol
Title: Re: Detailed Version Check
Post by: hcfwesker on January 29, 2012, 12:18:30 PM
Well, one fix is this.  Goto edit

PersonalMessage.template.php

at the very top

Find
Code: [Select]
* @version 2.0
Replace with
Code: [Select]
* @version 2.0.2
Title: Re: Detailed Version Check
Post by: Illori on January 29, 2012, 12:29:38 PM
no that is not the fix, that does not fix the issue which is on the SERVER here and not on any smf install. the team is aware of the issue and working on a fix, but that is not the fix as there are no changes to that file.
Title: Re: Detailed Version Check
Post by: hcfwesker on January 29, 2012, 12:45:55 PM
I understand it's not the permanent fix, but to at least remove the error when comparing current files, it makes it go away.  and some of us wont be bothered by it until hopefully the current version comes along with 2.0.3 or soemthing.
Title: Re: Detailed Version Check
Post by: Illori on January 29, 2012, 01:00:41 PM
well if the fix is made on the server then those that used your fix will then have a wrong version again. so it is not the right way to fix it.
Title: Re: Detailed Version Check
Post by: Storman™ on February 15, 2012, 06:31:04 AM
Any more news on this one, is this still outstanding ?
Title: Re: Detailed Version Check
Post by: Illori on February 15, 2012, 06:32:53 AM
yes this is still not resolved on the server side. if there are any changes it should be posted in one of the many threads on this issue.
Title: Re: Detailed Version Check
Post by: Storman™ on February 15, 2012, 06:12:02 PM
ok cheers
Title: Re: Detailed Version Check
Post by: Aleksi "Lex" Kilpinen on March 10, 2012, 05:45:41 AM
As far as I can tell - This should not be an issue at the moment. If your version check still looks like this, could you check out what files under "Default" show as outdated?
Title: Re: Detailed Version Check
Post by: Illori on March 10, 2012, 06:28:52 AM
lex, this is still an issue. norv does not really know how to fix this and would have to recode some of the js to fix it i believe as all "default" templates use the same version.
Title: Re: Detailed Version Check
Post by: Aleksi "Lex" Kilpinen on March 10, 2012, 06:32:10 AM
lex, this is still an issue. norv does not really know how to fix this and would have to recode some of the js to fix it i believe as all "default" templates use the same version.
Huh? What's the problem? 2.0.2 patch updated PersonalMessage.template.php so the file version should now be 2.0.2, and the current version my forum is showing from SM fetched info is 2.0.2.
I fail to see the problem.
Title: Re: Detailed Version Check
Post by: Illori on March 10, 2012, 06:33:59 AM
the default theme personalmessage.template.php file was not updated for version so it shows outdated, check the detailed version check.
Title: Re: Detailed Version Check
Post by: Aleksi "Lex" Kilpinen on March 10, 2012, 06:36:13 AM
So the problem was in the patch - not in the version check.
Title: Re: Detailed Version Check
Post by: Illori on March 10, 2012, 06:38:01 AM
no it is not a problem in the patch, the default theme did not change just the core theme and the js file that shows versions shows the same for all "default" themes.
Title: Re: Detailed Version Check
Post by: Aleksi "Lex" Kilpinen on March 10, 2012, 06:39:39 AM
Oh... Now I get it. Actually I should've spotted that, sorry.

But then the detailed version check simply doesn't work correctly, and really should be fixed somehow. But now I understand it may be harder than it seemed.
Title: Re: Detailed Version Check
Post by: Illori on March 10, 2012, 06:41:12 AM
yep, so it is a team issue to resolve not the users, and this has been brought to the teams attention, no idea when we will get it fixed though. should we mark this solved in the mean time?
Title: Re: Detailed Version Check
Post by: Aleksi "Lex" Kilpinen on March 10, 2012, 06:42:09 AM
Probably. It is a known issue, that can not be easily solved at the moment.