Simple Machines Community Forum

SMF Support => SMF 2.0.x Support => Topic started by: b00mer on February 22, 2012, 02:12:00 PM

Title: spell checker not working
Post by: b00mer on February 22, 2012, 02:12:00 PM
hi guys i`ve a few questions but i`ll get around to them one at a time if thats ok i dont want confussing as its to easilly done  :-[

the spell checker is no longer working on my forum and i`ve no idea why i`m currently using
SMF 2.0.2 with the theme
SMF Default Theme - curve

i`ve had a quick look into the files but not modified anything "spellcheck.js is listed if this helps

if there are files that need changing please be gentle with me

many thanks in advance
Title: Re: spell checker not working
Post by: Matthew K. on February 22, 2012, 02:23:32 PM
Hey there!

Are you sure you have the PHP extension configured?
Title: Re: spell checker not working
Post by: kat on February 22, 2012, 02:30:41 PM
confussing  easilly

Hmm... seems that ours has broken, too. ;)
Title: Re: spell checker not working
Post by: b00mer on February 22, 2012, 03:30:32 PM
Hey there!

Are you sure you have the PHP extension configured?

you may need to go into a bit more detail for me labradoodle  :-[
Title: Re: spell checker not working
Post by: Matthew K. on February 22, 2012, 03:40:27 PM
You need to have the PSpell PHP library configured.
Title: Re: spell checker not working
Post by: kat on February 22, 2012, 03:45:35 PM
For what it's worth, b00mer, Firefox, SeaMonkey and Opera have built-in spellcheckers.
Title: Re: spell checker not working
Post by: NanoSector on February 22, 2012, 03:46:22 PM
confussing  easilly

Hmm... seems that ours has broken, too. ;)
That's so cruel of you :o
(just joking ;))

You may need to ask your host instead, if they have the library configured, unless you are the host, ofcourse :P

For what it's worth, b00mer, Firefox, SeaMonkey and Opera have built-in spellcheckers.
Google Chrome, Safari and a few others have one, too.
Title: Re: spell checker not working
Post by: Matthew K. on February 22, 2012, 03:48:35 PM
Although Webkit's spellcheck doesn't seem to be nearly as complete as FireFox's.
Title: Re: spell checker not working
Post by: NanoSector on February 22, 2012, 03:49:36 PM
Although Webkit's spellcheck doesn't seem to be nearly as complete as FireFox's.
Not by far, really.

I was surprised as how Google Chrome didn't realize that I was typing in English so it was recognizing everything as Dutch...
I'm now using Opera and it's way better :)
Title: Re: spell checker not working
Post by: kat on February 22, 2012, 03:54:25 PM
That's so cruel of you :o

I was just joking, too. Hence the wink. :)

I'm no paragon of virtue, myself. ;)
Title: Re: spell checker not working
Post by: b00mer on February 22, 2012, 03:56:06 PM
there is a lot of my members asking why its suddenly not working

i`m just having a look to see if i can find my php files
Title: Re: spell checker not working
Post by: Matthew K. on February 22, 2012, 04:26:22 PM
PSpell wouldn't be in PHP files...you might want to contact your host and ask them to make sure the PSpell library is configured.
Title: Re: spell checker not working
Post by: kfoster17 on August 17, 2012, 12:10:55 PM
While this is an older thread I thought I'd throw in my 2 cents to maybe clear things up.

1. You must have aspell installed on your linux box (don't know about windows). aspell is the spell checker that is needed before you can go any further.

To check if you have it installed you can run
 
   rpm -q aspell-en  (or whatever language you are using other than -en)
 
Of course if you're not using CentOS/Redhat rpm use whatever package manager you use to find out if you even have aspell. If you don't have it then you must get it before proceeding.

2. Good. Now you have aspell installed. Is your php install setup to use it though? The php install must have pspell compiled in. Yes, pspell, not aspell. pspell is a php module that uses aspell.

Use the old trusty phpinfo() command to find out:

<?php
    phpinfo();
?>

Run phpinfo() and do a search for pspell on the output screen. If your search shows this:

 '--without-pspell'

Then you don't have pspell compiled into your php install. So either live without spellcheck or recompile php yourself unless you can find a package for your distro that does have pspell setup. And as mentioned earlier many browsers have a spellcheck anyhow.

If your search shows this:

 '--with-pspell'

Then you are in luck.

3. Next, while signed in to the forum as admin, click on Admin->Posts and Topics and see if spellcheck is enabled. If not click on it.

One last check you can perform is to double check your setup is to create a file which contains:

<?php
$pspell_link = pspell_new("en");
?>

And run it. If you get the error message:

Fatal error: Call to undefined function pspell_new() in /home/kfoster/spelltest.php on line 2

Then either pspell is not compiled in or something is screwy.

Title: Re: spell checker not working
Post by: Hawkmoth on July 23, 2013, 02:06:21 PM
I know this is an old thread but I thought it best to write this.

It seems Pspell is no longer supported/bundled with PHP 5.3

http://php.net/manual/en/book.pspell.php (http://php.net/manual/en/book.pspell.php)