Simple Machines Community Forum

SMF Support => Language Specific Support => Русский (Russian) => Topic started by: Grek.Kamchatka on August 30, 2005, 09:44:31 PM

Title: Как решить проблему?
Post by: Grek.Kamchatka on August 30, 2005, 09:44:31 PM
Всем привет!
Закончил свой первый мод, совместил его с package manager'ом, нужный мне код исполняется, файлы правятся, а вот новые файлы, которые отсутствуют в форуме, но присутствуют в моей модификации извлекаются в папку и почему-то(?????????) их размер равен нулю? Как быть? Что с этим делать? Смотрел подобные моды, где есть извлечение новых файлов, все абсолютно также делается, но в их модах файлы извлекаются нормально, а в моем случае они просто создаются на форуме пустыми и все... Дома думал что-то намудрил с правами в линуксе, пришел на работу, на винде тоже самое=(( Подскажите, что делать?
Title: Re: Как решить проблему?
Post by: Grek.Kamchatka on September 07, 2005, 07:44:32 PM
Сенкс, уже разобрался.
Title: Re: Как решить проблему?
Post by: Grek.Kamchatka on September 07, 2005, 09:22:52 PM
Возникла новая проблема((( Задолбался уже
Вобщем есть пакет (мод). Открываю его, делаю некоторое изменение в xml файле. Кто-нибудь вообще занимался такими делами? Я надеюсь что здесь есть такие... Так вот, в xml файле делаются изменения сначала для admin.php затем karma.php затем Boardindex.template.php и так далее. В том секторе, где делаются изменения для Boardindex.template.php я меняю всего дно слово, например search="before" на search="after". Дальше все сохраняю, пакую и пытаюсь поставить на форум. После закачки и нажатия на "применить мод" выдает ошибку, якобы не может внести изменения в admin.php и в karma.php! Спрашивается... причем тут эти файлы, если изменения делаются в другом и эти файлы даже не затрагиваются((( Имеется ввиду в xml файле...