Simple Machines Community Forum

SMF Support => Language Specific Support => Русский (Russian) => Topic started by: Айронсофт on May 24, 2012, 10:23:59 AM

Title: Не устанавливаются/удаляются пакеты модификаций
Post by: Айронсофт on May 24, 2012, 10:23:59 AM
Здравствуйте.
У меня на форуме вдруг перестали устанавливаться и удаляться пакеты модификаций, хотя я по-прежнему могу их загружать. При попытке установки или удаления отображается пустая белая страница. В чём проблема и как её решить?
И, если можете, выложите в теме "здоровые" файлы, отвечающие за установку и удаление пакетов модификаций.
Title: Re: Не устанавливаются/удаляются пакеты модификаций
Post by: maestrosite.ru on May 24, 2012, 10:43:54 AM
Смотрите логи ошибок сервера. Ключевые слова fatal и error
Title: Re: Не устанавливаются/удаляются пакеты модификаций
Post by: Айронсофт on May 25, 2012, 05:24:05 AM
Смотрел. Пишет "Записей не найдено".
Title: Re: Не устанавливаются/удаляются пакеты модификаций
Post by: maestrosite.ru on May 25, 2012, 05:29:54 AM
Смотрел. Пишет "Записей не найдено".
возможно:
1. Стало быть имеет место волшебство.

но более вероятно:
2. Такая надпись имеет место быть в админке форума. А надо смотреть логи сервера, то есть apache. Часто именуется error_log
Title: Решение
Post by: Айронсофт on June 10, 2012, 05:17:37 AM
Заменил в папке Source следующие файлы на те же самые файлы из установочного пакета: PackageGet.php, Packages.php и Subs-Package.php. Теперь всё работает.
Title: Re: Не устанавливаются/удаляются пакеты модификаций
Post by: deminua on May 22, 2013, 05:03:40 AM
Такая же проблема и у меня, не знаю что делать и файлы менял - не помогло.

Грешу на open_basedir

Local есть
Master no value
Title: Re: Не устанавливаются/удаляются пакеты модификаций
Post by: igod on May 28, 2013, 10:04:44 AM
И у меня появился данный глюк.
Токо при всем при этом еще когда заходиш в Менеджер пакетов тоже бросает белый экран.
Докопался что затык появляется на коде
Code: [Select]
// Get the package info...
$packageInfo = getPackageInfo($context['filename']);
в файле Packages.php, а именно когда идет вызов из Subs-Package.php
Code: [Select]
// Parse package-info.xml into an xmlArray.
loadClassFile('Class-Package.php');
$packageInfo = new xmlArray($packageInfo);
я так понимаю здесь происходит парсинг xml, но почему раньше все работало, а сейчас глючит незнаю, никаких обновлений не ставил.  :-\
Title: Re: Не устанавливаются/удаляются пакеты модификаций
Post by: Chip.and.Dale on July 07, 2013, 06:36:20 PM
Аналогичная проблема:(((Мод загружается, но потом белая страница и все. Ничего не помагает.
Title: Re: Не устанавливаются/удаляются пакеты модификаций
Post by: inter on July 24, 2013, 01:55:09 AM
если белая страница, то смотрите лог ошибок апача