Simple Machines Community Forum

SMF Development => Bug Reports => Topic started by: infabo on July 09, 2012, 02:29:44 AM

Title: Search malfunction - applies to 1.1.x and 2.x
Post by: infabo on July 09, 2012, 02:29:44 AM
Hello!

I'll try to explain it, so you can reproduce it yourself.
For example, I have a topic "xyz" where user "max" has posted 4 messages. In three of these messages he has used the word "manual". Okay.

I go to the search function and I only check the sub-board where the topic is located and say "search for: manual", "By user: max", "show results as messages".

As result I would expect all 3 messages where the user max has written the word "manual" in the topic "xyz".
But what happens instead? Only one matching result! Bug!

For a realtime example:
http://www.simplemachines.org/community/index.php?topic=481163.msg3368462

"Trekkie101" writes "features" in the first and the second post.
Do a search:
"Search for: features"
"By user: Trekkie101"
"Show results as messages"
Choose only "SMF Documentation Help"

See what I mean? It seems that only the first match gets into the results.
This bug applies to 1.1.x too. Thanks
Title: Re: Search malfunction - applies to 1.1.x and 2.x
Post by: Arantor on July 09, 2012, 11:02:32 AM
I seem to recall it groups search results by topic to avoid giving you many many more results than you might actually want, and IIRC it is done that way by design, not accidentally as a bug.

Whether that's right or not is another matter.
Title: Re: Search malfunction - applies to 1.1.x and 2.x
Post by: imno007 on July 11, 2012, 01:29:33 PM
infabo, I posted a topic here that might be related to what you're experiencing:

http://www.simplemachines.org/community/index.php?topic=481240.0

No acknowledgement yet of a known problem, but time will tell....
Title: Re: Search malfunction - applies to 1.1.x and 2.x
Post by: Gwenwyfar on July 22, 2018, 08:49:49 AM
No longer happens in 2.1 with advanced search and results as messages view, but still does in quick search. Maybe the problem here now is that there is no clear difference in the results from view results as messages on or off. They both look exactly the same and you don't know which it is using.

Related to this report (https://www.simplemachines.org/community/index.php?topic=526045.0).