Simple Machines Community Forum

SMF Support => SMF 2.0.x Support => Topic started by: revail on August 26, 2012, 05:59:31 PM

Title: Installing mod error
Post by: revail on August 26, 2012, 05:59:31 PM
Hello guys..
I have a problem installing mods on my forum
when im going to install a mod i have this error
"You cannot download or install new packages because the Packages directory or one of the files in it are not writable!"

Does anyone know why i get this error??
If someone know and know how i can solve it plzz reply me :)
Title: Re: Installing mod error
Post by: Kays on August 26, 2012, 06:06:43 PM
Hi, welcome to SMF. :)

In the Packages folder, create a new folder named temp and chmod it to 777. That should fix that.

I hope. ???
Title: Re: Installing mod error
Post by: revail on August 26, 2012, 06:09:29 PM
when you are telling chmod it to 777 what you mean exactly to do?
im new and i dont everything well...:P
i didnt understand
Title: Re: Installing mod error
Post by: Kays on August 26, 2012, 06:14:12 PM
How do I use FTP? / What is FTP? (http://wiki.simplemachines.org/smf/How_do_I_use_FTP)
How do I chmod? / what is chmod? (http://wiki.simplemachines.org/smf/What_is_chmod)

If you're using a site manager, try just creating the temp folder and see it that helps. If not then you might need to chmod it.
Title: Re: Installing mod error
Post by: revail on August 26, 2012, 06:23:31 PM
i cant do it :/
you can help me with skype or teamviewer?
Title: Re: Installing mod error
Post by: Kays on August 26, 2012, 06:25:20 PM
Why can't you do it? ???
Title: Re: Installing mod error
Post by: revail on August 26, 2012, 06:27:30 PM
i cant understand exactly what i must do :/
Title: Re: Installing mod error
Post by: Kays on August 26, 2012, 06:45:28 PM
OK, let's start from the beginning. How did you install your forum?

If it was with an installer in your site control panel. Then somewhere in that control panel is a file manager which allows you to browse through the files on you site. Browse to folder your forum is installed in and then to the packages folder. There should be an option there to create a new folder.

The other method is to use an FTP client such as FileZilla. There should be more details on how to use one in the link I posted previously.
Title: Re: Installing mod error
Post by: revail on August 26, 2012, 06:46:51 PM
a friend has installed my forum..
but i have username and password and i can browse the files with filezilla
Title: Re: Installing mod error
Post by: revail on August 26, 2012, 06:53:34 PM
i must go to forum folders?
then to the package folder and creater there a forlder named temp..and then inside in this folder named temp
i must make a text named chmod 777?
Title: Re: Installing mod error
Post by: Kays on August 26, 2012, 06:59:15 PM
OK, then. Just browse to the Packages folder and open it. Then right click and select create directory. When that is done to check or change permission. Again right click and select File permissions. Basically, the permissions on the temp folder should be the same as the permissions of the other folders in your forum root.
Title: Re: Installing mod error
Post by: revail on August 26, 2012, 07:05:58 PM
i made it..!!!!!!!
Thank you my friendddddddddd :********* :D :D
Title: Re: Installing mod error
Post by: Kays on August 26, 2012, 07:09:37 PM
Great, it wasn't that difficult to do was it. :)

Marked as solved.
Title: Re: Installing mod error
Post by: revail on August 26, 2012, 07:10:32 PM
yeah finally it wasnt so difficult :D
Title: Re: Installing mod error
Post by: Kays on August 26, 2012, 07:26:12 PM
Forgot to ask. Are you able to install your mod now? ???
Title: Re: Installing mod error
Post by: revail on August 26, 2012, 07:29:55 PM
yes i was installed the mods that i want.. :P
but this mod i installed it but i cant find from where i can active it on the forum...
http://custom.simplemachines.org/mods/index.php?mod=3067 (http://custom.simplemachines.org/mods/index.php?mod=3067)
in my wamp server that i have for tests when i installed this mod i activated it forum modifications>miscalenious
but now on the live forum i cant find any option there or anywere else :P
Title: Re: Installing mod error
Post by: Kays on August 26, 2012, 07:37:29 PM
It should be in the same place.

This mod uses hooks, can you verify that there's a file named "Subs-SimpleColorizer.php" in the Sources directory?

I wonder if it didn't get copied over.
Title: Re: Installing mod error
Post by: revail on August 26, 2012, 07:41:15 PM
I look there but its not there :/
yy it have a file named "Subs-SimpleColorizer.php"
Title: Re: Installing mod error
Post by: Kays on August 26, 2012, 07:49:50 PM
If the file is there. Then the best place to start looking for answers is the support thread for that mod,

http://www.simplemachines.org/community/index.php?topic=439878.0
Title: Re: Installing mod error
Post by: revail on August 27, 2012, 06:23:53 AM
@Kays i go to install new mod but i get again the same error..
i must make again new folder and chmod it?

ok this fixed the temp folder was deleted it..
Title: Re: Installing mod error
Post by: revail on August 27, 2012, 06:50:22 AM
another problem is that if i install any mod it doesnt work...
Title: Re: Installing mod error
Post by: Kays on August 27, 2012, 08:53:13 AM
Unfortunately, that's normal.

What's suppose to happen is the SMF creates that folder to use to unpack the mod. After it's done the folder gets deleted. But due to some configuration in your server, SMF is unable to create that temp folder. But it can still delete it.
Title: Re: Installing mod error
Post by: revail on August 27, 2012, 09:09:47 AM
hmmm this is not good :/

but why the mod cant work?
Title: Re: Installing mod error
Post by: Kays on August 27, 2012, 09:12:32 AM
Is this for the one mod or do you have the same problem with other mods?
Title: Re: Installing mod error
Post by: revail on August 27, 2012, 09:15:58 AM
i have the some problem with all the mods that i installed
Title: Re: Installing mod error
Post by: Kays on August 27, 2012, 09:38:47 AM
Do they install fine on your local server?

Who are you hosted with?
Title: Re: Installing mod error
Post by: revail on August 27, 2012, 09:46:06 AM
in my local server they are absolutely fine and works well..


in my friend host server :)
Title: Re: Installing mod error
Post by: Kays on August 27, 2012, 09:53:12 AM
Then, I would suggest that you get him to look into this problem.

Since something ain't quite right there and he's the most qualified person to look into this.
Title: Re: Installing mod error
Post by: revail on August 27, 2012, 10:03:37 AM
ok i will tell him to look it..

but in the Administrator>package manager>file permissions all the files are "writable" except "sources" that are all the files in this folder is "Not Writable"


Maybe this is the problem and the mods cant work?
Title: Re: Installing mod error
Post by: Kays on August 27, 2012, 10:23:27 AM
It could be. Try making it writable. Use the FTP client and set the permissions to be the same as the other folders.
Title: Re: Installing mod error
Post by: revail on August 27, 2012, 10:42:50 AM
i try it but nothing they dont change :/
i make them 777 and i open them again tey are 645
Title: Re: Installing mod error
Post by: Kays on August 27, 2012, 11:15:46 AM
Hmm, defiantly contact your friend about this. Things won't work properly if the Sources folder is unwritable.
Title: Re: Installing mod error
Post by: revail on August 27, 2012, 11:17:03 AM
ok...

if i reinstall the forum all will be ok?or i will again this problem/
Title: Re: Installing mod error
Post by: Kays on August 27, 2012, 11:21:11 AM
It does look to me like there's a permissions or ownership problem with that folder.

Rather than re-installing. rename it and then re-upload the Sources folder from the install package.
Title: Re: Installing mod error
Post by: revail on August 27, 2012, 11:27:52 AM
you tell me to rename the folder and then re-upload the sources in the same folder e?:P
Title: Re: Installing mod error
Post by: Kays on August 27, 2012, 11:37:33 AM
It's worth a try. :)
Title: Re: Installing mod error
Post by: revail on August 27, 2012, 11:42:35 AM
i must re-upload the sources in the same folder that are now??

just change the name of the folder?

Title: Re: Installing mod error
Post by: Kays on August 27, 2012, 11:47:39 AM
No, the idea is to replace the existing Sources folder with a fresh one. In order to do that the original folder needs to be renamed to something other than "Sources".
Title: Re: Installing mod error
Post by: revail on August 27, 2012, 11:55:33 AM
when you tell fresh one...?
you mean to take the "sources" folder from the smf 2.0.2 version .zip?

or to copy the "sources" folder that i have already install in the forum and just re-upload it? :P


sorry for the many questions :)
Title: Re: Installing mod error
Post by: Kays on August 27, 2012, 01:29:50 PM
Option 1. :P

Since there seems to be a problem with the current folder. Rename it so it's not being used by SMF and then re-upload the Sources folder from the 2.0.2 install package. If you don't have a copy you can download it from here

http://download.simplemachines.org/
Title: Re: Installing mod error
Post by: revail on August 27, 2012, 05:58:08 PM
Ahhh thank you man!!a lot!!!!! :P
it works now all files are writable and all mods works...
(the old folder sources that renamed i can delete it?)

the temp folder that chmod it to 777 will be deleted every day?and i must make it again?
Title: Re: Installing mod error
Post by: revail on August 28, 2012, 06:40:45 AM
man i go to install new mod again..

i installed it succesfully but is not working again while all files are writable...

maybe want again to re-upload the "sources" folder?
Title: Re: Installing mod error
Post by: MrPhil on August 28, 2012, 09:52:59 AM
the temp folder that chmod it to 777 will be deleted every day?and i must make it again?

SMF will not delete the folder, but your host might be deleting it because it's a security hazard (world writable). You never make a directory 777 until you have tried 755 and then 775 without success.
Title: Re: Installing mod error
Post by: revail on August 28, 2012, 09:56:57 AM
ok my friend...

Do you know why mods are not working while they have been installed succesfully without any error??
Title: Re: Installing mod error
Post by: Kays on August 29, 2012, 08:54:39 AM
You're best to contact your friend about the problem with the mods. If they work fine for most people and on your local sever. Then it's probably a server related problem and there's not much we can do about that.
Title: Re: Installing mod error
Post by: revail on August 29, 2012, 09:28:37 AM
ok my friend :)

thank you for the help
Question:but why the simplecolorizer mod works?cause is with hook?
Title: Re: Installing mod error
Post by: Kays on August 29, 2012, 10:15:32 AM
Probably. When hooks are used there's can be no file edits. At least in the case of this one there aren't any.
Title: Re: Installing mod error
Post by: dkpeppard on December 20, 2012, 01:39:45 PM
Hi, welcome to SMF. :)

In the Packages folder, create a new folder named temp and chmod it to 777. That should fix that.

I hope. ???

I did this for the recent 2.0.3 security patch and it fixed my "You cannot download or install new packages because the Packages directory or one of the files in it are not writable!" error.  I was able to successfully install the patch after following Kays' instructions of creating the 'temp' folder, and CHMOD to 777.

Hope this helps others.