Simple Machines Community Forum

SMF Support => Language Specific Support => Magyar (Hungarian) => Topic started by: rumosdio on December 31, 2012, 08:23:02 AM

Title: 2.0.3 frissítési hiba!
Post by: rumosdio on December 31, 2012, 08:23:02 AM
sziasztok!

Szeretnék felrakni egy újabb kiegészítő csomagot és a következő hiba üzenet jött:

Code: [Select]
Table 'smf.members' doesn't exist
Fájl: C:\xampp\htdocs\smf\Packages\temp\2b3-dbmodify.php
Sor: 19

Megjegyzés: Úgy tűnik az adatbázisodnak szüksége lehet frissítésre. A fórumod fájljainak jelenlegi verziója SMF 2.0.3, míg az adatbázis verziója 2.0.2. A fenti hiba talán eltűnik, ha lefuttatod a legutóbbi verzió upgrade.php fájlját.

Hogy lehet megoldani, hogy az adatbázisban is a 2.0.3-as verzió szerepeljen?
Title: Re: 2.0.3 frissítési hiba!
Post by: novill on January 02, 2013, 04:22:13 PM
Ha letöltöd az adatbázisodat és megnyitod a notepad++ programmal és rákeressel a 2.0.2 kifejezésre akkor láthatod melyek azok a részek melyeket nem módosította. Ha hiba nélkül futott le a frissítés a 2.0.3 -ra akkor az adatbázisban az említett részeket Írd át nyugodtan 2.0.2 - ről 2.0.3 -ra tömörítsd vissza az adatbázist és töltsd fel újra. Utána mennie kell a frissítésnek.  ;)
Title: Re: 2.0.3 frissítési hiba!
Post by: rumosdio on January 02, 2013, 04:42:25 PM
Ha letöltöd az adatbázisodat és megnyitod a notepad++ programmal és rákeressel a 2.0.2 kifejezésre akkor láthatod melyek azok a részek melyeket nem módosította. Ha hiba nélkül futott le a frissítés a 2.0.3 -ra akkor az adatbázisban az említett részeket Írd át nyugodtan 2.0.2 - ről 2.0.3 -ra tömörítsd vissza az adatbázist és töltsd fel újra. Utána mennie kell a frissítésnek.  ;)

Kaptam egy fülest, hogy kb 1-2 hónap és kijön az alap 2.0.3 motor, és nem csak frissítésben.

Azt lehet, hogy még megvárom, max ha nagyon unatkozok akkor nyúlok bele az adatbázisban, meg még az is lehet, hogy nem csak ebben fog eltérni az alap 2.0.3-as motor adatbázis szinten aztán nem akarom elrontani az adatbázist.
Title: Re: 2.0.3 frissítési hiba!
Post by: novill on January 02, 2013, 04:51:33 PM
Kitől kaptál ilyen fülest?  :o

Csak azért kérdezzem, mert én rendszeresen olvasom ezt a fórumot. Itt mindig szó van a fejlesztésekről is. A legutóbbi frissítés is biztonsági volt. Most is letöltheted a telepítő mely tartalmazza ezt.

http://download.simplemachines.org/

Amúgy a 2.0.3 - 2.0.99 verzióig csak hibajavítás vagy biztonsági hibák javítása jön ki.
Title: Re: 2.0.3 frissítési hiba!
Post by: rumosdio on January 02, 2013, 04:59:47 PM
Lehet, hogy erre gondolt akitől hallottam.

De ha már így letölthető ez a motor, h alapból 2.0.3 akkor lehet, hogy ott már ki van javítva az a hiba amit írtam.

Mert az a hiba a csomagkezelőn telepítésre került frissítés után jön elő.
Title: Re: 2.0.3 frissítési hiba!
Post by: novill on January 02, 2013, 05:06:45 PM
Akkor annak valamilyen oka van, lehet egy régebbi frissítés nem volt sikeres. Ezért is javasolják ilyenkor a nagy frissítő csomag futtatását. Igaz ez mindent alapra állít vissza és telepítheted a modokat újra.
Ha nem nagy a probléma egyszerűbb az adatbázisban átírni.
Title: Re: 2.0.3 frissítési hiba!
Post by: rumosdio on January 02, 2013, 05:16:43 PM
localhost-on letesztelem a 2.0.3-as motort, hogy azon megy e a csomag.

Ha esetleg menne, akkor kitalálom, hogy akarok e vele dolgozni vagy sem :)