Simple Machines Community Forum

SMF Support => Language Specific Support => Italiano (Italian) => Topic started by: Alex_Ita on January 10, 2013, 06:34:55 AM

Title: immagini linkabili
Post by: Alex_Ita on January 10, 2013, 06:34:55 AM
Ed ora veniamo alla mia seconda richiesta:

nonostante abbia chiamato in causa ogni genere di bbode e codice html, non riesco ad ottenere in un post un'immagine che sia collegata ad un link.

A titolo di esempio vi riporto un bbcode per riuscire a spiegarmi meglio ciò che vorrei ottenere:

[url=http://www.linkdelsito.xxx][img]http://www.linkdellimmagine.xxx/nomefile.jpg[/img][/url]
Title: Re: immagini linkabili
Post by: emanuele on January 10, 2013, 08:21:12 AM
mmm...non son sicuro di aver capito.

Quindi tu vorresti che quando qualcuno posta un'immagine con il bbc img questa venga automaticamente linkata a qualcosa?
Oppure semplicemente un bbcode non funziona?
Title: Re: immagini linkabili
Post by: Alex_Ita on January 10, 2013, 08:49:08 AM
provo a spiegarmi meglio.


Quote from: emanuele on January 10, 2013, 08:21:12 AM
Quindi tu vorresti che quando qualcuno posta un'immagine con il bbc img questa venga automaticamente linkata a qualcosa?

No.

Vorrei avere la possibilità di fare in modo che un'immagine compresa tra i  tag img possa essere cliccabile, e che quindi porti verso un link a scelta.
Ovvero ciò che in html si otterrebbe con un codice del genere:
<a href="esempio.htm"><img src="esempio.jpg"></a>

Quote from: emanuele on January 10, 2013, 08:21:12 AM
Oppure semplicemente un bbcode non funziona?

Tra le plugin presenti in rete, trovai anche un bbcode che in automatico scriveva quanto da me richiesto (vedi il codice nel mio primo post), tuttavia il risultato non era quello sperato in quanto l'immagine tra i tag img non veniva riconosciuta, il link tra i tag url invece funziova correttamente mostrando però ovviamente il link testuale.

Un esempio di un'immagine con link puoi vederlo a questo indirizzo
http://www.echoecho.com/htmllinks06.htm (http://www.echoecho.com/htmllinks06.htm)

Grazie per la collaborazione  :)
Title: Re: immagini linkabili
Post by: emanuele on January 10, 2013, 10:53:48 AM
mmm...quindi così?
(http://www.simplemachines.org/community/index.php?topic=494673.msg3468249#msg3468249)

[url=http://www.simplemachines.org/community/index.php?topic=494673.msg3468249#msg3468249][img]http://avatars.simplemachinesweb.com/smf/avatar_193241_1352794021.png[/img][/url]

Che poi non è altro che il bbcode che hai postato all'inizio...è questo che non mi torna... :)

Ma di preciso *dove* vuoi quest'immagine? Nei post o da qualche parte nel template?
Perché se fosse nel template allora dovresti usare un po' di html:
<a href="http://quelchevuoi.it/"><img src="http://linkallimmagine.it/immagine.png" /></a>
Title: Re: immagini linkabili
Post by: Alex_Ita on January 11, 2013, 03:28:05 AM
Quote from: emanuele on January 10, 2013, 10:53:48 AM
mmm...quindi così?
(http://www.simplemachines.org/community/index.php?topic=494673.msg3468249#msg3468249)



Bingo!

E' proprio quello che vorrei ottenere ma sul mio forum questo non accade. Inserendo il bbcode così come lo hai scritto, mi viene restituito il link testuale e il tag img viene ignorato.
Title: Re: immagini linkabili
Post by: emanuele on January 11, 2013, 03:43:47 AM
??? ...
Immagini da sole e link da soli funzionano?
Title: Re: immagini linkabili
Post by: Alex_Ita on January 11, 2013, 03:55:36 AM
perfettamente.
Title: Re: immagini linkabili
Post by: emanuele on January 11, 2013, 04:22:24 AM
Mod installati?
Title: Re: immagini linkabili
Post by: Alex_Ita on January 11, 2013, 05:24:17 AM
fra le decine e decine di quelle installate, mi sta ricadendo il sospetto su questa:
Show Local Url Titles.

La 1293 della sezione custum di questo portale.
Title: Re: immagini linkabili
Post by: emanuele on January 11, 2013, 05:31:00 AM
mmm...in effetti potrebbe essere un buon candidato.
Title: Re: immagini linkabili
Post by: Alex_Ita on January 12, 2013, 08:26:09 AM
Era proprio quella! Dannata!

Una volta disinstalla la mod di cui abbiamo parlato, hanno ripreso a funzionare correttamente i tag img contenuti nei tag url.

Problema risolto.