Simple Machines Community Forum

SMF Support => SMF 2.0.x Support => Topic started by: Fenz0 on March 29, 2013, 02:38:48 PM

Title: [SMF MOD INSTALL] Need to login again.
Post by: Fenz0 on March 29, 2013, 02:38:48 PM
Hello guys!,

Everytime i try to install mods like dreamportal or SMFStaff etc, I need to login again and when i login no mod is installed and it keeps on going like that.

PLEASE HELP!!! :(


Sorry for bad english :(
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Suki on March 29, 2013, 02:43:23 PM
Welcome to SMF.

There is no need for a poll.

SMF ask you to enter your password as a security measure, you just need to enter your password every once in a while, after you entered it, you  still need to actually install the mod: Package Manager (http://wiki.simplemachines.org/smf/Packages)
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Kindred on March 29, 2013, 03:14:36 PM
hmm... actually, Suki, a few people have been complaining about this.   Their SMF is not behaving normally...   it keeps asking for the login in the admin and never completes the action.

Fenz0,

poll removed.
What smf version?
what is your setting for:
local cookies?
subdomain independent cookies?
database driven sessions?

What is your forum URL in the server settings?
What URL are you using to access your forum (specifically, does one of those answers have a www. and the other not have the www?)

Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Fenz0 on March 29, 2013, 04:23:13 PM
Quote from: Kindred on March 29, 2013, 03:14:36 PM
hmm... actually, Suki, a few people have been complaining about this.   Their SMF is not behaving normally...   it keeps asking for the login in the admin and never completes the action.

Fenz0,

poll removed.
What smf version?
what is your setting for:
local cookies?
subdomain independent cookies?
database driven sessions?

What is your forum URL in the server settings?
What URL are you using to access your forum (specifically, does one of those answers have a www. and the other not have the www?)

Version: 2.0.4
Local cookies?: Yes.
Subdomain independent cookies?: No.
Database driven sessions?: Yes.
Url: www.Verygaming.se
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Fenz0 on March 30, 2013, 04:51:43 AM
*Bump*
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Herman's Mixen on March 30, 2013, 04:59:51 AM
Can only recall the FTP login when installing mods when the permissions on folders and files are not set properly !!

chmod 750 your root folder /public_html or /httpdocs depends on your hosting panel (Cpanel / Plesk / DA )
chmod 755 all files and folders underneath

try again afterwards
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Fenz0 on March 30, 2013, 07:09:26 AM
Quote from: The Burglar! on March 30, 2013, 04:59:51 AM
Can only recall the FTP login when installing mods when the permissions on folders and files are not set properly !!

chmod 750 your root folder /public_html or /httpdocs depends on your hosting panel (Cpanel / Plesk / DA )
chmod 755 all files and folders underneath

try again afterwards

didnt work
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Fenz0 on March 30, 2013, 10:37:44 AM
*Bump* Beacuse problem not solved
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Chalky on March 30, 2013, 11:03:57 AM
Hi Fenz0, just so you know, there's a rule here not to bump posts within less than 24 hours.  This is because everybody here is a volunteer and provides support in their own time in between work, family, real life, etc.  The people who can help you may well be either at work or asleep right now, so please be patient and somebody will be along to help you when they are available.

Also, please try to help us to help you by providing as much detail as possible.  Replying "didnt work" doesn't help anybody.
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Herman's Mixen on March 30, 2013, 11:10:13 AM
You also can make an screen-shot of the page showing the error you get, if you can not describe it well
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Fenz0 on March 31, 2013, 03:31:57 PM
Screenshot:http://gyazo.com/f46ae2b6aaf154d9e2fe8f11f31d4b10.png?1364758267
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Chalky on March 31, 2013, 03:35:01 PM
Can you upload the image as an attachment here?  Lots of us are wary of following unfamiliar links.
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Fenz0 on March 31, 2013, 03:54:15 PM
(http://gyazo.com/f46ae2b6aaf154d9e2fe8f11f31d4b10.png?1364758267)
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Kindred on March 31, 2013, 03:58:20 PM
right...


So this is what I explained in my first response.

It's not an error message.
Basically, the session is not being preserved and thus is requiring a new login for every action, even without resolving the previous action.

Cookie settings and session setting are the two main causes for this

it is not an FTP thing
it is not a chmod thing.
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Fenz0 on March 31, 2013, 03:59:51 PM
I need to login again yes.

But what settings do i need to use?

Edit: I dont need to write username or password i just click on the login in button then im in.
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Kindred on March 31, 2013, 04:03:17 PM
in which case you system is even more screwed up than it looks...
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Fenz0 on March 31, 2013, 04:06:53 PM
I know


And i really need help fast!

Edit: (http://gyazo.com/f6da5b018a16a2cafcc91ef3696592d4.png?1364760481)
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Kindred on March 31, 2013, 04:23:16 PM
well, that explains it...

you either need local cookies OR subdomain independent cookies.
having BOTH unchecked is causing your problem.
I'd suggest using subdomain independent cookies, unless your server is using zeus.
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Fenz0 on March 31, 2013, 04:39:43 PM
Quote from: Kindred on March 31, 2013, 04:23:16 PM
well, that explains it...

you either need local cookies OR subdomain independent cookies.
having BOTH unchecked is causing your problem.
I'd suggest using subdomain independent cookies, unless your server is using zeus.

Have tested both and it aint works
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Chalky on March 31, 2013, 07:24:04 PM
Quote from: Sabrinova on March 30, 2013, 11:03:57 AM
Hi Fenz0, just so you know, there's a rule here not to bump posts within less than 24 hours.  This is because everybody here is a volunteer and provides support in their own time in between work, family, real life, etc.  The people who can help you may well be either at work or asleep right now, so please be patient and somebody will be along to help you when they are available.

Also, please try to help us to help you by providing as much detail as possible.  Replying "didnt work" doesn't help anybody.
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Fenz0 on March 31, 2013, 07:28:44 PM
Quote from: Sabrinova on March 31, 2013, 07:24:04 PM
Quote from: Sabrinova on March 30, 2013, 11:03:57 AM
Hi Fenz0, just so you know, there's a rule here not to bump posts within less than 24 hours.  This is because everybody here is a volunteer and provides support in their own time in between work, family, real life, etc.  The people who can help you may well be either at work or asleep right now, so please be patient and somebody will be along to help you when they are available.

Also, please try to help us to help you by providing as much detail as possible.  Replying "didnt work" doesn't help anybody.


Oh , sorry... but i really need help
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Chalky on March 31, 2013, 07:39:49 PM
Have you checked the box for "subdomain independent cookies" as Kindred suggested?  What was the result?  If it didn't work, please explain, did the forum continue to log you out?
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Kindred on March 31, 2013, 07:44:18 PM
Fenz0,

you have already been told. DO NOT BUMP YOUR POSTS.

So, you set subdomain independent cookies to CHECKED and you left Local cookies UNCHECKED
and then you cleared your browser's stored cookies and cache?
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Fenz0 on March 31, 2013, 07:54:04 PM
Still not working ;(
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Kindred on March 31, 2013, 10:57:31 PM
well, "not working" is hardly a useful description.

However, if you ACTUALLY meant "It is still doing the same behavior"
then I have no idea.  My only suggestion is that you try installing a second forum on the same host in a different directory and see if it also acts the same.

(hmmmm... just occurred to me: How did you install the forum in the first place?)
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Fenz0 on April 02, 2013, 12:35:55 PM
its still the same :(
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Kindred on April 02, 2013, 02:33:42 PM
Quote from: Kindred on March 31, 2013, 10:57:31 PM
(hmmmm... just occurred to me: How did you install the forum in the first place?)
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Fenz0 on April 02, 2013, 07:39:06 PM
Quote from: Kindred on April 02, 2013, 02:33:42 PM
Quote from: Kindred on March 31, 2013, 10:57:31 PM
(hmmmm... just occurred to me: How did you install the forum in the first place?)

Hmm, maybe u can help?

Can u help me via TeamViewer? :D
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Kindred on April 02, 2013, 07:58:45 PM
no. I answer questions on the forum and occasionally help people with a login, but I do not have team viewer and do not do support via IM.

you still have not answered my question:
How did you install SMF?
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Fenz0 on April 03, 2013, 09:58:41 PM
I've uploaded it via FTP.

I've done everything u told me to do, but it still doesnt work.

I have tried to make new databases and i have buyed like 10 new domains to try but no result!

Im begging for help guys!


Cya! Fenz0.
Title: Re: [SMF MOD INSTALL] Need to login again.
Post by: Kindred on April 03, 2013, 11:14:47 PM
why would you be buying new domains?  When did we ever tell you to do something like that?

If you have a fresh installation on smf in a different directory and with a different database, but on the same server and it still gives you the same result, then it is a problem with your host.