Simple Machines Community Forum

SMF Support => SMF 2.0.x Support => Topic started by: HyperCube.us on May 23, 2013, 12:34:51 AM

Title: Right click when posting does not show "copy" or "paste"
Post by: HyperCube.us on May 23, 2013, 12:34:51 AM
On my board, after typing anything, copy or paste option on right click of the mouse shows only once. After that, right click does not display the option. However, the Control C and Control V for copy and paste works.
I noticed that if I disable the "insert Hyperlink" button in theme options with "WYSIWYG" changed, then the right click works correctly but the Insert Hyperlink button does not work. So one or the other works and this is irritating to all my members.

Any ideas?

Thanks
Title: Re: Right click when posting does not show "copy" or "paste"
Post by: kat on May 23, 2013, 05:55:17 AM
(http://www.katzy.dsl.pipex.com/SMF/welcome.gif)

Let's be honest about this...

The WYSIWYG editor is a bug-ridden pile of poo, I'm afraid. :(

It's being revamped, for the next version of SMF. So, you might want to disable it, in your profile.
Title: Re: Right click when posting does not show "copy" or "paste"
Post by: YogiBear on May 23, 2013, 08:53:26 AM
If it's any consolation this WYSIWYG problem also occurs on other makes of software I've worked with. The solution was the same as K@ has said.
Title: Re: Right click when posting does not show "copy" or "paste"
Post by: HyperCube.us on May 25, 2013, 08:55:18 PM
Thank you both!
Title: Re: Right click when posting does not show "copy" or "paste"
Post by: kat on May 26, 2013, 04:57:41 AM
(http://www.katzy.dsl.pipex.com/Smileys/c014.gif)

Just sorry that we could be more helpful. :)