Simple Machines Community Forum

SMF Support => SMF 2.0.x Support => Topic started by: gulch on October 28, 2013, 07:29:14 PM

Title: Upgraded to 2.0.6 - "users active in the last 15" went crazy
Post by: gulch on October 28, 2013, 07:29:14 PM
Last night, I upgraded from 2.0.4 to 2.0.5.  It finished successfully.  I then upgraded to 2.0.6 which also finished successfully.  Everything seems to be working fine EXCEPT the "Users active in the last 15 minutes" section.  It shows my user id multiple times.  Even when I logoff, it shows my ID as active multiple times. 
Any ideas on what I should do to fix this?

Many thanks
Title: Re: Upgraded to 2.0.6 - "users active in the last 15" went crazy
Post by: Kill Em All on October 28, 2013, 08:37:41 PM
Is it just your user ID or does it do so for others as well? Might want to try clearing your browsers cookies and cache. If that doesn't work, clearing your database's smf_sessions table should do that trick.
Title: Re: Upgraded to 2.0.6 - "users active in the last 15" went crazy
Post by: gulch on October 28, 2013, 10:04:23 PM
It is only my ID but it happens even when I am not logged on.  Other members have told me about it.  I will try the ideas you've suggested.  Thank you very much.
Title: Re: Upgraded to 2.0.6 - "users active in the last 15" went crazy
Post by: gulch on October 28, 2013, 10:40:16 PM
Ok.  I did both of these things and it is still happening.  Do you have any other thoughts?
Title: Re: Upgraded to 2.0.6 - "users active in the last 15" went crazy
Post by: kat on October 29, 2013, 06:33:27 AM
Admin>Forum maintenance>"Empty the file cache" & "Find and repair any errors".

If that doesn't cure it, what does it look like, if you use the SMF default theme?
Title: Re: Upgraded to 2.0.6 - "users active in the last 15" went crazy
Post by: gulch on October 29, 2013, 09:13:07 AM
I did that and it did not fix it.  We are using the default theme.
I noticed a new bit of info.
When I click "who's online", my user name is not repeated.  Instead, it shows a list of guests - likely web crawlers
Title: Re: Upgraded to 2.0.6 - "users active in the last 15" went crazy
Post by: gulch on October 29, 2013, 09:29:17 AM
Also, to make it just a bit more interesting, one of the other admins deleted my account in frustration.  I'm working with another admin account but the problem persists - my old account name shows up many times in the "active in the last 15"
Title: Re: Upgraded to 2.0.6 - "users active in the last 15" went crazy
Post by: Storman™ on October 29, 2013, 09:55:15 AM
Quoteone of the other admins deleted my account in frustration.

Huh !   :o

Sorry but it sounds like a forum out of control with multiple people allowed to make rash changes.

Who knows what else the other admins have done. I suggest you get a little order there and some procedures in place.
Title: Re: Upgraded to 2.0.6 - "users active in the last 15" went crazy
Post by: gulch on October 29, 2013, 10:00:10 AM
We have procedures for things such as this - they aren't always followed.
Title: Re: Upgraded to 2.0.6 - "users active in the last 15" went crazy
Post by: gulch on October 29, 2013, 12:43:39 PM
Just to consolidate:
The issue:
When I look at "active in the last 15", it shows my now-deleted user id multiple times.
When you click "who's online", it does not show my now-deleted id - it shows "guests" as it should.

I have tried:
clearing the cache on cookies on my browser (restarting my computer afterwards)
clearing smf_sessions
Admin>Forum maintenance>"Empty the file cache" & "Find and repair any errors"

Other data:
The id that shows up multiple time is an admin account that has now been deleted by another admin.  when I ran "find and repair any errors", it noticed the posts that I'd made (posts without a user).  I let them alone for the time being.

Before he deleted me, he banned me, unbanned me.  This was all done after the problem surfaced.

So far, nothing has remedied  the problem.  Any other suggestions will be appreciated.
Title: Re: Upgraded to 2.0.6 - "users active in the last 15" went crazy
Post by: Kindred on October 29, 2013, 12:54:53 PM
URL? What mods do you have installed?


Obviously, this is not a 2.0.6 problem, specifically, since this and hundreds (thousands) of other sites are running 2.0.6 now without seeing this error.
Which means that it has to come down to something specific on your system...
Title: Re: Upgraded to 2.0.6 - "users active in the last 15" went crazy
Post by: gulch on October 29, 2013, 03:09:59 PM
The URL is gunslingersgulch.com

the mods are listed in this picture:
(http://i1125.photobucket.com/albums/l593/bulldogwatch/mods_zpsb64d90dc.png) (http://s1125.photobucket.com/user/bulldogwatch/media/mods_zpsb64d90dc.png.html)
Title: Re: Upgraded to 2.0.6 - "users active in the last 15" went crazy
Post by: kat on October 29, 2013, 03:31:03 PM
I wonder if the "Users online today" mod's playing-up...?
Title: Re: Upgraded to 2.0.6 - "users active in the last 15" went crazy
Post by: Kindred on October 29, 2013, 03:35:46 PM
since I can not view pictures form my office (one of the many things that gets blocked), it would be better if you pasted the TEXT list rather than a screen shot of the list.

However, I suspect that K@ has probably hit it...   try removing/disabling that mod
Title: Re: Upgraded to 2.0.6 - "users active in the last 15" went crazy
Post by: gulch on October 29, 2013, 03:40:21 PM
here they are:
1.    Simple Audio Video Embedder    2.0.6    [ Uninstall ] [ List Files ] [ Delete ]
2.    SMF 2.0.4 Update    1.0    [ List Files ] [ Delete ]
3.    Stupid bouncy BBC    1.0    [ Uninstall ] [ List Files ] [ Delete ]
4.    Medal Honor For Years    1.0    [ Uninstall ] [ List Files ] [ Delete ]
5.    Users Online Today    2.0.3    [ Uninstall ] [ List Files ] [ Delete ]
6.    NChat    1.3.2    [ Uninstall ] [ List Files ] [ Delete ]
7.    News Letter Mod for SMF2    1.14    [ Uninstall ] [ List Files ] [ Delete ]
8.    Board Icons    1.0    [ Uninstall ] [ List Files ] [ Delete ]
9.    Karma Description Mod    2.7.1    [ List Files ] [ Delete ]
10.    Stop Forum Spam    1.0    [ Uninstall ] [ List Files ] [ Delete ]
11.    SMF 1.1.19 / 2.0.6 Update    1.0    [ Uninstall ] [ List Files ] [ Delete ]
12.    Live Clock In Header    1.0    [ Install Mod ] [ List Files ] [ Delete ]
13.    Add Avatar To Who Is Online Version 1.1    1.0    [ Uninstall ] [ List Files ] [ Delete ]
14.    SMF 2.0.5 Update    1.0    [ List Files ] [ Delete ]
15.    SMFPacks Shoutbox    1.0.4    [ Uninstall ] [ List Files ] [ Delete ]
16.    Auto Email Inactive Users    1.7    [ Install Mod ] [ List Files ] [ Delete ]
17.    Simple Image Upload    1.3.0    [ Uninstall ] [ List Files ] [ Delete ]
18.    SMF 2.0.2 Update    1.0    [ List Files ] [ Delete ]
19.    PM Informer    4.0    [ Uninstall ] [ List Files ] [ Delete ]
20.    Welcome Topic Mod    2.1    [ Uninstall ] [ List Files ] [ Delete ]
21.    Karma Buttons    1.1    [ Install Mod ] [ List Files ] [ Delete ]
22.    Birthday Posts    0.13 Beta    [ Uninstall ] [ List Files ] [ Delete ]
23.    SMF 2.0.3 Update    1.0    [ List Files ] [ Delete ]
24.    Prevent Adding Signature Images And Links    2.0    [ Uninstall ] [ List Files ] [ Delete ]
Title: Re: Upgraded to 2.0.6 - "users active in the last 15" went crazy
Post by: gulch on October 29, 2013, 03:43:56 PM
You might be on to something!  When I tried to remove that mod, I got errors and a warning that said don't do it unless you know what you are doing (and I pretty much don't)

1.    Execute Modification    ./Sources/BoardIndex.php    Test failed
      1.    Replace    ./Sources/BoardIndex.php    Test failed
Title: Re: Upgraded to 2.0.6 - "users active in the last 15" went crazy
Post by: Kindred on October 29, 2013, 03:49:34 PM
that just means that SOMETHING (some other mod, proibably) changed the code that the users online mod changed - so it can not auto-uninstall...  and you will have to manually alter the affected code in order to get it uninstalled
Title: Re: Upgraded to 2.0.6 - "users active in the last 15" went crazy
Post by: gulch on October 29, 2013, 03:54:00 PM
Thank you for your help. 
How do I manually alter the code so that I can get it uninstalled?
Title: Re: Upgraded to 2.0.6 - "users active in the last 15" went crazy
Post by: Kindred on October 29, 2013, 03:55:18 PM
http://wiki.simplemachines.org/smf/Error_in_mod_installation
Title: Re: Upgraded to 2.0.6 - "users active in the last 15" went crazy
Post by: kat on October 29, 2013, 03:57:55 PM
To make life a bit easier, edit that file, manually.

If you comment-out this:

// Get the user online today list.
$context += getUsersOnlineTodayStats();

         
and this:

// Users Online Today
echo '
<div class="title_barIC">
<h4 class="titlebg">
<span class="ie6_header floatleft">
<img class="icon" src="', $settings['images_url'], '/icons/online.gif', '" alt="', $txt['online_users'], '" />', $txt['uot_users_online_'.$modSettings['uot_setting_period']], '
</span>
</h4>
</div>
<p class="inline smalltext">';
echo
$txt['uot_total'], ': <b>', $context['num_users_online_today'], '</b>';

if ($context['viewing_allowed'])
echo
' (', $txt['uot_visible'], ': ', ($context['num_users_online_today'] - $context['num_users_hidden_today']), ', ', $txt['uot_hidden'], ': ', $context['num_users_hidden_today'], ')';

// Assuming there ARE users online... each user in users_online has an id, username, name, group, href, and link.
if (!empty($context['users_online_today']) && $context['viewing_allowed'])
{
echo
'<br />', implode(', ', $context['list_users_online_today']);
}
echo '
</p>';



The mod will, effectively, be uninstalled.
Title: Re: Upgraded to 2.0.6 - "users active in the last 15" went crazy
Post by: gulch on October 29, 2013, 06:15:40 PM
Thank you for your help.  I'm running a full backup now and we will make the suggested changes as soon as finishes.
Title: Re: Upgraded to 2.0.6 - "users active in the last 15" went crazy
Post by: gulch on October 29, 2013, 09:42:37 PM
The problem appears to be solved.  Thank you all so much for your kind help
Title: Re: Upgraded to 2.0.6 - "users active in the last 15" went crazy
Post by: margarett on October 29, 2013, 09:46:45 PM
Just for the record, it was related to this:
http://www.simplemachines.org/community/index.php?topic=513451

The #1 user had the ID changed to 0 and this brought all kind of madness :P
Title: Re: Upgraded to 2.0.6 - "users active in the last 15" went crazy
Post by: kat on October 30, 2013, 07:14:44 AM
Phew.

At least we got there, in the end, ay? :)
Title: Re: Upgraded to 2.0.6 - "users active in the last 15" went crazy
Post by: gulch on October 30, 2013, 09:20:16 AM
We did, indeed!  You folks are amazing and greatly appreciated.
Title: Re: Upgraded to 2.0.6 - "users active in the last 15" went crazy
Post by: kat on October 30, 2013, 09:40:19 AM
No problem. :)