Simple Machines Community Forum

SMF Support => Nederlands (Dutch) => Language Specific Support => Archief => Topic started by: luxsat on November 06, 2013, 05:51:58 AM

Title: Data Base
Post by: luxsat on November 06, 2013, 05:51:58 AM
Is het mogelijk een bestaande Data Base die nu in een SMF 1.1.19 staat in een SMF 2.0.6 te plaatsen en hoe te werk te gaan ?

Title: Re: Data Base
Post by: NanoSector on November 06, 2013, 06:27:33 AM
Hoi luxsat,

Het minimum wat je nodig hebt is het Large Upgrade pakket op de downloadsite, en de Settings.php en Settings_bak.php van een SMF 1.1.19 installatie.

Zie ook hier: http://wiki.simplemachines.org/smf/Upgrading
Title: Re: Data Base
Post by: luxsat on November 06, 2013, 07:16:22 AM
Ik heb een bestaande SMF 1.1.19 versie.
Op de zelfde server heb ik nu een nieuwe SMF 2.0.6 geïnstalleerd.
Nu wil ik de data base van die SMF 1.1.19 in de SMF 2.0.6 brengen

Dus wat ik hier bedoel is gewoon te werken met de bestaande data base in een nieuw geïnstalleerde versie 2.0.6 versie zonder een Large Upgrade te doen.
Title: Re: Data Base
Post by: NanoSector on November 06, 2013, 08:18:43 AM
Dan zou je een kopie moeten maken van je 1.1.19 forum naar een nieuwe database en daar een upgrade doen. Je kunt niet zomaar een 2.0.6 forum pakken met een 1.1.19 database.
Title: Re: Data Base
Post by: luxsat on November 06, 2013, 08:34:51 AM
Ja inderdaad daar was ik ook over aan het denken.
Wel jammer dat het niet anders en eenvoudiger kan want mensen die gewoon hun forum via Large Upgrade pakket willen upgraden hebben dan echt wel een hoop problemen met verouderde Templates en mods die niet meer werken.
Een goed lopend forum met 40000 leden gooi je niet zomaar even offline om zulke grote veranderingen door te voeren.
Dus een verdere ondersteuning van de 1.1.xxxx versies is voor veel mensen wel wenselijk.
Title: Re: Data Base
Post by: Herman's Mixen on November 06, 2013, 09:30:13 AM
Eerst checken of je template en of mods dan wel geschikt zijn voor de versie welke je installeerd...
als je echt naar 2.x wil dan zul je echt aan andere theme moeten denken aangezien we over een geheel ander engine hebben dan de 1.1.x branche
ander zijds de theme geheel opnieuw opbouwen in de 2.x trend....

de meeste mods zijn tegenwoordig ook compatible dus check en dubble check...
Title: Re: Data Base
Post by: NanoSector on November 06, 2013, 10:41:52 AM
Ja inderdaad daar was ik ook over aan het denken.
Wel jammer dat het niet anders en eenvoudiger kan want mensen die gewoon hun forum via Large Upgrade pakket willen upgraden hebben dan echt wel een hoop problemen met verouderde Templates en mods die niet meer werken.
Dat is logisch wanneer je van een major versie wisselt.

Quote
Een goed lopend forum met 40000 leden gooi je niet zomaar even offline om zulke grote veranderingen door te voeren.
Daarom zou je dit offline moeten testen.

Quote
Dus een verdere ondersteuning van de 1.1.xxxx versies is voor veel mensen wel wenselijk.
Tsjah er moet ooit een einde aan komen...
Title: Re: Data Base
Post by: luxsat on November 06, 2013, 11:00:14 AM

Quote
Tsjah er moet ooit een einde aan komen...

Ik weet echt niet waarom  (https://www.simplemachines.org/community/proxy.php?request=http%3A%2F%2Fwww.luxsat.be%2Fforum%2FSmileys%2Fclassic%2F35kweetniet.gif&hash=3e9cc3deea4853855fab5d296c8316f1)
Als er geen nieuwe Mods of themes meer voor komen dat begrijp ik nog maar essentiële veiligheid updates zou toch moeten kunnen vind je ook niet (https://www.simplemachines.org/community/proxy.php?request=http%3A%2F%2Fwww.luxsat.be%2Fforum%2FSmileys%2Fclassic%2F29vraagteken.gif&hash=da850c5b3150f29277e8e53a23782ad1)

Title: Re: Data Base
Post by: CoreISP on November 06, 2013, 03:10:45 PM
Het probleem is voornamelijk het compatible houden van dat spul met nieuwere technologien, dat wordt steeds lastiger.
En gezien we hier met vrijwilligers werken is het wel steeds meer en meer werk om alle versies te onderhouden; dat is niet te doen.

Op een gegeven moment is een product gewoon te oud en moet het bijgewerkt worden naar een nieuwe versie. :)
SMF 1.1.x is echter nog niet deprecated dus voorlopig zit het wel goed. :)