Simple Machines Community Forum

SMF Support => Português (Portuguese) => Language Specific Support => Modificações (Mods) => Topic started by: Isa.F on July 31, 2014, 09:57:54 PM

Title: MOD SA Chat
Post by: Isa.F on July 31, 2014, 09:57:54 PM
Olá novamente... Estou aqui a desesperar com este mod SA Chat: http://custom.simplemachines.org/mods/index.php?mod=2534

O mod faz aquilo que eu queria que era um chat privado tipo facebook...

Instalei-o sem qualquer erro nem problema...

No entanto, não vejo NADA!! Nem barra de chat, nem lista de membros no chat, NADA, é como se não tivesse instalado mod nenhum...  :-\


Já tentei imensas coisas:

Confirmar as permissões de grupo para ter a certeza que tenho autorização para ver: tudo ok
Confirmar se a barra de chat não está desactivada: tudo ok
Colocar o fórum em tema default e em ingles: tudo igual
Confirmar as permissões de ficheiros: tipo 755
Perguntar ao meu host se o mod estava a ser barrado por segurança: dizem eles que não está

Já pedi ajuda no tópico de apoio, mas ninguém me responde, cá para mim assustaram-se com o meu ingles...  :-[ LOL


Por favor, será que alguém consegue dar-me umas ideias do que posso estar aqui a fazer mal? É que muita gente o instala e a maioria ve tudo sem problemas e eu simplesmente nao vejo chat nenhum...

Apesar de que parece bem instalado pois no menu da admi consta lá o separador SA chat com todas as configurações possíveis...


Por favor, uma ajudinha...  :laugh:


Obrigada  ;)
Title: Re: SA Chat
Post by: margarett on July 31, 2014, 10:35:07 PM
Que tema usas? Para tentar reproduzir. Não deve ser do tema mas vale a pena experimentar.
Title: Re: SA Chat
Post by: Isa.F on August 01, 2014, 05:34:41 AM
Que tema usas? Para tentar reproduzir. Não deve ser do tema mas vale a pena experimentar.

Olá margarett, obrigada por responderes  ;)

Pois, também acho que não é problema do tema, até porque o tema supostamente funciona bem em todos os temas "ancorados"  (ou lá como se diz) ao default...


Mas ainda assim, eu fiz o teste e mudei o fórum para tema default, até coloquei em língua inglesa, mas continuei sem ver mesmo nada que tivesse a ver com o chat, a não ser o tal menu na admin...  :(
Title: Re: SA Chat
Post by: margarett on August 01, 2014, 05:54:58 AM
Vou experimentar ;)
Title: Re: SA Chat
Post by: Isa.F on August 01, 2014, 06:04:51 AM
Vou experimentar ;)

Boa!!   :D Obrigada!!  :D
Title: Re: SA Chat
Post by: margarett on August 01, 2014, 07:17:01 AM
Pois, não sei que te diga... Instalei e imediatamente apareceu no fundo da página a dita barra do chat (vê o anexo)

Experimenta desinstalar e reinstalar o MOD, pode ser que te falte algum ficheiro. Experimenta também com outro browser ;)
Title: Re: SA Chat
Post by: Isa.F on August 01, 2014, 09:06:33 AM
Pois, não sei que te diga... Instalei e imediatamente apareceu no fundo da página a dita barra do chat (vê o anexo)

Experimenta desinstalar e reinstalar o MOD, pode ser que te falte algum ficheiro. Experimenta também com outro browser ;)

Olha, tens razão!!  :o


Desinstalei e voltei a instalar, e desta vez tudo ok!!  :o A única coisa que fiz de diferente, foi aquela opção "Enable group permissions
 Enable group permissions that you can modify in the permission manager in SMF."

Eu tinha selecionado essa opção e depois na administração de grupos alterei as permissões de grupos, mas desta vez tirei o visto dessa opção.. Não sei se foi disso ou não...  :o

Nem quero acreditar, depois de andar 3horas á volta disto, de repente aparece-me a dita cuja,,,  :o


Bem, antes assim!  :)


Obrigada!!  ;)
Title: Re: SA Chat
Post by: Isa.F on August 03, 2014, 06:46:12 AM
Afinal o mod só funcionou bem durante algumas horas... :S

Fiz logout no forum, e no dia seguinte, quando voltei a abrir o forum, reparei que passei a ter outro problema. É que a tal barra de chat que aparece ao fundo, nao está a sincronizar com o loggin no forum... Ou seja, o membro faz loggin no forum, mas continua off no chat, aparecendo esta mensagem:

" Welcome, Guest. Please login or register."


Ja desinstalei, voltei a instalar, desactivei a barra, voltei a activar, limpei cookies, fechei pagina, abri pagina, tudo na mesma...


Porque será que isto acontece?

Obrigada!
Title: Re: NOVAMENTE SA Chat
Post by: Joomlamz on August 03, 2014, 07:06:01 PM
Vou fzer um demo sobre assunto depois coloco aqui

Title: Re: NOVAMENTE SA Chat
Post by: Isa.F on August 03, 2014, 07:22:11 PM
Vou fzer um demo sobre assunto depois coloco aqui

Obrigada Joomlamz!!  :)

Eu entretanto desinstalei a versao SAChatBar-0.1.2.zip disponivel aqui http://custom.simplemachines.org/mods/index.php?mod=2534http://custom.simplemachines.org/mods/index.php?mod=2534  e instalei a versao  SAMods-SAChatBar-4417ee3 que eles tem no site http://samods.github.io/SAChatBar/ , mas o erro é o mesmo: continuo sem conseguir sincronizaçao entre o login no forum e o login no chat...


Mas pelo menos descobri um dado novo: no chrome funciona bem... Nao está a funcionar no IE11 que é o que tenho...

Um membro que tem firefox tambem refere que funciona correctamente em termos de sincronizaçao, apesar de referir que nao está a conseguir minimizar a janela...

Será que tem a ver com o IE??


Obrigada! ;)
Title: Re: NOVAMENTE SA Chat
Post by: Isa.F on August 03, 2014, 10:55:50 PM
Ja consegui resolver o problema!  :D

Desinstalei a shoutbox (um outro mod) e voltei a instala-lo, e o chat passou a funcionar! Devia estar a haver alguma imcompatibilidade, mas desinstalando ambas e voltando a instala-los aos dois, ja funcionam ambos sem problemas!!

Obrigada!  :D
Title: Re: NOVAMENTE SA Chat
Post by: Isa.F on August 06, 2014, 12:32:34 PM
E mais uma vez com uma duvida sobre o SA Chat...  :-[


Como posso desactivar o chat para alguns grupos de membros daqueles activados por numero de mensagem...?

É que quando meto uma cruz para activar isso no menu do SAChat, :

Enable group permissions
 Enable group permissions that you can modify in the permission manager in SMF.
Note: The settings here will override permission settings.


fico eu imediatamente sem ver a barra de chat, apesar de no menu das permissões eu me ter dado a mim e aos restantes grupos a permissão de ver...


Para me explicar melhor, segue o esquema:

Se eu activar o Enable group permissions:

(https://imagizer.imageshack.us/v2/806x312q90/908/JdRaKZ.jpg)

Mesmo dando  permissão no menu do fórum ao meu grupo:

(https://imagizer.imageshack.us/v2/806x409q90/912/NjEQ75.jpg)

A barra desaparece:

(https://imagizer.imageshack.us/v2/806x85q90/538/SfTJ9I.jpg)


Apesar de que, se eu fizer logout ela volta a  ficar activa para visitantes:

(https://imagizer.imageshack.us/v2/806x119q90/540/vkJmqB.jpg)


E se eu depois fizer login novamente, e desactivar o Enable group permissions volto novamente a ver a barra:

(https://imagizer.imageshack.us/v2/806x298q90/536/bEpZ2v.jpg)


No entanto, tentei com a conta original de admin, e aí já tenho acesso mesmo com o tal Enable group permissions activado, por isso tem mesmo que ser alguma coisa na área das permissões...




Em resumo, o que eu queria era, quando activo o Enable group permissions e dou as seguintes permissões ao grupo dos Recém-chegados (grupo regulado por numero de mensagens:

(https://imagizer.imageshack.us/v2/542x358q90/908/bHyM5T.jpg)

Os recém-chegados não vissem a tal barra, mas o que está a acontecer é que TODOS ficam sem ver a barra excepto o admin original e os visitantes, apesar de eu ter dados permissões para os restantes grupos excepto o tal dos Recém-chegados....


Onde estará o gato?


Obrigada  ;)



PS: desculpem o testamento...  :-* Achei melhor colocar imagens para se perceber melhor  :-*
Title: Re: E MAIS UMA VEZ NOVAMENTE O SA Chat
Post by: margarett on August 06, 2014, 02:42:56 PM
Julgo que estás a fazer confusão com as permissões. Eu fiz aqui um teste rapidinho e deu bem...

Vais às permissões e, em *TODOS* os grupos (todos mesmo), colocas as permissões do "SA Chat" tudo desmarcado (reset :P )
Ou seja, neste momento, ninguém (à excepção do administrador) vê a barra do chat

Depois, vais APENAS aos grupos de membros acima do 1º post e colocas as permissões como tens aqui.
(https://imagizer.imageshack.us/v2/806x409q90/912/NjEQ75.jpg)

E já vai dar ;)

Onde é que estás a fazer confusão, penso eu?
Quote
Enable group permissions
 Enable group permissions that you can modify in the permission manager in SMF.
Note: The settings here will override permission settings.
Com esta opção desmarcada, toda a gente vê o chat, ponto.

Quote
No entanto, tentei com a conta original de admin, e aí já tenho acesso mesmo com o tal Enable group permissions activado
O admin faz tudo e vê tudo, sempre ;) Daí que com essa conta não faça diferença se tens ou não o tal visto assinalado ;)

(https://imagizer.imageshack.us/v2/542x358q90/908/bHyM5T.jpg)
Esta permissão não faz com que os utilizadores de certo grupo não vejam o chat. Faz com que esses utilizadores possam desabilitar a barra do chat.

Quote
Onde estará o gato?
Julgo eu que não tenhas retirado as permissões dos visitantes e dos membros não agrupados. Como as permissões no SMF são inclusivas e cada membro é sempre parte de, pelo menos, 2 grupos de permissões, acontece frequentemente esquecermo-nos de tirar de todo o lado. Por isso é que te disse para começares por retirar as permissões a todos os grupos e depois dar só onde se pretende
Title: Re: E MAIS UMA VEZ NOVAMENTE O SA Chat
Post by: Isa.F on August 06, 2014, 09:19:36 PM


OMG, voltei á estaca zero...  :-[

Hoje enquanto desinstalava o sitemap e o PRetty URL, a dada altura, voltei a ficar sem sincronização entre login no fórum e login no chat...  :-[

Entao ja desinstalei todos os mods e voltei a reinstala-los, desinstalei o sitemap e o prettu url, mas continuo sem conseguir sincronização...  :-[

O que se passará..??
Title: Re: E MAIS UMA VEZ NOVAMENTE O SA Chat
Post by: margarett on August 06, 2014, 10:42:21 PM
Experimenta esvaziar a cache do forum bem como refrescar a página no teu browser com ctrl+f5 (hard refresh)
Title: Re: E MAIS UMA VEZ NOVAMENTE O SA Chat
Post by: Isa.F on August 06, 2014, 11:12:11 PM
Olha, enervei-me e esvaziei mas foi o fórum todo e reinstalei-o... Agora com este mod já não tenho problemas, já funciona...

No entanto, agora estou com problemas no outro mod... A serio, hoje não é o meu dia...  :-[

Pelo menos este assunto já está resolvido, ah, e as permissões já estão como eu queria, essa é a boa noticia  :)

No entanto já tenho erros noutra banda... Socorro...  :-[
Title: Re: E MAIS UMA VEZ NOVAMENTE O SA Chat
Post by: Isa.F on August 07, 2014, 10:13:13 PM
E eis que assim do nada, fiquei novamente com o chat avariado...   :-[

Ontem depois de reinstalar o fórum, ja tinha ficado com o chat activo novamente, mas hoje a dada altura, acho que foi quando estava a mexer na base de dados relativamente ao email inactive users (mas pode ter sido coincidência), quando voltei ao fórum ja o chat estava off, quando eu estava mesmo online... Limpei cache, actualizei, saí, voltei a entrar, etc, etc, etc... e nada... Estou online no fórum, e offline no chat... mais uma vez...

Já me aconteceu isso tantas vezes que ja estou a ficar farta deste mod... Ele é muito sensível, qualquer alteraçaozinha ele deixa de sincronizar... Acho que este mod ja está a abusar!

Tem que haver alguma explicação logica para ele assim do nada, resolver deixar de dar no IE, sem eu estar a instalar nada! So depois instalei o outro mod do email inactive users, que foi o único mod, mas que quando o instalei ja tinha deixado de estar online no chat! Apenas coincidiu com eu estar a apagar 3 colunas na base de dados! Até acho que foi coincidência pois penso não ter nada a ver com este mod!

O problema é apenas no IE, isto é uma parvoíce, pois no chrome funciona bem!

Não me apetece nada estar a voltar a desinstalar TODOS os mods e voltar a instalar para isto estar sempre a acontecer!! Sujeito-me a que cada vez que instalo qualquer coisa, deixe de ter chat!!

Não se admite que um mod cause assim tanto distúrbio!



Será que alguém me consegue dizer se há alguma explicação logica para isto acontecer, de o mod funcionar SERMPRE bem no chrome, e volta  meia deixar de funcionar no IE, por qualquer coisinha que a gente faça no fórum?

Eu adoro este mod, mas isto tem que parar de acontecer, fogo, terei que abdicar dele para não ficar louca de vez...  ::)
Title: Re: AVARIA NOVAMENTE NO SA Chat
Post by: margarett on August 07, 2014, 10:31:51 PM
Que versão do IE é que usas tu?
Title: Re: AVARIA NOVAMENTE NO SA Chat
Post by: margarett on August 07, 2014, 10:54:28 PM
Aquilo que o Ninja escreveu no tópico do MOD é verdade. A culpa é do IE que é uma bosta :(
Sobretudo as versões até ao IE9.

Podes experimentar apagar os cookies e os ficheiros temporários da net e depois carregar a página com CTRL+F5 para obrigar a puxar novamente os scripts e os cookies
Title: Re: AVARIA NOVAMENTE NO SA Chat
Post by: Isa.F on August 08, 2014, 12:55:01 PM
Aquilo que o Ninja escreveu no tópico do MOD é verdade. A culpa é do IE que é uma bosta :(
Sobretudo as versões até ao IE9.

Olha, fartei-me de rir com as imagens que ele postou, chegaste a ver? LOL  :laugh: Engraçado que nao sou propriamente fã desse membro, mas ontem até achei piada! LOL

Sim, eu até concordo com o que ele disse, mas tal como lhe disse a ele, eu nao posso ter um forum apenas para quem nao tem IE...  :-\ A coisa tem que funcionar para todos, até porque a maioria das pessoas que conheço têm IE...  :-\


Podes experimentar apagar os cookies e os ficheiros temporários da net e depois carregar a página com CTRL+F5 para obrigar a puxar novamente os scripts e os cookies

Olha, Bruno, ontem experimentei tudo e mais alguma coisa (tudo menos desinstalar mods nem desinstalar fórum, disso já estou pelos cabelos). Faltou-me ir á bruxa! LOL Ás tantas, ja nem sei o que fiz, mas hoje de repente, passou a funcionar!!  :o

Será que teve a ver com o facto de eu ter reiniciado o computador? Mas eu limpei os cookies, ficheiros temporários, e todas aquelas limpezas que se fazem através das opções de internet, fechei os separadores e abri novamente, entrei e saí do fórum vezes sem conta fiz isto mil e uma vezes e nada!! Hoje, horas depois, abro o PC, e está tudo OK! Tem que ter a ver com o facto de eu ter desligado o computador!!

MAs seja como for, porquê de repente o mod deixa de funcionar? Tipo, eu estou online, faço uma modificação qualquer e de repente fico offline, já varias vezes isto me aconteceu! Porque afinal? Porquê este erro surge e porque é que só resolve quando se reinicia o PC??


Olha, fico sem saber afinal onde diabo está o bug, pois assim como aparece o bug de repente, também desaparece!  :o Só sei que coincide com mudanças no fórum...  ::) Eu tenho neste portátil dois browsers, o IE11 e o Chrome, e sempre que o bug surgia no IE, eu ia ao Crome e estava tudo ok! Um membro que tem firefox também comentou que estava tudo bem e nunca tinha tido problemas! É mesmo um mistério, coincide com mudanças no fórum, mas não sei onde está o trigger deste bug...  8)

Seja como for, para já está ok novamente...  8)

Hoje de manha no meu trabalho fui dar um saltinho de 30 segundos ao meu fórum (não dá para mais, lol) e os computadores lá têm ainda o IE8 e também está ok o chat, sincronizado!


Já agora, sei que existe um programa simulador de browsers, que simula como é visualizado o site em todas as versões de todos os browsers... Qual é, mesmo?  ???

Obrigada por teres paciência para as minhas frustrações!  :)
Title: Re: AVARIA NOVAMENTE NO SA Chat
Post by: margarett on August 08, 2014, 01:25:36 PM
No tópico do MOD estava a discutir-se qualquer coisa sobre cookies e tal. Mas confesso que isso já não é a minha praia, baralho-me todo :P

Para simular browsers, nada como instalá-los. IE, Firefox e Chrome cobrem praticamente toda a utilização da net em PCs. Depois há os móveis, mas isso é outra guerra :P
Também não conheço nada, mas o tio Google deve ajudar-te com uma pesquisa "simulador de browsers"
Title: Re: AVARIA NOVAMENTE NO SA Chat
Post by: Isa.F on August 08, 2014, 01:36:25 PM
No tópico do MOD estava a discutir-se qualquer coisa sobre cookies e tal. Mas confesso que isso já não é a minha praia, baralho-me todo :P

Para simular browsers, nada como instalá-los. IE, Firefox e Chrome cobrem praticamente toda a utilização da net em PCs. Depois há os móveis, mas isso é outra guerra :P
Também não conheço nada, mas o tio Google deve ajudar-te com uma pesquisa "simulador de browsers"

Olha, nem de propósito, eu ia agora mesmo perguntar-te que raio estavam eles a dizer, pois não percebi patavina, se bem que o meu inglês tem 14 anos de ferrugem, nem sei como me entenderam eles, então a conjugar verbos nem se fala, LOL, mas fico a achar que mesmo que eles estivessem a falar português, eu não iria entender na mesma...  8)


Uma vez tentei instalar o firefox, e achei que o computador ficou mais lento... não sei se é impressão minha...  :-\

Tenho o IE e o Chrome, mas tenho a noção que se so tivesse um browser o computador seria mais rápido, pois era antes de eu o instalar. Se bem que temos que dar um desconto ao meu portátil, que já deve ter uns 4 ou 5 aninhos...  :D
Title: Re: AVARIA NOVAMENTE NO SA Chat
Post by: margarett on August 08, 2014, 01:42:37 PM
Ehehehe não. É da idade, não tem que ver com o browser. Até porque tanto o FF, o Chrome, o Safari, etc, quando não estão a correr não carregam nada. Em funcionamento o FF é mais pesadote, mas pouco. Só o IE é que, como se integra no sistema operativo, tem sempre "resquícios" :P no sistema, esteja a correr ou não ;)

Uma vez que isso agora está a bulir, eu sugeria-te pedires aos teus membros para te reportarem qualquer problema que tenham com o dito chat. Pode ser só o teu PC a precisar de uma formatação ;) Se não acontecer a mais ninguém...
Title: Re: AVARIA NOVAMENTE NO SA Chat
Post by: Isa.F on August 08, 2014, 02:08:28 PM
Ok!  :)

Eu estou a pensar instalar aquele mod que dá cor ao tipo de cor e tamanho ao tipo de tamanho, lol, mas isso será quando ganhar coragem, pois esta semana não me correu la muito bem em termos informáticos...  8)

Depois se acontecer o mesmo erro no chat durante a instalação de esse novo mod, vou estar mais atenta e ver se reiniciando o PC a coisa se dá...  ;)

Obrigada!!!  ;)
Title: Re: MOD SA Chat
Post by: clubreef on October 24, 2014, 09:20:59 AM
existe algum outro mod que não dar tanto problema igual a esse
Title: Re: MOD SA Chat
Post by: margarett on October 24, 2014, 09:52:04 AM
Já testaste? Pode não acontecer nada contigo, aliás, este é provavelmente o chat mais popular do momento ;)