Simple Machines Community Forum

Customizing SMF => Modifications and Packages => Topic started by: live627 on August 22, 2015, 08:50:05 PM

Title: PM Auto Respond
Post by: live627 on August 22, 2015, 08:50:05 PM
Link to Mod (https://custom.simplemachines.org/mods/index.php?mod=3779)

This mod is something similar to a vacation responder in that it sends a PM to a user who sent a PM. The message and subject are customisable, so the auto PM can be totally unique.

It is based on permissions, so under membergroup permissions, a new entry is added to the centralized permissions management area under the category "Contact members using the personal messaging system" called "Automatically respond to incoming PMs".

Depending on certain criteria found in the incoming message, you can create different variations for auto response. This feature is very similar in nature to the PM Rules in SMF 2.

The choices of criteria are:
Title: Re: PM Auto Respond
Post by: Shambles on August 23, 2015, 04:22:32 AM
Could be very useful, thanks.

That changelog suggests you've had the mod quite a while :D


Quote
I will NOT backport this mod. One for SMF 1.1.x can be found at http://custom.simplemachines.org/mods/index.php?mod=23
That version of the mod has been removed, it seems.
Title: Re: PM Auto Respond
Post by: live627 on August 23, 2015, 07:39:07 PM
QuoteThat changelog suggests you've had the mod quite a while :D
This is an older mod of mine ported from Wedge and used to be on livemods.

Quote from: Shambles on August 23, 2015, 04:22:32 AM
Quote
I will NOT backport this mod. One for SMF 1.1.x can be found at http://custom.simplemachines.org/mods/index.php?mod=23
That version of the mod has been removed, it seems.
That wads a typo. Fixed,  thanks.
Title: Re: PM Auto Respond
Post by: chrishicks on March 19, 2016, 12:14:34 AM
I just installed this on my forum and am having a bit of trouble with it. It installed just fine but I can't seem to actually turn it on in a users profile. I have the permissions for all usergroups set to allow but when I try to set it up it doesn't seem to take effect.

I'm guessing I'm missing something but here's what I do. I put a check in the box to turn it on and fill in the info as seen in this screengrab.

http://i.imgur.com/m8JPhtY.png

When I click on change profile I get this:

http://i.imgur.com/HQwGrqj.png

and everything is empty again. Am I missing a step somewhere? The above is with an Admin account by the way.

EDIT: I should add that I tested this by using a test account to send a PM to my admin account and the auto respond doesn't actually respond. Same goes if I go in reverse and send from my admin account to my test account. I just can't seem to turn on the auto respond.
Title: Re: PM Auto Respond
Post by: Biology Forums on March 19, 2016, 01:59:36 AM
Is there a way to prevent it from being saved in the outbox if the member has it automatically programmed to store all outgoing PMs?
Title: Re: PM Auto Respond
Post by: aegersz on June 13, 2016, 11:52:41 AM
this does not work for me at all. i am running the Enhanced PM mod. but i removed it and i still can't save settings.

and NO auto response at all.

i have tried two systems, same problem.

i have exactly the same problem with the Lite version too.

I am not seeing any errors in the log either.
Title: Re: PM Auto Respond
Post by: aegersz on July 15, 2016, 08:42:36 AM
*bump*