Simple Machines Community Forum

SMF Development => Bug Reports => Topic started by: spitfire80 on February 22, 2016, 05:21:57 PM

Title: Members blocked out of forum (IPs seemingly blocked)
Post by: spitfire80 on February 22, 2016, 05:21:57 PM
Hello,

Not sure if this is the right section but giving it a try. Im an admin on a forum using version 1.1.21. (old, I know). In the last number of months, a number of members, myself included, have gone to post a new thread topic or reply, or maybe have also cut and pasted some info from another site. When the post was ready to be previewed or posted, a 500 error screen would appear, but after 3 tries to get the post to go thru, suddenly access to the forum was seemingly blocked.

I use both Firefox and Safari and on both, the small wheel would spin, indicating that the page was waiting to load. It would then time out, saying the site might be too busy, etc and to try later.

It seemed my IP was blocked. Only when i reset my airport express (im an Apple user), did that seem to work as a new IP was generated from the wireless device.

But I have a couple members that have been "locked out" for weeks and cannot change their IPs.

I guess the question is... what would cause this? And is there a way to fix this? Is it in the software, or a firewall issue? Im at a bit of a loss, to be honest.

Thanks all!

Jeff
Title: Re: Members blocked out of forum (IPs seemingly blocked)
Post by: lurkalot on February 22, 2016, 05:27:34 PM
Quote from: spitfire80 on February 22, 2016, 05:21:57 PM
Hello,

Not sure if this is the right section but giving it a try. Im an admin on a forum using version 2.0.11. In the last number of months, a number of members, myself included, have gone to post a new thread topic or reply, or maybe have also cut and pasted some info from another site. When the post was ready to be previewed or posted, a 500 error screen would appear, but after 3 tries to get the post to go thru, suddenly access to the forum was seemingly blocked.

I use both Firefox and Safari and on both, the small wheel would spin, indicating that the page was waiting to load. It would then time out, saying the site might be too busy, etc and to try later.

It seemed my IP was blocked. Only when i reset my airport express (im an Apple user), did that seem to work as a new IP was generated from the wireless device.

But I have a couple members that have been "locked out" for weeks and cannot change their IPs.

I guess the question is... what would cause this? And is there a way to fix this? Is it in the software, or a firewall issue? Im at a bit of a loss, to be honest.

Thanks all!

Jeff

What mods have you got installed?  And have you set up any ban triggers in your ban list relevant to those IP's
Title: Re: Members blocked out of forum (IPs seemingly blocked)
Post by: spitfire80 on February 22, 2016, 05:28:34 PM
I should add, too, that this member was able to log on fine, up until a few weeks ago. His issue happened when he was cutting and pasting some text from an article and was also wanting to include the website URL he was quoting from in his post.

He got the same 500 error once or twice, but the 3rd time, he was blocked from the forum, with the time out issue happening, that I mentioned.

I will check the ban list but I dont believe that anything associated with his (newer) IP is on that list. He recently switched to AT&T Uverse and has the newer IPv6 IP address.

As far as the mods installed, I need to delve deeper to know. Im not the forum owner and I need to be able to know this info as Im sure it would be helpful, too.

Where do i look to see what mods are installed? Is this in the Admin Panel? (Sorry for the ignorant sounding question here).

Title: Re: Members blocked out of forum (IPs seemingly blocked)
Post by: spitfire80 on February 22, 2016, 05:37:07 PM
These are the mods installed:

   Mod Name    Version    
1.    SMF 1.0.20 / 1.1.12 Update    1.0    
2.    SMF 1.0.21 / 1.1.13 Update    1.0    
3.    SMF 1.1.14 Update    1.0    
4.    SMF 1.1.15 Update    1.0    
5.    SMF 1.0.22 / 1.1.16 Update    1.0    
6.    Tapatalk SMF Plugin    2.1.0    
7.    SMF 1.0.23 / 1.1.17 Update    1.0    
8.    SMF 1.1.18 Update    1.0    
9.    SMF 1.1.19 / 2.0.6 Update    1.0    
10.    SMF 1.1.20 / 2.0.9 Update    1.0    
11.    SMF 1.1.21 / 2.0.10 Update    1.0
Title: Re: Members blocked out of forum (IPs seemingly blocked)
Post by: Kindred on February 22, 2016, 06:33:00 PM
sounds like
1- your host added some new things... probably mod_security
2- your HOST has some sort of security measure in place which locks someone out by IP if they fail the security three times.

As far as I can tell, there is nothing is SMF or in your mod list which would cause this... so it is almost certainly a host issue
Title: Re: Members blocked out of forum (IPs seemingly blocked)
Post by: spitfire80 on February 22, 2016, 06:40:12 PM
Thanks so much for that response and info. I have just emailed the host company,.. sending them your reply, to see what they might say.

Can I ask how cutting and pasting plain text from one site, in order to re-post it to a forum could cause the three "500 errors" and then the lockout on the 4th try? Any idea?



Title: Re: Members blocked out of forum (IPs seemingly blocked)
Post by: lurkalot on February 22, 2016, 06:45:26 PM
Quote from: spitfire80 on February 22, 2016, 06:40:12 PM
Thanks so much for that response and info. I have just emailed the host company,.. sending them your reply, to see what they might say.

Can I ask how cutting and pasting plain text from one site, in order to re-post it to a forum could cause the three "500 errors" and then the lockout on the 4th try? Any idea?





Example.  I had a similar problem a year or two back when typing certain words in a post would trigger the mod security on my host. Got them to turn it off pronto.
Title: Re: Members blocked out of forum (IPs seemingly blocked)
Post by: spitfire80 on February 22, 2016, 06:57:34 PM
Thanks again! I just sent the hosting co. one last note, seeing if they could turn the mod_security "off." They already made some adjustment to it, so maybe they already have done something similar.

I have to wait until the 2 affected members try to log on again from their blocked IPs to see if the host adjustment is working.

Will keep you posted, for sure!  :D
Title: Re: Members blocked out of forum (IPs seemingly blocked)
Post by: spitfire80 on February 22, 2016, 07:30:33 PM
Well, the host company turned "off" the mod_security on our forum's server. They also wanted me to send them the 2 IP addresses, just in case, so they could plug them in manually, into the "allow" part of any firewall that might have previously blocked them, too.

Now to wait for the 2 gents who were locked out, to give it another try and see if they are able to get back in.

And thanks again, to those who replied here!