Simple Machines Community Forum

SMF Support => SMF 2.0.x Support => Topic started by: morris91 on July 13, 2016, 05:20:42 PM

Title: Need help, Problem with uploading.
Post by: morris91 on July 13, 2016, 05:20:42 PM
Hello. Iv got a problem at the moment with my forum and its really got me scratching my head.
I can't seem to upload anything, No avatars, no attachments & nothing on Aeva media.

Iv searched many topics on these forums already trying different things and yet nothing seems to work.

Right now with trying to upload a attachment i get the following error

Your attachment couldn't be saved. This might happen because it took too long to upload or the file is bigger than the server will allow.

Please consult your server administrator for more information.


And with Aeva i had a similar error but have since removed aeva for the time being.
Iv checked my php.ini and changed everything people was suggesting in other posts. I can't really ask my administrator as that's kinda me, i run my forum on my VPS.
Heres a link to my php info file > http://ultrastunting.net/test.php

All files in my forum directory are 777 and on forum say writable.
And this is my attachment path
(https://s31.postimg.org/442e91myz/attachments.png)
I created a second path just to test, Still nothing of course.


The only thing that has recently changed is i moved to a new VPS. I used VestaCP before and used the same panel to restore the website. so all the directory owner would of the stayed the same which is 'ultrast1' and all folders in the smf directory are indeed 'ultrast1'

So I'm stuck, Can anything think of any more idea's for me to try?

Thanks. Chris.

EDIT: I solved the attachments problem, my php.ini temp folder was not in the correct owners name so i changed it to 'ultrast1' and attachments upload fine.
But am still having a problem with Aeva, Im Still getting this error.

An error happened during the upload process, please try again or contact the administrator.
Array

Anyone know how to solve that? Much appreciated

EDIT2:
If it helps in my errors log im getting this

8: Array to string conversion
File: /Themes/default/Aeva.template.php
Line: 2037


And on that line is this,

$error_array[] = $error['fname'] . ' - ' . (isset($error['context']) ? sprintf($message, $error['context']) : $message);

[/code]
Title: Re: Need help, Problem with uploading.
Post by: Kindred on July 13, 2016, 11:51:38 PM
We don't actually support mods here...  And AEVA is no longer supported by the author