Simple Machines Community Forum

SMF Support => SMF 2.0.x Support => Topic started by: eskie on April 16, 2017, 10:39:52 PM

Title: how to remove default avatar minimum dimensions?
Post by: eskie on April 16, 2017, 10:39:52 PM
on my forum, i've set the maximum avatr dimensions to 150x150px, which is fine. but avatars that are smaller than this automatically become rezied to 150x150px, which is certainly not what i wanted.

an image below shows this: as you can see, my own avatar has been resized to fit the maxiumum dimensions, as the original imaged is actually only 20x20px so you can see this.
(https://www.simplemachines.org/community/proxy.php?request=http%3A%2F%2Fi.imgur.com%2FrrEXQ4m.png&hash=dad8784a61503f7860a136fec7cc82e9)

how can i fix this?
Title: Re: how to remove default avatar minimum dimensions?
Post by: Linkjay on April 16, 2017, 10:58:39 PM
You must have changed more than the maximum size of a profile picture in the admin settings. If you just set the maximum width and height in the admin settings, it should not be behaving this way afaik.
Title: Re: how to remove default avatar minimum dimensions?
Post by: eskie on April 16, 2017, 11:10:09 PM
any idea as to what might cause this then? i'm not sure where to check, now.
Title: Re: how to remove default avatar minimum dimensions?
Post by: Linkjay on April 16, 2017, 11:19:23 PM
I guess try and revert everything you did and after it reverts back to normal, just set the maximum height and width under Admin -> Forum -> Attachments and Avatars -> Avatar settings for each one you're using. (Uploadable or external avatars)

What exactly did you do to accomplish this? Did you mess with any of the code to do this? Can you link your site?
Title: Re: how to remove default avatar minimum dimensions?
Post by: Antechinus on April 20, 2017, 08:59:59 PM
This is caused by using the html resize option. It sucks, big time. Change the admin setting to use the javascript resize, which is much better.
Title: Re: how to remove default avatar minimum dimensions?
Post by: eskie on April 21, 2017, 08:44:14 PM
thank you so much, antechinus!! it works perfectly, now.