Simple Machines Community Forum

SMF Support => SMF 2.0.x Support => Topic started by: DJ Omnimaga on April 18, 2017, 11:50:16 AM

Title: Guests can't view attachments even with permission set to allow
Post by: DJ Omnimaga on April 18, 2017, 11:50:16 AM
I have a problem on one of my boards: Guests can't view attachments even with permission set to allow it. They are asked to login in order to do so.

SMF 2.0.13
Emptied cache via admin panel
Emptied unimportant logs via admin panel
Recounted board stats

Mods:
Last active on Member List
Simple Audio Video Embedder
SimplePortal
Attachments in Topics
Last Post on Member list

Works for me in Chrome and Opera since the cache/logs clear, but other guests still get the same error.
Title: Re: Guests can't view attachments even with permission set to allow
Post by: a10 on April 18, 2017, 02:33:43 PM
Take a look in admin > reports > boards permissions, maybe an 'allow' is missing...
Title: Re: Guests can't view attachments even with permission set to allow
Post by: DJ Omnimaga on April 18, 2017, 05:13:28 PM
I just checked the reports and the allow is indeed missing. Why is it missing there when the checkbox is checked in the permission options, even after saving my changes?
Title: Re: Guests can't view attachments even with permission set to allow
Post by: Illori on April 18, 2017, 05:36:49 PM
is there a permissions profile applied that board?
Title: Re: Guests can't view attachments even with permission set to allow
Post by: DJ Omnimaga on April 19, 2017, 10:40:05 AM
Hm I don't remember, but I made the entire board read-only
Title: Re: Guests can't view attachments even with permission set to allow
Post by: Illori on April 19, 2017, 10:45:06 AM
that would be why, you cant modify the permissions on that profile. so you would need to create your own and grant the permissions you want and then assign it to the board.
Title: Re: Guests can't view attachments even with permission set to allow
Post by: DJ Omnimaga on April 21, 2017, 12:51:41 AM
Oh wait, I completely forgot that each mode (read-only, can post anywhere and can't make topic or whatever) had their own separate sets of permissions. I'm gonna have to recreate one myself, then. Thanks for the heads up.