Simple Machines Community Forum

SMF Support => SMF 2.0.x Support => Topic started by: nax on June 11, 2017, 09:11:58 AM

Title: 2.0.13 to 2.0.14 theme issue
Post by: nax on June 11, 2017, 09:11:58 AM
Hi, I see that there is an upgrade, I started to install this but I get a couple of failure warnings re my installed themes. I get a failure on ./Themes/brightforest_23/index.template.php where

<input type="hidden" name="hash_passwrd" value="" /> is supposed to be replaced by

 <input type="hidden" name="hash_passwrd" value="" /><input type="hidden" name="', $context['session_var'], '" value="', $context['session_id'], '" />

I can't find a statement like this in ./Themes/brightforest_23/index.template.php - what do I do?  Any advice?  (still a bit of a novice even though I've been running SMF forums for almost 10 years)

My server details are:-
cPanel Version   64.0 (build 24)
Apache Version   2.2.31
PHP Version   5.5.30
MySQL Version   5.5.54-cll
Architecture   x86_64
Operating System   linux
Title: Re: 2.0.13 to 2.0.14 theme issue
Post by: lurkalot on June 11, 2017, 09:21:00 AM
This might help, https://www.simplemachines.org/community/index.php?topic=553902.0
Title: Re: 2.0.13 to 2.0.14 theme issue
Post by: nax on June 11, 2017, 10:14:56 AM
Thanks for that, my form statements in my index.template.php look nothing like yours, but I did find the area, I added the statement the upgrade is looking for and ran the upgrade.  It seems to be ok I did get one error as I logged out and logged in again but so far I thnnk it has worked.